The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"netscape-7 в FreeBSD"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"netscape-7 в FreeBSD"
Сообщение от soba emailИскать по авторуВ закладки on 06-Мрт-04, 14:14  (MSK)
Ставил Netscape7 из портов. Похоже что никто не отругался. В результате при запуске имеет место быть

sys# /usr/local/bin/netscape7english
ELF binary type "0" not known.
./netscape-bin: 1: Syntax error: "(" unexpected

Как справиться с этим и заставить Netscape работать?

  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "netscape-7 в FreeBSD"
Сообщение от lavr emailИскать по авторуВ закладки on 06-Мрт-04, 16:45  (MSK)
>Ставил Netscape7 из портов. Похоже что никто не отругался. В результате при
>запуске имеет место быть
>
>sys# /usr/local/bin/netscape7english
>ELF binary type "0" not known.
>./netscape-bin: 1: Syntax error: "(" unexpected
>
>Как справиться с этим и заставить Netscape работать?

# kldstat | grep linux (эмуляция Linux в ядре или подгружается модуль?)

# sysctl -a | grep linux
# sysctl -a | grep elf_brand

# man brandelf (чтение handbook поможет)

  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "netscape-7 в FreeBSD"
Сообщение от soba emailИскать по авторуВ закладки on 06-Мрт-04, 17:11  (MSK)
Всё дело в том, что сразу после установки порта Netscape7, он загрузился нормально. После этого осуществлялись телодвижения связанные только с настройкой локали (менялись файлы rc.conf /etc/profile csh.login XF86Config ..... Система пару раз перезагружалась, и после этого появилась описанная выше ошибка.
  Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "netscape-7 в FreeBSD"
Сообщение от lavr emailИскать по авторуВ закладки on 06-Мрт-04, 17:29  (MSK)
>Всё дело в том, что сразу после установки порта Netscape7, он загрузился
>нормально. После этого осуществлялись телодвижения связанные только с настройкой локали (менялись
>файлы rc.conf /etc/profile csh.login XF86Config ..... Система пару раз перезагружалась, и
>после этого появилась описанная выше ошибка.

я тебе конкретно отписал что читать и смотреть.

1) смотреть ГДЕ включена эмуляция Linux (в ядре или в /etc/rc.conf)
2) возможны проблемы с определением типа в elf у исполняемого модуля
при включении одновременной эмуляции: sysv, sco, linux - попробуй убрать
всю эмуляцию кроме linux

Бывает что при включении эмуляции в ядре, неверно устанавливается brand_elf для линуксовых binaries.

Либо используя верхнее можешь все вернуть в норму, либо для ВСЕХ установленных у тебя линуксовых бинарников выполни команду:

# brandelf -t Linux /path/filename_linux_binary

  Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "netscape-7 в FreeBSD"
Сообщение от soba emailИскать по авторуВ закладки on 06-Мрт-04, 18:10  (MSK)
Спасибо большое!
Запускается
По невнимательности удалил из rc.conf linux_enabled
а где он (netscape) хранит информацию о профайлах?
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру