The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"FreeBSD + zebra + bgp"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"FreeBSD + zebra + bgp"  
Сообщение от rawsik email(ok) on 01-Мрт-07, 10:10 
помогите плиз!

настраиваю quagga (она же zebra) для bgp маршрутизации каналов интернета
их всего два, который 192.168.12 предпочтительней

т.е. есть сеть 192.168.29.0/24 - > 192.168.29.1(FreeBSD)
| |
192.168.12.0/30 192.168.9.0/30
| |
сеть 192.168.11.0/24 -> 192.168.11.1(FreeBSD)

т.е. две сети, объеденены через vpn каналы, сейчас статика, или через один маршрут, или через другой соответственно.

установил квагу, вот файлы настроек

192.168.29.1

zebra.conf Код:
hostname ZebYab
password zebra
enable password zebra
log file /var/log/zebra/zebra.log
interface rl0(внутренняя сеть 192.168.29/24)
interface tun2 (192.168.9/30)
interface tun3 (192.168.12/30)
ip forwarding
line vty

bgpd.conf Код:

hostname BgpYab
password zebra
log file /var/log/bgpd.log
log stdout
!
!
router bgp 65001
!
bgp router-id 192.168.29.1
!
network 192.168.29.0/24
!
!network 192.168.9.0/30
!network 192.168.12.0/30
!
!
neighbor 192.168.9.1 remote-as 65002
neighbor 192.168.9.1 weight 2000
!
!
neighbor 192.168.12.1 remote-as 65002
neighbor 192.168.12.1 weight 1000
!
redistribute connected
!
!
line vty
!
debug bgp events
debug bgp filters
debug bgp fsm
debug bgp keepalives
debug bgp updates
!


и конфиг кваги и бгп на 192.168.11.1

zebra.conf

[conf]
hostname ZebSko
password zebra
enable password zebra
log file /var/log/zebra/zebra.log
interface fxp0(внутренняя сеть 192.168.11/24)
interface tun1 (192.168.9/30)
interface tun2 (192.168.12/30)
ip forwarding
line vty

и bgpd.conf Код:

hostname BgpSko
password zebra
log file /var/log/bgpd.log
log stdout
!
!
router bgp 65002
!
bgp router-id 192.168.11.1
!
network 192.168.11.0/24
!network 192.168.9.0/30
!network 192.168.12.0/30
!
neighbor 192.168.9.2 remote-as 65001
neighbor 192.168.9.2 weight 2000
!
!
neighbor 192.168.12.2 remote-as 65001
neighbor 192.168.12.2 weight 1000
!
redistribute connected
!
!neighbor 192.168.9.2 fall-over
!bgp fast-external-fallover
!timers bgp 5 15
!
!neighbor 192.168.12.2 fall-over
!bgp fast-external-fallover
!timers bgp 5 15
!
line vty
!
debug bgp events
debug bgp filters
debug bgp fsm
debug bgp keepalives
debug bgp updates
!


вот собственно, стартую демоны.
и связь к 192.168.11/24 польностью пропадает -(
(я нахожусь на 192.168.29/0)

таблица роутинга статическая не изменяется
т.е. даже не идут пинги к 29/24

захожу на bgp демон и ввожу команды

BgpYab# show ip bgp summary Код:
BGP router identifier 192.168.29.1, local AS number 65001
RIB entries 21, using 1344 bytes of memory
Peers 2, using 5016 bytes of memory

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.9.1     4 65002       9      29        0    0    0 00:01:20        6
192.168.12.1    4 65002      22      23        0    0    0 00:01:03        6

BgpYab# show ip bgpКод:

BGP table version is 0, local router ID is 192.168.29.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  192.168.5.0      192.168.12.1             1          1000 65002 ?
*>                  192.168.9.1              1          2000 65002 ?
*> 192.168.7.0      0.0.0.0                  1         32768  ?
*  192.168.9.0      192.168.12.1             1          1000 65002 ?
*                   192.168.9.1              1          2000 65002 ?
*>                  0.0.0.0                  1         32768  ?
*  192.168.11.0     192.168.12.1             0          1000 65002 i
*>                  192.168.9.1              0          2000 65002 i
*  192.168.12.0     192.168.12.1             1          1000 65002 ?
*                   192.168.9.1              1          2000 65002 ?
*>                  0.0.0.0                  1         32768  ?
*  192.168.25.0     192.168.12.1             1          1000 65002 ?
*>                  192.168.9.1              1          2000 65002 ?
*> 192.168.25.0/30  0.0.0.0                  1         32768  ?
*> 192.168.28.0     0.0.0.0                  1         32768  ?
*> 192.168.29.0     0.0.0.0                  0         32768  i
*> 192.168.29.0/25  0.0.0.0                  1         32768  ?
*  внешнийIP_11/24_фрюхи/30
                    192.168.12.1             1          1000 65002 ?
*>                  192.168.9.1              1          2000 65002 ?
*> внешнийIP_29/24_/32
                    0.0.0.0                  1         32768  ?

на 11/24 у меня доступа нет, поэтому не могу выложить

в логах пусто

файрвол открыть между фрюхами всё

когда останавливаю bgpd, то сразу связь появляется

скажите пожалуйста куда копать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "FreeBSD + zebra + bgp"  
Сообщение от rawsik email(ok) on 01-Мрт-07, 13:23 
ок, поставлю вопрос по другому,

в bgp

для того чтобы сконфигурировать балансировку (или или ) межд каналами в инет, через тунели

как нужно описывать конфигурацию
т.е.

neighbor 192.168.9.2 remote-as 65001
neighbor 192.168.9.2 weight 2000
!
!
neighbor 192.168.12.2 remote-as 65001
neighbor 192.168.12.2 weight 1000

это корректно?!
указывать одну автономную систему вот так, или нет

подскажите плиз!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру