The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"tunnel Cisco FreeBSD"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"tunnel Cisco FreeBSD"  
Сообщение от Rules (ok) on 05-Май-08, 18:37 
Доброго времени суток! Не могу понять почему не работает тоннель между фрей и циской, всю голову себе сломал...
вкратце обрисую ситуевину:
имеется две сетки 192.168.3.0 и 192.168.2.0
между ними был проброшен gre-тоннель на цисках, вот их конфа:
cisco в сети 3.0
interface Tunnel0
description shik
ip address 172.31.129.29 255.255.255.248
ip mtu 1500
tunnel source FastEthernet4
tunnel destination 10.10.1.1
tunnel path-mtu-discovery
!
interface FastEthernet4
description $ETH-LAN$
ip address 10.10.1.9 255.255.255.248
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description shick3.0
ip address 192.168.3.222 255.255.255.0
ip tcp adjust-mss 1452
!
ip route 0.0.0.0 0.0.0.0 10.10.1.10
ip route 10.10.1.0 255.255.255.248 10.10.1.10
ip route 192.168.2.0 255.255.255.0 Tunnel0

cisco в сети 192.168.2.0
interface Tunnel0
ip address 172.31.129.30 255.255.255.248
ip mtu 1280
tunnel source FastEthernet4
tunnel destination 10.10.1.9
tunnel path-mtu-discovery
!
description $ETH-LAN$
ip address 10.10.1.1 255.255.255.248
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 192.168.2.128 255.255.255.0
ip tcp adjust-mss 1452
!
ip route 0.0.0.0 0.0.0.0 10.10.1.2
ip route 10.10.1.8 255.255.255.248 10.10.1.2
ip route 192.168.3.0 255.255.255.0 Tunnel0

на данной конфигурации все работало, возникла необходимость в создании еще одного тоннеля, для которого нужна циска, вот я из третьей сетки циску и убрал, заменив на FreeBSD 6.2
эта фря у меня является шлюзом, хочу на ней поднять тоннель до второй подсетки, вот конф этого тоннеля в rc.conf:

ifconfig_vr0="inet 10.10.1.9 netmask 255.255.255.248"

gif_interfaces="gif0"
gifconfig_gif0="10.10.1.9 10.10.1.1"

ifconfig_gif0="inet 172.31.129.29 172.31.129.30 netmask 255.255.255.248"
static_routes="tun0"
route_tunf="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"

и еще добавляю маршрут на фре:
route add 10.10.1.0/29 10.10.1.10

и измененный (для gif-тоннеля)конф циски со второй подсетки - изменил tunnel mode
interface Tunnel0
ip address 172.31.129.30 255.255.255.248
ip mtu 1280
tunnel source FastEthernet4
tunnel destination 10.10.1.9
tunnel mode ipip
остальное так-же осталось

с данной конфигурацией работает gif, тоесть с циски и с фри пингаются оба конца тоннеля (freebsdd# ping 10.10.1.1
PING 10.10.1.2 (10.10.1.1): 56 data bytes
64 bytes from 10.10.1.1: icmp_seq=0 ttl=254 time=255.026 ms
и с циски пингается 10.10.1.9)
собственно вопрос - в чем трабл, почему с концов тоннеля я не вижу ни сеть 2.0 ни сеть 3.0? может кто подскажет???

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "tunnel Cisco FreeBSD"  
Сообщение от universite email(ok) on 05-Май-08, 20:05 

>ifconfig_gif0="inet 172.31.129.29 172.31.129.30 netmask 255.255.255.248"
>static_routes="tun0"
>route_tunf="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"
>

Очепятка. Надо:
route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "tunnel Cisco FreeBSD"  
Сообщение от Rules email(ok) on 06-Май-08, 03:07 
>
>>ifconfig_gif0="inet 172.31.129.29 172.31.129.30 netmask 255.255.255.248"
>>static_routes="tun0"
>>route_tunf="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"
>>
>
>Очепятка. Надо:
>route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"

Именно очепятка, так и есть - именно этот маршрут route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0" прописан на самом деле

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "tunnel Cisco FreeBSD"  
Сообщение от universite email(ok) on 06-Май-08, 03:56 
>[оверквотинг удален]
>>>ifconfig_gif0="inet 172.31.129.29 172.31.129.30 netmask 255.255.255.248"
>>>static_routes="tun0"
>>>route_tunf="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"
>>>
>>
>>Очепятка. Надо:
>>route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"
>
>Именно очепятка, так и есть - именно этот маршрут route_tun0="-net 192.168.2.0 -netmask
>255.255.255.0 -interface gif0" прописан на самом деле

netstat -rn покажите и куда нет доступа с подсети с роутером на FreeBSD

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "tunnel Cisco FreeBSD"  
Сообщение от crash (ok) on 06-Май-08, 04:15 
>[оверквотинг удален]
>>>ifconfig_gif0="inet 172.31.129.29 172.31.129.30 netmask 255.255.255.248"
>>>static_routes="tun0"
>>>route_tunf="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"
>>>
>>
>>Очепятка. Надо:
>>route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"
>
>Именно очепятка, так и есть - именно этот маршрут route_tun0="-net 192.168.2.0 -netmask
>255.255.255.0 -interface gif0" прописан на самом деле

/etc/rc.conf:
gateway_enable=yes ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "tunnel Cisco FreeBSD"  
Сообщение от Rules email(ok) on 06-Май-08, 05:05 
сейчас значит такой конфиг:

gif_interfaces="gif0"
gifconfig_gif0="10.10.1.9 10.10.1.1"
ifconfig_gif0="inet 172.31.129.1 172.31.129.2 netmask 255.255.255.252"

static_routes="tun0"
route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"

netstat -nr
default            87.241.*.*         UGS         0     9141    rl1
10.10.1/29         10.10.1.10         UGS         0     1180    vr0
10.10.1.8/29       link#3             UC          0        0    vr0
10.10.1.9          00:0f:3d:cb:13:4c  UHLW        1      176    lo0
10.10.1.10         00:15:62:95:89:b0  UHLW        2        0    vr0    218
87.241.*.*/30      link#2             UC          0        0    rl1
87.241.*.*3        00:16:c7:57:bd:08  UHLW        2       19    rl1     61
127.0.0.1          127.0.0.1          UH          0       74    lo0
172.31.129.1       127.0.0.1          UH          0        2    lo0
192.168.2          gif0               US          0     1262   gif0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "tunnel Cisco FreeBSD"  
Сообщение от universite email(ok) on 06-Май-08, 05:26 
>сейчас значит такой конфиг:
>
>gif_interfaces="gif0"
>gifconfig_gif0="10.10.1.9 10.10.1.1"
>ifconfig_gif0="inet 172.31.129.1 172.31.129.2 netmask 255.255.255.252"
>
>static_routes="tun0"
>route_tun0="-net 192.168.2.0 -netmask 255.255.255.0 -interface gif0"

пробуем:
route_tun0="-net 192.168.2.0/24 172.31.129.2"

И еще есть подозрение, что нет роутинга к 172.31.129.2.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "tunnel Cisco FreeBSD"  
Сообщение от Rules email(ok) on 06-Май-08, 09:18 
все, решение проблемы простое до одури:
firewall резал, открыл интерфейс и все заработало!
спасибо!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру