The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"yum"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 10:01 
Помогите мне с yum, я уже куда только не писал, и не чего полезного не кто не написал.
А проблемма в следущем, когда я пытаюсь поставить какой-нить пакет или просто пишу yum update он начинает проверять зависимости и в конце выдает ошибки
Вот вывод ошибок после команды yum update:

--> Processing Dependency: libcrypto.so.6 for package: gnupg
--> Processing Dependency: libcrypto.so.6 for package: mutt
--> Processing Dependency: libssl.so.6 for package: pyOpenSSL
--> Processing Dependency: libssl.so.6 for package: gnupg
--> Processing Dependency: libssl.so.6 for package: python-ldap
--> Processing Dependency: libgomp = 4.1.2-14.el5 for package: gcc
--> Processing Dependency: libssl.so.6 for package: elinks
--> Processing Dependency: libssl.so.6 for package: stunnel
--> Processing Dependency: libcrypto.so.6 for package: m2crypto
--> Processing Dependency: libcrypto.so.6 for package: cyrus-sasl
--> Processing Dependency: libssl.so.6 for package: cadaver
--> Processing Dependency: liblber-2.2.so.7 for package: samba-client
--> Finished Dependency Resolution
Error: Missing Dependency: libreadline.so.4 is needed by package lftp
Error: Missing Dependency: libevent-1.1a.so.1 is needed by package nfs-utils
Error: Missing Dependency: libreadline.so.4 is needed by package samba-common
Error: Missing Dependency: libldap-2.2.so.7 is needed by package samba-common
Error: Missing Dependency: libldap-2.2.so.7 is needed by package nss_ldap
Error: Missing Dependency: libreadline.so.4 is needed by package lvm2
Error: Missing Dependency: libgomp = 4.1.2-14.el5 is needed by package gcc
Error: Missing Dependency: gecko-libs = 1.8.0.8 is needed by package yelp
Error: Missing Dependency: libreadline.so.4 is needed by package samba-client
Error: Missing Dependency: libldap-2.2.so.7 is needed by package samba-client
Error: Missing Dependency: liblber-2.2.so.7 is needed by package nss_ldap
Error: Missing Dependency: liblber-2.2.so.7 is needed by package samba-common
Error: Missing Dependency: liblber-2.2.so.7 is needed by package samba
Error: Missing Dependency: libldap-2.2.so.7 is needed by package samba
Error: Missing Dependency: liblber-2.2.so.7 is needed by package samba-client
Error: Missing Dependency: libcrypto.so.6 is needed by package libwvstreams
Error: Missing Dependency: libcrypto.so.6 is needed by package cadaver
Error: Missing Dependency: libcrypto.so.6 is needed by package pyOpenSSL
Error: Missing Dependency: libssl.so.6 is needed by package neon
Error: Missing Dependency: libcrypto.so.6 is needed by package openldap
Error: Missing Dependency: libcrypto.so.6 is needed by package ntp
Error: Missing Dependency: libssl.so.6 is needed by package wget
Error: Missing Dependency: libcrypto.so.6 is needed by package rpm
Error: Missing Dependency: libssl.so.6 is needed by package fetchmail
Error: Missing Dependency: libcrypto.so.6 is needed by package hplip
Error: Missing Dependency: libssl.so.6 is needed by package openldap
Error: Missing Dependency: libcrypto.so.6 is needed by package curl
Error: Missing Dependency: libssl.so.6 is needed by package python
Error: Missing Dependency: libssl.so.6 is needed by package sendmail
Error: Missing Dependency: libcrypto.so.6 is needed by package bind-libs
Error: Missing Dependency: libcrypto.so.6 is needed by package openssh-server
Error: Missing Dependency: libcrypto.so.6 is needed by package slrn
Error: Missing Dependency: libssl.so.6 is needed by package mutt
Error: Missing Dependency: libssl.so.6 is needed by package curl
Error: Missing Dependency: libcrypto.so.6 is needed by package stunnel
Error: Missing Dependency: libcrypto.so.6 is needed by package openssh
Error: Missing Dependency: libcrypto.so.6 is needed by package elinks
Error: Missing Dependency: libcrypto.so.6 is needed by package python
Error: Missing Dependency: libcrypto.so.6 is needed by package sendmail
Error: Missing Dependency: libssl.so.6 is needed by package libwvstreams
Error: Missing Dependency: libcrypto.so.6 is needed by package fetchmail
Error: Missing Dependency: libssl.so.6 is needed by package slrn
Error: Missing Dependency: libcrypto.so.6 is needed by package libsane-hpaio
Error: Missing Dependency: libcrypto.so.6 is needed by package pam_ccreds
Error: Missing Dependency: libssl.so.6 is needed by package elinks
Error: Missing Dependency: tcl = 8.4.7 is needed by package tk
Error: Missing Dependency: libcrypto.so.6 is needed by package vorbis-tools
Error: Missing Dependency: libcrypto.so.6 is needed by package bind-utils
Error: Missing Dependency: libcrypto.so.6 is needed by package gnome-vfs2
Error: Missing Dependency: libssl.so.6 is needed by package m2crypto
Error: Missing Dependency: libssl.so.6 is needed by package rpm
Error: Missing Dependency: libssl.so.6 is needed by package gnome-vfs2
Error: Missing Dependency: libcrypto.so.6 is needed by package openssh-clients
Error: Missing Dependency: libcrypto.so.6 is needed by package wget
Error: Missing Dependency: libcrypto.so.6 is needed by package ipsec-tools
Error: Missing Dependency: /usr/X11R6/bin/xauth is needed by package xorg-x11
Error: Missing Dependency: libcrypto.so.6 is needed by package neon
Error: Missing Dependency: libcrypto.so.6 is needed by package tcpdump
Error: Missing Dependency: libcrypto.so.6 is needed by package net-snmp-libs
Error: Missing Dependency: libcrypto.so.6 is needed by package bind
Error: initscripts conflicts with xorg-x11
Error: Missing Dependency: libssl.so.6 is needed by package pyOpenSSL
Error: Missing Dependency: libssl.so.6 is needed by package vorbis-tools
Error: Missing Dependency: libcrypto.so.6 is needed by package dhcpv6_client
Error: Missing Dependency: libcrypto.so.6 is needed by package python-ldap
Error: Missing Dependency: libcrypto.so.6 is needed by package gnupg
Error: Missing Dependency: libcrypto.so.6 is needed by package mutt
Error: Missing Dependency: libssl.so.6 is needed by package gnupg
Error: Missing Dependency: libssl.so.6 is needed by package python-ldap
Error: Missing Dependency: libssl.so.6 is needed by package stunnel
Error: Missing Dependency: libcrypto.so.6 is needed by package m2crypto
Error: Missing Dependency: libcrypto.so.6 is needed by package cyrus-sasl
Error: Missing Dependency: libssl.so.6 is needed by package cadaver
Error: fontconfig conflicts with fonts-xorg-base

вот что у меня в файле yum.conf:

[base2]
name=CentOS-$releasever - Base2
baseurl=http://www.jasonlitka.com/media/EL5/i386/
gpgcheck=0


[base]
name=CentOS-$releasever - Base
baseurl=http://mirror.centos.org/centos/4/os/i386/
gpgcheck=0

#released updates
[update]
name=CentOS-$releasever - Updates
baseurl=http://mirror.centos.org/centos/4/updates/i386/
gpgcheck=0

#packages used/produced in the build but not released
[addons]
name=CentOS-$releasever - Addons
baseurl=http://mirror.centos.org/centos/4/addons/$basearch/
gpgcheck=0

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
baseurl=http://mirror.centos.org/centos/4/extras/$basearch/
gpgcheck=0

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
baseurl=http://mirror.centos.org/centos/4/centosplus/$basearch/
gpgcheck=0

#contribs - packages by Centos Users
[contribs]
name=CentOS-$releasever - Contribs
baseurl=http://mirror.centos.org/centos/4/contrib/$basearch/
gpgcheck=0

[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el4/en/i386/dag/
gpgcheck=0
enabled=1

[livna]
name=Livna.org Fedora Compatible Packages (stable)
baseurl=http://rpm.livna.org/fedora/3/i386/RPMS.stable
gpgcheck=0
enabled=1


Дистр. у меня RedHat, если что-то с чем-то конфликтует как это исправить?
на всякий случай вот вывод команды rpm -qa| grep glibc:

[root@artem ~]# rpm -qa| grep glibc
glibc-headers-2.5-18
glibc-devel-2.5-18
glibc-2.5-18
glibc-common-2.5-18

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

  • yum, Bosh, 13:21 , 21-Май-09, (1)  
    • yum, fate29, 13:26 , 21-Май-09, (2)  
      • yum, Bosh, 13:41 , 21-Май-09, (3)  
        • yum, fate29, 14:27 , 21-Май-09, (4)  
          • yum, Bosh, 14:38 , 21-Май-09, (5)  
            • yum, fate29, 14:40 , 21-Май-09, (6)  
              • yum, Bosh, 14:42 , 21-Май-09, (7)  
                • yum, fate29, 14:59 , 21-Май-09, (10)  
                • yum, fate29, 15:10 , 21-Май-09, (11)  
              • yum, Bosh, 14:47 , 21-Май-09, (8)  
                • yum, fate29, 14:56 , 21-Май-09, (9)  
                  • yum, bill, 19:59 , 21-Май-09, (12)  
                    • yum, fate29, 09:27 , 22-Май-09, (13)  
                      • yum, bill, 17:27 , 23-Май-09, (14)  
                        • yum, fate29, 12:15 , 25-Май-09, (15)  
                        • yum, aaaaaaaaaaaaaaa, 15:17 , 25-Май-09, (16)  
                        • yum, fate29, 16:04 , 25-Май-09, (17)  
                        • yum, aaaaaaaaaaaaaaa, 16:33 , 25-Май-09, (18)  
                        • yum, fate29, 17:21 , 25-Май-09, (19)  

Сообщения по теме [Сортировка по времени | RSS]


1. "yum"  +/
Сообщение от Bosh on 21-Май-09, 13:21 
покажи
cat /etc/issue


>[оверквотинг удален]
>
>Дистр. у меня RedHat, если что-то с чем-то конфликтует как это исправить?
>
>на всякий случай вот вывод команды rpm -qa| grep glibc:
>
>[root@artem ~]# rpm -qa| grep glibc
>glibc-headers-2.5-18
>glibc-devel-2.5-18
>glibc-2.5-18
>glibc-common-2.5-18

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 13:26 
>покажи
>cat /etc/issue
>

Red Hat Enterprise Linux Server release 4.92 (Tikanga)
Kernel \r on an \m

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "yum"  +/
Сообщение от Bosh on 21-Май-09, 13:41 
Крутой ты перец .
У тебя чистый RedHat
Твой юм настроен на репозитарий цент-оса (репозитарий красной шапки энтерпрайз тока за лицензию  доступен)
RH устанавливает все утилей up2date , и только за бабало .
В принципе то что yum RH  настроен на репоз  CentOS это  частичтно правильно(как вариант) ,  но есть одно но ,  что бы правильно  апдейтиться с него  необходимо  иинортировать ключ
rpm --import http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-4
тут варианты ключей под ту  версию centos  скоторой тебе надо обновляться
http://mirror.centos.org/centos/
и второе хотя centos это достаточно точная копия RH не все пакеты совместимы,  поэтому возможны ошибки которые ты получаешь.
Зависимости в репозитария действительно могут быть разные.
Если есть варинат поставь Centos и не парься

>>покажи
>>cat /etc/issue
>>
>
>Red Hat Enterprise Linux Server release 4.92 (Tikanga)
>Kernel \r on an \m

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 14:27 
>
>Если есть варинат поставь Centos и не парься
>

Поздно менять ОС у меня на redHat уже многочего полезного стоит
а ключ что-то не импортируется (
этот импорт ключа поможет?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "yum"  +/
Сообщение от Bosh on 21-Май-09, 14:38 
До конца нет , это необходимое условие ,но не достаточное.
И вообще  именно yum update работать не должен .
yum install  что там  еще покатит , а глобальное обновление системы - нет  

>>
>>Если есть варинат поставь Centos и не парься
>>
>
>Поздно менять ОС у меня на redHat уже многочего полезного стоит
>а ключ что-то не импортируется (
>этот импорт ключа поможет?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 14:40 
>До конца нет , это необходимое условие ,но не достаточное.
>И вообще  именно yum update работать не должен .
>yum install  что там  еще покатит , а глобальное обновление
>системы - нет
>

а я могу создать файл с содержанием этого ключа и сделать rpm --import имя файла ??

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "yum"  +/
Сообщение от Bosh on 21-Май-09, 14:42 
Да
>>До конца нет , это необходимое условие ,но не достаточное.
>>И вообще  именно yum update работать не должен .
>>yum install  что там  еще покатит , а глобальное обновление
>>системы - нет
>>
>
>а я могу создать файл с содержанием этого ключа и сделать rpm
>--import имя файла ??
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 14:59 
>Да
>>>До конца нет , это необходимое условие ,но не достаточное.
>>>И вообще  именно yum update работать не должен .
>>>yum install  что там  еще покатит , а глобальное обновление
>>>системы - нет
>>>
>>
>>а я могу создать файл с содержанием этого ключа и сделать rpm
>>--import имя файла ??

после импорта вообще перестал yum работать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 15:10 
>Да
>>>До конца нет , это необходимое условие ,но не достаточное.
>>>И вообще  именно yum update работать не должен .
>>>yum install  что там  еще покатит , а глобальное обновление
>>>системы - нет
>>>
>>
>>а я могу создать файл с содержанием этого ключа и сделать rpm
>>--import имя файла ??

закоментировал в yum.conf

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

gpgcheck=1


вроде заработало

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "yum"  +/
Сообщение от Bosh on 21-Май-09, 14:47 
[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

gpgcheck=1 важно

>>До конца нет , это необходимое условие ,но не достаточное.
>>И вообще  именно yum update работать не должен .
>>yum install  что там  еще покатит , а глобальное обновление
>>системы - нет
>>
>
>а я могу создать файл с содержанием этого ключа и сделать rpm
>--import имя файла ??

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "yum"  +/
Сообщение от fate29 email(ok) on 21-Май-09, 14:56 
>[base]
>name=CentOS-$releasever - Base
>mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
>gpgcheck=1
>gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
>
>gpgcheck=1 важно
>

not using ftp, http[s], or file for repos, skipping - Null is not a valid release or hasnt been released yet
Error: Cannot find a valid baseurl for repo: base

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "yum"  +/
Сообщение от bill (ok) on 21-Май-09, 19:59 
>[оверквотинг удален]
>>mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
>>gpgcheck=1
>>gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
>>
>>gpgcheck=1 важно
>>
>
>not using ftp, http[s], or file for repos, skipping - Null is
>not a valid release or hasnt been released yet
>Error: Cannot find a valid baseurl for repo: base

Для начала я бы отключил все эти в большинстве случаев ненужные репозитории типа ливны и дага. Extras и addons , plus , contrib тоже не нужны.
Оставить только base и update. Rpmforge не полностью совместим с основными репами. Чтоб его верно подключить надо использовать плагины к yum -  priorities и protectbase.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "yum"  +/
Сообщение от fate29 email(ok) on 22-Май-09, 09:27 

>
>Для начала я бы отключил все эти в большинстве случаев ненужные репозитории
>типа ливны и дага. Extras и addons , plus , contrib
>тоже не нужны.
>Оставить только base и update. Rpmforge не полностью совместим с основными репами.
>Чтоб его верно подключить надо использовать плагины к yum -  
>priorities и protectbase.

а можно подробнее что мне нужно сделать? в yum.conf оставил только base и update поставил пакет protectbase

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "yum"  +/
Сообщение от bill (ok) on 23-Май-09, 17:27 
>[оверквотинг удален]
>>
>>Для начала я бы отключил все эти в большинстве случаев ненужные репозитории
>>типа ливны и дага. Extras и addons , plus , contrib
>>тоже не нужны.
>>Оставить только base и update. Rpmforge не полностью совместим с основными репами.
>>Чтоб его верно подключить надо использовать плагины к yum -  
>>priorities и protectbase.
>
>а можно подробнее что мне нужно сделать? в yum.conf оставил только base
>и update поставил пакет protectbase

Теперь просто попробуйте прогнать yum update. Если пройдет успешно, то можно уже пробовать подключить сторонние репозитории.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "yum"  +/
Сообщение от fate29 email(ok) on 25-Май-09, 12:15 

>
>Теперь просто попробуйте прогнать yum update. Если пройдет успешно, то можно уже
>пробовать подключить сторонние репозитории.

все равно ошибки (

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "yum"  +/
Сообщение от aaaaaaaaaaaaaaa on 25-Май-09, 15:17 
>все равно ошибки (

yum clean all
rpm -Uhv --nodeps http://mirror.centos.org/centos/5/os/i386/CentOS/centos-rele...
yum.conf
[base]
name=CentOS-$releasever - Base
baseurl=http://mirror.centos.org/centos/5.3/os/i386/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

[updates]
name=CentOS-$releasever - Updates
baseurl=http://mirror.centos.org/centos/5.3/updates/i386/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5

yum update
ошибки в студию


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "yum"  +/
Сообщение от fate29 email(ok) on 25-Май-09, 16:04 
>[оверквотинг удален]
>gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
>
>[updates]
>name=CentOS-$releasever - Updates
>baseurl=http://mirror.centos.org/centos/5.3/updates/i386/
>gpgcheck=1
>gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
>
>yum update
>ошибки в студию

заработало только одну ошибку в конце выдал
Error: yum conflicts with yum-rhn-plugin < 0.5.2-1.el5

может не работало потому что я не делал yum clean all

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "yum"  +/
Сообщение от aaaaaaaaaaaaaaa on 25-Май-09, 16:33 
>заработало только одну ошибку в конце выдал
>Error: yum conflicts with yum-rhn-plugin < 0.5.2-1.el5
>
>может не работало потому что я не делал yum clean all

rpm -e yum-rhn-plugin

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "yum"  +/
Сообщение от fate29 email(ok) on 25-Май-09, 17:21 
>>заработало только одну ошибку в конце выдал
>>Error: yum conflicts with yum-rhn-plugin < 0.5.2-1.el5
>>
>>может не работало потому что я не делал yum clean all
>
>rpm -e yum-rhn-plugin

все спасибо ))))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру