The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Openbsd 4.6 Nat"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Openbsd 4.6 Nat"  +/
Сообщение от orfos (ok) on 22-Окт-09, 19:17 
Дано
три машины:
1 OpenBSD 4.6 с 3 сетевыми картами
ne3 192.168.1.2 (к ней подключен ADSL модем)
vr0 10.0.0.1
rl1 10.0.1.1

2 Gentoo x86
eth0 10.0.0.2

3 Ubuntu 9.04
eth0 10.0.1.2
Как видно Gentoo и Ubuntu соединяются с сервером посредством обычной витой пары.
Требуется обеспечить всем компьютерам доступ в интернет через ADSL соединение

Что сделано:
После прочтения руководства по pf сдеал следующее:
Решил связать вначале два компьютера (Gentoo и OpenBSD)

pf.conf
$ext_if = "ne3" #192.168.1.2 Сетевая на которой висит модем
$int_if = "vr0" #10.0.0.1 Сетевая, которая соединяется с Gentoo
nat on $ext_if from $int_if:network to any -> $ext_if

sysctl.conf
net.inet.ip.forwarding =1
net.inet.gre.allow=1

Соответственно в Gentoo:
route add default gw 10.0.0.1 eth0

Далее в OpenBSD:
ppp -ddial pppoe
Интернет работает, из под BSD можно нормально бегать по сайтам

Пробуем зайти в интернет из под Gentoo.. ноль реакции

Хотя:
pfctl -sn

nat on ne3 inet from 10.0.0.0/24 to any -> 192.168.1.2

То есть ip вроде транслируются, а траффик не идет.
Пробовал:
nat on $ext_if from $int_if:network to any -> tun0

Тогда:
pfctl -sn
nat on ne3 inet from 10.0.0.0/24 to any -> 95.158.250.94

А при ifconfig:
tun0: flags=8051<UP> mtu 1492
priority: 0
groups: tun, egress
media: Ethernet autoselect
status:active
inet 95.158.250.94 --> 10.130.192.1 netmask0xffffffff

то есть 95.158.250.94 - это внутренний ip, который мне дает провайдер, 10.130.192.1 -внешний ip.
Результат тот же.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • Решено, orfos, 01:29 , 23-Окт-09, (1)  

Сообщения по теме [Сортировка по времени | RSS]


1. "Решено"  +/
Сообщение от orfos (ok) on 23-Окт-09, 01:29 
Проблема успешно решена, требовалось :
nat on tun0 from $int_if:network to any -> tun0
после чего все отлично стало работать))
Мне думается, что это из-за динамического адреса, который присваивает провайдер.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру