The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не могу обновить ClamAv"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (Системное и пользовательское ПО / Linux)
Изначальное сообщение [ Отслеживать ]

"Не могу обновить ClamAv"  +/
Сообщение от oldduality (ok) on 18-Май-10, 09:05 
После выхода новой версии ClamAv, возникла необходимость обновить мой старый ClamAv.
Попытался обновить следующим образом, выполняю команду:
rpm -Uvh clamav-0.96-3.el4.rf.i386.rpm
Получаю следующее сообщение:
ошибка: Неудовлетворенные зависимости:
        libclamav.so.3 нужен для (установлен)clamd-0.92.1-1.el4.rf.i386
        clamav = 0.92.1-1.el4.rf нужен для (установлен)clamd-0.92.1-1.el4.rf.i386

Операционная система CentOs 4.2
Стоит ClamAv 0.92.1

Попробовал обновить через YUM.
yum update clamav

В конце выдал ошибку:
Error: Missing Dependency: rtld(GNU_HASH) is needed by package clamav
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package clamav
Error: Missing Dependency: rtld(GNU_HASH) is needed by package clamd
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package clamd

Подскажите пожалуйста, что в данной ситуации делать?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не могу обновить ClamAv"  +/
Сообщение от Vladimir (??) on 18-Май-10, 09:21 
>[оверквотинг удален]
>        libclamav.so.3 нужен для (установлен)clamd-0.92.1-1.el4.rf.i386
>
>        clamav = 0.92.1-1.el4.rf нужен
>для (установлен)clamd-0.92.1-1.el4.rf.i386
>
>Операционная система CentOs 4.2
>Стоит ClamAv 0.92.1
>
>Подскажите пожалуйста, что в данной ситуации делать?
>> rpm -Uvh clamav*

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Не могу обновить ClamAv"  +/
Сообщение от oldduality (ok) on 18-Май-10, 09:32 
>>[оверквотинг удален]

//skip
>>Стоит ClamAv 0.92.1
>>> rpm -Uvh clamav*

После выполнения команды: rpm -Uvh clamav*
Выдал
предупреждение: пакет clamav = 0.96-3.el4.rf уже был добавлен, заменяется clamav <= 0.96-3.el4.rf
ошибка: Неудовлетворенные зависимости:
        clamd = 0.96-3.el4.rf нужен для clamav-milter-0.96-3.el4.rf.i386
        sendmail нужен для clamav-milter-0.96-3.el4.rf.i386
        libclamav.so.3 нужен для (установлен)clamd-0.92.1-1.el4.rf.i386
        clamav = 0.92.1-1.el4.rf нужен для (установлен)clamd-0.92.1-1.el4.rf.i386
    Предлагаемое разрешение:
        /home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/sendmail-8.13.1-3.2.el4.i386.rpm
А с этим что делать?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Не могу обновить ClamAv"  +/
Сообщение от Vladimir (??) on 18-Май-10, 11:08 
>    Предлагаемое разрешение:
>        /home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/sendmail-8.13.1-3.2.el4.i386.rpm
>А с этим что делать?

Установить


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Не могу обновить ClamAv"  +/
Сообщение от oldduality (ok) on 18-Май-10, 11:59 
>>    Предлагаемое разрешение:
>>        /home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/sendmail-8.13.1-3.2.el4.i386.rpm
>
> Установить

Скачал, установил: rpm -Uvh sendmail-8.13.1-3.2.el4.i386.rpm
После повторного выполнения команды: rpm -Uvh clamav*
Выдало сообщение:
предупреждение: пакет clamav = 0.96-3.el4.rf уже был добавлен, заменяется clamav <= 0.96-3.el4.rf
ошибка: Неудовлетворенные зависимости:
        clamd = 0.96-3.el4.rf нужен для clamav-milter-0.96-3.el4.rf.i386
        libclamav.so.3 нужен для (установлен)clamd-0.92.1-1.el4.rf.i386
        clamav = 0.92.1-1.el4.rf нужен для (установлен)clamd-0.92.1-1.el4.rf.i386

Сообщение о sendmail исчезло, но эти три висят.

Если попробовать сделать через yum
yum update clamav*
то выдает в конце:
Error: Missing Dependency: rtld(GNU_HASH) is needed by package clamd
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package clamd
Error: Missing Dependency: rtld(GNU_HASH) is needed by package clamav
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package clamav
Выходит, что нужно доставить rtld(GNU_HASH) и libc.so.6(GLIBC_2.4)?
Вопрос как?

Нашел тут www.mail-archive.com/centos@centos.org/msg03801.html
информацию, вроде как нужно обновить сам  rpm

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Не могу обновить ClamAv"  +/
Сообщение от oldduality (ok) on 20-Май-10, 14:52 
вобщем решилось все просто.
ClamAv не обновлялся из за не обновленной CentOs, версия была 4.2
Сделал следующее:
!бакапимся :)
во первых смотрим что у нас прописано в /etc/yum.repos.d/rpmforge.repo, смотрим что бы были указаны пути на ваши репозитории,
в моем случае почему-то были указаны не на то, что нужно:

# Name: RPMforge RPM Repository for Red Hat Enterprise 5 - dag
# URL: http://rpmforge.net/
[rpmforge]
name = Red Hat Enterprise $releasever - RPMforge.net - dag
#baseurl = http://apt.sw.be/redhat/el5/en/$basearch/dag
mirrorlist = http://apt.sw.be/redhat/el5/en/mirrors-rpmforge
#mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge
enabled = 1
protect = 0
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
gpgcheck = 1

а надо было:
# Name: RPMforge RPM Repository for Red Hat Enterprise 5 - dag
# URL: http://rpmforge.net/
[rpmforge]
name = Red Hat Enterprise $releasever - RPMforge.net - dag
#baseurl = http://apt.sw.be/redhat/el5/en/$basearch/dag
mirrorlist = http://apt.sw.be/redhat/el4/en/mirrors-rpmforge
#mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge
enabled = 1
protect = 0
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
gpgcheck = 1

вобщем все el5 меняем на el4
сохраняем

ну и собственно все.

yum clean all

далее

yum update

чекаются репозитории, предлагает скачать, говорим "y"

в принципе все.

у меня вылезло еще пару ошибок, типа:
Error: Missing Dependency: gcc = 3.4.6-8 is needed by package gcc-c++
Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.20 is needed by package openssh-clients
Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.20 is needed by package openssh-server
Error: Missing Dependency: postgresql = 7.4.19-1.el4_6.1 is needed by package postgresql-devel

ничего страшного, просто умельцы его ставили ручками.
Кстати если проверить, что с clamAv, то выяснилось, что он уже чудесным образом обновился
мочим теми же ручками:
yum remove gcc
yum remove openssh
yum remove postgresql

ну потом ставим :)
yum install gcc
yum install openssh
yum install postgresql

вроде все.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру