The OpenNET Project

 
Поиск (теги):    НОВОСТИ (+) КОНТЕНТ WIKI MAN'ы ФОРУМ twitter

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"В Chrome 51 наблюдаются проблемы с невозможностью использова..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от opennews (??) on 07-Июн-16, 23:04 
Разработчики NGINX обратили (https://www.nginx.com/blog/supporting-http2-google-chrome-users/) внимание на проблему с прекращением использования HTTP/2 при обращении при помощи web-браузера Chrome 51 к большинству сайтов, доступных по протоколу HTTP/2. В Chrome 51 прекращена поддержка TLS-расширения NPN, развиваемого в паре с SPDY, на смену которому вместе с HTTP/2 пришло TLS-расширение ALPN. Большая часть сайтов, поддерживающих HTTP/2, работает под управлением nginx и LiteSpeed, в которых применяется реализация TLS из OpenSSL.


Проблема заключается в том, что поддержка ALPN появилась только в OpenSSL 1.0.2, который ещё почти не используется в популярных серверных дистрибутивах Linux. В частности, OpenSSL 1.0.2 присутствует только в Ubuntu 16.04, а в CentOS/RHEL 6.x/7.x, Debian 7.x/8.x и Ubuntu 14.04 применяется OpenSSL 1.0.1, который поддерживает только NPN. В качестве возможных решений проблемы предлагается сменить дистрибутив, вручную пересборать nginx с новым выпуском OpenSSL или запустить  nginx в контейнере с Ubuntu 16.04 LTS. В противном случае, пользователи Chrome 51 будут ограничены использованием HTTP/1.

URL: https://www.nginx.com/blog/supporting-http2-google-chrome-users/
Новость: http://www.opennet.ru/opennews/art.shtml?num=44561

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +16 +/
Сообщение от Аноним (??) on 07-Июн-16, 23:04 
Но есть лучший способ решить эту проблему: забить и подождать ещё годик-другой.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

18. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +17 +/
Сообщение от MPEG LA (ok) on 08-Июн-16, 00:46 
в последнее время это становится одним из лучших вариантов решения веб-проблем.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

31. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –1 +/
Сообщение от Аноним (??) on 08-Июн-16, 10:57 
Растушее количество ботнетов на серверных линуксах, а точнее на не обновленных вовремя, серверных линуксах, гарантируют это.
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

2. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +13 +/
Сообщение от th3m3 (ok) on 07-Июн-16, 23:06 
Или предложить пользователям использовать браузер для людей, например Firefox.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +6 +/
Сообщение от Аноним (??) on 08-Июн-16, 08:12 
Ничего, для уравновешивания ситуации разрабы FF полным ходом ухудшают его до потери конкурентноспособности.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

25. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Andrey Mitrofanov on 08-Июн-16, 10:23 
> Ничего, для уравновешивания ситуации разрабы FF полным ходом ухудшают его до потери
> конкурентноспособности.

Зато у него в свете новости есть неоспоримое преимущество. Pазработчики NGINX INC. на него даже не посмотрят! Ура.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

41. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –2 +/
Сообщение от Аноним (??) on 08-Июн-16, 15:05 
На компьютерах можно, но мобильный FF к использованию непригоден.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +14 +/
Сообщение от Аноним (??) on 07-Июн-16, 23:07 
Для CentOS/RHEL специально делаем сборки NGINX и Apache.
https://codeit.guru/ru_RU/

SRPM доступны. Сами пользуемся для хостинга клиентских сервисов и сайтов.
Пршу критиковать и комментировать.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

23. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Нанобот (ok) on 08-Июн-16, 09:06 
а объясните такой момент: что случится, если я поставлю эти пакеты на 6/7 центос, в котором нету openssl 1.0.2? не запустится? запустится, но не будет работать с http/2? или оно там статически слинковано и всё будет ок?
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

24. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +2 +/
Сообщение от xl32 (ok) on 08-Июн-16, 10:21 
Да специально же для CentOS/RHEL mod_ssl собран статически с OpenSSL 1.0.2h.
В NGINX собран сам бинарь nginx статически, так что будет запускаться на CentOS/RHEL 6/7 и точно ничего (кроме веб-сервера, конечно) не зацепит проблемами бинарной совместимости.
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

28. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +1 +/
Сообщение от Аноним (??) on 08-Июн-16, 10:31 
> для CentOS/RHEL mod_ssl собран статически с OpenSSL 1.0.2h

ентепрайзненько!

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

29. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Andrey Mitrofanov on 08-Июн-16, 10:41 
>> для CentOS/RHEL mod_ssl собран статически с OpenSSL 1.0.2h
> ентепрайзненько!

Ммм... А mod_ssl собранного в отдельный дорккер-контейнер не завезли? "Будем искать."Ц

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

30. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +1 +/
Сообщение от xl32 (ok) on 08-Июн-16, 10:44 
Я подумываю о разворачивании какого-нибудь пакета openssl102-1.0.2h-1.el7.rpm в /opt, чтобы было действительно энтерпрайзненько.
Чуть позже обкатаем и такие пакеты.
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

32. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –5 +/
Сообщение от Аноним (??) on 08-Июн-16, 11:06 
>mod_ssl собран статически с OpenSSL

facepalm

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

5. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +6 +/
Сообщение от Аноним (??) on 07-Июн-16, 23:10 
Спасибо Хабру за предупреждение, поставил кастомный nginx ещё в конце мая
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +7 +/
Сообщение от Аноним (??) on 07-Июн-16, 23:20 
Согласен, весьма и весьма вовремя предупредили.
Тогда же начали делать тестовые сборки для вышеуказанного репо, позже добавили автоскачивание свежих версий libbrotli, openssl, nginx mainline- и stable-веток, автосборку и подписывание всего этого добра.
Успели как раз всё выкатить в паблик до апокалипсиса.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +3 +/
Сообщение от Аноним (??) on 07-Июн-16, 23:37 
обязательно надо всех переводить на новый опенссл, в старом уже бекдоров не осталось почти, инвесторы анб негодуют.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –3 +/
Сообщение от OpensslNew email on 07-Июн-16, 23:52 
> openssl version

OpenSSL 1.0.2h-fips  3 May 2016
> nginx -v

nginx version: nginx/1.11.1

Хоромозеры over 51 level, welcome :-)

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Аноним (??) on 07-Июн-16, 23:57 
А теперь nginx -V 2>&1 | grep OpenSSL
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

14. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от OpensslNew email on 08-Июн-16, 00:02 
Веткой ошибся, смотри ниже ⬋
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

15. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от h31 (ok) on 08-Июн-16, 00:02 
А FIPS нафига включил?
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от OpensslNew email on 08-Июн-16, 00:00 
> nginx -V 2>&1 | grep OpenSSL

built with OpenSSL 1.0.2h  3 May 2016

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +3 +/
Сообщение от burik666 (ok) on 08-Июн-16, 00:11 
Gentoo:
built with OpenSSL 1.0.2h  3 May 2016
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Аноним (??) on 08-Июн-16, 02:46 
А что будет? https останется работать, просто отвалится HTTP/2 и будет работать как HTTP/1? Или сайт не откроется вообще?

У меня есть сайт с HTTP/2 и Chrome 51. Всё открывается как и раньше. Не вижу видимых никаких проблем с открытием сайта через Хром.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

21. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +1 +/
Сообщение от xl32 (ok) on 08-Июн-16, 02:48 
> А что будет? https останется работать, просто отвалится HTTP/2 и будет работать
> как HTTP/1? Или сайт не откроется вообще?

Будет работать как HTTP/1.1. Они отрубили NPN, убрали этот костыль, и теперь HTTP/1.1 не апгрейдится до HTTP/2.
Оставили только ALPN, который согласовывает версию HTTP на этапе установки TLS-соединения.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

26. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Andrey Mitrofanov on 08-Июн-16, 10:28 
>> как HTTP/1? Или сайт не откроется вообще?
> Будет работать как HTTP/1.1. Они отрубили NPN, убрали этот костыль, и теперь
> HTTP/1.1 не апгрейдится до HTTP/2.

О! Вот это нужно! Спасибо опенет за наводку!! А теперь нужно будет пол-системы патчить, чтобы пол-http отломать??  <///><

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

27. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +2 +/
Сообщение от xl32 (ok) on 08-Июн-16, 10:30 
Да. Или см. ссылки выше, использовать веб-сервера, статически слинкованные с OpenSSL 1.0.2 и бдительно следить за её свежестью.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

33. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –2 +/
Сообщение от Аноним (??) on 08-Июн-16, 11:58 
Похоже centos 6/7 и debian 7/8 для зверей.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

34. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +3 +/
Сообщение от xl32 (ok) on 08-Июн-16, 12:14 
Не для зверей. А просто поддержка 10 лет для бизнеса — необходимость и, более того, необходимый минимум.
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

35. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Аноним (??) on 08-Июн-16, 13:05 
PPA для Ubuntu Trusty 14.04 LTS:

https://launchpad.net/~fxr/+archive/ubuntu/nginx-alpn

Собран из официальных пакетов с nginx.org/packages, модифицированных для статической сборки с OpenSSL 1.0.2h. Только stable ветка nginx, за каждым релизом mainline поспевать сил не хватит.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

36. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +1 +/
Сообщение от xl32 (ok) on 08-Июн-16, 13:08 
> Только stable ветка nginx, за каждым релизом
> mainline поспевать сил не хватит.

Могу поделиться исходниками наших обновляторов и сборщиков для CentOS, чтобы поспевать за всем автоматически.
Модификаций там, думаю, будет требоваться немного.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

37. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –1 +/
Сообщение от Аноним (??) on 08-Июн-16, 13:19 
Буду премного благодарен!

mail сбк kbaryshnikov точка-ру

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

38. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +2 +/
Сообщение от xl32 (ok) on 08-Июн-16, 13:26 
> Буду премного благодарен!

Да чего там уже жадничать, держите, выложил в паблик.
https://repo.codeit.guru/build.tools/

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

39. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Аноним (??) on 08-Июн-16, 13:26 
Спасибо!
Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

43. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –1 +/
Сообщение от Аноним (??) on 08-Июн-16, 15:16 
>> Буду премного благодарен!
> Да чего там уже жадничать, держите, выложил в паблик.
> https://repo.codeit.guru/build.tools/

С ланчпадом и deb-ами все совсем иначе...  В общем, только вытягивалка openssl пригодилась. :-) Но все равно спасибо.

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

40. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Аноним (??) on 08-Июн-16, 14:19 
> Только stable ветка nginx, за каждым релизом mainline поспевать сил не хватит.

Посмотри в сторону webhook автоматизации деплоя и aptly https://www.aptly.info/

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

42. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –1 +/
Сообщение от Аноним (??) on 08-Июн-16, 15:15 
>> Только stable ветка nginx, за каждым релизом mainline поспевать сил не хватит.
> Посмотри в сторону webhook автоматизации деплоя и aptly https://www.aptly.info/

Спасибо за совет, но на Лапчпаде своя билд-ферма, туда достаточно исходники заливать.
Я уже накостылил на шелле  проверялку-генерялку-заливалку, тестирую :-)

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

47. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –1 +/
Сообщение от XXXasd (ok) on 08-Июн-16, 21:05 
ну "отлично" оформлена новость :-) ..

"""В Chrome 51 наблюдаются проблемы с невозможностью использования HTTP/2"""

потом читаешь текст и оказывается что в Chrome-51 проблем ни каких нет :-) .. а проблемы лишь на серверных сторонах

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

48. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  –1 +/
Сообщение от Аноним (??) on 08-Июн-16, 22:34 
Поддержку предыдущей версии серверного софта сломали в Chrome, а не на сервере.
Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

49. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +/
Сообщение от Xasd (ok) on 09-Июн-16, 00:23 
HTTP/1.1 не ломали..

поддержка HTTP/2 -- в соответствии со спецификацией..

а совместимость с НЕправильным-HTTP/2 -- это как-то уже через-чур.. отсутствие этой совместимости -- ни сколько не является проблемой, а скорее наоборот -- очень правильный шаг..

HTTPS и без того достаточно сложный протокол, чтобы ещё и заниматься поощрением зоопарков его вариантов реализаций. совершенно вероно что именно радикальный откат до HTTP/1.1 -- должен поисходить -- в случае если кто-то пытается разводить эти зоопарки :-)

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

50. "В Chrome 51 наблюдаются проблемы с невозможностью использова..."  +1 +/
Сообщение от КО on 09-Июн-16, 08:50 
>HTTPS и без того достаточно сложный протокол, чтобы ещё и заниматься поощрением зоопарков

Теперь никаких зоопарков. У клиента крокодилы у сервера аллигаторы. Вместе они не живут. :)
Поэтому и те и другие используют мартышек оставшихся из старого зоопарка.

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

51. "В Chrome 51 наблюдаются проблемы с использованием HTTP/2"  +/
Сообщение от Аноним (??) on 10-Июн-16, 15:49 
Никто видимо не заметит как перехода на HTTP/2, так и отказа работать с ним.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



  Закладки на сайте
  Проследить за страницей
Created 1996-2016 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor TopList