The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от opennews (?), 09-Авг-18, 20:20 
Сформированы (https://www.postgresql.org/about/news/1878/) корректирующие обновления для всех поддерживаемых веток PostgreSQL: 10.5 (https://www.postgresql.org/docs/current/static/release-10-5....), 9.6.10 (http://www.postgresql.org/docs/current/static/release-9-6-10...), 9.5.14 (http://www.postgresql.org/docs/current/static/release-9-5-14...), 9.4.19 (http://www.postgresql.org/docs/current/static/release-9-4-19...) и 9.3.24 (http://www.postgresql.org/docs/current/static/release-9-3-24...), в которых представлена порция исправлений ошибок.  Выпуск обновлений для ветки 9.3 продлится (http://www.postgresql.org/support/versioning/)  до сентября 2018 г., 9.4 до декабря 2019 г., 9.5 до января 2021 г., 9.6 - до сентября 2021 года, 10 - до октября 2022 года.


В обновлении исправлено около 40 ошибок и устранены две уязвимости:  

-  CVE-2018-10915 - уязвимость в libpq, библиотеке с клиентским API, связанная с отсутствием должного сброса всех переменных состояния соединения при повторном соединении. В частности, может остаться не сброшенная переменная, определяющая необходимость проверки  пароля для соединения, что позволяет пользователям надстроек над libpq, таким как расширения  dblink и postgres_fdw, подключиться к серверам, не имея соответствующих прав доступа;

-  CVE-2018-10925 - утечка содержимого памяти при выполнении "INSERT ... ON CONFLICT DO UPDATE". Атакующий может инициировать создание таблицы, через которую можно получить доступ к произвольным байтам памяти сервера при выполнении операции "INSERT ... ON CONFLICT DO UPDATE".

URL: https://www.postgresql.org/about/news/1878/
Новость: https://www.opennet.ru/opennews/art.shtml?num=49108

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от DEF (?), 09-Авг-18, 20:20 
Еще забыл указать, что вышла 11b3
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  –2 +/
Сообщение от Анонимemail (2), 09-Авг-18, 23:52 
Betta это betta
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  –14 +/
Сообщение от Аноним (3), 10-Авг-18, 06:52 
Оракул лучше по всем параметрам. А это недоразумение сами знаете насколько нужно.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +2 +/
Сообщение от Аноним (4), 10-Авг-18, 07:02 
Это так толсто, что даже тонко!
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +1 +/
Сообщение от Catwoolfii (ok), 10-Авг-18, 07:32 
просто у тебя руки под рукоблудие заточены
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от Олег (??), 10-Авг-18, 07:35 
оракул тормознутое поделие, и очень дорогое. Знакомый 5 проектов аналитических перевел с оракла на постгрю, скорость работы на том же железе отличается в разы.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +1 +/
Сообщение от Аноним (8), 10-Авг-18, 09:43 
Ну так если накостыленное за несколько лет ещё с 9-й версии ( если не с восьмой ), нормально проанализировать и сделать на pg то так и должно быть, другое дело что если нормально сделать на 12.2/18 то тогда можно будет сравнивать, а так некорректно.
p.s. Если устраивеает производительность решения на PG то конечно PG выгодней, другое дело если PG  в принципе такое не тянет, на том же железе, даже на уровне обычного SQL с внешней Informatica вот тогда Oracle и нужен.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  –1 +/
Сообщение от ano (??), 10-Авг-18, 10:46 
для каждого задания свой продукт, куда-то надо ораКОЛ, а куда-то - Постгре.
Но ваш коммент суперкрут.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

13. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +1 +/
Сообщение от Xasd (ok), 11-Авг-18, 21:35 
> куда-то надо ораКОЛ

обычно ни куда. кроме случаев когда команда проограммистов умеют писать только под Oracle.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

14. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от Аноним (14), 13-Авг-18, 08:38 
Oracle, это не только ценный мех (откат при покупке), но и кормление причастных на прохождении курсов (HR-служба тоже жрать в три горла хочет, имеют на это полное право). А без бумажки, подтверждающих их прохождение, ты ничто и звать тебя никак. Хучь ты типа DBA, хучь ты типа разработчик.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +1 +/
Сообщение от Вареник (?), 13-Авг-18, 18:08 
Действительно, что за недоразумение - когда без отката. Глупость какая-то, а не софт.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  –2 +/
Сообщение от Вопрос (?), 10-Авг-18, 09:26 
Не в тему, но что это с RussianFedora?:

https://ru.fedoracommunity.org/
Владелец ru.fedoracommunity.org неправильно настроил свой веб-сайт. Чтобы защитить вашу информацию от кражи, Firefox не соединился с этим веб-сайтом.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +1 +/
Сообщение от Igor (??), 10-Авг-18, 10:16 
Там-же в дополнительной информации все сказано - вчера истек срок действия сертификата.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

11. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от Аноним (11), 10-Авг-18, 13:15 
ставь чистую федору, без модификаций от русского васяна (чистая федора вполне себе русифицирована, русскому васяну там прибавить нечего)
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

12. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от Аноне (?), 10-Авг-18, 20:45 
Let's Encrypt bot глюканул наверно.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

16. "Выпуск PostgreSQL 10.5, 9.6.10, 9.5.14, 9.4.19, 9.3.24"  +/
Сообщение от Николай Попов (?), 15-Авг-18, 15:44 
единственная нормальная СУБД
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor