The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DWG"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DWG"  +/
Сообщение от opennews (??), 06-Дек-18, 10:44 
Опубликован (http://savannah.gnu.org/forum/forum.php?forum_id=9320) релиз библиотеки  GNU LibreDWG 0.7 (https://www.gnu.org/software/libredwg/), предлагающей свободную реализацию формата DWG (https://ru.wikipedia.org/wiki/DWG), применяемого в большинстве САПР, включая AutoCAD. До 2017 года  LibreDWG  входил в список (https://www.opennet.ru/opennews/art.shtml?num=41863) наиболее приоритетных проектов Фонда свободного ПО. Код библиотеки написан на языке Си и поставляется (https://github.com/LibreDWG/libredwg/) под лицензией GPLv3. Из-за невозможности включения GPLv3 кода в проекты, распространяемые под лицензией GPLv2, многие свободные САПР, такие как  LibreCAD и FreeCAD, не могут (https://www.opennet.ru/opennews/art.shtml?num=32972) использовать LibreDWG. Новая версия LibreDWG 0.7 примечательна реализацией нового API dwg_get_OBJECT(dwg), который можно использовать для получения доступа ко всем объектами в файле DWG.


URL: http://savannah.gnu.org/forum/forum.php?forum_id=9320
Новость: https://www.opennet.ru/opennews/art.shtml?num=49727

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –5 +/
Сообщение от Аноним (1), 06-Дек-18, 10:44 
зачем оно нужно если этим пользоваться нельзя? почесать столману что-то?
Закопайте!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +1 +/
Сообщение от Мууу (?), 06-Дек-18, 11:33 
Курсовик написать сгодится. Подождите закапывать.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –2 +/
Сообщение от Arrr (?), 06-Дек-18, 11:49 
А для курсовика разве нет автокада со студенческой лицензией?
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

10. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +5 +/
Сообщение от Qwerty (??), 06-Дек-18, 13:12 
Это не труЪ! Каждый, кто пользуется загнивающей проприетарщиной, спонсирует IntelME и массовую слежку!
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

29. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +3 +/
Сообщение от Аноним (29), 07-Дек-18, 04:37 
вот потом и преходят тупни на предприятия которые кроме автокада и мсофиса нихрена не могут,
конечно студентам бесплатно, первая доза всегда дешевле и чище, а когда подсядешь сойдет все что угодно.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

31. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от прпв (?), 07-Дек-18, 08:33 
А если к тебе придет гений либрекада в типичную проектную шарагу, где все поголовно на паленом автокаде сидят и с другимим шарагами в его же форматах взаимодействуют?
Кто и где даст рабобу такому умнику?
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

33. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +1 +/
Сообщение от Ю.Т. (?), 07-Дек-18, 08:41 
> А если к тебе придет гений либрекада в типичную проектную шарагу, где
> все поголовно на паленом автокаде сидят и с другимим шарагами в
> его же форматах взаимодействуют?

Что там за форматы такие? Qcad 3.21 вроде бы умеет работать с форматом 15-го автокада, но я этим классом ПО мало пользуюсь.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

41. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от prokoudine (ok), 07-Дек-18, 10:50 
DXF — нативный формат либрекада.
Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

43. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от аа (?), 07-Дек-18, 11:16 
А все чертежы передают в dwg.
Да и совместимость даже в одном формате плохая между ними.
Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

55. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (-), 07-Дек-18, 16:36 
Дык сам автодеск и развел с дюжину субформатов. И таки это икается. Например обладатели лазерных резаков любят старый DXF. И если вы им припрете какой-нибудь 2014 - получите вместо выкройки дырку от бублика, потому что софт на резаке это не жрет. Или жрет криво.
Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

60. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Arrr (?), 08-Дек-18, 11:16 
На какие предприятия? Я работал на нескольких предприятиях, на нескольких других работали мои друзья и везде был Автокад.
Да им перейти с Автокада на другую программу не должно был большой историей, инженеры это не бухгалтерши.
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

54. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (-), 07-Дек-18, 16:34 
> А для курсовика разве нет автокада со студенческой лицензией?

Ты курсач сдать не успеешь если автокад будешь осваивать, чудило. LibreCAD в 100500 раз проще, когда надо быстренько что-то CADовское сделать. Ну там курсач. Или вот контур фрезеру или лазерному резаку отдать для выкройки будущего корпуса железки.

А автокад - это если кто решил с головой вдариться в инженерию и проектировать будет не менее чем мост или самолет какой, огромной фирмой с толпой народа. Курсач в нем делать - столь же эпично как подруливать на авиалайнере в булочную.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

59. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Arrr (?), 08-Дек-18, 11:10 
Сам ты чудило, я работал в Автокада несколько лет, не надо мне рассказывать сказки
Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

61. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Arrr (?), 08-Дек-18, 11:21 
В Автокаде конечно, опечатался со злости.
Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

62. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (62), 08-Дек-18, 12:16 
> В Автокаде конечно, опечатался со злости.

Злись себе наздоровье, я автокад видел, и когда мне приспичило именно курсач, от руки его нарисовать быстрее вышло чем автокад освоить. Вот такой вот анекдот.

А вот LibreCAD - достаточно прост и тривиален, поэтому можно просто пойти и просто начертить то что надо было. Без освоения огроменного супермонстра с убер-газилионом фич на все оказии. Поэтому пока найдешь нужную и вообще что-то сможешь сделать - рак на горе свистеть устанет. Там даже просто разобраться как это сделать чтобы потом на распечатке масштаб правильный был без поллитра малореально. И для курсача вот это вот - крайне не рационально, кроме случая когда потом планируется в этом мощно наворачивать в какой-то конторе как основной род деятельности, фултайм. И вот это вот - весьма и весьма не для всех.

Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

63. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Arrr (?), 08-Дек-18, 12:54 
А я Автокад увидел, когда ходил в кружок программирования в доме творчества. Я тогда был школьник, наверное шестого класса.
Нам задали задание начертить болт в программе, которую мы увидели первый раз в жизни и мы кое как справились.
Да и тогда почти не использовалась мышь, всё приходилось делать через команды.
Не надо всех равнять по себе.
Если у тебя возникли сложности с Автокадом, то это твои личные проблемы.
Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

5. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +2 +/
Сообщение от Fomalhaut (?), 06-Дек-18, 11:56 
Добавлять нельзя в проект и распространять в его составе, но почему нельзя поддерживать? А уж пользователь поставит самостоятельно.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

24. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (24), 06-Дек-18, 18:01 
Вангую, что большинство пользователей (тех кто реально пользуетмся, а не поставил поиграться) этих проектов сидят на винде, а бинарные сборки с таким лицензионным конлфиктом распространять нельзя. По этому воспользоваться поддержкой libredwg смогут только пользователи source-based дистров и те, кто собирает из исходников руками. В результате, оправдать поддержку libredwg могла бы только потреьность самих авторов в совместимости с автокадом, и очевидно, что ее нет
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

32. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от аа (?), 07-Дек-18, 08:35 
Потому что опенсорс создан чтоб решать свои внутренние проблемы, например переписывать одно и то же под несовместимыми лицензиями. А проектированием занимаются другие люди на другом софте.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

26. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Анончик999999 (?), 06-Дек-18, 20:20 
Черчение свободным софтом аналогичных чертежов, как в AutoCAD,- просто в плачевном состоянии. Так еще и сами себе палки в колеса засовывают!
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +6 +/
Сообщение от vedronim (?), 06-Дек-18, 11:19 
Нужно просто все перелицензировать под жпл3
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +1 +/
Сообщение от Andrey Mitrofanov (?), 06-Дек-18, 11:58 
> Нужно просто все перелицензировать под жпл3

"" either version 3 of the License, or (at your option) any later version. ""

GPLv3+.

Скокажможнатаспасибодосвиданья.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

11. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от J.L. (?), 06-Дек-18, 13:18 
>> Нужно просто все перелицензировать под жпл3
> "" either version 3 of the License, or (at your option) any
> later version. ""
> GPLv3+.
> Скокажможнатаспасибодосвиданья.

это значит что любой может "перевыложить" этот проект под GPLv4+ без согласования со всеми авторами (но не обязан этого делать если вышедшая GPLv4 ему не нравится)?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

14. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Andrey Mitrofanov (?), 06-Дек-18, 14:34 
>>> Нужно просто все перелицензировать под жпл3
>> "" either version 3 of the License, or (at your option) any
>> later version. ""
>> GPLv3+.
>> Скокажможнатаспасибодосвиданья.
> это значит что любой может "перевыложить" этот проект под GPLv4+ без согласования
> со всеми авторами (но не обязан этого делать если вышедшая GPLv4
> ему не нравится)?

Нет.  Это значит, что вы, не следующие инструкции по применению, опять снова в любой момент будете бегать, как курица с отрубленной головой, с "оригинальной" проблемой -

"Нужно просто все перелицензировать под жпл4".

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

18. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –2 +/
Сообщение от Аноним (1), 06-Дек-18, 15:28 
то есть кто-то сможет решить за авторов какая лицензия им нравится.
Очень у духе GPL-ков, сначала они просят перелицензировать драйвера с BSDL, на GPL - а потом отказываются отдавать исправления под предлогом что не та лицензия.

Помним-помним.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

19. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Andrey Mitrofanov (?), 06-Дек-18, 15:57 
> то есть кто-то сможет решить за авторов какая лицензия им нравится.

И этот кто-то -- таки их пользователи.

Прикинь!!

Да, это написано в GPL.   Прочитайте наконец.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

34. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –1 +/
Сообщение от Аноним (34), 07-Дек-18, 09:06 
>И этот кто-то -- таки их пользователи.

И сколько тех "пользователей" действительно сей софт пользуют, для работы например, а не для цомпеляния и дроча на лицензию?

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

36. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +1 +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 09:28 
>>И этот кто-то -- таки их пользователи.
> И сколько тех "пользователей" действительно сей софт пользуют, для работы например, а
> не для цомпеляния и дроча на лицензию?

Про сей софт не знаю.  Подозреваю немного.

Но у вас претензии-то к _лицензии_, да?

Посчитай поользователей GNU gcc, GNU glibc. GNU binutils, скажем.  Можно только в версиях под GPLv3+.

И нет, "миллионы мух ^W загрузок" _не_аргумент_.  Статистика, в лучшем.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

57. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (34), 07-Дек-18, 16:44 
Нет, у меня претензии к пользователям, которые совсем не пользователи, но которые мнение имеют и вони от них много. Я тоже статистикой не обладаю, но таки прозреваю, что "применителям" глубоко побоку, какая там лицензия, докуда это не мешает им работать, а вот борцунам за вселенскую справедливость и за все хорошее супротив всего плохого, как раз этот вопрос в одном месте и свербит.

И да, я ни "за", ни "против", ни GPL, ни BSD, ни прочих. "Чума на оба ваших дома"(с)

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

56. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (-), 07-Дек-18, 16:39 
> И сколько тех "пользователей" действительно сей софт пользуют, для работы например, а
> не для цомпеляния и дроча на лицензию?

Ну я в LibreCAD рисую. Он простой как тапка и в нем за разумное время можно нарисовать что-то несложное. Я себе кастомные корпуса для девайсов рисую, потом из листового пластика на CNC резаке крою - культурно получается. Идея не моя, сперто у других малотиражников.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

27. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +2 +/
Сообщение от КО (?), 06-Дек-18, 23:22 
>это значит что любой может "перевыложить" этот проект под GPLv4+

Это означает, что каждый может использовать продукт в соответствии с 3 версией или любой последующей. Но предоставлять кому-либо еще он обязан на тех же условиях на которых получил (т.е на 3+)

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

44. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –1 +/
Сообщение от J.L. (?), 07-Дек-18, 11:41 
>>это значит что любой может "перевыложить" этот проект под GPLv4+
> Это означает, что каждый может использовать продукт в соответствии с 3 версией
> или любой последующей. Но предоставлять кому-либо еще он обязан на тех
> же условиях на которых получил (т.е на 3+)

спасибо
а какие есть методы чтоб дать возможность в будущем поднимать версию (A)(L)GPL не передавая права и не опрашивая всех участвующих? давать на подпись некое соглашение "заранее разрешаю поднять версию (A)(L)GPL"?

Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

47. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 12:45 
[[ Хватит уже переспрашивать. Неконкретные вопросы ведут к ДЛИИИННЫм ответами и пустопорожним обсуждениям "из стороны в сторону, на месте и по кругу".  Если Вы этого и добиваетесь, я-таки всё равно продолжу: ]]

>>>это значит что любой может "перевыложить" этот проект под GPLv4+
>> Это означает, что каждый может использовать продукт в соответствии с 3 версией
>> или любой последующей. Но предоставлять кому-либо еще он обязан на тех
>> же условиях на которых получил (т.е на 3+)

[[  Я интерпретирую (#include <IANAL>) "на тех же условиях", как часть каждой конкретной vN и, думаю, реализация права полученного по v3= обязывает передавать на условиях v3=, что в случае получения на v2+, "использовании" получения по -or-above, даёт мне получение на усл.конкретной v3= и миним.обязанность передачи на v3= .... и по индукции... возможность передачи на v3+

Такие рассуждения дают [как бы] возможность форка (см.ниже) v2+ -> v2=; v2+ -> v3+;  v2+ -> v3=; и т.пр.  но не v2= <- v3+ [межа Ричарда-Линуса].  ]]

> спасибо
> а какие есть методы чтоб дать возможность в будущем поднимать версию (A)(L)GPL
> не передавая права и не опрашивая всех участвующих? давать на подпись

"GPL either version ${CURRENT} of the License, or (at your option) any later version"

_вроде_ же.

Отличие от того, что делает FSF, подписывая явные договора на передачу от всех участников себе, _может_ быть в том ....  [мои измышления, я-не-лояр, лояр-чек-подпись-required по-любому]  ..., что GPLv2+ [для примера], как на мой необразованный взгляд!,  позволяет _кому_угодно_ выпустить тот-же код под GPLv3+ [в нашем примере], но фактически это окажется форком.  Если все разрабы не "перебегут" на новую "площадку" разом, и развитие на старом месте не остановится и полностью не продолжится только  на новом.....  то получится 2 ветки, под GPLv2+ и GPLv3+, но совместимость по переносу "патчей" (в отсутствие явного созласия автора, авторов всего кода, на котором основано и их всехних лояров?)  будет только в одну сторону.

Кому оно надо такое "счастье"...

Ну, BSD и "лёгкий-легковатый" саппорт gcc-4-2-1+22коммита  в поисках... спонсера своих недешёвых привычек.

...Монти с МариаДБ супротив Оригинального Оракла, мож? -- чего там с v2+ => v3+, кто следил?

Навскидку, то есть, -- вражда и форки.

Если есть задача наоборот, объединить два форка, видимо, две стороны должны провести ревизию кода, лицензий (если разные в примере), перелицензировать[ся] к общему знаменателю,  утрясти _орг.вопросы_ (кто главный?, где хостится общий результирующий код, как поддержать при переходе пользователей с обоих "сторон" и т.пр.)

> некое соглашение "заранее разрешаю поднять версию (A)(L)GPL"?

Все, кто коммитит в проект под ${LICENЗИЯ}vN-or-above дают своё [не]явное разрешение на распространение кода под любой из or-above, то есть "на круг" и под ${LICENЗИЯ}v$((N+1)-or-above  _в частности_.  Даже без передачи прав, как  в CLA.

Наверное.  Мне верить нельзя: или самостоятельные выводы, или оплата адвоката, или поверить любому из адвокатов-или-нет в интернетах с наиболее симпотичной [из всего разнообразия!] лично Вам Т.З.  ....

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

58. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (58), 07-Дек-18, 18:29 
только что описали проблему с obj-c когда FSF пытался нагибать и что-то требовать у Apple.
Из-за тупости автовров GPL v3 (сделавших ее не совместимой) оказалось невозможно продолжать совместную разработку с теми кто захотел остаться на v2.
В результате имеем отличный проект llvm / clang

Привет фанатикам.

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

6. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +1 +/
Сообщение от fi (ok), 06-Дек-18, 11:58 
LibreCAD и FreeCAD  нужно поднажать и перейти на GPLv3 - они последние из CAD которые тормозят - тот же QCAD в 2013 перешел.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (8), 06-Дек-18, 12:35 
Тем более, что у них не столько проблем с опросом всех разработчиков, ввиду их гораздо меньшего числа, чем у разработчиков ядра.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

13. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от prokoudine (ok), 06-Дек-18, 14:05 
> LibreCAD и FreeCAD  нужно поднажать и перейти на GPLv3

https://github.com/LibreCAD/LibreCAD_3/blob/master/LICENSE

LibreCAD 3 consists of several modules and these modules may have
a different license than the application itself.
For specific licenses, check respective folders.

LibreCAD 3 itself is under the GNU GPLv3 or later License.

> они последние из CAD которые тормозят - тот же QCAD в 2013 перешел.

Если б ты ещё понимал, чем эти "тормоза" вызваны.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

12. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Ю.Т. (?), 06-Дек-18, 14:03 
Странно, почему ссылка на QCAD 3.1, если уже имеется 3.21?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от prokoudine (ok), 06-Дек-18, 14:53 
Потому что на сайте не было новости про QCad 3.21.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

30. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Ю.Т. (?), 07-Дек-18, 08:03 
> Потому что на сайте не было новости про QCad 3.21.

Не аргумент. Внешние ссылки в таких текстах всё равно нужны, и если уж разговор о версиях, нужны ещё раз.
Кроме того, данная ссылка в тексте напрямую не была использована, да и статья уже выглядит иначе.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

37. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от prokoudineemail (ok), 07-Дек-18, 09:47 
> Не аргумент.

Для тебя не аргумент, что список ссылок на посты по теме автоматически формируется из существующих, а не желаемых тобой постов?

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

39. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Ю.Т. (?), 07-Дек-18, 10:03 
>> Не аргумент.
> Для тебя не аргумент, что список ссылок на посты по теме автоматически
> формируется из существующих, а не желаемых тобой постов?

Нет. Способ формирования ссылок не моя проблема. Ценна только их релевантность.

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

15. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +2 +/
Сообщение от prokoudine (ok), 06-Дек-18, 14:41 
> Из-за невозможности включения GPLv3 кода в проекты, распространяемые под лицензией GPLv2, многие свободные САПР, такие как LibreCAD и FreeCAD, не могут использовать LibreDWG

Эта информация устарела.

В третьей ветке LibreCAD переписано доставшееся от QCad ядро вычислительной геометрии, из-за которого релицензирование было невозможно (GPLv2 only), так что GPLv2 теперь только во второй ветке проекта. В третьей уже переехали на GPLv3+.

Обновление лицензии FreeCAD изначально было заблокировано несовместимой с GPL лицензией на Coin3D и OCCT (если я правильно помню). Это было препятствие было устранено 3-4 года назад. Сейчас разработчики просто не хотят релицензировать до GPLv3+. Причины называются разные.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +2 +/
Сообщение от prokoudine (ok), 06-Дек-18, 14:59 
Ах да, на раннем этапе разработки LibreCAD_3 (года четыре назад) студиозус из GSoC прикрутил на пробу LibreDWG, но потом убрал её в пользу своей "родной" libdxfrw. А теперь ещё и libopencad прикрутили зачем-то. И с этим зоопарком они пытаются взлететь :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –1 +/
Сообщение от Аноним (-), 06-Дек-18, 16:23 
Вопросы к ежедневным пользователям.

1) Есть спецификация формата DWG, а на него самого есть какие-то лицензии, авторские права или ограничения? DWG вроде как торговая марка. Почему до сих пор не выпустили свободную историю типа ODF?

2) FreeCAD может полностью заменить всю эту 2D историю своими средствами и верстаками?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +1 +/
Сообщение от prokoudineemail (ok), 06-Дек-18, 17:13 
1) Авторы спецификации бодались с Автодеском на на эту тему. См. https://www.digitalengineering247.com/article/open-design-al... например.

2) До некоторой степени может.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

21. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  +/
Сообщение от Аноним (21), 06-Дек-18, 17:07 
>  Из-за невозможности включения GPLv3 кода в проекты, распространяемые под лицензией GPLv2

свободная лицензия, она такая

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

23. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –1 +/
Сообщение от Andrey Mitrofanov (?), 06-Дек-18, 17:43 
>>  Из-за невозможности включения GPLv3 кода в проекты, распространяемые под лицензией GPLv2
> свободная лицензия, она такая

"Свободные" лицензиары _они_ такие.

Лучше авторов лицензии знают, что в ней и -- "How to Apply These Terms to Your New Programs" -- как.
http://www.opennet.ru/openforum/vsluhforumID3/115994.html#7

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

25. "Выпуск GNU LibreDWG 0.7, библиотеки для поддержки формата DW..."  –1 +/
Сообщение от Аноним (1), 06-Дек-18, 18:41 
BSDL не страдает таким.
Только жлобский GPL имеет не совместимости между версиями.

version 2 не совместимо с version 3 - ну шо тут сделать.. карма у GPL-ков такая.
потом version 4 будет не совместима с v3.

А v5 вообще заставит бить поклоны столману, и все поставившие v3 or later автоматом попадут в рабство.
Мы такое уже проходили - когда из gcc "случайно" (мы же все верим что юристы могли случайно забыть) - исключения.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

35. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 09:19 
> BSDL не страдает таким.
> Только жлобский

Нет, ты!  http://www.opennet.ru/openforum/vsluhforumID3/112997.html#153

>GPL имеет не совместимости между версиями.

Да откудаж вы (*м), Свободные, от мозгов!, беседеельщики лезете-то?!

Когда кашку ложкой кушать изволишь, ложку-то по инструкции применяешь?  Или, как дитё несмышлёное,  в глаз, у ухо норовишь???????  Про вилку даже не начинай -- я уже фшокке.

|
Повторяй со мной:

По инcтрукции по применению: GPLv2+  абсолютно совсем окончательно всегда соместима с GPLv3+ .

По инcтрукции по применению: GPLv2+  абсолютно совсем окончательно всегда соместима с GPLv3+ .

По инcтрукции по применению: GPLv2+  абсолютно совсем окончательно всегда соместима с GPLv3+ .


Рас-рас!!  Слышно меня?  Повторяй.
|


> version 2 не совместимо с version 3 - ну шо тут сделать..
> карма у GPL-ков такая.

Твои проблемы.

> потом version 4 будет не совместима с v3.

И ты опять будешь страдать?  Хо-ро-шо1

> А v5 вообще заставит бить поклоны столману, и все поставившие v3 or
> later автоматом попадут в рабство.

Враньё.

> Мы такое уже проходили - когда из gcc "случайно" (мы же все
> верим что юристы могли случайно забыть) - исключения.

Враньё. (*л)

Впрочем, да, юристы проприертариев могли [и нет, не "случайно"] забыть почитать GPLv3 все те три-пять[-семь!!??] лет, что Столман ездил по миру и готовил выход новой версии, лекции читал, консультировался с заинтересованными...  Видать лояры потреб--телей FreeBSD, например, решили, что чем _больше_ у FreeBSD будет проблем с лицензиями, тем больше им, капроративным лоярам, потом запишут нормочасов.

У FreeBSD ж нет своих-то лояров, да?...
И тычутся они в потёмках, да.
С того самого основополагающего суда с AT&T.

Но Прогресс не остановить! Многие даже мнением о GPL обзавелись.

(*л)
http://www.opennet.ru/openforum/vsluhforumID3/107110.html#183
http://www.opennet.ru/openforum/vsluhforumID3/109978.html#38
http://www.opennet.ru/openforum/vsluhforumID3/110680.html#124
http://www.opennet.ru/openforum/vsluhforumID3/111743.html#138
http://www.opennet.ru/openforum/vsluhforumID3/111834.html#22
http://www.opennet.ru/openforum/vsluhforumID3/113867.html#53
   http://www.opennet.ru/openforum/vsluhforumID3/113867.html#29
   http://www.opennet.ru/openforum/vsluhforumID3/113867.html#56
http://www.opennet.ru/openforum/vsluhforumID3/114650.html#36

http://www.opennet.ru/openforum/vsluhforumID3/107145.html#61

(*м)
http://www.opennet.ru/openforum/vsluhforumID3/102623.html#14
http://www.opennet.ru/openforum/vsluhforumID3/112513.html#98

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

38. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  –2 +/
Сообщение от prokoudineemail (ok), 07-Дек-18, 09:49 
GPLv2 only (LibreCAD 2.x) несовместима с GPLv3+ (LibreDWG), хоть ты убейся.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

40. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 10:45 
> GPLv2 only (LibreCAD 2.x) несовместима с GPLv3+ (LibreDWG), хоть ты убейся.

Казалось бы, при чём тут Лужков ^W я.

...мочало, начинай с начала. http://www.opennet.ru/openforum/vsluhforumID3/115994.html#23

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

42. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от prokoudine (ok), 07-Дек-18, 10:54 
>> GPLv2 only (LibreCAD 2.x) несовместима с GPLv3+ (LibreDWG), хоть ты убейся.
> Казалось бы, при чём тут Лужков ^W я.
> ...мочало, начинай с начала. http://www.opennet.ru/openforum/vsluhforumID3/115994.html#23

https://www.gnu.org/licenses/gpl-faq.en.html#v2v3Compatibility

No. Many requirements have changed from GPLv2 to GPLv3, which means that the precise requirement of GPLv2 is not present in GPLv3, and vice versa. For instance, the Termination conditions of GPLv3 are considerably more permissive than those of GPLv2, and thus different from the Termination conditions of GPLv2.

Due to these differences, the two licenses are not compatible: if you tried to combine code released under GPLv2 with code under GPLv3, you would violate section 6 of GPLv2.

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

45. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 12:01 
>>> GPLv2 only (LibreCAD 2.x) несовместима с GPLv3+ (LibreDWG), хоть ты убейся.
>> Казалось бы, при чём тут Лужков ^W я.
>www.gnu.org/licenses/gpl-faq.en.html#v2v3Compatibility

Спасибо за кол-мочало-начало, я в курсе, спасибо.

Теперь я понял, "хоть ты убейся" было не про меня.

Кто "убейся"-то?

Вижу два проекта с несовместимыми лицензиями.

Если им обоим _надо_, они _могут_ менять лицензии, двигаться к совместимости.

Если им _не_надо_, могут или прямо об этом сказать, или, как большинство ораторов на форумах, обвинять в своих проблемах с танцами _кого_угодно_ и всех остальных, кроме себя.  Вот примерно, как ты убейся, я убейся, он убейся.

Можно ещё пообвинять друг дружку, поискать виноватого в том, откуда есть пошла и кто создал рассматриваемую совместимость.  Тоже _отличный_ повод по-пере-кидываться ароматными форумными постами.

Тут разговаривать не о чем -- всё по 100500 раз жёвано-пережёвано, кидано-перекидано.  Форумные комментарии _не_ приводят ни к какому движению [к совместимости - выше].

Другие предложения?

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

46. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от prokoudine (ok), 07-Дек-18, 12:09 
> Кто "убейся"-то?

Ты.

> Если им обоим _надо_, они _могут_ менять лицензии, двигаться к совместимости.

Нет, авторы LibreCAD и LibreDWG не могут взять и просто поменять лицензии. И это именно что жёвано и пережёвано по сто раз. Но тебе обязательно нужно влезть со своим очень ценным мнением, не имеющим никакого отношения к реальности.

Парень, есть матчасть. Её надо знать. Ну или не знать. Но тогда и не постить всякую фигню.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

48. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 13:24 
>> Кто "убейся"-то?
> Ты.

Вот это обидно было счас.  

>> Если им обоим _надо_, они _могут_ менять лицензии, двигаться к совместимости.
> Нет, авторы LibreCAD и LibreDWG не могут взять и просто поменять лицензии.

Не "не могут", а не хотят.  Впрочем, ладно, те, которые "под ярмом Столмана" и рпавда не могут.  Окэ.

> И это именно что жёвано и пережёвано по сто раз. Но
> тебе обязательно нужно влезть со своим очень ценным мнением, не имеющим
> никакого отношения к реальности.

Ценных мений два.  Я написал об этом выше.

№1:  У нас GPLv2== и менять её мы не хочим/можим/будим.
  и
№2Ж  У нас GPLv3+ и менять её мы хочим/можим/будим только в сторону N>3.

Всё остальное лирика.

Обвинения с одной стороны в сторону другой, её лицензии, бузинес-практик, личной чистоплотности итпр. приведут к "диалогу" только в виде ответных обвинений.

> Парень, есть матчасть. Её надо знать. Ну или не знать. Но тогда
> и не постить всякую фигню.

Это значит, что ничего нельзя изменить, и ничего не изменится?

Окэ.

Можете в _это_ верить.

А фигню я буду постить -- в ответ на фигню.  Свободный Интернет, о волки---

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

49. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +1 +/
Сообщение от prokoudine (ok), 07-Дек-18, 13:42 
> Не "не могут", а не хотят.  Впрочем, ладно, те, которые "под ярмом Столмана" и рпавда не могут.  Окэ.

Я довольно понятным русским языком описал ситуацию с либрекадом выше. Ещё более понятным русским языком, в подробностях и с цитатами непосредственных участников событий я это описывал лет шесть назад в отдельной статье. Даже тут, на опеннете, перепощивали. Можно пойти ознакомиться. Или хотя бы почитать коммент выше — это занимает примерно полминуты.

Почему надо 100500 раз повторять, что нельзя взять и перелицензировать чужой GPLv2 only код под GPLv3+ потому, что так захотелось, без разрешения владельца копирайта?

Почему надо 100500 раз напоминать, что FSF отказались делать даунгрейд LibreDWG до GPLv2+, в связи с чем LibreDWG не может сделать вообще никаких подвижек в сторону проектов с несовместимой лицензией?

Почему надо 100500 раз тыкать пальцами в репозиторий с LibreCAD_3 и показывать, что за четыре года переписывания ядра (которое в 2.х под GPLv2 only) эта ветка проекта так и не стала хоть сколь-либо юзабельной, так что пользователям приходится жить на второй ветке и без нормальной поддержки DWG?

Ты взрослый мужик. Ты вроде умеешь читать. Ну камон.

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

50. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 14:27 
> Почему надо 100500 раз повторять, что нельзя взять и перелицензировать чужой GPLv2
> only код под GPLv3+ потому, что так захотелось, без разрешения владельца
> копирайта?

Я писал, что можно?

Плохой я, покарай меня и повтори ещё что-нибудь ещё два... нет, ТРИ! раза.

> Почему надо 100500 раз напоминать, что FSF отказались делать даунгрейд LibreDWG до
> GPLv2+, в связи с чем LibreDWG не может сделать вообще никаких
> подвижек в сторону проектов с несовместимой лицензией?

Ээээ.  Раз.  "под ярмом Столмана"

> Почему надо 100500 раз тыкать пальцами в репозиторий с LibreCAD_3 и показывать,
> что за четыре года переписывания ядра (которое в 2.х под GPLv2
> only) эта ветка проекта так и не стала хоть сколь-либо юзабельной,
>юзабельной,

Это _несущественные_ мелочи.

> так что пользователям приходится жить на второй ветке и без нормальной
> поддержки DWG?

И правильный ответ "патамучта Столман GPLv3+" ?   О, не-е-е-т!111

> Ты взрослый мужик. Ты вроде умеешь читать. Ну камон.

Поймал, так поймал...

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

51. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +1 +/
Сообщение от prokoudine (ok), 07-Дек-18, 14:41 
>> Почему надо 100500 раз повторять, что нельзя взять и перелицензировать чужой GPLv2
>> only код под GPLv3+ потому, что так захотелось, без разрешения владельца
>> копирайта?
> Я писал, что можно?

Да. Ты писал: "Если им обоим _надо_, они _могут_ менять лицензии, двигаться к совместимости".

Как убедительно продемонстрировано выше — не могут. Сначала надо написать туеву хучу кода с нуля.

>> Почему надо 100500 раз тыкать пальцами в репозиторий с LibreCAD_3 и показывать,
>> что за четыре года переписывания ядра (которое в 2.х под GPLv2
>> only) эта ветка проекта так и не стала хоть сколь-либо юзабельной,
> >юзабельной,
> Это _несущественные_ мелочи.

Это "мелочи" настолько "несущественны", что делают либрекад непригодным к использованию в среде, где принято обмениваться файлами DWG. Т.е. почти везде.

>> так что пользователям приходится жить на второй ветке и без нормальной
>> поддержки DWG?
> И правильный ответ "патамучта Столман GPLv3+" ?

Да, шесть (или сколько там) лет назад можно было сделать даунгрейд лицензии, и сейчас у людей был бы рабочий либрекад 2.х с поддержкой DWG.

Столлман пошёл на принцип — поэтому либрекад теперь нужен узкой прослойке таких же принципиальных как он фанатов.

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

52. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от prokoudine (ok), 07-Дек-18, 15:01 
> Ээээ.  Раз.  "под ярмом Столмана"

Это исправление ты внёс уже сильно позднее. А до этого бегал и закатывал глаза, мол, какие все тупые кругом.

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

53. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Andrey Mitrofanov (?), 07-Дек-18, 15:24 
>> Ээээ.  Раз.  "под ярмом Столмана"
> Это исправление ты внёс уже сильно позднее. А до этого бегал и
> закатывал глаза, мол, какие все тупые кругом.

Да, всё-всё.  Не все.  Тебя признаю острым.

А хотя нет, постой...  Хотя да, "не по инструкции" -- тупые, все.

Всё так.

Только я не "глаза закатываю", а даю "альтернативное прочтение ситуации".  Настолько альтернативное, что признал наличие двух сторон сего танца.  На Ваш вкус слишком?  Посыпаю голову, ухожу, лан.

Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

64. "Я сегодня добрый, повторю ещё раз.  БЫЛО:  Выпуск GNU Libre..."  +/
Сообщение от Аноним (64), 08-Дек-18, 22:02 
не смотри на местного дурочка, он идейный. Главное для него идея - а что в результате получим не рабочий софт, это мелочи.
Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor