The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Релиз системы самодостаточных пакетов Flatpak 1.14.0"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от opennews (?), 24-Авг-22, 11:44 
Опубликована  новая стабильная ветка инструментария Flatpak 1.14, который предоставляет систему для сборки самодостаточных пакетов, не привязанных к конкретным дистрибутивам Linux и выполняемых в специальном контейнере, изолирующем приложение от остальной системы. Поддержка выполнения Flatpak-пакетов обеспечена для Arch Linux, CentOS, Debian, Fedora, Gentoo, Mageia, Linux Mint, Alt Linux и Ubuntu. Пакеты с Flatpak включены в репозиторий Fedora и поддерживаются в штатной программе управления приложениями GNOME...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=57673

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Klizma (?), 24-Авг-22, 11:44 
Лучшие! молодцы.
Ответить | Правка | Наверх | Cообщить модератору

22. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от Аноним (22), 24-Авг-22, 12:50 
а в чём, позвольте полюбопытствовать, они молодцы?
Ответить | Правка | Наверх | Cообщить модератору

70. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (70), 24-Авг-22, 17:23 
Очевидно же, в том, что создали инструмент для разработчиков приложений, котрый даёт возможность упростить распространение своих программ. А простым пользрователям дает возможность без каких-либо дополнительных телодвижений пользоваться свежими версиями этих программ, а не шарить по варезным сторонним репозиториям, приложения в которых могут быть несовместимы с текущими установленными зависимыми библиотеками.
Ответить | Правка | Наверх | Cообщить модератору

83. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от Аноним (83), 24-Авг-22, 18:03 
> приложения в которых могут быть несовместимы с текущими установленными зависимыми библиотеками.

библиотеки в шлакпаке могут быть несовместимы с текущей установленной системой.

Ответить | Правка | Наверх | Cообщить модератору

153. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от _hide_ (ok), 25-Авг-22, 10:28 
А статическая линковка чем плоха?
Ответить | Правка | Наверх | Cообщить модератору

185. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (185), 26-Авг-22, 00:52 
> чем плоха?

Всем, если версия либы конфликтует с системой по любому поводу.

Ответить | Правка | Наверх | Cообщить модератору

186. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –1 +/
Сообщение от _hide_ (ok), 26-Авг-22, 09:46 
> Всем, если версия либы конфликтует с системой по любому поводу.

И раз мы не в состоянии определиться с версией библиотеки (но каким-то боком тащим её в зависимости), то будем запускать приложение полностью в контейнере. Опупеть. Я чувствую, что чего-то не понимаю в этом мире (на самом деле такой подход называется "жрите с лопаты").

Ответить | Правка | Наверх | Cообщить модератору

194. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (194), 26-Авг-22, 20:57 
Жор памяти: что оперативки, что диска. Протухшие, уязвимые зависимости.
Ответить | Правка | К родителю #153 | Наверх | Cообщить модератору

197. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Neon (??), 28-Авг-22, 00:29 
А дыры в статически прилинкованных библиотеках останутся дырами навсегда ?))) Кто их затыкать будет
Ответить | Правка | К родителю #153 | Наверх | Cообщить модератору

109. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (109), 24-Авг-22, 21:13 
Благодаря шлакбяке пользователь теперь может ставить васянские приложения с набором рекомендованных васяном ископаемых библиотек!
WinSxS как есть. Другой, но точно такой же.
Ответить | Правка | К родителю #70 | Наверх | Cообщить модератору

111. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Bdfybec (?), 24-Авг-22, 21:22 
На практике, наоборот, в флэтпаке более свежие библиотеки, чем в диструбутиве.
Ответить | Правка | Наверх | Cообщить модератору

139. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от КО (?), 25-Авг-22, 05:27 
"изолированное окружение полностью независимо от используемого дистрибутива"
-Представьте если в винде все директы, вулканы, visual c++ жрали место отдельно для каждой программы...
-Да ну бред, какой-то.
Ответить | Правка | Наверх | Cообщить модератору

147. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от BeLord (ok), 25-Авг-22, 09:42 
Если бы под Виндой, можно было указать проге каталог и она свой хлам складывала только туда, а не засоряла систему, это было бы счастье. Место на диске вообще не важный параметр.
Ответить | Правка | Наверх | Cообщить модератору

198. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Neon (??), 28-Авг-22, 01:10 
Ну так обычно и делается под Виндой. Каждая программа хранится в своем каталоге и там же её динамические библиотеки. И ищутся они по умолчанию в каталоге программы, а не как в линуксах, пока не ткнешь носом, не догадается, что библиотеки рядом лежат с исполняемым файлом.
Ответить | Правка | Наверх | Cообщить модератору

181. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (109), 25-Авг-22, 21:58 
Куда уж свежее чем в раче.
Ответить | Правка | К родителю #111 | Наверх | Cообщить модератору

177. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:56 
Вот именно, что может. А когда может пересобрать приложение со свежими библотеками, то обновит пакет. Но когда не может, то хотя бы так.

Напомнить, как было раньше? Обновление Debian. Из репозиториев удалено 0, 1, ..., n приложение по причине несовместимости со "свежими" (даже по меркам Дебиана) тулкитами и отсутствия поддержки со стороны разработчика. И всё, приплыли.

И это открытое ПО, где каждый может форкнуть и обновить. Может, да не хочет.
А в закрытом ПО и выбирать не приходится. Разработчик вывалил с лопаты - жрите, что дают. Не работает с новым Куте, а старого уже нет в репах? Ваши проблемы.

До сих пор коробит, сколько отличных программ на Gtk2 были выброшены из репозиториев на мороз, потому что не поспевали за трендами. А другие насилком, кое-как портировались на Gtk3, чтобы не вылететь.

Ответить | Правка | К родителю #109 | Наверх | Cообщить модератору

182. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (109), 25-Авг-22, 21:59 
> А когда может пересобрать приложение со свежими библотеками

Никогда. Зачем? И так сойдет!

Ответить | Правка | Наверх | Cообщить модератору

188. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от йцук (?), 26-Авг-22, 11:57 
https://flatkill.org/

Не молодцы.

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

2. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Балалайка (?), 24-Авг-22, 12:03 
Гладко было на бумаге, да забыли про овраги.
Ответить | Правка | Наверх | Cообщить модератору

3. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –5 +/
Сообщение от pashev.ru (?), 24-Авг-22, 12:03 
# apt-mark showhold
flatpak
flatpak-builder
flatpak-xdg-utils
xdg-desktop-portal
xdg-desktop-portal-gtk

Ответить | Правка | Наверх | Cообщить модератору

4. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –3 +/
Сообщение от pashev.ru (?), 24-Авг-22, 12:04 
↑↑ пакеты не установлены.
Ответить | Правка | Наверх | Cообщить модератору

5. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (5), 24-Авг-22, 12:09 
а че, в никсоси теперь apt? Эй, Пашев.ру, ты че.
Ответить | Правка | К родителю #3 | Наверх | Cообщить модератору

27. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от EuPhobos (ok), 24-Авг-22, 12:54 
..и в ios apt, и в андройде apt.. почему бы не в никсОсе?
Ответить | Правка | Наверх | Cообщить модератору

6. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +8 +/
Сообщение от Анончик (?), 24-Авг-22, 12:10 
Жрет место как не в себя. Куча зависимостей и костыль на костыле костылем погоняет.
Ответить | Правка | Наверх | Cообщить модератору

46. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Kuromi (ok), 24-Авг-22, 14:19 
Ну так потому что "Flatpak создаёт отдельный от системы контейнер и оперирует крупными runtime-наборами, предоставляя в качестве зависимостей не пакеты, а типовые системные окружения".

Печалька, но у любого решения есть и плюсы и минусы.

Ответить | Правка | Наверх | Cообщить модератору

60. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от sdkhflskhgl (?), 24-Авг-22, 16:11 
а какие здесь плюсы? так и до дистрибутива на программу докатиться недолго
Ответить | Правка | Наверх | Cообщить модератору

62. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от Аноним (62), 24-Авг-22, 16:31 
Docker же
Ответить | Правка | Наверх | Cообщить модератору

82. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Kuromi (ok), 24-Авг-22, 17:51 
> а какие здесь плюсы? так и до дистрибутива на программу докатиться недолго

Плюсы у всей этой затеи, что Шнапс, что Фталпак - для удобства разработчков и мейнтейнеров. Удобство ПОЛЬЗОВАТЕЛЯ тут в самую последнюю очередь, разве что в духе "Ну вот тебе последняя версия софтины, хотя бы в виде флатпака, иначе долбайся сам". Что, много места занимает? Ну, се ля ви. И вообще, именно для этого вы террабайтный SSD покупали, не киношки же там хранить :)) Вероятнее всего логика именно такая.

Как я уже писал ИНОГДА эти штуки пригождаются, мне в своё время до зарезу нужен был VLC 3, которого в репозитория дистрибутива не было и быть не могло из-за зависимостей. Пригодился Флатпак, но как основной способ распространения софта это все просто ужасно. Тормознуто, глючно и раздуто.

Ответить | Правка | К родителю #60 | Наверх | Cообщить модератору

101. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Отражение луны (ok), 24-Авг-22, 19:37 
Для юзера отлично, что приложеньки можно ставить напрямую со стора, вместо того, чтобы лзиить по сайтам, выполнять какие-то команды на подключение странных реп, которые тебе еще и систему убить могут.
Все доступно в 1 клик.
Ответить | Правка | Наверх | Cообщить модератору

134. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (134), 25-Авг-22, 03:16 
Для юзера винды.
Ответить | Правка | Наверх | Cообщить модератору

156. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 25-Авг-22, 11:10 
> Фталпак - для удобства разработчков

Я что-то не вижу радостной толпы разрабочиков использующих это.
Добавляет огромную кучу проблем.

Ответить | Правка | К родителю #82 | Наверх | Cообщить модератору

95. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Анончик (?), 24-Авг-22, 19:08 
В бытность skype когда еще не было докера и прочей прелестей, пихал это самый skype в chroot, через ldd выковыривали зависимости, звук прокидывали. Все работало. И главное занимало очень мало места.

А что мне flatpak предлагает? Бахнуть рантайм от федоры, вжух -400 мбайт. Другое приложение хочет рантайм от убунты. Вжух -400 мбайт. Я как пользователь этого зоопарка смотрю и фигею.
Мне тут проще самому нужный пакет собрать, тем более в некоторых дистрибутивах, не будем показывать пальцем, некоторые пакеты старые.

Ответить | Правка | К родителю #46 | Наверх | Cообщить модератору

96. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (96), 24-Авг-22, 19:15 
Это ты где рантайм убунты во flatpack увидел? И рантайм федоры можешь не ставить, если не подключишь репозиторий федоры.
Ответить | Правка | Наверх | Cообщить модератору

117. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Анончик (?), 24-Авг-22, 22:18 
может я что то и путаю, сейчас проверить не могу я его снес.
ставил OpenShot и blender, и мне не понравилось по занимаемому месту.
Ответить | Правка | Наверх | Cообщить модератору

97. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (97), 24-Авг-22, 19:16 
В этом смысле там пока только один рантайм предлагают. От Flathub'а. Просто runtime'ом они условно называют все KDE библиотеки в одном пакете. Или Gnome. Или другой большой набор совместно используемых библиотек.
Ответить | Правка | К родителю #95 | Наверх | Cообщить модератору

71. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (70), 24-Авг-22, 17:25 
О какой куче речь? Ты список покажи. Чушь написать каждый может.
Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

7. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от Аноним (7), 24-Авг-22, 12:10 
Обожаю, когда к каждому пакету пара гигов зависимостей
Ответить | Правка | Наверх | Cообщить модератору

72. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (70), 24-Авг-22, 17:28 
тогда тебе на Windows надо переходить, так как раз так, как ты обожаешь.
Ответить | Правка | Наверх | Cообщить модератору

79. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 24-Авг-22, 17:37 
Ну в Windows хотя бы гигабайт KDE просто так не прилетит с телеграммом, как мне в Flatpak.
Ответить | Правка | Наверх | Cообщить модератору

86. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (97), 24-Авг-22, 18:19 
Во Flatpak тебе лишь один раз на все пакеты прилетит по полгига пары-тройки, по необходимости, рантаймов (KDE,Gnome,freedesktop). Новые версии будут как бинарные diff'ы к предыдущим. Причем старые удалятся, если не используются ни одним приложением.

В Винде каждый телеграмм, блокнот и калькулятор притащит в систему тонну зависимостей отличающихся от уже установленных последней цифрой в номере версии. Поставит рядом и оставит до следущей ежемесячной плановой переустановки Винды.

Хотя, в Винде обычно предустановленных рантаймов целый вагон. Три мажорных версии dotNETа, как-минимум. Чтобы инсталлятор драйвера от Невидии запустился. Без дотнетов же никак не поставить драйвер..

Ответить | Правка | Наверх | Cообщить модератору

118. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от microsoft (?), 24-Авг-22, 22:34 
Смотрю размер телеги винды, 50 мб. Смотрю размер телеги хрясьпака, более 800 метров. Хмммм... кажется ты лжец.
Ответить | Правка | Наверх | Cообщить модератору

164. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (177), 25-Авг-22, 17:35 
Кажется, Телеграм - это для школьников.

В любом случае:
> ID Download
> org.telegram.desktop.webview < 35.9 MB
> org.telegram.desktop < 56.0 MB

Ответить | Правка | Наверх | Cообщить модератору

119. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от microsoft (?), 24-Авг-22, 22:36 
Пысы, смотрю у меня нету донетав, а драйвер нвиди ставится нормально. Хмммм... у тебя патология.
Ответить | Правка | К родителю #86 | Наверх | Cообщить модератору

165. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 17:38 
У тебя проблемы со зрением. Инсталлятор драйвера Невидии построен на NETFramework и без него, очевидно, не запустится. И с ним не запустится, если не угадать с мажорной версией.
Ответить | Правка | Наверх | Cообщить модератору

140. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 25-Авг-22, 07:17 
> Во Flatpak тебе лишь один раз на все пакеты прилетит по полгига пары-тройки, по необходимости

Я же написал - гиг КДЕ.

Ответить | Правка | К родителю #86 | Наверх | Cообщить модератору

166. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 17:39 
Там KDE и Qt. Два в одном гиге.
Ответить | Правка | Наверх | Cообщить модератору

141. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 25-Авг-22, 07:20 
> Новые версии будут как бинарные diff'ы к предыдущим.

Кстате отдельная байка, про могучий diff.

В случае жирных файлов ака локализация KDE. Поправили там точку в жирном при жирном лакализации - всё будет жрать по полной без diff.  

Ответить | Правка | К родителю #86 | Наверх | Cообщить модератору

167. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 17:42 
Бинарные диффы, действительно, не так хороши, как текстовые. Но это компенсируется своевременным обновлением зависимостей со стороны сопроводителя, и удалением неиспользуемого со стороны пользователя.
Ответить | Правка | Наверх | Cообщить модератору

143. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 25-Авг-22, 07:26 
> Причем старые удалятся, если не используются ни одним приложением.

Не заметил, может на бумаге в теории. на практике баг на баге

https://github.com/flatpak/flatpak/issues?page=2&q=is%3...

Ответить | Правка | К родителю #86 | Наверх | Cообщить модератору

168. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 17:45 
Всё ещё можно удалить весь мусор одной командой:
flatpak uninstall --unused
А теперь попробуй так в Винде.

Баги, уязвимости и т.п. - это временное и ненормированное поведение. Не аргумент.

Ответить | Правка | Наверх | Cообщить модератору

179. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от iPony129412 (?), 25-Авг-22, 19:36 
И это не сработает.

> Баги, уязвимости и т.п. - это временное и ненормированное поведен

Аргумент. особенно учтивая сколько лет Flatpak.

> теперь попробуй так в Винде

И начинается сравнение реальной Windows, с этаким выдуманным нереальном линуксом с идеальным и вылизанным Flatpak с хороше инфраструктурой.

Ответить | Правка | Наверх | Cообщить модератору

189. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (194), 26-Авг-22, 13:59 
Сработает.

Все эти много лет Flatpak активно развивался, а не покрывался плесенью.

Выдуманные и нереальные - "проблемы" на Гитхабе, треть которых уже закрыта, треть написана идиотами, оставшиеся трудновоспроизводимы в окружениях близких к адекватным.

А в "идеальной" Винде за десятки лет так даже доставку ПО так и не смогли нормально реализовать. Ходят несчастные по файлопомойкам устанавливают трояны и мейлру.помощники и ругают клятый Линукс.

Ответить | Правка | Наверх | Cообщить модератору

110. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (109), 24-Авг-22, 21:16 
Берешь какой-нибудь SmPlayer. О он радостно ставит культи.
Ответить | Правка | К родителю #79 | Наверх | Cообщить модератору

112. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Bdfybec (?), 24-Авг-22, 21:28 
Ты что хотел сказать-то? Что где-то SmPlayer будет работать без культей?
Ответить | Правка | Наверх | Cообщить модератору

184. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (109), 25-Авг-22, 22:04 
То, что в винде каждая софтина на Qt таскает экземпляр культей с собой.
Ответить | Правка | Наверх | Cообщить модератору

142. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 25-Авг-22, 07:21 
> Берешь какой-нибудь SmPlayer. О он радостно ставит культи.

Ты не видишь разницу между QT и кучей KDE барахла?

Ответить | Правка | К родителю #110 | Наверх | Cообщить модератору

169. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 17:49 
Это проблема только для тех, кто ставит один пакет, чтобы повозмущаться. Когда используемых пакетов десятки, большой роли не играет таскать с Qt ещё и KDElibs, или нет. Наверняка, оба будут в зависимостях.
Ответить | Правка | К родителю #110 | Наверх | Cообщить модератору

130. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (130), 25-Авг-22, 00:29 
> Хотя, в Винде обычно предустановленных рантаймов целый вагон.

Нет.

Ответить | Правка | К родителю #79 | Наверх | Cообщить модератору

170. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:05 
Как минимум, через системные обновления прилетают увесистые NETFramework 3.x, 4.x и дальше больше.

А так - да, вместо использования системных обновлений, в Винде принято всё отдельными инсталляторами с приложениями поставлять. Причем, нарочно спроектированными так, чтобы таскать их пришлось при любых минорных отличиях от предустановленных. Впрочем, узнать какие предустановлены тоже никак нельзя.

Поэтому ворох языковых рантаймов неизбежно прилетит с приложениями на C++, Java, ActionScript. А также ворох DirectX, PhysX и т.п. с приложениями использующими эти API.

Ответить | Правка | Наверх | Cообщить модератору

9. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Гость (??), 24-Авг-22, 12:13 
Популярный запрос в интернете:
bubblewrap блокирует flatpak chromium-based browsers на alt linux.

На Альте не работают флетпаки с браузерами на основе хромиума - это хорошая защита Альта или как?

Ответить | Правка | Наверх | Cообщить модератору

11. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Амомин (?), 24-Авг-22, 12:30 
Я не смог в Альте Телегу на флатпаке под пользователем установить - ни Телегу не обновляют, ни Флатпак нормально не работает. Так что скорее всего - последнее.
Ответить | Правка | Наверх | Cообщить модератору

64. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (64), 24-Авг-22, 16:43 
Надо ставить нормально поддерживаемые майнстримные ос - debian, ubuntu, mint, arch, manjaro, fedora, opensuse. А всякие васяновские подделки не нужны
Ответить | Правка | Наверх | Cообщить модератору

67. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Бывалый (?), 24-Авг-22, 17:03 
Ничего нового - ищем где послаще
Ответить | Правка | Наверх | Cообщить модератору

120. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –1 +/
Сообщение от microsoft (?), 24-Авг-22, 22:37 
Ты хотел сказать - просто поставьте шиндовс?
Ответить | Правка | К родителю #64 | Наверх | Cообщить модератору

52. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Бывалый смузихлёб (?), 24-Авг-22, 15:25 
это хорошая защита Альта от ухода пользователя с тропы юниксвейности
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

80. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (80), 24-Авг-22, 17:38 
Альт с Вентоя не ставится, не может решить, что делать с флэшкой, на которой лежит )
Ответить | Правка | Наверх | Cообщить модератору

63. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от я из фейсбука (?), 24-Авг-22, 16:43 
Попробуй Астру
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

10. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от какая разница (?), 24-Авг-22, 12:22 
Это https://www.opennet.ru/opennews/art.shtml?num=57662 включили по умолчанию?
Ответить | Правка | Наверх | Cообщить модератору

39. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (62), 24-Авг-22, 13:38 
Само собой, а куда же без самого главного
Ответить | Правка | Наверх | Cообщить модератору

89. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (97), 24-Авг-22, 18:33 
А что должны были включить в клиент (Flatpak)? Обещали только модернизацию серверного бэкенда (Flathub).
Ответить | Правка | К родителю #10 | Наверх | Cообщить модератору

12. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –3 +/
Сообщение от Аноним (12), 24-Авг-22, 12:32 
что посоветуют опытные линуксоиды: flatpak, snap или appimage?
Ответить | Правка | Наверх | Cообщить модератору

15. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +14 +/
Сообщение от Аноним (83), 24-Авг-22, 12:40 
deb, rpm, tar.gz
Ответить | Правка | Наверх | Cообщить модератору

29. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +9 +/
Сообщение от Анонимemail (29), 24-Авг-22, 12:57 
ebuild, попрошу!
Ответить | Правка | Наверх | Cообщить модератору

47. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от ryoken (ok), 24-Авг-22, 14:22 
ППКС
Ответить | Правка | Наверх | Cообщить модератору

133. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iCat (ok), 25-Авг-22, 02:10 
>ebuild, попрошу!

Трудно написать самостоятельно?
Чаще всего - нетрудно.

Ответить | Правка | К родителю #29 | Наверх | Cообщить модератору

16. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (16), 24-Авг-22, 12:40 
Пакеты AppImage собранные собственоручно.
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

58. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от _kp (ok), 24-Авг-22, 16:08 
Если уж самому собирать, то на кой мне тогда всякие Appimage.
Там смысл, чтоб работало на какой нибудь системе, а собираеть можно сразу под нужную.
Ответить | Правка | Наверх | Cообщить модератору

131. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (131), 25-Авг-22, 00:31 
Смысл не только, чтоб везде, но и чтоб не болтались в основной системе какие-то уникальные, нужные только конткретной проге, зависимости.
Ответить | Правка | Наверх | Cообщить модератору

159. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от _kp (ok), 25-Авг-22, 14:55 
>  чтоб не болтались в основной системе какие-то уникальные .. зависимости.

Стоп. Мы же под конкретную систему и собираем, а не для раздачи.
Явно место установки типа /opt. Если конфликт имен и версий, то префиксы.
Какие там конфликты?

А если надо в на чем то типа Devuan запихать systemd в snap, или подобные научные эксперименты, то лучше уж  виртуалки.  :)


Ответить | Правка | Наверх | Cообщить модератору

17. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +6 +/
Сообщение от Аноним (17), 24-Авг-22, 12:41 
Опытные линуксоиды советуют ставить из репозитариев, но если очень хочется пожрать добра, то возьми appimage.
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

33. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от CDCromemail (??), 24-Авг-22, 13:15 
Мне в Appimage понравилась возможность взять приложение с собой на флешке и спокойно запустить без бубнов на другой машине.
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

35. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Ваня (??), 24-Авг-22, 13:34 
срр и нрр
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

38. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (12), 24-Авг-22, 13:36 
Хип-хоп, хаус и рок-н-ролл?
Ответить | Правка | Наверх | Cообщить модератору

36. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (36), 24-Авг-22, 13:35 
appimage
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

40. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (62), 24-Авг-22, 13:41 
Собрать вручную из исходников.
configure
Make
Make install

Все пакеты для латентных виндузятников

Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

43. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (12), 24-Авг-22, 13:49 
Это вам в #2.15 нужно было отвечать
Ответить | Правка | Наверх | Cообщить модератору

54. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Бывалый смузихлёб (?), 24-Авг-22, 15:27 
но что если всё чуть сложнее ввода пары-тройки команд, заточенных под способности самой дурной обезьяны ?
Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

66. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (64), 24-Авг-22, 16:48 
Ага, на старых слабых ноутах по паре часов каждый пакет собирать, как раз на несколько суток для всех нужных программ, да ещё и за обновами вручную следить на всех гитхабах
Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

61. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (61), 24-Авг-22, 16:30 
С точки зрения функциональности - портаж, юзабилити - пакман.
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

65. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –1 +/
Сообщение от Аноним (64), 24-Авг-22, 16:47 
Говори правильно. Не pacman, а pamac
Ответить | Правка | Наверх | Cообщить модератору

73. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (70), 24-Авг-22, 17:29 
Очевидно же что  flatpak
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

90. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (97), 24-Авг-22, 18:34 
Интернет-опрос показал, что 100% опрошенных пользуются Интернетом?
Ответить | Правка | Наверх | Cообщить модератору

121. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от microsoft (?), 24-Авг-22, 22:39 
Посоветуют больше не связываться с ляликсам на десктопах. он там умер. ляликс только для серверов
Ответить | Правка | К родителю #12 | Наверх | Cообщить модератору

13. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +6 +/
Сообщение от Аноним (13), 24-Авг-22, 12:36 
Почему из новости в новость про флатпак вранье. При чем тут самодостаточные пакеты? Как пакеты, требующие установки рантайма, могут называться самодостаточными? Или у вас выпускники журфака новости пишут? gecrfq
Ответить | Правка | Наверх | Cообщить модератору

18. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (83), 24-Авг-22, 12:41 
> Или у вас выпускники журфака новости пишут?

Более того, они ещё и придумывают всё это...

Ответить | Правка | Наверх | Cообщить модератору

20. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (83), 24-Авг-22, 12:42 
P.S. Не все журфаковцы идут работать "свободная касса!", кто-то даже в кодинг сваливается.
Ответить | Правка | Наверх | Cообщить модератору

31. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от КрымчунЗлой (?), 24-Авг-22, 13:10 
Вот, вот. Самодостаточен только appimage. Скачал и запустил. Остальным нужно непоими какое Г окружение непойми каких версий.
Ответить | Правка | К родителю #18 | Наверх | Cообщить модератору

44. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (13), 24-Авг-22, 13:54 
>Вот, вот. Самодостаточен только appimage. Скачал и запустил.

Угу, правда если он запуститься. А то тут как повезет.

Ответить | Правка | Наверх | Cообщить модератору

154. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от _hide_ (ok), 25-Авг-22, 10:37 
Да, есть такое. Ну тут можно просто сформировать список пакетов с обязательными зависимостями для своего дистрибутива.
Без X-ов большая часть гуйёвин не работает :-)
Ответить | Правка | Наверх | Cообщить модератору

21. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (16), 24-Авг-22, 12:45 
По моему скромному мнению, не могут. В самодостаточный должны быть и GTK (Qt) требуемых версий засунуты.
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

37. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Ваня (??), 24-Авг-22, 13:36 
Демон то понятно.
Штука в том, что они еще и другие флатпаки требовают.
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

41. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –6 +/
Сообщение от Аноним (62), 24-Авг-22, 13:42 
В этом суть так называемого "свободного" ПО. Одно сплошное враньё и маркетинговый булшит
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

45. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (16), 24-Авг-22, 14:11 
Маркетинг предполагает профит на карман, что более подходит для проприетарного ПО.
Ответить | Правка | Наверх | Cообщить модератору

59. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (59), 24-Авг-22, 16:11 
Не стоит проицировать свои фантазии на реальный мир
Ответить | Правка | К родителю #41 | Наверх | Cообщить модератору

122. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от microsoft (?), 24-Авг-22, 22:42 
Это не фантазии уж как с 2002 года.
Ответить | Правка | Наверх | Cообщить модератору

128. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (131), 25-Авг-22, 00:22 
А чего в 2002 такого знаменательного было?
Ответить | Правка | Наверх | Cообщить модератору

50. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от FixingGunsInAir (ok), 24-Авг-22, 14:42 
По тем же причинам, по которым некоторые умники называют Docker самодостаточным.
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

55. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Juha (ok), 24-Авг-22, 15:34 
Так же как любой пакет в системе что то да требует. Внезапно.

Если подойти к этому вопросу с другой стороны, достаточно создать дистр который умеет только запускать эти пакеты и устанавливать ничего не надо.

Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

75. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (70), 24-Авг-22, 17:32 
Так ты дай определение, что такое "самодостаточные пакеты", я тебе тоже напишу, что вранье, нужна еще ОС и т.п.
Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

85. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (62), 24-Авг-22, 18:16 
Настоящий самодостаточный пакет должен работать без операционной системы
Ответить | Правка | Наверх | Cообщить модератору

113. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Bdfybec (?), 24-Авг-22, 21:32 
А также без процессора, компьютера, в безвоздушном пространстве, без электричества и т.п.
Ответить | Правка | Наверх | Cообщить модератору

187. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Juha (ok), 26-Авг-22, 11:20 
И без желания и надежд.
Ответить | Правка | Наверх | Cообщить модератору

132. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (130), 25-Авг-22, 01:11 
И без железки.
Ответить | Правка | К родителю #85 | Наверх | Cообщить модератору

92. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (97), 24-Авг-22, 18:44 
Пакеты не требуют установки рантайма, он автоматически устанавливается как зависимость. В момент запуска приложения из него и пакета собирается самодостаточное (для запуска приложения) окружение.

Требуется только установка клиента (для установки пакета). Также, как требуется ПК, ОС, драйвера.

Ответить | Правка | К родителю #13 | Наверх | Cообщить модератору

155. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от _hide_ (ok), 25-Авг-22, 10:41 
> Пакеты не требуют установки рантайма, он автоматически устанавливается как зависимость.
> В момент запуска приложения из него и пакета собирается самодостаточное (для
> запуска приложения) окружение.
> Требуется только установка клиента (для установки пакета). Также, как требуется ПК, ОС,
> драйвера.

Самодостаточный и "только установка клиента" + "1-10ГБ свободного места". Нда... Филологи совсем стыд потеряли

Ответить | Правка | Наверх | Cообщить модератору

14. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Sw00p aka Jerom (?), 24-Авг-22, 12:39 
Main of Puppets :)
Ответить | Правка | Наверх | Cообщить модератору

19. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Sw00p aka Jerom (?), 24-Авг-22, 12:41 
в контексте со словом master если нет слова slave, с какого бодуна это неполиткорректно?
Ответить | Правка | Наверх | Cообщить модератору

28. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (-), 24-Авг-22, 12:55 
ты так мило ведёшь монолог, не хочется мешать аж
Ответить | Правка | Наверх | Cообщить модератору

107. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Sw00p aka Jerom (?), 24-Авг-22, 20:54 
> ты так мило ведёшь монолог, не хочется мешать аж

автор любой книги такой же диалог ведет:)

короч, мысли в коментах

Ответить | Правка | Наверх | Cообщить модератору

48. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –1 +/
Сообщение от FixingGunsInAir (ok), 24-Авг-22, 14:31 
> Основная ветка в Git-репозитории переименована с "master" на "main", так как слово "master" считается последнее время неполиткорректным.

Есть хоть кто-то, кто не прогнулся под это?

master форева (с).

Ответить | Правка | Наверх | Cообщить модератору

53. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (53), 24-Авг-22, 15:26 
Я поменял просто так, просто потому что main лучше master во всех смыслах.
Ответить | Правка | Наверх | Cообщить модератору

201. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от FixingGunsInAir (ok), 17-Сен-22, 16:14 
> Я поменял просто так, просто потому что main лучше master во всех
> смыслах.

В каких во всех? Чем лучше? Бла-бла-бла и никакой конкретики. Лучше видимо, только потому, что вам так в голову насрaли.

Ответить | Правка | Наверх | Cообщить модератору

49. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +5 +/
Сообщение от Аноним (-), 24-Авг-22, 14:37 
Appimage объективно лучше!
Ответить | Правка | Наверх | Cообщить модератору

51. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от FixingGunsInAir (ok), 24-Авг-22, 14:50 
Чем же он так сильно "лучше"? Вы случаем не пытаетесь сравнить контейнеровоз с кемпингом? Или Docker со статическим бинарём всё-в-одном (Windows-style).
Ответить | Правка | Наверх | Cообщить модератору

56. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от keydon (ok), 24-Авг-22, 15:41 
Flatpak это ошибка. И как идея и как реализация. Вместо того чтобы решать проблемы, он их создаёт.
Ответить | Правка | Наверх | Cообщить модератору

57. Скрыто модератором  +3 +/
Сообщение от Аноним (57), 24-Авг-22, 15:59 
Ответить | Правка | Наверх | Cообщить модератору

68. Скрыто модератором  +/
Сообщение от Juha (ok), 24-Авг-22, 17:07 
Ответить | Правка | Наверх | Cообщить модератору

74. Скрыто модератором  +2 +/
Сообщение от 1 (??), 24-Авг-22, 17:30 
Ответить | Правка | Наверх | Cообщить модератору

84. Скрыто модератором  +/
Сообщение от Аноним (97), 24-Авг-22, 18:04 
Ответить | Правка | К родителю #68 | Наверх | Cообщить модератору

150. Скрыто модератором  +/
Сообщение от Juha (ok), 25-Авг-22, 09:51 
Ответить | Правка | Наверх | Cообщить модератору

100. Скрыто модератором  +/
Сообщение от Отвечаю (?), 24-Авг-22, 19:32 
Ответить | Правка | К родителю #68 | Наверх | Cообщить модератору

149. Скрыто модератором  +/
Сообщение от Juha (ok), 25-Авг-22, 09:48 
Ответить | Правка | Наверх | Cообщить модератору

78. Скрыто модератором  –1 +/
Сообщение от Аноним (70), 24-Авг-22, 17:35 
Ответить | Правка | К родителю #57 | Наверх | Cообщить модератору

91. Скрыто модератором  +1 +/
Сообщение от RANDOMIZE USR 15616 (?), 24-Авг-22, 18:41 
Ответить | Правка | К родителю #57 | Наверх | Cообщить модератору

148. Скрыто модератором  +/
Сообщение от Juha (ok), 25-Авг-22, 09:44 
Ответить | Правка | Наверх | Cообщить модератору

76. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –3 +/
Сообщение от Аноним (76), 24-Авг-22, 17:32 
Приятно видеть, как экосистема линукса развивается в сторону удобства пользователей.
Ответить | Правка | Наверх | Cообщить модератору

81. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (83), 24-Авг-22, 17:48 
> в сторону удобства

программистов, у которых руки вместо ног растут.

Ответить | Правка | Наверх | Cообщить модератору

87. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –2 +/
Сообщение от Аноним (62), 24-Авг-22, 18:23 
Ох уж эти современные open source программисты ни память за собой освободить не могут, ни пакеты собрать ещё и руки не из того места.
Вместо того чтобы собрать несколько десятков, ну сотню, пакетов под все версии всех популярных дистрибутивов им подавай единый формат и магазин. И ещё с оплатой виртуальных пикселей.
Одним словом виндо-вэй.
Ответить | Правка | Наверх | Cообщить модератору

94. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от Аноним (97), 24-Авг-22, 18:58 
Сразу видно теоретика.

От разработчика требуется лишь src.tgz. Всё остальное обычно делают люди с прямыми руками под свои окружения, на своих мощностях.

Ещё, желательно, скрипт сборки под популярную для ЯП систему сборки. Но у практикующих разработчиков ПО это само собой разумеющееся, независимо от таргетируемых платформ.

Ответить | Правка | Наверх | Cообщить модератору

116. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Admino (ok), 24-Авг-22, 21:47 
> Всё остальное обычно делают люди с прямыми руками под свои окружения, на своих мощностях.

Это совершенно замечательные люди, а конечным криворуким пользователям, коих подавляющее большинство, ждать ебилдов?

Ответить | Правка | Наверх | Cообщить модератору

136. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iCat (ok), 25-Авг-22, 03:42 
>...ждать ебилдов?

Писать ебилды...
Это не сложнее, чем "поставить (условно) танчкики, найти ломалку и сделать анонимную регистрацию"

Ответить | Правка | Наверх | Cообщить модератору

125. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (62), 24-Авг-22, 22:59 
Ждать пока как-то с прямыми как палки руками что-то соберёт это виндо-вэй.
Настоящий Линукс-вэй это
Configure
Make
Make install
Остальное для неосиляторов.
Ответить | Правка | К родителю #94 | Наверх | Cообщить модератору

176. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:45 
@Admino
Криворуким пользователям рекомендуется обратиться за квалифицированной помощью к пряморуким. А что они обычно делают, когда у них случается пожар или отравление? Они же в обществе живут, а не волком в лесу. Что они как маленькие?
Ответить | Правка | К родителю #94 | Наверх | Cообщить модератору

88. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –2 +/
Сообщение от Аноним (62), 24-Авг-22, 18:27 
Жаль что те кто пытается что-то делать под Линукс не видят комментарии местных экспертов.
Они бы поняли что не в коем случае не стоит ничего разрабатывать
Это напрасный труд, за который получишь только упрёки и унижение
Ответить | Правка | К родителю #81 | Наверх | Cообщить модератору

99. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +5 +/
Сообщение от user90 (?), 24-Авг-22, 19:32 
> Жаль что те кто пытается что-то делать под Линукс

Сделали нопремер:
- третьгном,
- системда.
Спасибо не надо.

Ответить | Правка | Наверх | Cообщить модератору

126. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (62), 24-Авг-22, 23:00 
Правильно, чем меньше программ для Линукс тем лучше
Ответить | Правка | Наверх | Cообщить модератору

129. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (131), 25-Авг-22, 00:24 
Чем больше _прикладных_ программ, тем лучше.
Ответить | Правка | Наверх | Cообщить модератору

135. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (76), 25-Авг-22, 03:41 
Пользуюсь и тем, и другим. Systemd — топчик. Всё сделано так, как надо. Третий гном тоже шикарен, я предыдущие на дух не переносил, пользовался тайлингом. Недавно заценил на чужом компе, сразу же проникся и выкинул нафиг stumpwm.
Ответить | Правка | К родителю #99 | Наверх | Cообщить модератору

137. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –3 +/
Сообщение от iCat (ok), 25-Авг-22, 03:50 
>Systemd — топчик

Ты просто не ту OS для себя выбрал...
Надо было Windows или OSX выбирать.

Ответить | Правка | Наверх | Cообщить модератору

146. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (62), 25-Авг-22, 09:07 
В винде нет системд, вайланд, пулсаудио, гном3, флатпак и прочего блоатвар. Идеальная ос для опеннетОвцев
Ответить | Правка | Наверх | Cообщить модератору

152. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от Аноним (152), 25-Авг-22, 10:10 
Ты сейчас описал Chrome OS
Ответить | Правка | Наверх | Cообщить модератору

157. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (157), 25-Авг-22, 12:06 
>В винде нет системд

Это уже вопрос времени ;) Будет вам и даже на Verona.

Ответить | Правка | К родителю #146 | Наверх | Cообщить модератору

98. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от user90 (?), 24-Авг-22, 19:27 
Не юзал и не собираюсь. Ну и зависимости - это как раз фича, иначе "как на венде". Нафиг надо?
Ответить | Правка | Наверх | Cообщить модератору

108. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +3 +/
Сообщение от истина в последней инстанции (?), 24-Авг-22, 21:07 
Самое главное достоинство всех этих флатошлаков это то что они отлично показывают уровень грамотности разработчика. Если разработчик не смог осилить нормальную сборку и хотябы 3-ку популярных пакетов - смело можно сказать, апликашка-<тут следует рифма на слок 'ка'>.

Так забавно как неосиляторы нормальных сборок городят велосипеды на квадратных колёсах. Местами ещё и без руля.

Одно хорошо, позволяет оценить количество невежественных бездарей вокруг.

Ответить | Правка | Наверх | Cообщить модератору

115. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –2 +/
Сообщение от Bdfybec (?), 24-Авг-22, 21:41 
Очевидно, что ты не в теме и никогда не имел дело с разработкой софта и его распространением. Прямо вот так все разработчики приложений распространяемых через флэтхаб тупые "не осилившие сборку 3-х пакетов", а ты кукарека на опеннете - знаток какх свет не видывал.
Ответить | Правка | Наверх | Cообщить модератору

124. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от microsoft (?), 24-Авг-22, 22:50 
Тобиш ты мне щас выкатишь легко и не принужденно во флятпряках ceph собранный в двух-трех вариациях? Я так понял тебе это легко? Или как всегда... построить умника?
Ответить | Правка | Наверх | Cообщить модератору

127. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  –1 +/
Сообщение от Bdfybec (?), 24-Авг-22, 23:05 
Это чуваку выше все легко и все у него неосиляторы.
Ответить | Правка | Наверх | Cообщить модератору

161. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от истина в последней инстанции (?), 25-Авг-22, 16:03 
Прикинь а я запросто.

У меня уже 4 года автоматом собирается под debian (stable, testing, unstable), rhel и suse

Ответить | Правка | Наверх | Cообщить модератору

162. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от истина в последней инстанции (?), 25-Авг-22, 16:05 
Прикинь а я запросто.

У меня уже 4 года автоматом собирается под debian (stable, testing, unstable), rhel и suse BSD и даже opk облегченный для buildroot. И вообще я давно про это забыл. Сборка сама себя подтягивает и держит в актуальном состоянии.

Если ты такой маленький но у тебя достойное приложение - давай и тебе буду собирать под основные дистры.

Ответить | Правка | К родителю #127 | Наверх | Cообщить модератору

138. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iCat (ok), 25-Авг-22, 03:54 
>...в двух-трех вариациях?

С полным набором QT, GTK, motif, Java, wine и .NET на всякий случай...

Ответить | Правка | К родителю #124 | Наверх | Cообщить модератору

144. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +2 +/
Сообщение от iPony129412 (?), 25-Авг-22, 07:34 
> Если разработчик не смог осилить нормальную сборку и хотябы 3-ку популярных пакетов

Я бы скорее подписался на сборку трёх популряных пакетов, чем на Flatpak - это прям адъ.

А для тех кому лень - распространяешь бинарники в tar.gz с жирной сборкой. А там пользователь суй куда хочет.

Ответить | Правка | К родителю #108 | Наверх | Cообщить модератору

163. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от истина в последней инстанции (?), 25-Авг-22, 16:07 
> Я бы скорее подписался на сборку трёх популряных пакетов, чем на Flatpak - это прям адъ.

Коняш, ты не осилишь.

Ответить | Правка | Наверх | Cообщить модератору

180. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от iPony129412 (?), 25-Авг-22, 19:38 
> ты не осилишь.

Почему? Я имею опыт только с DEB, yocto, SNAP.
Что в RPM так уж сложно?

Ответить | Правка | Наверх | Cообщить модератору

145. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (-), 25-Авг-22, 07:40 
> Для уменьшения размера пакета он включает лишь специфичные для приложения зависимости
> с использованием технологии OSTree ... избавляющие от необходимости полной замены образа при каждом обновлении

Сильные заявления, одного не понимаю, как заставить это чудо перестать плодить дубликаты рантаймов с дровами, флаг --user. И ладно, если бы оно копировало из глобально установленных - системных, так нет же, специально выкачивает для каждого юзера отдельно. Оказывается можно сделать хуже вантуза, главное побольше смузи-технологий добавить, занавес.

Ответить | Правка | Наверх | Cообщить модератору

175. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:39 
Эээм. Перестать использовать флаг `--user`?

Для избегания дупликации файлов обычно используют средства ФС. Например, Btrfs.

А как это там в вантузе "лучше" сделано. Не поделитесь?

Ответить | Правка | Наверх | Cообщить модератору

151. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (152), 25-Авг-22, 10:10 
Странно почему же этот ваш Линус, который по совместительству ещё и Товальдс сразу не предусмотрел такую возможность и не сделали всё по человечески. Почему такие задачи решают средствами, которые надо прикручивать где-то сбоку?
Ответить | Правка | Наверх | Cообщить модератору

173. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:33 
Наш Линус aka Торвальдс занимается разработкой ядра, а не пространства пользователя. А доставка ПО до человеков в зону отвественности ядра, очевидно, не входит.
Ответить | Правка | Наверх | Cообщить модератору

174. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:34 
А вот изоляция процессов во Flatpak'е, как раз и реализована средствами ядра.
Ответить | Правка | К родителю #151 | Наверх | Cообщить модератору

191. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (191), 26-Авг-22, 15:19 
Почему их нельзя реализовать без флатпака?
Ответить | Правка | Наверх | Cообщить модератору

196. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (196), 27-Авг-22, 20:16 
Можно, но сложно. Из-за особенностей Filesystem Hierarchy Standard.
Ответить | Правка | Наверх | Cообщить модератору

158. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от А (??), 25-Авг-22, 14:44 
> не может напрямую обращаться к оборудованию, за исключением вывода через DRI, и обращений к сетевой подсистеме.

Вона во чё... оказыться. Широкий заход. :(

Ответить | Правка | Наверх | Cообщить модератору

172. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (177), 25-Авг-22, 18:30 
Исключения, то есть доступ к /dev/dri и network namespace, должны быть предоставлены явно.
Ответить | Правка | Наверх | Cообщить модератору

160. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от zog (??), 25-Авг-22, 16:01 
Классическое костыльное ненужно. Вместо того, чтобы решить проблему фрагментации платформы Linux они навяели ковнокостыль с изоляцией и прочими источниками поблем и проседания производительности. В топку флатпак и все прочие подобные решения.
Ответить | Правка | Наверх | Cообщить модератору

171. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +1 +/
Сообщение от Аноним (177), 25-Авг-22, 18:28 
В фрагментации платформы Linux нет никакой проблемы. Как нет никакой Единой Платформы Linux(TM).

Изоляция и прочие источники проблем во Flatpak - не костыли, а ядерные решения. То есть средствами Kernel, с минимальными затратами для производительности и потребления памяти.

Ответить | Правка | Наверх | Cообщить модератору

192. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (191), 26-Авг-22, 15:20 
Есть и проблемы большие. Посмотри на венду там всё просто берет и работает.

Затраты есть, но они не нужны. Линукс всё запорол и он не нужен.

Ответить | Правка | Наверх | Cообщить модератору

195. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (196), 27-Авг-22, 20:13 
Я больше десяти лет *эксклюзивно* использую Arch Linux на десктопе для работы и отдыха. А Виндовс удалил за ненужностью. Сталкиваюсь с ним только на чужих машинах, где он просто берёт и нифига не работает, а меня просят починить. И куда мне смотреть? В параллельную Вселенную?

Ответить | Правка | Наверх | Cообщить модератору

200. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от Аноним (200), 01-Сен-22, 14:14 
Есть - Android, и она единственная рабочая, остальное из серии - конструктор, а ты заставь меня работать как надо.
Ответить | Правка | К родителю #171 | Наверх | Cообщить модератору

199. "Релиз системы самодостаточных пакетов Flatpak 1.14.0"  +/
Сообщение от pic (?), 31-Авг-22, 20:43 
Android хорошее решение и всё что с ним связанное.
А костыль в виде настольного GNU/Linux надо оставить, он мёртвый, кроме как для серверов, разработки и узкого применения, дальше никуда не поедет, т.к. фрагментированное. Есть конечно SteamOS, но оно тоже узкое.
IBM PC вообще повезло что открыли стандарты, иначе бы в истории что-то более дельное стрельнуло бы.
Ответить | Правка | К родителю #160 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру