The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulkan "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulkan "  +/
Сообщение от opennews (??), 12-Май-23, 16:09 
Доступен выпуск прослойки DXVK 2.2, предоставляющей реализацию DXGI (DirectX Graphics Infrastructure), Direct3D 9, 10 и 11, работающую через трансляцию вызовов в API Vulkan. Для использования DXVK  требуется наличие драйверов с поддержкой API Vulkan 1.3, таких как Mesa RADV 22.0, NVIDIA 510.47.03, Intel ANV 22.0 и AMDVLK. DXVK может применяться для запуска 3D-приложений и игр в Linux при помощи Wine, выступая в качестве более высокопроизводительной альтернативы  встроенных в Wine реализаций Direct3D 9/10/11, работающих поверх OpenGL...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=59127

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +10 +/
Сообщение от Аноним (1), 12-Май-23, 16:09 
Хоть я сам и не играю (времени нет, занят сильно), но считаю очень важным развивать DXVK. Еще было бы неплохо влить туда D8VK -- это бы очень обрадовало некоторых из игроков.
Ответить | Правка | Наверх | Cообщить модератору

2. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  –3 +/
Сообщение от дАнон (?), 12-Май-23, 16:32 
Уже нужно во всю осваивать DXVK Native, а они дальше углубляются в DXVK...
Ответить | Правка | Наверх | Cообщить модератору

3. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +/
Сообщение от Анонус (?), 12-Май-23, 17:01 
> DXVK Native
> This repository has been archived by the owner on Nov 5, 2022. It is now read-only.

Ну такое.

Ответить | Правка | Наверх | Cообщить модератору

8. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +3 +/
Сообщение от анонснс (?), 13-Май-23, 05:31 
Ну так в релизах репо doitsujin/dxvk поставляется DXVK Native...
Ответить | Правка | Наверх | Cообщить модератору

4. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +/
Сообщение от Парень твоего папы (?), 12-Май-23, 17:36 
Куда развивать? DXVK native является частью DXVK, бери да компиляй сошку, если надо.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

9. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +/
Сообщение от Аноним (9), 13-Май-23, 11:48 
Nine же есть, зачем какой-то костыль поверх Вулкана?
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

5. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +1 +/
Сообщение от ИмяХ (?), 12-Май-23, 18:00 
>>поддержка прослойки D3D11On12, обеспечивающей работу Direct3D 11 поверх Direct3D 12

Больше прослоек богу прослоек! Надо ещё запилить прослойку dx12->dx11, прослойку dx12->dx9, прослойку dx11->dx8 и в конце dx8->vulcan

Ответить | Правка | Наверх | Cообщить модератору

7. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +4 +/
Сообщение от maximnik0 (?), 13-Май-23, 02:48 
Перевод не точный,это не транслятор dx12>dx12, а транслятор ddi (интерфейс драйвера устройств). Кстати это официальный код с win10, Майкрософт выложила под мит лицензией.
Ответить | Правка | Наверх | Cообщить модератору

12. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +/
Сообщение от Антним (?), 14-Май-23, 11:17 
>dx8->vulcan

Соседняя новость, запилили.

>dx12->dx9
>dx11->dx8

К сожалению, скорее всего и невозможно, и смысла нет (ибо игры, требующие 12 и 11 скорее всего тр5буют и производительность, соответствующую поколению карты).

Ответить | Правка | К родителю #5 | Наверх | Cообщить модератору

6. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +2 +/
Сообщение от Аноним (6), 12-Май-23, 19:01 
А мне чисто интересно. Сам проверить не могу. А сохранился там виндовый баг DXGI, при котором FindClosestMatchingMode не выдает режимы с Scaling = DXGI_MODE_SCALING_UNSPECIFIED, если все параметры установлены в UNSPECIFIED? Косяк связан с тем, что DXGI_MODE_SCALING_UNSPECIFIED трактуется и как неопределенное значение и как дефолтное для монитора. В списке режимов выдается DXGI_MODE_SCALING_UNSPECIFIED, что трактуется FindClosestMatchingMode как неопределенное значение.
Ответить | Правка | Наверх | Cообщить модератору

10. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  –1 +/
Сообщение от YM2608 (?), 13-Май-23, 13:56 
Кто-нибудь уже пробовал скомпилировать под Windows 10 ?
Ответить | Правка | Наверх | Cообщить модератору

11. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +1 +/
Сообщение от Профессор Кругловemail (?), 13-Май-23, 16:57 
Вы слишком ленивы. На официальном гитхабе лежат архивы с бинарниками под винду. Ссылка на гитхаб прямо в тексте новости. Удачи.
Ответить | Правка | Наверх | Cообщить модератору

13. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +/
Сообщение от iFRAME (ok), 16-Май-23, 08:28 
А зачем? Под виндой и так всё отлично работает.
Ответить | Правка | К родителю #10 | Наверх | Cообщить модератору

14. "Выпуск DXVK 2.2, реализации Direct3D 9/10/11 поверх API Vulk..."  +/
Сообщение от Аноним (14), 16-Май-23, 11:04 
Он просто стесняется написать, что ему оно под ХР надо.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру