The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1...."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"OpenNews: Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1...."  +/
Сообщение от opennews (??) on 09-Сен-07, 19:30 
Анонсирован выход трех новых релизов HTTP сервера Apache: 2.2.6 (http://www.apache.org/dist/httpd/Announcement2.2.html),  2.0.61 (http://www.apache.org/dist/httpd/Announcement2.0.html) и 1.3.39 (http://www.apache.org/dist/httpd/Announcement1.3.html).


Кроме исправления накопившихся ошибок, в Apache 2.2.6 устранено 5 некритических проблем связанных с безопасностью, в 2.0.61 - 4, а в 1.3.39 - 2 проблемы:


-  Добавление проверок для исключения возможности отправки сигнала от родительского процесса к стороннему, не дочернему, процессу (2.2.6, 2.0.61, 1.3.39);

-  mod_status: XSS (cross site scripting) уязвимость, c передачей данных злоумышленника через параметр с кодировкой документа, при включенном ExtendedStatus (2.2.6, 2.0.61, 1.3.39);

-  mod_proxy: Возможность чтения хвоста промежуточного буфера при парсинге заголовков с датой (2.2.6, 2.0.61);

-  mod_cache: Аварийное завершение процесса при передаче заголовка Cache-Control с пустыми данными (2.2.6, 2.0.61);

-  mod_mem_cache: утечка памяти из-за хранение заголовков запросов в долгоживущем кэше, без их последующего удаления (2.2.6).


URL: http://httpd.apache.org/
Новость: http://www.opennet.ru/opennews/art.shtml?num=11954

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от admin (??) on 09-Сен-07, 19:30 
ага (((
плюс изменили API и теперь не работают некоторые сторонние модули
например mod_rpaf который надо для работы в связке с nginx ((((( деятели
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от wS email on 09-Сен-07, 22:43 
как говориться не "всё новое есть ХОРОШО..."
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от cobold on 10-Сен-07, 13:03 
может extract_forwarded_module пойдет?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от SIava on 10-Сен-07, 01:58 
mod__rpaf у меня работает нормально (httpd 2.2.6). Правда я его не собирал заново,  а оставил тот, что собран при httpd 2.2.4.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от replicant on 10-Сен-07, 09:33 
А mod_ssl теперь под 1.3.39 будет жить или уже не судьба и ждать новой версии мода?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от PavelR (??) on 10-Сен-07, 11:58 
А что, перестал собираться ?

Не думал что там так много изменений, чтобы переставали собираться дополнительные модули.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от Полосатый Хряк email on 10-Сен-07, 13:53 
чет при компиляции пишет:
/usr/bin/ld: cannot find -lexpat


есть какиенить соображения?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от Аноним on 10-Сен-07, 16:13 
очевидно нет или не находит libexpat
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от Melkor email on 06-Окт-07, 23:24 
На одном из буржуйских форумов прочитал что надо собирать с --with-expat=buildin
Я проверил у себя - все завелось :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от auk on 10-Сен-07, 15:29 
Во FreeBSD перестал запускаться c ключем -DSSL
Строчка в /etc/rc.conf больше не работает:
apache2ssl_enable='YES'
пришлось воткнуть:
apache2_flags='-DSSL'
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от longers on 12-Сен-07, 22:58 
А слабо посмотреть /usr/local/etc/rc.d/apache22 на предмет:
Add the following lines to /etc/rc.conf to enable apache22
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от Анонис on 10-Сен-07, 20:59 
а нафига ему вдруг понадобился  libexpat
предыдущим вроде не нужен был... и все компилилось
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от fox email(??) on 11-Сен-07, 00:02 
FreeBSD 6.2, Apache 2.2.4 устанавливался из портов.
Обновление с 2.2.4 до 2.2.6 прошло без замечаний.
Пока полёт нормальный.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от V_V_L email on 12-Сен-07, 14:30 
ПОМОГИТЕ!!! Перестал запускаться при старте
apache_enable="YES" - не работает.
Что делать
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от fox email(??) on 12-Сен-07, 16:31 
Надо вот так:
apache22_enable="YES"
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от iTux email on 13-Дек-07, 19:02 
Под MacOS 10.5 - 10.5.1 жрет много виртуальной памяти, можно ли это исправить, а то винта нехватает (
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Обновление HTTP сервера Apache: 2.2.6, 2.0.61 и 1.3.39 "  +/
Сообщение от Аноним (??) on 10-Июн-09, 17:36 
Можно при помощи ╝╛╟╙>║Z╠√♦О^←
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру