The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: Акция по отказу от использования PHP 4 "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от opennews (??) on 02-Фев-08, 12:15 
Несмотря на то, что критические исправления ошибок безопасности для ветки PHP 4.4 будут выходить до 8 августа 2008 года, ряд популярных открытых проектов, написанных на PHP, заявили (http://www.internetnews.com/dev-news/article.php/3725291) о полном прекращении поддержки данной ветки в своих проектах.


Акция GoPHP5 (http://gophp5.org/)  проводится в целях стимулирования перехода на ветку PHP 5, которая по прежнему не обрела должной популярности, несмотря на полное прекращение развития PHP 4. К инициативе присоединились (http://gophp5.org/projects) такие проекты, как Drupal, phpBB, IceBB, MyBB, PEAR, phpMyAdmin, phpPgAdmin, Symfony, Typo3 и WordPress. Все версии принявших участие в акции проектов, выпущенные после 5 февраля, будут требовать для своей работы установки PHP 5.2.


Например, на web-серверах в зоне .ru, c активным mod_php, число установок (http://www.opennet.ru/opennews/art.shtml?num=13899)  версии PHP4 в два раза превышает PHP5.

URL: http://www.internetnews.com/dev-news/article.php/3725291
Новость: http://www.opennet.ru/opennews/art.shtml?num=13993

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Акция по отказу от использования PHP 4 "  
Сообщение от anonymous (??) on 02-Фев-08, 12:15 
Давно пора.
Только не только от 4 но и от пхп вообще :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Акция по отказу от использования PHP 4 "  
Сообщение от ЩекнИтрч on 03-Фев-08, 04:38 
>Давно пора.
>Только не только от 4 но и от пхп вообще :)

Прочитал всю ветку.
Кретины :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

61. "Акция по отказу от использования PHP 4 "  
Сообщение от glyph on 04-Фев-08, 12:21 
+1
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

68. "Акция по отказу от использования PHP 4 "  
Сообщение от Sergey (??) on 07-Фев-08, 15:11 
>Давно пора.
>Только не только от 4 но и от пхп вообще :)

А тебя никто и не заставляет его использовать. Каждый инструмент хорош в своем деле. PHP удобен для написания персональных сайтов и проектов чуть покрупнее. А мнения подобных тебе, подобны Моськам лающим на слонов(имеется в виду % соотношение проектов), так что смело вступай в общество любителей хаять все и всех. А еще можешь посоревноваться в качестве и в длине своего достоинства, тоже полезное занятие;-)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 02-Фев-08, 12:42 
Вот это скорее.... отказа.. совсем отморозки. Люди старали старались писали под пхп4 а тут такое.
Вот есть сайт который какойнить дядька заказал и ему сделали на пхп4. а потом ему возьмут и выключат пхп4 на серваке. Скандаааал :)
пхп маст дай.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 20:43 
>Вот это скорее.... отказа.. совсем отморозки. Люди старали старались писали под пхп4
>а тут такое.
>Вот есть сайт который какойнить дядька заказал и ему сделали на пхп4.
>а потом ему возьмут и выключат пхп4 на серваке. Скандаааал :)
>
>пхп маст дай.

ну будет для таких тормозов за отдельные деньги на хостинге крутиться какой-нить openvz со всяким старьём, делов-то.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

71. "Акция по отказу от использования PHP 4 "  
Сообщение от SCIF email(ok) on 15-Фев-08, 12:09 
>Вот есть сайт который какойнить дядька заказал и ему сделали на пхп4.
>а потом ему возьмут и выключат пхп4 на серваке. Скандаааал :)

Ню-ню. Об обратной совместимости уважаемый Константин наверно не знает. А пишет, наверно, чтобы не отличаться от всех и "посрать" в ветку.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

72. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 15-Фев-08, 12:15 
>>Вот есть сайт который какойнить дядька заказал и ему сделали на пхп4.
>>а потом ему возьмут и выключат пхп4 на серваке. Скандаааал :)
>
>Ню-ню. Об обратной совместимости уважаемый Константин наверно не знает. А пишет, наверно,
>чтобы не отличаться от всех и "посрать" в ветку.

Я - знаю. а вот вы наверное не знаете о том что обратная совместимость не всегда стопроцентна. ;-)
если я чтото говорю то наверняка я знаю примеры когда переключение на пхп5 сломало софт написанный под пхп4. Не срите в ветку пожалуйста просто чтобы в неё посрать.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

73. "Акция по отказу от использования PHP 4 "  
Сообщение от SCIF email(ok) on 16-Фев-08, 08:58 
>Я - знаю. а вот вы наверное не знаете о том что
>обратная совместимость не всегда стопроцентна. ;-)
>если я чтото говорю то наверняка я знаю примеры когда переключение на
>пхп5 сломало софт написанный под пхп4. Не срите в ветку пожалуйста
>просто чтобы в неё посрать.

Извиняюсь за свою предыдущую вонь в ветке - http://us3.php.net/manual/en/migration5.incompatible.php Сорри.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Акция по отказу от использования PHP 4 "  
Сообщение от Oles email on 02-Фев-08, 13:01 
А ещё рассказывают анекдоты про горячих эстонских парней. Наконец-то открыли глазки и посмотрели в будущее.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 13:39 
Отсутствие обратной совместимости это плохо
и как теперь на одном серве держать приложения написанные на разных версиях???
ИМХО ТУПОСТЬ!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 13:41 
тогда бы уж назвали бы по другому и отдельно поддержку бы отдельную делали


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Акция по отказу от использования PHP 4 "  
Сообщение от anonymous (??) on 03-Фев-08, 02:13 
Легко.  FastCGI, suPHP и прочие.  Я вот другое хочу спросить, как можно держать shared hosting используя mod_php.  Это ж все процессы под nobody.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

45. "Акция по отказу от использования PHP 4 "  
Сообщение от Oles email on 03-Фев-08, 16:15 
А вам мёд так и ложкой. mod_php это для быстроты работы, для конкретного приложение а не для массового хостинга.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 14:03 
пхп4 давно устарел. почему-то никого не удивляет что linux2.2 не поддерживается, а то что пхп4 не поддерживается так сразу скандал.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 14:46 
>linux2.2 не поддерживается

Это как это?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

38. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 03-Фев-08, 13:53 
>пхп4 давно устарел. почему-то никого не удивляет что linux2.2 не поддерживается, а
>то что пхп4 не поддерживается так сразу скандал.

а под linux2.2 приложений больше чем под оставшиеся linux2.4 и 2.6 ???
это не скандал... просто тупость какая-то.
хочешь сделать полную реорганизацию сделай тогда, что бы было можно и php4 и php5 на одном серве держать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

55. "Акция по отказу от использования PHP 4 "  
Сообщение от Ne01eX (??) on 04-Фев-08, 08:40 
>
>это не скандал... просто тупость какая-то.
>хочешь сделать полную реорганизацию сделай тогда, что бы было можно и php4
>и php5 на одном серве держать

./configure --prefix=/opt/php4
./configure --prefix=/opt/php5

Текущий php выбирается симлинком. Имхо, две ветки можно даже одновременно заставить работать, было бы желание. Вот только нафига? PHP5 давно уже объявлен стабильным, хотя и развивающимся. В планах PHP6 и все суперрадикальное откладывается туда...

Есть проблемы? Как там у падонков? "Пеши в бактрах и не ипай моск". Это всем, анонимусам сказано.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

57. "Акция по отказу от использования PHP 4 "  
Сообщение от AleXgRey (ok) on 04-Фев-08, 10:10 
>[оверквотинг удален]
>./configure --prefix=/opt/php4
>./configure --prefix=/opt/php5
>
>Текущий php выбирается симлинком. Имхо, две ветки можно даже одновременно заставить работать,
>было бы желание. Вот только нафига? PHP5 давно уже объявлен стабильным,
>хотя и развивающимся. В планах PHP6 и все суперрадикальное откладывается туда...
>
>
>Есть проблемы? Как там у падонков? "Пеши в бактрах и не ипай
>моск". Это всем, анонимусам сказано.

как у падонкофф
Вы тофарисч читать умеете???
видимо с посещением данного рода ресурсов у вы разучились читать... дело не в стабильность или устаревании.. у меня есть рабочее ПО под версию 4, я не програмер, я переделывать буду??? нафиг  выберу другую платформу
PHP так сдохнит.. во выйдет php6 который будет не совместим с php5 и таже песня..


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

65. "Акция по отказу от использования PHP 4 "  
Сообщение от vinzz on 04-Фев-08, 16:08 
>[оверквотинг удален]
>./configure --prefix=/opt/php4
>./configure --prefix=/opt/php5
>
>Текущий php выбирается симлинком. Имхо, две ветки можно даже одновременно заставить работать,
>было бы желание. Вот только нафига? PHP5 давно уже объявлен стабильным,
>хотя и развивающимся. В планах PHP6 и все суперрадикальное откладывается туда...
>
>
>Есть проблемы? Как там у падонков? "Пеши в бактрах и не ипай
>моск". Это всем, анонимусам сказано.

про "моск" это очень чётко подмечено, респект

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

60. "Акция по отказу от использования PHP 4 "  
Сообщение от mdv email(??) on 04-Фев-08, 12:16 

>хочешь сделать полную реорганизацию сделай тогда, что бы было можно и php4
>и php5 на одном серве держать

А кто мешает?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 14:26 
А как насчет акции по отказу от использования похапе вообще ?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Акция по отказу от использования PHP 4 "  
Сообщение от Ноним on 02-Фев-08, 14:51 
>А как насчет акции по отказу от использования похапе вообще ?

А что взамен?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 02-Фев-08, 14:54 
>>А как насчет акции по отказу от использования похапе вообще ?
>
>А что взамен?

питон:)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Акция по отказу от использования PHP 4 "  
Сообщение от WhiteWind (ok) on 02-Фев-08, 15:04 
Шутка удалась)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Акция по отказу от использования PHP 4 "  
Сообщение от Ноним on 02-Фев-08, 17:33 
Ты б еще луа предложил...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 02-Фев-08, 17:45 
>Ты б еще луа предложил...

я не знаю луа. а питон знаю

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

41. "Акция по отказу от использования PHP 4 "  
Сообщение от Ноним on 03-Фев-08, 15:46 
А я достаточно стар чтоб знать фортран, и он от этого не стал больше для веба подходить
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

56. "Акция по отказу от использования PHP 4 "  
Сообщение от Кирилл (??) on 04-Фев-08, 09:25 
>Ты б еще луа предложил...

Ruby? Крайне удачный язык. В сочетании с рельсой так вообще.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Отказываться от ПХП совсем - нельзя!"  
Сообщение от Василий (??) on 02-Фев-08, 16:22 
Отказываться от ПХП совсем - нельзя!

Иначе может появиться столько же много "программистов" на перле и такого же качества, что заказчики и работодатели так же косо начнут посматривать потом на всех перловодов без разбору. Так что я - за сохранение ПХП, чтобы продолжала существовать разница между качеством (перл) и ширпотребом (пхп). :-)))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Отказываться от ПХП совсем - нельзя!"  
Сообщение от Аноним on 02-Фев-08, 17:49 
Вот имеено! - перловодов.. че вы прицепились к языку, писать надо нормально, я за присест сервак перевел и все работает все счастливы, может просветите дремучего чем они так координально отличаются? отсутсвием функций которые давным давно обещали заменить и призывали не использовать.. ну дык кто виноват...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

58. "Отказываться от ПХП совсем - нельзя!"  
Сообщение от Кирилл (??) on 04-Фев-08, 10:14 
Мне кажется ваши страхи не оправданы ;) Во-первых, пхп язык напрочь отучающий элементарно думать, к тому же у него очень низкий потолок управляемой сложности проекта. Поэтому привыкшему к пхп будет труднее, чем начинающему вообще без всяких прикладных знаний программирования. Так что этот контенгент перловодам не угрожает :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 02-Фев-08, 18:40 
php5 ф топку, 4 ветка рулит, php5 секеса больше, а эфект тот же. ))
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 02-Фев-08, 18:42 
>php5 ф топку, 4 ветка рулит, php5 секеса больше, а эфект тот
>же. ))

Вот и я думаю что от циферки языку лучше не стало, а гимороя больше. Да и со совими отказами тоже мороку создают...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Акция по отказу от использования PHP 4 "  
Сообщение от WhiteWind (ok) on 02-Фев-08, 19:45 
От циферки много лучше стало: появилось более-менее человеческое ООП, убраны возможности, которые позволяют всяким шлемазлам из-за лени понаделать дыр в безопасности, убраны возможности, которые и без шлемазлов являются дырами...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

34. "Акция по отказу от использования PHP 4 "  
Сообщение от skyogre on 03-Фев-08, 09:13 
Все переменные теперь передаются по ссылке. Производительность они увеличили на пол процента, а людям трахайся после этого..
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

35. "Акция по отказу от использования PHP 4 "  
Сообщение от skyogre on 03-Фев-08, 09:17 
У нас половина клиентов на RHEL4 живут. Может для них тоже акцию устроить "смени сервак" или каждому собирать из исходников...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

62. "Акция по отказу от использования PHP 4 "  
Сообщение от Виктор (??) on 04-Фев-08, 12:43 
тоже живу на RHEL4, взял srpm из 5-ки, переправил spec и собрал пакеты, которые прекрасно уживаются с 5-кой на одном сервере.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от uldus (ok) on 02-Фев-08, 19:45 
Если кто-то не спешит уходить с php4, значит на то есть причины. PHP 5 рулит, особенно учитывая, что последняя версия PHP 5.2.5 под нагрузкой трещит и падает (http://www.lexa.ru/nginx-ru/msg15279.html). Конечно можно откатиться на 5.2.4 и получить несколько незаткнутых дыр или поставить девелоперский снапшот и ощутить всю прелесть вылавливания новых багов. PHP 4 более стабильна, по крайней мере предсказуема и существуют карты обхода разложенных граблей.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

28. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от ЩекнИтрч on 03-Фев-08, 04:44 
Под какой "нагрузкой"??? :)
По все ссылками ДЕФЕКТЫ СБОРКИ :)
Научитесь компилять. В документации ОЧЕНЬ ПОДРОБНО описаны изменения от версии 4.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

42. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от thedix (??) on 03-Фев-08, 15:51 
Можете указать, что за дефекты сборки?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

43. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 03-Фев-08, 15:52 
>Можете указать, что за дефекты сборки?

наверное нехватка деталей :-D

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

50. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от uldus (ok) on 03-Фев-08, 19:13 
>Под какой "нагрузкой"??? :)
>По все ссылками ДЕФЕКТЫ СБОРКИ :)
>Научитесь компилять. В документации ОЧЕНЬ ПОДРОБНО описаны изменения от версии 4.

Какие дефекты сборки ? Баг разработчики php признали и сразу пофиксили.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Акция по отказу от использования PHP 4 "  
Сообщение от пехапешник on 02-Фев-08, 23:29 
спасибо, посмеялсо..
несовместимость, бу-га-га.
а то что, скоро питон3 будет, несовместимый с 2.х, забыли.. не нравится что-то, купи себе vds да поставь че хошь.

про несовместимость орут только ленивые тупые быдлокодеры, неважно на чем пишушие.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 03-Фев-08, 00:16 
>спасибо, посмеялсо..
>несовместимость, бу-га-га.
>а то что, скоро питон3 будет, несовместимый с 2.х, забыли.. не нравится
>что-то, купи себе vds да поставь че хошь.
>
>про несовместимость орут только ленивые тупые быдлокодеры, неважно на чем пишушие.

Ну в питоне много чего меняют. и говорят "чтоб всем было хорошо".
Те изменения должны отсечь плохое наследство исторически сложившееся.
Про последнюю строку - согласен. Если писать с регистер глобалс например то много граблей насобираешь :))) я таких "профессиАНАЛьчегофф" которые так пишут...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

31. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 03-Фев-08, 08:45 
Присоединяюсь! Ха-хаха!-)
перловоды еще про перл6 не знают/-)
и как они свои ^$&*^&*%$$%$#$^^**%^#$%#${{W$%^& переписывать будут!-)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

48. "Акция по отказу от использования PHP 4 "  
Сообщение от пехапешник on 03-Фев-08, 17:23 
>Присоединяюсь! Ха-хаха!-)
>перловоды еще про перл6 не знают/-)
>и как они свои ^$&*^&*%$$%$#$^^**%^#$%#${{W$%^& переписывать будут!-)

нормально будут, если все спроектировано хорошо и никто не занимался выпендриванием.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

39. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 03-Фев-08, 14:02 
>спасибо, посмеялсо..
>несовместимость, бу-га-га.
>а то что, скоро питон3 будет, несовместимый с 2.х, забыли.. не нравится
>что-то, купи себе vds да поставь че хошь.
>
>про несовместимость орут только ленивые тупые быдлокодеры, неважно на чем пишушие.

а против совместимости орут тупые не видящие дальше собственно быдловского носа кодеры..
не забывай есть ряд людей которым нужно работающее приложение, а не язык программирования... тогда вам быдло батька пора писать собственную ОС предлагаю Bidl-o-NIX
или вы тоже ленивый быдлокодер???

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

40. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 03-Фев-08, 14:32 
>[оверквотинг удален]
>>что-то, купи себе vds да поставь че хошь.
>>
>>про несовместимость орут только ленивые тупые быдлокодеры, неважно на чем пишушие.
>
>а против совместимости орут тупые не видящие дальше собственно быдловского носа кодеры..
>
>не забывай есть ряд людей которым нужно работающее приложение, а не язык
>программирования... тогда вам быдло батька пора писать собственную ОС предлагаю Bidl-o-NIX
>
>или вы тоже ленивый быдлокодер???

Я считаю что обратная совместимость это признако хорошего тона программирования.
Если её нет - создателю(ям) глубоко насрать на мнение пользователей(программистов) и(или) просто ниасилил свой же код.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

47. "Акция по отказу от использования PHP 4 "  
Сообщение от пехапешник on 03-Фев-08, 17:15 
собственно да..
если разработчик выбрал средство разработки, то ему и отдуваться за изменения в этих средствах, либо менять их, что в любом случае приведет в большой работе.

в любом случае 100% совместимости достичь не удастся, если продукт эволюционирует.
выполнять php4 код в 5-ке можно, если не используются те костыли, которые были в 4-ке для облегчения жизни, но в результате привели к обратному.

либо править пехапе.ини для включения этих костылей. но работать будет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

46. "Акция по отказу от использования PHP 4 "  
Сообщение от пехапешник on 03-Фев-08, 17:04 
совместимость должна быть на уровне дизайна приложения, если оно спроектировано через заднее место, то туда ему и дорога.. самое время переписать с нуля.
все, что я писал под 4-ку работает в 5-ке без проблем, после небольшого фикса стрикт-стандартс, как будет работать на 6-ке уже имею редставление. наверное я что-то неправильно делаю.

про ОС посмешил, да.. меня в существующих ОС все устраивает вне зависимости от того, какое там ядро и т.д. Не умеешь примеры выбирать, лучше не начинай.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

69. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним (??) on 13-Фев-08, 17:35 
>а то что, скоро питон3 будет, несовместимый с 2.х, забыли..

Главную разницу не заметил? Питон идет на новую версию несовместимую со старой потому что сообщество этого хочет, по крайней мере большинство. У вас же тут большинство ОРЁТ во все горло - нам в х%# не упёрлись бантики из 5-ки - ОСТАВЬТЕ 4-ку! А оне то им о ответ - НЕТ! :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

70. "Акция по отказу от использования PHP 4 "  
Сообщение от Oles email on 14-Фев-08, 01:52 
И долго питонисты будут поддерживать старую ветку после того как новая станет стабильной? Посмотрим на это сообщество... :)
В том то и дело что аргументы против перехода с 4-й на 5-й пых просто растут из гипертрофированных лени и консерватизма. Любой девелопер предпочтёт 5-ку. КАЖДЫЙ. 4-ка себя изжила и уже давно является просто легаси. И времени на крохи поправок которые могут понадобиться для перехода (если вообще таковые есть в проекте) было масса.

По своему опыту скажу (приходилось один немаленький проект перевести) что пришлось именно те куски, которые изначально были криво написаны (связанные с ООП, я вообще удивлялся что они работали - использовали "фичи"). Плюс парсер иксемеля начал всё в утф8 выдавать - пришлось строчку с иконвом добавить. Плюс варнинги поправить кое-где. Делов то.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 03-Фев-08, 00:12 
>[оверквотинг удален]
>Выбери irc-чаты с 13-летними девочками,
>после фразы "упало в корку" превращающимися
>в 40-летних бородатых вонючих мужиков.
>Выбери терабайты бесплатного кода,написанного
>криворукими самоучками.Выбери несовместимость
>версий.Выбери проблемы с xslt.Выбери нищенскую
>зарплату.Выбери конкурентов готовых работать за еду.
>
>Выбери своё будущее.
>Выбери PHP.

пхп - язык для стартапов :) так что на самом деле для многих проектов подходит когда нужно запустить проект как можно быстрее. Не рассматриваем конечно множество фреймворков на разных языках. Они значительно меняют ситуацию

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

67. "Акция по отказу от использования PHP 4 "  
Сообщение от Кирилл (??) on 05-Фев-08, 12:42 
Спорные утверждения, пхп лишь инстумент и иногда уместный, а сейчас к тому же востребованный. Труд хорошего пхп-кодера (программером такое существо назвать не решусь) довольно пристойно оплачивается. Хотя ниже в этой иерархии только 1С-золотники.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "Акция по отказу от использования PHP 4 "  
Сообщение от mechanix (??) on 03-Фев-08, 02:58 
viva apache 1.3 ! (шутка)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 03-Фев-08, 06:14 
php очень хороший язык программирования. Я на нем все умею делать. Он очень быстрый, и очень легки
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

33. "Акция по отказу от использования PHP 4 "  
Сообщение от tim2k email on 03-Фев-08, 09:13 
>php очень хороший язык программирования. Я на нем все умею делать. Он
>очень быстрый, и очень легки

Да, пхп = это глобально и надежно, это знают все...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

36. "Акция по отказу от использования PHP 4 "  
Сообщение от Аноним on 03-Фев-08, 11:29 
докажите обратное
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

37. "Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 03-Фев-08, 12:05 
>>php очень хороший язык программирования. Я на нем все умею делать. Он
>>очень быстрый, и очень легки
>
>Да, пхп = это глобально и надежно, это знают все...

php знают далеко не все. за не надобностью ;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

32. "Акция по отказу от использования PHP 4 "  
Сообщение от ЮзверЪ on 03-Фев-08, 08:56 
Надо было голодовку протеста устроить! :-D
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

44. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от Oles email on 03-Фев-08, 16:11 
Предлагаю акцию протеста против PHP! Все кому он не нравится дружно бьются головой апстену одновременно с голодовкой и воздержанием, а перед этим выжечь на лбу надпись Python Forever или Ruby Forever (что кому как нравиццо). Чтоб сомнений не осталось :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

51. "Акция по отказу от использования PHP 4 "  
Сообщение от Dreammaker on 03-Фев-08, 20:15 
Эх, жалко я себе такой хоумпейдж как digg.com не наваял в году 2004. Я тогда не знал быдлоязыка на котором он написан, и не использовал недоБД, на которой хранятся у него данные :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

52. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от пехапешник on 03-Фев-08, 23:10 
Кстати, коль некоторым тут не нравится: ну проведите акцию "В задницу друпал, пхпбб и т.д."
И пересядьте обратно за IE3, NN3.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

53. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от reg email on 03-Фев-08, 23:38 
если вы тут все такие крутые то просто поймите одну простую вещь. ваши питоны и пхп хороши конечно но это СКРИПТЫ. Приложение на СИ будет быстрее и лучше. Несовместимость версий - чушь. Если вы переходите на новую версию то это ваши проблемы. Пользователю нужно РАБОТАЮЩЕЕ ПРИЛОЖЕНИЕ, и ему глубоко пофиг на 3м это пхп или на 6м. Если вы испытываете эти глупые проблемы, то вставляйте в руки спицы чтоб выпрямить их. И то это получается не у многих. Развели бадягу на пустом месте. Ужас. Я в шоке.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

54. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от Konstantin email(??) on 04-Фев-08, 05:56 
>если вы тут все такие крутые то просто поймите одну простую вещь.
>ваши питоны и пхп хороши конечно но это СКРИПТЫ. Приложение на
>СИ будет быстрее и лучше. Несовместимость версий - чушь. Если вы
>переходите на новую версию то это ваши проблемы. Пользователю нужно РАБОТАЮЩЕЕ
>ПРИЛОЖЕНИЕ, и ему глубоко пофиг на 3м это пхп или на
>6м. Если вы испытываете эти глупые проблемы, то вставляйте в руки
>спицы чтоб выпрямить их. И то это получается не у многих.
>Развели бадягу на пустом месте. Ужас. Я в шоке.

Одно дело когда тебе надо разработать качественную, высокопроизводительную систему за которую тебе платят много денег. Другое дело когда нужно разработать быстро и не изобретать велосипеды и возможно тоже много но за скорость работы. Это разные вещи

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

59. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от GateKeeper (??) on 04-Фев-08, 11:27 
Если пользователю _нужно_ РАБОТАЮЩЕЕ приложение, то, надеюсь, сэр соизволит и поддержку этого приложения прикупить?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

64. "OpenNews: Акция по отказу от использования PHP 4 "  
Сообщение от Кирилл (??) on 04-Фев-08, 15:21 
>если вы тут все такие крутые то просто поймите одну простую вещь.
>ваши питоны и пхп хороши конечно но это СКРИПТЫ. Приложение на
>СИ будет быстрее и лучше. Несовместимость версий - чушь. Если вы
>переходите на новую версию то это ваши проблемы. Пользователю нужно РАБОТАЮЩЕЕ
>ПРИЛОЖЕНИЕ, и ему глубоко пофиг на 3м это пхп или на
>6м. Если вы испытываете эти глупые проблемы, то вставляйте в руки
>спицы чтоб выпрямить их. И то это получается не у многих.
>Развели бадягу на пустом месте. Ужас. Я в шоке.

Ты в корне не прав. Си хорош для системного программирования или когда существенно ограничены аппаратные ресурсы. В обычной жизни куда эффективней купить сервер мощнее в н-раз, чем создавать крупный динамичный проект на Си и прочих языках низкого уровня. Но ПХП это конечно уродец. Это другая крайность.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

63. "Акция по отказу от использования PHP 4 "  
Сообщение от SKeeper email on 04-Фев-08, 12:48 
Эта акция не означает, что на всех серваках сразу отрубят пхп4. Просто должна стимулировать разработчиков писать НОВЫЕ проекты и ПЕРЕПИСЫВАТЬ старые под пхп5. А пхп5 реально лучше пхп4. Многое из грязи которой поливают пхп - относится к пхп4, но не к пхп5.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

74. "Акция по отказу от использования PHP 4 "  
Сообщение от AmdY on 24-Фев-08, 04:40 
Вот всегда смешно читать, как несмыслящие "спецы" поливают грязью успешны проект.
Чтобы понять разницу между 5-й и 4-й нужно быть ООПытным и просто неопытным.
В 5-ке есть обратная совместимость, которая позволяет заводить 90 и более процентов проектов написанных под 4-ку (у меня 100% 4-ых работают под 5-ым).
Есть возможность держать на серваке одновременно 4-ку и 5-ку.
Все эти высказывания неоспоримы, непонимаю о чём флуд?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру