The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от opennews on 03-Мрт-08, 22:41 
В тестовом 2.6.25 ядре был запрещен (http://kerneltrap.org/Linux/NDISwrapper_and_the_GPL) экспорт символов катерогии GPLONLY для не GPL модулей ядра. Данное нововведение в частности сломало работу модуля NDISwrapper (http://ndiswrapper.sourceforge.net/), позволяющего использовать Windows драйверы для беспроводных карт.


Linus Torvalds посоветовал разработчикам ndiswrapper связаться с создателями подсистем ядра установивших для своего кода флаг экспорта GPLONLY. Код NDISwrapper распространяется под лицензией GPL, но тем не менее не является GPL-совместимым, так как использует для своей работы внешние проприетарные бинарные компоненты.

URL: http://kerneltrap.org/Linux/NDISwrapper_and_the_GPL
Новость: http://www.opennet.ru/opennews/art.shtml?num=14535

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Бурзум on 03-Мрт-08, 22:41 
Зато b43 запахал. Йууухууу. Все владельцы Broadcom 43xx радуюцо.

зы. гдето видел, что ограничение 11Мбит, нифига, 24Мбита жует легко.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от prapor (??) on 03-Мрт-08, 22:53 
Че, больше не теряет сигнал? Тады ура.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Бурзум on 04-Мрт-08, 01:22 
Ну есть один костыль. Если стоит минуту-две без пакетиков то txpower ставицо в off. Решение - в фоне ping -i 20 host.dom может есть решение и лучше, но впринципе и так устраивает.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

3. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от BayaN (ok) on 03-Мрт-08, 23:23 
Это происки Ричарда Столлмана?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Michael Shigorin email(ok) on 04-Мрт-08, 01:53 
Это весеннее обострение...
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от prapor (??) on 04-Мрт-08, 02:08 
Миша, ты как всегда в своем репертуаре ;). О добавлении такой баги предупреждали давно.
Хотя IMHO, она должна элементарно отключаться при сборке ядра.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

34. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от R007 (??) on 05-Мрт-08, 00:05 
Побольше бы таких происков.Запарили уже закрытые блобы с идиотской лицензией, не дающей их поставлять вместе с дистрами, невозможность фикса глюков если разработчик забил болт и прочая.А ndiswrapper - вообще тот еще костыль.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Аноним (??) on 04-Мрт-08, 02:30 
У-у-у, пора сваливать с линукса. Ни в одной системе нет такого фанатизма, как учет лицензий кусков ядра. Учет лицензий пакетов еще ладно, но ядра это п-ц. Сегодня же заменю все упоминания GPL в ядре на BSD, скомпилю бинарник и выложу без исходников. Чисто чтобы эту ублюдскую GPL нарушить... два раза.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

14. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Nick email(??) on 04-Мрт-08, 10:49 
>У-у-у, пора сваливать с линукса.

это самое правильное что ты можешь сделать

>Ни в одной системе нет такого фанатизма,
>как учет лицензий кусков ядра. Учет лицензий пакетов еще ладно, но
>ядра это п-ц. Сегодня же заменю все упоминания GPL в ядре
>на BSD, скомпилю бинарник и выложу без исходников. Чисто чтобы эту
>ублюдскую GPL нарушить... два раза.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

35. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Юзеръ (ok) on 05-Мрт-08, 10:30 
>У-у-у, пора сваливать с линукса. Ни в одной системе нет такого фанатизма,

Конечно.Подумаешь в современной винде цифровые подписи на драйвера и то что не одобрено минздравом...ах, простите, Майкрософт просто не загрузится у юзеров вообще, а так фигня.

>как учет лицензий кусков ядра. Учет лицензий пакетов еще ладно, но
>ядра это п-ц. Сегодня же заменю все упоминания GPL в ядре
>на BSD, скомпилю бинарник и выложу без исходников. Чисто чтобы эту
>ублюдскую GPL нарушить... два раза.

Боюсь что ублюдская не GPL а ваше видение мира.На досуге - почитайте EULA от MS к вистам всяким.Потом сравните - что там еще ублюдское большой вопрос.И, кстати, BSDшный код на раз-два-три становится кодом под ублюдским EULA от MS и вы стройными рядами идете покупать его за много денег на тупых условиях.Такая вот у бздунов "свобода".Вон, макось например - эппл творит что хочет и скажем запрещает дебаггинг некоторых программ и прочая.Короче та же фигня что и Windows в итоге получится.Наф-наф-наф такую "свободу", GPL как раз не дает такие злобства вытворять с GPLнутым кодом.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Аноним (??) on 04-Мрт-08, 04:43 
> Сегодня же заменю все упоминания GPL в ядре на BSD, скомпилю бинарник и выложу без исходников. Чисто чтобы эту ублюдскую GPL нарушить... два раза.

Выкладывай, только кому он нужен, твой бинарник.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

10. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от MarCo email on 04-Мрт-08, 07:11 
Двойные стандарты - дорога в АД.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Аноним (??) on 04-Мрт-08, 07:14 
интересно. а как с дровами, например, nvidia?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

15. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Nick email(??) on 04-Мрт-08, 10:50 
>интересно. а как с дровами, например, nvidia?

отлично. Они не собираюцо :)

С радостью перешел на xf86-video-nv

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

36. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Юзеръ (ok) on 05-Мрт-08, 10:35 
>интересно. а как с дровами, например, nvidia?

Хреново.Закрытые блобы с ограниченной лицензией не позволяют например класть их на сидюк с системой.Посему с такими драйверами невозможна ситуация что юзер ставит систему и вуаля, все работает.А значит оно зло, по определению.Да и интель и АТИ не сволочатся как-то, у меня такое ощущение что игроков на этом рынке и без нвидии хватит.А на месте нвидии я бы вообще начал вертеться немного - в будущее надо немного заглядывать... а то на рынке чипсетов им хвост прищемили уже.Что интель что амд.Профукать растущий рынок линуксных решений - тоже вариант :).Ну вон такая незначительная мелкота как Делл атю юзает %)

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

12. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от _umka_ (ok) on 04-Мрт-08, 08:38 
>В тестовом 2.6.25 ядре был запрещен (http://kerneltrap.org/Linux/NDISwrapper_and_the_GPL) экспорт символов катерогии GPLONLY для
>не GPL модулей ядра. Данное нововведение в частности сломало работу модуля
>NDISwrapper (http://ndiswrapper.sourceforge.net/), позволяющего использовать Windows драйверы для беспроводных карт.
>
>

Ура красноглазикам! они эту политику проводят с самого начала 2.6 ветки. Один раз наступили на ногу IBM, теперь сломали популярный NDISwrapper. Попутно запретили закрытые модули к NFS (вторглись в сферу интересов HP?) Что будет следующее?
Хотя с другой стороны тот же RedHat без зазрения совести сделает
s/GPLONLY/GPL/ - и будет продавать свой дистрибутив заявлая о совместимости с NDISwrapper.

PS. Для скептиков - советую открыть патчики RHEL для ядра - и найти там тот который фиксит тип экспорта. Он там уже есть.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от Nick email(??) on 04-Мрт-08, 10:52 
А что нам RedHat? Единый и неповторимый?
Им надо - они правят ядро. Их право.

Мое право - хотеть свободного софта. И Линукс всячески поддерживает
меня в этом уже и технически.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

28. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от _umka_ (ok) on 04-Мрт-08, 14:03 
Когда вы поставите Oracle/DB2 ... etc на Gento и у вас что-то не заработает,
сапорт Oracle направит вас в сторону кошерного дистрибутива (RH) - или на юх.
куда имеено - выберете сами ;)
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

29. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от _Nick_ email(ok) on 04-Мрт-08, 14:14 
>Когда вы поставите Oracle/DB2 ... etc на Gento и у вас что-то
>не заработает,
>сапорт Oracle направит вас в сторону кошерного дистрибутива (RH) - или на
>юх.
>куда имеено - выберете сами ;)

а че это я к ним буду обращаться? я ж не выполняю их
технические требования по дистрам.

У меня все впорядке с логикой (по краймей мере в этом).

А по оруклям и комьюнити поможет. Там, знаете ли, не дураки.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

31. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от vitek (??) on 04-Мрт-08, 14:22 
точно
особенно если oracle/db2 gorbushka edition
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

40. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от ABorland email on 05-Мрт-08, 14:34 
Накуа горбушка едишин?
Скачиваем с офсайта и все отлично пашет
(Это по крайней мере про оракел)
Просто в серьезный продакшин такое ставить стремает, ибо любая проверка - админукапец.
и своей попой за работу проекта никто отвечать тоже не хочет,
а за денушки получаем тех(и этих)поддержку, возможность перекладывания ответственности и ощущение прикрытого зада.
Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

19. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от vitek (??) on 04-Мрт-08, 11:01 
> Ура красноглазикам! они эту политику проводят с самого начала 2.6 ветки. Один раз наступили на ногу IBM, теперь сломали популярный NDISwrapper. Попутно запретили закрытые модули к NFS (вторглись в сферу интересов HP?) Что будет следующее?

Ну и отлично. Посмотрим, что с этим будут делать nvidia, hp вместе с титаниумом,...
А Вам дорога в MacOS c DRM'ом и прочая..

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

38. "OpenNews: В Linux ядре 2.6.25-rc нарушена работа не GPL моду..."  +/
Сообщение от Юзеръ (ok) on 05-Мрт-08, 10:54 
>> Ура красноглазикам! они эту политику проводят с самого начала 2.6 ветки. Один раз
>> наступили на ногу IBM, теперь сломали популярный NDISwrapper.

О, костыль сломали.В пререлизном ядре послезавтрашнего дня.А латентные вантузятники уже икру мечут :).Если честно - в задницу всякие врапперы, НОРМАЛЬНЫЕ ДРОВА нужны а не костыли работающие через задний проход.

>А Вам дорога в MacOS c DRM'ом и прочая..

+1.В макоси эппл уже дебаг некоторых программ внаглую запрещает и прочая.Что там следующее?Такая вот свобода по BSDшному - анархия, она, блин, двусторонняя.Ее могут ведь и к самим злобствующим анархистам применить, вломив оным не по детски.Хапнув их анархистский код, закрыв его к такой-то матери, сменив лицензию и напихав в систему антипользовательских фич.Что и наблюдается.Нафиг-нафиг такую "свободу".

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

13. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Bakytn (??) on 04-Мрт-08, 09:40 
http://ndiswrapper.sourceforge.net/joomla/
В версии 1.52 released
>> Compilation issues with current 2.6.25 kernel tree fixed

Так что все в порядке уже

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Nick email(??) on 04-Мрт-08, 10:53 
%)

зато заныли всякие умки.

Лишь бы газофицировать порочку водоемов.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

20. "рушена работа не"  +/
Сообщение от Andrey Mitrofanov on 04-Мрт-08, 11:09 
>В версии 1.52 released
>>> Compilation issues with current 2.6.25 kernel tree fixed
>
>Так что все в порядке уже

Торвальдс в курсе? :))
http://kerneltrap.org/Linux/NDISwrapper_and_the_GPL
Точно весеннее.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

18. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Аноним (??) on 04-Мрт-08, 11:00 
Почитал. Линус, как всегда, в своём репертуаре. Хамит и не слушает собеседников...

Pavel Roskin, имхо, совершенно прав, не отступает от исходной трактовки GPLONLY:

Actually, it's a flawed comparison.  The only thing ndiswrapper exports
to NDIS modules is NDIS API.  GPLONLY symbols are only used to implement
that API in the code that's under GPL.  That's the code you can fork,
change and redistribute.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

21. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от vitek (??) on 04-Мрт-08, 11:13 
все он правильно пишет.
В конце концов не на тебя будут наезжать с твоим установленным ndiswraper'ом.
И не сюда надо писать гневные письма, если нет дров от конкретной железки.
Например, acer убрала ви-фи дрова на aspire 4720z даже для вин хп (козлы!)
А крафтвей продает системники с вистой дешевле на 900 р. чем вообще без ОС!
Вот туда и надо спамить! А еще в антимонопольные комитеты!
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

22. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от AsphyX (??) on 04-Мрт-08, 11:36 
Да не собираюсь я не на кого наезжать. Разве похоже моё сообщение на гневное письмо или спам? Я просто почитах переписку 2х человек и оценил их умение вести дискуссию.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

23. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от vitek (??) on 04-Мрт-08, 11:39 
эта дискуссия ведется давно.
и порядком уже надоела.

вот и я не сдерживаюсь. :-)

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

39. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Юзеръ (ok) on 05-Мрт-08, 10:59 
>А крафтвей продает системники с вистой дешевле на 900 р. чем вообще
>без ОС!

Это значит что просто послав дурацкий крафтвей на йух можно сэкономить весьма приличную сумму баблосов.Примерно так 900 рублей + стоимость лицензии висты-DеRьMисты :)

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

24. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от gaux (ok) on 04-Мрт-08, 12:20 
Пахоже линухокапец настанет раньше вендекапца - жаль:(((
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

25. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от _Nick_ email(??) on 04-Мрт-08, 12:23 
>Пахоже линухокапец настанет раньше вендекапца - жаль:(((

происходящее - следсивие вендекапца :)
он УЖЕ наступил %)

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

26. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от gaux (ok) on 04-Мрт-08, 12:28 
Я знаю - и уже давно. Не приятно, что дрова nvidia пахать не будут. Торопятся уж слишком.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

27. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от _Nick_ email(??) on 04-Мрт-08, 12:35 
>Не приятно, что дрова nvidia пахать не будут.

Да будут. Куда они денуцо.
Это ж версия под старое API не собираеццо.
Нужно дать Nvidia время выпустить новую версию.

>Торопятся уж слишком.

а кого ждать? :))

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

30. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от vitek (??) on 04-Мрт-08, 14:19 
+1
Пусть догоняют
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

32. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от alll (??) on 04-Мрт-08, 18:26 
>+1
>Пусть догоняют

Главное что б не надоело догонять.Если в каждой версии ядра будут ломать АПИ, то производителям проще будет забить на линух (


Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

33. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от _Nick_ email(ok) on 04-Мрт-08, 19:02 
>Главное что б не надоело догонять.Если в каждой версии ядра будут ломать
>АПИ

это достаточно нечасто происходит.
А раз в полгода напомнить о себе - в пользу ;)


>то производителям проще будет забить на линух (

не проще.
Деньги... деньги... ;)
а у Линухоидов они есть. Есть как ни у кого другого,
если сравнивать усредненно.

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

37. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от vitek (??) on 05-Мрт-08, 10:39 
> Главное что б не надоело догонять.Если в каждой версии ядра будут ломать АПИ, то производителям проще будет забить на линух (

А как это происходит у M$? И почему на хп directx 10 не ставиться?
Установка закрытых драйверов, например, от nvidia - это нарушение GPL.
Очень долго на это закрывали глаза (видимо что б не спугнуть удачу)
Сейчас этим компаниям есть о чем задуматься и понять, что линух ядро не проститутка и за такими "клиентами" гоняться не будет.
Да и намеки M$ о судебном преследовании клиентов линуховых компаний отвалятся.

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

41. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от гость on 06-Мрт-08, 16:58 
Отлично, давно пора ядро от мусора подчистить.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

42. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от Аноним (??) on 23-Июн-08, 22:39 
>>>Главное что б не надоело догонять.Если в каждой версии ядра будут ломать АПИ, то производителям проще будет забить на линух (

На линукс уже никто не забъет. Если производители оборудования не будут сотрудничать с "Линукс", то уже совсем скоро будут терять ощутимые деньги.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

43. "В Linux ядре 2.6.25-rc нарушена работа не GPL модулей и NDIS..."  +/
Сообщение от sdaasd on 11-Мрт-15, 17:59 
Они просто перейдут на BSD-like.
Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру