The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от opennews (??) on 10-Фев-10, 10:54 
Представлено (http://lkml.org/lkml/2010/2/9/107) очередное обновление Linux ядра 2.6.32.8 (http://www.kernel.org) в котором отмечено 76 исправлений (http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.32.8), затронувших такие подсистемы, как ath9k, mac80211, usb, libata, scsi_lib, KVM, firewire,  drm/i915, iwlwifi, e1000, ACPI.


Несколько исправлений связаны с безопасностью: в коде SELinux имелась проблем с передачей значения RLIMIT_RTTIME вместо RLIMIT_CPU в функцию  update_rlimit_cpu(); исправлена ошибка в коде обработки фрагментированных Ethernet jumbo-фреймов, которую можно было использовать для совершения DoS атаки через драйвер e1000e.


Кроме того, можно отметить два опубликованных в последние дни уведомления об уязвимостях:


-  Сообщается (http://secunia.com/advisories/38502/) об обнаружении в функции ядра do_pages_move() уязвимости, позволяющей локальному пользователю, через отправку специально оформленного сиситемного вызова "move_pages", инициировать отказ в ...

URL: http://lkml.org/lkml/2010/2/9/107
Новость: http://www.opennet.ru/opennews/art.shtml?num=25356

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


2. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 11:25 
Я запутался. Кто разобрался, подскажите. Собрался обновлять ядро 2.6.28.x, какое выбрать? Какое не прекратило развитие, и содержит все исправления безопасности от взлома, но при этом в нём (30, 31, 32?) ещё не замедлена работа ext4?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Зилибоба (ok) on 10-Фев-10, 11:27 
Если вы первое и второе не можите совместить, зачем вам такой симбиоз?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +1 +/
Сообщение от uldus (ok) on 10-Фев-10, 11:31 
>Я запутался. Кто разобрался, подскажите. Собрался обновлять ядро 2.6.28.x, какое выбрать?

Если вы не разработчик ядра и не доброволец по проведению тестирования, используйте только то ядро, которое поставляется в комплекте с вашим дистрибутивом.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 12:42 
С моим дистрибутивом идёт ядро 2006 года, которое не поддерживает мой контроллер жёстких дисков.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от pavlinux (ok) on 10-Фев-10, 16:36 
Замени контроллер жёстких дисков. =)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

23. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Andrey Mitrofanov on 10-Фев-10, 16:44 
Лучше его год выпуска. |)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

26. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 17:03 
>Лучше его год выпуска. |)

В 2006-м, скорее всего, не было ни SATA2, ни контроллера ATi. Generic это конечно тоже круто, но мне надо, чтобы было SATA II.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

28. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Andrey Mitrofanov on 10-Фев-10, 17:14 
Тогда предлагаю %)) Машину Времени! Твой дистр.2006-го внутри виртуализатора или контейнера на "совресменном" дистрибутиве, на "неправильном" железе.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

31. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от pavlinux (ok) on 10-Фев-10, 18:57 
>>Лучше его год выпуска. |)
>
>В 2006-м, скорее всего, не было ни SATA2, ни контроллера ATi. Generic
>это конечно тоже круто, но мне надо, чтобы было SATA II.
>

SATA II было, работал вот такой девайс - Promise SX8

http://www.promise.com/product/product_detail_eng.asp?produc...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

35. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  –2 +/
Сообщение от User294 (ok) on 10-Фев-10, 20:17 
>С моим дистрибутивом идёт ядро 2006 года,

Epic necromancy skills! oO

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

22. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от никс on 10-Фев-10, 16:43 
отсюда можно брать последнее не тестовое... http://kernel.ubuntu.com/~kernel-ppa/mainline/
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

24. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +1 +/
Сообщение от Zenitur email on 10-Фев-10, 17:00 
0_0 Сразу вспоминается цитата http://ibash.org.ru/quote.php?id=12276. Вы, видимо, очень удивитесь, узнав, что у меня не Ubuntu. Потому что предлагая мне собранные для него ядра, вы верно предполагали, что раз у меня Linux, то это конечно Ubuntu?
Но всё равно спасибо.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

37. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от IGX on 10-Фев-10, 22:05 
Лично вам советую попробовать самую последню стабильную фишку сезона - CentOS 3! :)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Ivan (??) on 10-Фев-10, 11:47 
2.6.27 либо 2.6.31
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +1 +/
Сообщение от Аноним (??) on 10-Фев-10, 12:21 
>2.6.27 либо 2.6.31

Это вредный совет, поддержка 2.6.27 будет прекращена через несколько месяцев, а для 2.6.31 пару недель назад выход обновлений прекращен.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 13:11 
Значит, 2.6.30.xx самый последний - мой выбор? Если в 31 замедления работы ext4 тоже нет - то выберу его.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от XoRe (ok) on 10-Фев-10, 14:52 
>Значит, 2.6.30.xx самый последний - мой выбор? Если в 31 замедления работы
>ext4 тоже нет - то выберу его.

Я бы порекомендовал 2.6.32.x
Хотя я не тестировал специально.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 15:55 
>>Значит, 2.6.30.xx самый последний - мой выбор? Если в 31 замедления работы
>>ext4 тоже нет - то выберу его.
>
>Я бы порекомендовал 2.6.32.x
>Хотя я не тестировал специально.

Раньше я не задумываясь брал последнюю стабильную версию... Но тут бают, что ext4 медленнее с какой-то из них, значит надо старую ветку. А какую-то из последних веток больше не развивают. Фороникс во всём виноват, из-за него все беды! Не сказал бы никому о падении скорости, и я бы не мучился.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от pkunk (ok) on 10-Фев-10, 16:10 
Use .32.x, Luke.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

27. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от XoRe (ok) on 10-Фев-10, 17:10 
>Раньше я не задумываясь брал последнюю стабильную версию... Но тут бают, что
>ext4 медленнее с какой-то из них, значит надо старую ветку. А
>какую-то из последних веток больше не развивают. Фороникс во всём виноват,
>из-за него все беды! Не сказал бы никому о падении скорости,
>и я бы не мучился.

Я говорю именно про 32.х.
По своим ощущениям и ощущениям коллеги, на этой версии ext4 работает очень шустро.
А баять могут много чего.
Бают, что java быстрее C =)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

38. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 22:44 
У меня просто IDE UATA-100 и скорость нужна ((
Решил остаться на 2.6.28 и не трогать то, что работает. Потому что начиная с 30-го какие-то галлюцинации у ядра. То Торвальдс говорит о сильом падении производительности, то дрова Интела замедляются, то ext4 замедляется, то ветка ядра перестаёт развиваться... Ну их! Я на 2.6.28 и всё работает как работало всегда.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

44. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от XoRe (ok) on 11-Фев-10, 11:09 
>У меня просто IDE UATA-100 и скорость нужна ((
>Решил остаться на 2.6.28 и не трогать то, что работает. Потому что
>начиная с 30-го какие-то галлюцинации у ядра. То Торвальдс говорит о
>сильом падении производительности, то дрова Интела замедляются, то ext4 замедляется, то
>ветка ядра перестаёт развиваться... Ну их! Я на 2.6.28 и всё
>работает как работало всегда.

Говорят... говорят разное.
Говорят, в Москве кур доят)
Тем более, что у вас зависит не только от ext4, но и от реализации IDE подсистемы.
А её сейчас переводят на libata, если не ошибаюсь.
И то, что у Торвальдса или у Форониксов - это одно, а то, что у ВАС на компьютере - это другое.
Могу порекомендовать поставить себе несколько ядер и запустить бенчмарки в каждом.
Сразу все узнаете для своей ситуации)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

32. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +1 +/
Сообщение от alex789 on 10-Фев-10, 19:24 
замедление ext4 сделано чтобы гарантировать целостность данных в случае внезапной перезагрузки(сбой питания...),
монтирую ext4 с опцией nobarrier и никакого замедления не будет(только не забудь юзать UPS)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

36. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  –1 +/
Сообщение от User294 (ok) on 10-Фев-10, 20:19 
>2.6.27

А может на 2.4 сразу?Чего мелочиться то? :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

42. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от vayerx (ok) on 11-Фев-10, 01:06 
самоубийцы! сырое оно еще, 2.4-ое! (с)
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

43. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от GArik on 11-Фев-10, 04:47 
Дело было так:
Re: US-CERT предупреждает о продолжающейся атаке на Линукс-системы
>Отдельные джедаи еще на 2.2 сидятъ

Вот экстремалы, я пока с 2.0 уходить не собираюсь, сырое еще 2.2...
anonymous (*) (27.08.2008 10:13:56)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +1 +/
Сообщение от vizor (ok) on 10-Фев-10, 11:55 
Вообще говоря уже давно была новость что для 27 ядра завершается цикл поддержки, следующим LTS будет 32 - так что ответ очевиден, насчёт ext4 - nobarrier спасёт вас от заботы разработчиков
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 13:11 
Писали, что "разработчики не рекомендуют".
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от pkunk (ok) on 10-Фев-10, 14:43 
Логично, либо скорость, либо надёжность. Выбор за Вами.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 15:52 
Пока что у меня 2.6.28 и есть и скорость, и надёжность!
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от pkunk (ok) on 10-Фев-10, 16:11 
>Пока что у меня 2.6.28 и есть и скорость, и надёжность!

Думаешь её просто так, из вредности, замедлили? =)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

25. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 17:01 
>>Пока что у меня 2.6.28 и есть и скорость, и надёжность!
>
>Думаешь её просто так, из вредности, замедлили? =)

Ну так у меня и не последнее ядро, чтобы ext4 стал в нём нестабильным.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

33. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +1 +/
Сообщение от User294 (ok) on 10-Фев-10, 20:05 
> Ну так у меня и не последнее ядро, чтобы ext4 стал в нём нестабильным.

Лолз! Если кто думает что в .28 EXT4 был офигенно стабилен, хочу порадовать: иногда полезно читать ченжлоги и врубать мозги. Стал нестабильным? У вас юмор такой своеобразный? Для начала EXT4 был нестабильным и вот где-то в районе 30-х ядер в нем пришибли ряд довольно мерзких багов (разрушения файлов и даже дестрой тома в редкой но меткой ситуации). И я кстати не уверен что в вашем 28 ядре эти фиксы есть. Удачи в курении на пороховых бочках :-).

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

39. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 22:46 
Почти год с ext4 и никаких сбоев. После вырубания питания ничего не пропадает. А вот на ext3 такие логи fsck несколько раз выдавал! Что я в панике бежал в IRC спрашивать, живой ли компьютер после этого или не совсем?!
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

46. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от User294 (ok) on 12-Фев-10, 01:38 
>Почти год с ext4 и никаких сбоев.

Ну, вообще-то я перешел на него местами. Но "никаких сбоев"... понимаете, судить по аж целому одному себе - не очень умно и достаточно самонадеянно. Вы и правда счмтаете что сможете загнать ФС в все возможные случаи в 1 фэйс? А хотите я докажу вам что это не так? Скажите, а у вас много файлов размером в 100Гб на вашем диске? А папок с 30 000 файлов? А чтоб еще и вложенных? А что случается при окончании места при всевозможных операциях?  Я бы заметил что в EXT4 была починена проблема вызывавшая полное разрушение тома. Да, редкая. Но "выиграть миллион" таким методом мне бы не хотелось. А если в игру будет играть миллион юзвергов - кто-то его выиграет. И будет крепко ругаться (не без оснований).

>После вырубания питания ничего не пропадает.

Что-то есть сомнения что вы специально устраивали стресс-тесты с ребутами раз в 10 минут при записи на всем ходу. А в крейсерском режиме - там уж как повезет.

>А вот на ext3 такие логи fsck несколько раз выдавал! Что я в панике
>бежал в IRC спрашивать, живой ли компьютер после этого или не совсем?!

Лично я с EXT4 на грабли натыкался. Заодно обнаружил что Теодору не пофигу на его ФС, он достаточно активно интересуется проблемами в его ФС и довольно шустро чинит их. И (да, пронесло... и меня тоже) фатальных проблем не было. Были минорные. Но - были. Из-за чего я и пообщался с Теодором, приятно удивившим оперативной и конструктивной реакцией. А ченжлоги ядер могут и напугать вообще. В *данный* момент - да, вроде стабилизировалось, особо воплей нет и ченжлоги уже не страшные. Есть надежды что баги более-менее вытоптали. Поэтому я местами рискую юзать его (хоть и с пониженным уровнем доверия). Но глядя на ченжлоги и прочая - я резонно полагаю что как можно более свежий кернель для работы с ext4 is a must. Теодор не делает свою ФС хуже с течением времени. Он всего лишь чинит грабли которые нашлись. Поэтому если вы думаете что в .28 ядре ext4 лучше чем в .32 - вы сильно неправы на этот счет. "Если вам кажется что дела идут хорошо, значит вы просто чего-то не заметили".

P.S. кстати да, EXT4 достаточно резвая ФС. EXT3 она делает основательно, как ни крути.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

34. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от User294 (ok) on 10-Фев-10, 20:10 
>Думаешь её просто так, из вредности, замедлили? =)

Он наивный чукотский юноша просто :). Ему б ченжлоги ext4 почитать сначала да мозг включить...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Аноним (??) on 10-Фев-10, 13:21 
Используйте gentoo: в системе все ядра начиная с 2.6.16 до текущего 2.6.32.8, причём включают не только официальные исправления
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Анон on 10-Фев-10, 13:43 
Еще есть git-sources-2.6.33_rc7-r3
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

21. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от pavlinux (ok) on 10-Фев-10, 16:39 
>Еще есть git-sources-2.6.33_rc7-r3

Уже 2.6.33-rc7-git4 =)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

29. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Аноним (??) on 10-Фев-10, 17:22 
Чёрт а я и не знал, что там ещё такое есть
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от Zenitur email on 10-Фев-10, 15:53 
>Используйте gentoo: в системе все ядра начиная с 2.6.16 до текущего 2.6.32.8,
>причём включают не только официальные исправления

Так не только в Gentoo. В любом популярном дистрибутиве то же самое, кроме SlackWare. И то в последнем релизе ядро в кои-то веки пропатчили, чтобы сделать комфортнее работу людям с ограниченными возможностями.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

45. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от vehn (ok) on 11-Фев-10, 18:37 
>>Используйте gentoo: в системе все ядра начиная с 2.6.16 до текущего 2.6.32.8,
>>причём включают не только официальные исправления
>
>Так не только в Gentoo. В любом популярном дистрибутиве то же самое,
>кроме SlackWare. И то в последнем релизе ядро в кои-то веки
>пропатчили, чтобы сделать комфортнее работу людям с ограниченными возможностями.

Эти патчи Патрик Ф. накладывает на ядра Slackware если не с появления Slackware как дистрибутива, то весьма близко к этому.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

47. "Обновление Linux ядра 2.6.32.8, исправлено несколько проблем..."  +/
Сообщение от alfa (??) on 12-Фев-10, 12:47 
А это уезвимость есть в kvm-88.tar.gz ???
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру