The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от opennews on 27-Окт-13, 22:59 
Вышла (http://permalink.gmane.org/gmane.org.fsf.announce/2047) новая версия популярной утилиты для организации поиска данных в текстовых файлах - GNU Grep 2.15. В новой версии для значительного ускорения поиска при использовании опции "-P"  добавлена поддержка JIT-компилятора для perl-совместимых регулярных выражений (PCRE). JIT-компилятор включается автоматически, но требует сборки grep с библиотекой PCRE, поддерживающей данную возможность. Кроме того, в новой версии налажено корректное сопоставление многобайтовых символов пробела с масками "\s" и "\S" и устранена серия крахов, проявляющихся при работе с текстом и локалями в многобайтовых кодировках.

URL: http://permalink.gmane.org/gmane.org.fsf.announce/2047
Новость: http://www.opennet.ru/opennews/art.shtml?num=38267

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


2. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –1 +/
Сообщение от vitalif (ok) on 27-Окт-13, 23:25 
Ух ты. Я давно уже pcregrep юзаю, а они pcre оказывается в обычный запиливают O_o
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –5 +/
Сообщение от Яйцассыром on 28-Окт-13, 00:29 
есть еще oniguruma, которая быстрее, чем pcre
если уж нужна максимальная скорость лучше ее запилить
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

13. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от kurokaze (ok) on 28-Окт-13, 12:13 
Regex: '.*fence.*'
[oniguruma] time:   220 ms (284 matches)
[ pcre-jit] time:   100 ms (284 matches)
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

16. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –5 +/
Сообщение от Яйцассыром on 28-Окт-13, 12:51 
что это за буквы и как они опровергают то, что oniguruma быстрее, чем pcre?
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

18. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от kurokaze (ok) on 28-Окт-13, 13:23 
> что это за буквы

Это латинские символы и арабские цифры, странно что ты этого не знаешь

> и как они опровергают то, что oniguruma быстрее, чем pcre?

Первый же найденый бенчмарк как бы говорит нам о том, что ты лжешь


Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

19. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –3 +/
Сообщение от Яйцассыром on 28-Окт-13, 14:24 
ясно, очередной тролляка.

а я тебе рассказываю не о бенчмарках, а о реальном программе, где юзаю около 30 намного более сложных регулярок(есть и относительно простые) и на каждом регэкспе oniguruma оказывалась лучшей. Кроме одного случая, где не требуется захват групп - там RE2 оказался быстрее всех.

Но я до сих пор держу движки boost, pcre, oniguruma, re2 и при добавлении нового выражения выбираю лучший, пока что oniguruma - 27, re2 - 1, pcre - 0, boost - 0

кстати вот нашел какой-то ьенчмарк там регэксп "a[^x]{20}b" - действительно pcre быстрее в 7 раз.

А вот для приведенного троллякой
".*fence.*":
re2 = 0.82s
boost = 3.22s
pcre = 2.37s
oniguruma = 2.30s

и для ".*(fence).*":
re2 = 24.11s
bost = 3.85s
pcre = 3.64s
oniguruma = 2.55s

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

31. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +3 +/
Сообщение от Аноним (??) on 28-Окт-13, 18:00 
Для тупых объясню еще один раз, последний:
>pcre = 3.64s
>oniguruma = 2.55s

а надо сравнивать с pcre-jit

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

38. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –4 +/
Сообщение от Яйцассыром on 28-Окт-13, 19:07 
тебе лишь бы ляпнуть? с чего ты решил, что я не использовал jit?
Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

40. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 28-Окт-13, 21:23 
Потому что у тебя в посте про не го ни слова.
Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

41. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 28-Окт-13, 22:48 
> тебе лишь бы ляпнуть? с чего ты решил, что я не использовал jit?

Потому что на приведенном регекспе (который .*fence.*) pcre-jit в ~2 раза быстрее, чем oniguruma.

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

53. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Яйцассыром on 29-Окт-13, 00:45 
ты это тестировал? на каких данных он быстрее?
Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

67. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 29-Окт-13, 15:56 
> ты это тестировал? на каких данных он быстрее?

Ну вот вы например никакого JIT в вашем посте не упоминали, зато права качаете. Почему вы вашему оппоненту предъявляете, а себе то же самое - не хотите? Вам не кажется что это слегка двойные стандарты?

Ответить | Правка | ^ к родителю #53 | Наверх | Cообщить модератору

82. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 29-Окт-13, 19:19 
> ты это тестировал?

http://www.opennet.ru/openforum/vsluhforumID3/92332.html#13

Ответить | Правка | ^ к родителю #53 | Наверх | Cообщить модератору

49. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 28-Окт-13, 23:02 
> Ух ты. Я давно уже pcregrep юзаю, а они pcre оказывается в обычный запиливают O_o

pcregrep - это особенность дебиановской сборки. Пакет grep - это обычный grep, но специально собранный без pcre.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

3. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –5 +/
Сообщение от Xasd (ok) on 28-Окт-13, 00:13 
а ведь на Windows_RT (и Apple_iOS) -- не поддерживается JIT?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Псевдоним (ok) on 28-Окт-13, 01:38 
Как напишешь транслятор, так и будет поддерживаться. Платформа здесь мало чем тебе помешать может.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

22. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Xasd (ok) on 28-Окт-13, 14:57 
> Платформа здесь мало чем тебе помешать может.

думаю проблема в специальном бите в оперативной памяти (Execute Disable Bit? или как там на ARM?) , который разрешает или запрещает выполнение машинных инструкций из области памяти.

разумеется виноват не сам бит -- а то как он испольуется в операционной системе :) ..

> Как напишешь транслятор, так и будет поддерживаться.

если только операционная система разрешит делать Memory Allocation с доступом на выполнение кода.

Linux -- разумеется разрешит! в Linux этот бит -- используется во благо :-)

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

60. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –1 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 02:01 
>> Платформа здесь мало чем тебе помешать может.
> думаю проблема в специальном бите в оперативной памяти (Execute Disable Bit? или
> как там на ARM?) , который разрешает или запрещает выполнение машинных
> инструкций из области памяти.
> разумеется виноват не сам бит -- а то как он испольуется в
> операционной системе :) ..

я бы сказал то как написан компилятор. никто не мешает сделать трамлины не на стеке - но в тоже время они сделаны в gcc только там.

>> Как напишешь транслятор, так и будет поддерживаться.
> если только операционная система разрешит делать Memory Allocation с доступом на выполнение
> кода.
> Linux -- разумеется разрешит! в Linux этот бит -- используется во благо
> :-)

hint. трамплины в gcc - пока это будет существовать, на стек поставить NX бит нельзя.


Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

64. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –1 +/
Сообщение от Псевдоним (ok) on 29-Окт-13, 13:43 
> думаю проблема в специальном бите в оперативной памяти (Execute Disable Bit? или
> как там на ARM?) , который разрешает или запрещает выполнение машинных
> инструкций из области памяти.

Это вопрос одного вызова mprotect/VirtualProtect.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

78. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 29-Окт-13, 16:18 
> Это вопрос одного вызова mprotect/VirtualProtect.

А кто сказал что вам собираются тебе позволять? Пометить область кода как readonly, а область данных как no execute - удачи в JIT.

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

6. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от pavlinux (ok) on 28-Окт-13, 01:52 
> а ведь на Windows_RT (и Apple_iOS) -- не поддерживается JIT?

Java и .NET уже не работают на венде?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

11. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –1 +/
Сообщение от Mr. Cake on 28-Окт-13, 11:46 
JVM на WinRT не заведётся, там нельзя самому вызывать VirtualProtect. Дотнетовский Reflection.Emit тоже порезали. Редиски, нехорошие люди.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

7. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +5 +/
Сообщение от Michael Shigorin email(ok) on 28-Окт-13, 02:47 
> а ведь на Windows_RT (и Apple_iOS) -- не поддерживается JIT?

Дорогой, куда там так спешить?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +3 +/
Сообщение от AlexAT (ok) on 28-Окт-13, 07:55 
Точнее - кому там спешить?
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 11:35 
дорогой ты к себе не думал применять пункт правил о создании флуда?
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

42. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 28-Окт-13, 22:49 
> дорогой ты к себе не думал применять пункт правил о создании флуда?

Потому что к тебе его применять гораздо веселее. Ты так прикольно бугуртишь))

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

54. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –4 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 01:53 
а как же не предвзятость модератора ?:)
Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

70. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от Аноним (??) on 29-Окт-13, 15:59 
> а как же не предвзятость модератора ?:)

Согласен, модераторы на этом ресурсе предвзятые. При непредвзятом рассмотрении твоей кандидатуры надо было стереть твои посты и забанить КЕМ. Вот это было бы по заслугам.

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

65. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Michael Shigorin email(ok) on 29-Окт-13, 14:04 
> Потому что к тебе его применять гораздо веселее.

Дело не в веселье, а в том, что мой ответ был техническим, но неуважаемый самозваный псевдооппонент оказался неспособен это уловить.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

23. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Xasd (ok) on 28-Окт-13, 15:02 
>> а ведь на Windows_RT (и Apple_iOS) -- не поддерживается JIT?
> Дорогой, куда там так спешить?

ды просто интересно.. не более того :-)

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

71. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от Аноним (??) on 29-Окт-13, 16:02 
> ды просто интересно.. не более того :-)

Мне интереснее другое: ты и правда собираешься использовать GNU Grep на этом огороженном г@вне? А ты уверен что для начала владельцы платформы вообще позволят тебе такую блажь? И что ты там грепать собираешься? Там же огорожено все что только можно и нельзя. И JIT по той же самой причине зарублен - чтоб хомяк из своей лабораторной клетки ненароком не сбежал.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

85. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Xasd (ok) on 03-Ноя-13, 00:54 
>> ды просто интересно.. не более того :-)
> Мне интереснее другое: ты и правда собираешься использовать GNU Grep на этом
> огороженном г@вне?

нет, не собираюсь :)

> А ты уверен что для начала владельцы платформы вообще
> позволят тебе такую блажь?

и мне это тоже интересно :-)

> И что ты там грепать собираешься?

хм... сказать трудно..

Ответить | Правка | ^ к родителю #71 | Наверх | Cообщить модератору

29. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –4 +/
Сообщение от CSRedRat (ok) on 28-Окт-13, 17:10 
В iOS сознательно выпилено, недавно читал статью. Разобрались и нашли причины поступить по своему правильно. У Apple свой путь и это тоже хорошо, путей должно быть свободно много.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

69. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 29-Окт-13, 15:58 
> путей должно быть свободно много.

Да, у Гитлера тоже свой путь был. Вот эппл чем-то таким напоминает - их путь тоже концлагерями попахивает, хоть и виртуальными.

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

68. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от Аноним (??) on 29-Окт-13, 15:56 
> а ведь на Windows_RT (и Apple_iOS) -- не поддерживается JIT?

Тем хуже для WinRT и Apple iOS //ваш Капитан.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

10. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –5 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 11:37 
> устранена серия крахов, проявляющихся при работе с текстом и локалями в многобайтовых кодировках.

сколько из этих крахов можно использовать для атаки? берем подсовываем хлам в /var/log/messages и когда админ делает grep по логу... выполняем произвольный код..

Линуксоиды делают все что можно лишь бы прятать свои ошибки в безопастности...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Andrey Mitrofanov on 28-Окт-13, 11:48 
> Линуксоиды делают все что можно лишь бы прятать свои ошибки в безопастности...

Ты бы пошёл, в новости об своей любовной freebsd, или кто там у тебя, поприбумывал заговоры. Ты же не объективен. Вот в новости про fbsd накакаешь -- поверю, всё взаправду.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

20. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –4 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 14:25 
на придумывал? да ну..

вот примерчик буквально недавний...

В Linux-утилите grep обнаружена опасная уязвимость (CVE-2012-5667), которая проявляется при обработке специально сформированного входного потока и может быть использована для инициирования отказа в обслуживании, а также, возможно, для выполнения произвольного кода. Подвержены выпуски утилиты grep до версии 2.11. В выпуске 2.11, вышедшем в начале марта 2012 года, эта уязвимость была исправлена, однако не было сделано никаких специальных анонсов о том, что ошибка имеет отношение к проблемам с безопасностью.

есть что сказать по теме? судя по новости в 2.15 еще одна тонна таких ошибок исправлена..

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

24. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +3 +/
Сообщение от Andrey Mitrofanov on 28-Окт-13, 15:22 
> на придумывал? да ну..

Докaжи, что ты
1. объективный, и гадшь во _все новости. Тебе же можно _верить_, да-а-а?
2. не тyпой, и понял, о чём я

Запости выжимку из (их! не перепутай) багтрекера в www.opennet.ru/opennews/art.shtml?num=38225

В своём обычном флyдo раcт ическом стиле, чтоб не меньше половины постов -- твои. И с теориями заговоров -- обязательно.

Ну?

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

35. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –4 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 19:00 
>> на придумывал? да ну..
> Докaжи, что ты
> 1. объективный, и гадшь во _все новости. Тебе же можно _верить_, да-а-а?  
> 2. не тyпой, и понял, о чём я

тебе сколько лет что бы ловить на слабо? мне незачем самоутверждаться :) А ты боишся видимо расстаться с своим ореолом гуру? Ты не бойся никто твой уютный linux не обижает :) не стоит выпячивать свои комплексы наружу, как и некомпетентность.


> Запости выжимку из (их! не перепутай) багтрекера в www.opennet.ru/opennews/art.shtml?num=38225

зачем?  я такой мелочью не развлекаюсь. Вот ext4-devel более адекватно реагировал на тыканье в многолетние проблемы в linux-mm, и таки suse родил патчик.. А ты чего добился?


> В своём обычном флyдo раcт ическом стиле, чтоб не меньше половины постов
> -- твои. И с теориями заговоров -- обязательно.

да да :) а по теме сказать есть чего? считаешь что CVE-2012-5667 не применимо к этой новости?
Хочешь сказать что если grep падает в крэш от просмотра текста, то нельзя через syslog слить что-то такое что из-за чего grep упадет при обработке /var/log/messages? хочешь сказать что не одна из этих ошибок (исправленых в этом релизе) не может быть эксплуатирована как это было сделано в CVE-2012-5667 ?

ну так?

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

45. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +3 +/
Сообщение от Аноним (??) on 28-Окт-13, 22:58 
> тебе сколько лет что бы ловить на слабо? мне незачем самоутверждаться :)

Сказал человек, который уже не первый год самоутверждается, пытаясь гадить на других.
(Каковой способ самоутверждения люди обычно используют только при отсутствии альтернативных методов)

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

46. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Andrey Mitrofanov on 28-Окт-13, 22:58 
>> 2. не тyпой, и понял, о чём я
> тебе сколько лет что бы ловить на слабо? мне незачем самоутверждаться :)

п.2

> А ты боишся видимо расстаться с своим ореолом гуру? Ты не
> ну так?

Доказательство во весь рост по обоим пунктам. Засранец довольно неискренний, говорящий не то, что думает. Тупой - соскакиваюший без огонька, либо вообще не въехавший в вопрос.

Ну, давай, потряси ещё своими неискренники рев.шароварами с запахом рассказов о патчах Novel-а 1800-лохматого года. Ты же за Безопасность /bin/grep-а? По тебе _видно.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

55. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –3 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 01:55 
>>> 2. не тyпой, и понял, о чём я
>> тебе сколько лет что бы ловить на слабо? мне незачем самоутверждаться :)
> п.2
>> А ты боишся видимо расстаться с своим ореолом гуру? Ты не
>> ну так?
> Доказательство во весь рост по обоим пунктам. Засранец довольно неискренний, говорящий
> не то, что думает. Тупой - соскакиваюший без огонька, либо вообще
> не въехавший в вопрос.
> Ну, давай, потряси ещё своими неискренники рев.шароварами с запахом рассказов о патчах
> Novel-а 1800-лохматого года. Ты же за Безопасность /bin/grep-а? По тебе _видно.

спасибо посмешил. Так по теме сказать есть что? или переход на личности все что можешь предложить ?
а патчи - не 1800 года, а 3.10 или 3.11, не помню уж - да и не интересно было.

А тебе уважаемый кроме злости есть что сказать ?

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

25. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним email(??) on 28-Окт-13, 15:25 
A также возможно для вызова духа Наполеона и запуска ядерных ракет, да.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

28. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от pavlinux (ok) on 28-Окт-13, 16:54 
> A также возможно для вызова духа Наполеона и запуска ядерных ракет, да.

В ядре нет ракет!

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

36. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 19:02 
>> A также возможно для вызова духа Наполеона и запуска ядерных ракет, да.
> В ядре нет ракет!

зато linux используют в том числе на кластерах которые производят расчеты по программе ядерного оружия США -> Sandia.gov с их кластером Cray XT. не помню какой именно там - года 4 назад был XT3 на catamount,  что сейчас стоит (в свете того что крей сказал что catamount больше нигде не используется) - не знаю.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

44. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 28-Окт-13, 22:56 
> зато linux используют в том числе на кластерах которые производят расчеты по
> программе ядерного оружия США -> Sandia.gov с их кластером Cray XT.

... и расчеты эти сводятся исключительно к запуску grep из-под рута.

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

56. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 01:56 
>> зато linux используют в том числе на кластерах которые производят расчеты по
>> программе ядерного оружия США -> Sandia.gov с их кластером Cray XT.
> ... и расчеты эти сводятся исключительно к запуску grep из-под рута.

grep из под рута там тоже используется :)

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

72. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 29-Окт-13, 16:04 
> В ядре нет ракет!

Безобразие! Ждем новую версию.

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

32. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от Аноним (??) on 28-Окт-13, 18:03 
> про fbsd накакаешь -- поверю, всё взаправду.

Андгей ... а ви таки вправду не заметили что лет уж 5 как лапяатые рекомендуют срочно обновиться из за проблем безопасности ... не расскрывая суть проблемы? И чем они лучше любимого тут оракала? Изложите будьте любезны, мы Вас внимательно скушаем :)

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

37. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –3 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 19:04 
>> про fbsd накакаешь -- поверю, всё взаправду.
> Андгей ... а ви таки вправду не заметили что лет уж 5
> как лапяатые рекомендуют срочно обновиться из за проблем безопасности ... не
> расскрывая суть проблемы? И чем они лучше любимого тут оракала? Изложите
> будьте любезны, мы Вас внимательно скушаем :)

не разрывай шаблон человеку... Плохим может быть только Oracle, FreeBSD (оскорбляющая всех своей BSDL) и тп.. а в FSF только святые (не забываем что grep развивается под патронажем GNU/FSF).

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

73. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 29-Окт-13, 16:05 
> что grep развивается под патронажем GNU/FSF).

Отлично. Он развивается и в нем полезная фича появилась. С чего вдруг такой сказочный батхерт? :)

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

80. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 18:24 
у вас? я лишь напомнил что в новости забыли указать на проблемы с безопастностью...
Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

48. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от Andrey Mitrofanov on 28-Окт-13, 23:01 
> как лапяатые рекомендуют

Прожуй, потом говори.

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

51. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +4 +/
Сообщение от Аноним (??) on 28-Окт-13, 23:03 
>> как лапяатые рекомендуют
> Прожуй, потом говори.

Если он начнет жевать то, что держит во рту - получит сапогом по морде. И поделом.

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

15. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от kurokaze (ok) on 28-Окт-13, 12:19 
> сколько из этих крахов можно использовать для атаки?

Т.е. ты как бы сам не знаешь, но ляпнуть чепуху очень хочется? Передерг отмечаем

> Линуксоиды делают все что можно

Где линуксоиды? Какие линуксоиды?
grep это GNU, линукс - это ядро.
Слушай завязывал бы ты уже бухать по утрам, печень отвалится и ты перестанешь нас своей альтернативной одаренностью радовать.

> лишь бы прятать свои ошибки в безопастности...

Э, да ты оракло-фоб, у них жабка обновляется только по расписанию, когда уже сотни уязвимостей в ней эксплуатируются

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

21. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –3 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 14:26 
>> сколько из этих крахов можно использовать для атаки?
> Т.е. ты как бы сам не знаешь, но ляпнуть чепуху очень хочется?
> Передерг отмечаем

да нет, просто напоминаю о CVE-2012-5667, при том что анализировать код просто лениво.. Устало я за выходные :)

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

33. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от pavel_simple (ok) on 28-Окт-13, 18:13 
>>> сколько из этих крахов можно использовать для атаки?
>> Т.е. ты как бы сам не знаешь, но ляпнуть чепуху очень хочется?
>> Передерг отмечаем
> да нет, просто напоминаю о CVE-2012-5667, при том что анализировать код просто
> лениво.. Устало я за выходные :)

если ты устало -- не напрагайся,  не стоит тратить на нас время

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

34. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от linux must __RIP__ on 28-Окт-13, 18:55 
на тебя не стоит. Но новичков надо предупредить. Что бы избавились от розовых очков и видели как замалчиваются проблемы безопасности. А ведь прошло меньше года с времен CVE-2012-5667 - но опять же предпочитают спрятать голову в песок и не замечать этого.
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

39. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от pavel_simple (ok) on 28-Окт-13, 21:03 
> на тебя не стоит. Но новичков надо предупредить. Что бы избавились от
> розовых очков и видели как замалчиваются проблемы безопасности. А ведь прошло
> меньше года с времен CVE-2012-5667 - но опять же предпочитают спрятать
> голову в песок и не замечать этого.

слушай, рип, я как-то пытался вести осмыслеенную беседу, пытался так-же как ты грубо набрасывать -- и итоге.... в итоге ничего -- ты просто дурак. жаль.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

52. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Led (ok) on 29-Окт-13, 00:35 
> я как-то пытался вести осмыслеенную беседу

С чем? с бревном? зачем?


Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

57. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –1 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 01:58 
>> на тебя не стоит. Но новичков надо предупредить. Что бы избавились от
>> розовых очков и видели как замалчиваются проблемы безопасности. А ведь прошло
>> меньше года с времен CVE-2012-5667 - но опять же предпочитают спрятать
>> голову в песок и не замечать этого.
> слушай, рип, я как-то пытался вести осмыслеенную беседу, пытался так-же как ты
> грубо набрасывать -- и итоге.... в итоге ничего -- ты просто
> дурак. жаль.

оо. переход на личности. Так есть что сказать по факту нового варианта CVE-2012-5667 спустя пол года?
или хамство - все что можно сказать?

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

62. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +2 +/
Сообщение от Andrey Mitrofanov on 29-Окт-13, 07:54 
>по факту нового варианта CVE-2012-5667 спустя пол года?

Пациент потерян для реальности.

> или хамство - все что можно сказать?

Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

63. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –1 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 11:51 
О.. линуксоиды для себя придумали паралельную реальность - когда баги в безопасности уже багами не являются ?:)  поздравляю. Ты так успешно показываешь свою не компетентность..
Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

66. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Michael Shigorin email(ok) on 29-Окт-13, 14:15 
> слушай, рип, я как-то пытался вести осмыслеенную беседу

Понимаете, Павел, в чём дело.  У него шоры специфические -- когда дело о GNU/Linux, то тут тебе и CVE, и скандалы, и что угодно вытряхнет на стол.  А когда дело об оракле, где, по его же словам, не работает -- моментально дыры самозалечиваются, скандалы самозабываются и стол сверкает новеньким зелёным сукном.  Даже если речь опять же о GNU/Linux, только чуть другого фасона, чем НенавистнаяШляпа(tm).

Вы как хотите, а я общение с этим человеком прекратил.  Порой, не посмотрев на ник, отвечаю, иногда не спохватываюсь до отправки сообщения.  Над такими ошибками ведётся работа.

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

81. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от pavel_simple (ok) on 29-Окт-13, 18:52 
>> слушай, рип, я как-то пытался вести осмыслеенную беседу
> Понимаете, Павел, в чём дело.  У него шоры специфические -- когда
> дело о GNU/Linux, то тут тебе и CVE, и скандалы, и
> что угодно вытряхнет на стол.  А когда дело об оракле,
> где, по его же словам, не работает -- моментально дыры самозалечиваются,
> скандалы самозабываются и стол сверкает новеньким зелёным сукном.  Даже если
> речь опять же о GNU/Linux, только чуть другого фасона, чем НенавистнаяШляпа(tm).
> Вы как хотите, а я общение с этим человеком прекратил.

именно это-же сделал и я, потому что дураком я не всякого называю
>  Порой,
> не посмотрев на ник, отвечаю, иногда не спохватываюсь до отправки сообщения.
>  Над такими ошибками ведётся работа.

Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

50. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +4 +/
Сообщение от Andrey Mitrofanov on 28-Окт-13, 23:03 
> на тебя не стоит. Но новичков надо предупредить.

У новичков в соседней ветке pf не фильтрует и wifi не заводится. Пройдите, маэстро! Непременно предупреждать!!

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

74. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 29-Окт-13, 16:10 
> на тебя не стоит. Но новичков надо предупредить. Что бы избавились от
> розовых очков и видели как замалчиваются проблемы безопасности.

Поэтому нефиг из себя дон-кихотов корчить: хочется отсутствия таковых проблем - используйте свежий софт. Если майнлайнщики говорят что надо обновиться - на это есть причины. При том причиной может быть невкусный баг или потенциальная дырка. И что характерно, все это есть и в другом софте. Более того, еще большой вопрос где качество кода лучше.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

79. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 29-Окт-13, 16:21 
> меньше года с времен CVE-2012-5667

Ты так с ним носишься что просто обязан вытутаировать это на лбу. Ну так, чтобы новичков предупреждать.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

43. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 28-Окт-13, 22:54 
> сколько из этих крахов можно использовать для атаки? берем подсовываем хлам в
> /var/log/messages и когда админ делает grep по логу... выполняем произвольный код..

Such injection issues are not treated as security issues © Debian security team

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

58. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от linux must __RIP__ on 29-Окт-13, 01:58 
>> сколько из этих крахов можно использовать для атаки? берем подсовываем хлам в
>> /var/log/messages и когда админ делает grep по логу... выполняем произвольный код..
> Such injection issues are not treated as security issues © Debian security
> team

это тот team - от работы которого страдает интернет из-за дыры в openssl ?

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

77. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 29-Окт-13, 16:14 
> это тот team - от работы которого страдает интернет из-за дыры в openssl ?

Послушать линуксрипа - так дыры и баги только в дебиане, в линуксе и в гнутых утилах. Хотя если уж о новичках и вранье - вот это как раз наглое вранье и двойные стандарты. Баги и дыры есть в любом софте сложнее hello world. Но про это линуксхрип тактично умалчивает, ведь неудобно же признавать очевидное.

Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

75. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Аноним (??) on 29-Окт-13, 16:11 
> Such injection issues are not treated as security issues

Если некто может писать в такие файлы - пожалуй они и в /dev/sda нули запишут. После чего не так уж и важно что они еще и в messages могли писать...

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

83. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +/
Сообщение от Michael Shigorin email(ok) on 29-Окт-13, 19:38 
>> Such injection issues are not treated as security issues
> Если некто может писать в такие файлы - пожалуй они и в
> /dev/sda нули запишут. После чего не так уж и важно что
> они еще и в messages могли писать...

Смотря насколько произволен доступ что в лог, что в sda.  Можно долго переливать из пустого в порожнее, но при обсуждении вопросов безопасности конкретика полезней.

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

14. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  –2 +/
Сообщение от Аноним (??) on 28-Окт-13, 12:15 
Сначала развалим инфраструктуру операционки до основания, а потом заявим: "зато у нас в grep теперь есть PCRE"
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

47. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +3 +/
Сообщение от Аноним (??) on 28-Окт-13, 22:59 
> Сначала развалим инфраструктуру операционки до основания, а потом заявим: "зато у нас
> в grep теперь есть PCRE"

Линуксмастрип, залогинься.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

76. "Выпуск GNU grep 2.15 с поддержкой JIT-компиляции для PCRE-вы..."  +1 +/
Сообщение от Аноним (??) on 29-Окт-13, 16:12 
> Сначала развалим инфраструктуру операционки до основания,

Какую инфраструктуру? Какой операционки? И главное - при чем здесь греп?

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру