The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"TRUNK+VLAN+CISCO"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 10:48 
Привет всем:-)))
Глупо задавать очевидные вопросы, но .....

Есть рутер 2811 включен транком в каталист 2960.
Задача:
1. Организовать некоторое кол-во вланов с возможностью роутинга между ними.
2. Весь трафик завернуть через роутер(типа vlan1<->2811<->vlan2)

cat2960#sh running-config

..............
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
switchport access vlan 11
!
interface FastEthernet0/6
switchport access vlan 11
......................
switchport access vlan 15
!
interface FastEthernet0/24
switchport access vlan 15
!
interface GigabitEthernet0/1
switchport mode trunk
mls qos trust dscp
macro description cisco-router
auto qos voip trust
spanning-tree portfast trunk
spanning-tree bpduguard enable
..................................
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan10
ip address 192.168.10.10 255.255.255.0
no ip route-cache
!
interface Vlan11
ip address 192.168.11.10 255.255.255.0
no ip route-cache
!
interface Vlan12
ip address 192.168.12.10 255.255.255.0
no ip route-cache
!
interface Vlan13
ip address 192.168.13.10 255.255.255.0
no ip route-cache
!
interface Vlan14
ip address 192.168.14.10 255.255.255.0
no ip route-cache
!
interface Vlan15
ip address 10.50.4.252 255.255.255.0
no ip route-cache

c2811-gw-voip#sh running-config

interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.11
description DMZ_1$ETH-LAN$
encapsulation dot1Q 11
ip address 192.168.11.1 255.255.255.0
!
interface FastEthernet0/1.12
description DMZ_2$ETH-LAN$
encapsulation dot1Q 12
ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1.13
description DMZ_3$ETH-LAN$
encapsulation dot1Q 13
ip address 192.168.13.1 255.255.255.0
!
interface FastEthernet0/1.14
description DMZ_4$ETH-LAN$
encapsulation dot1Q 14
ip address 192.168.14.1 255.255.255.0
!
interface FastEthernet0/1.15
encapsulation dot1Q 15
ip address 10.50.4.253 255.255.255.0

Проблема в том, что нет пингов(вообще нет движения) между вланами:-((
Не сочтите за труд разъясните в чем проблема!!!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • TRUNK+VLAN+CISCO, Николай, 10:55 , 19-Дек-06, (1)  
    • TRUNK+VLAN+CISCO, avator, 11:10 , 19-Дек-06, (2)  
  • TRUNK+VLAN+CISCO, Specialized P1, 11:24 , 19-Дек-06, (3)  
    • TRUNK+VLAN+CISCO, avator, 11:27 , 19-Дек-06, (4)  
    • TRUNK+VLAN+CISCO, Кирилл, 11:29 , 19-Дек-06, (5)  
      • TRUNK+VLAN+CISCO, Кирилл, 11:30 , 19-Дек-06, (6)  
      • TRUNK+VLAN+CISCO, avator, 11:32 , 19-Дек-06, (7)  
        • TRUNK+VLAN+CISCO, fantom, 11:46 , 19-Дек-06, (8)  
          • TRUNK+VLAN+CISCO, avator, 12:09 , 19-Дек-06, (9)  
            • TRUNK+VLAN+CISCO, fantom, 12:40 , 19-Дек-06, (10)  
              • TRUNK+VLAN+CISCO, avator, 12:45 , 19-Дек-06, (11)  
                • TRUNK+VLAN+CISCO, fantom, 12:48 , 19-Дек-06, (12)  
                  • TRUNK+VLAN+CISCO, avator, 12:50 , 19-Дек-06, (13)  
                    • TRUNK+VLAN+CISCO, fantom, 13:03 , 19-Дек-06, (14)  
                      • TRUNK+VLAN+CISCO, avator, 13:22 , 19-Дек-06, (15)  
                        • TRUNK+VLAN+CISCO, fantom, 13:48 , 19-Дек-06, (19)  
                      • TRUNK+VLAN+CISCO, Николай, 13:23 , 19-Дек-06, (16)  
                        • TRUNK+VLAN+CISCO, avator, 13:32 , 19-Дек-06, (17)  
                        • TRUNK+VLAN+CISCO, Николай, 13:46 , 19-Дек-06, (18)  
  • TRUNK+VLAN+CISCO, Сайко, 14:51 , 19-Дек-06, (20)  
    • TRUNK+VLAN+CISCO, avator, 18:05 , 19-Дек-06, (21)  
      • TRUNK+VLAN+CISCO, lomo, 16:51 , 25-Дек-06, (22)  
  • TRUNK+VLAN+CISCO, Barbos, 10:57 , 26-Дек-06, (23)  
    • TRUNK+VLAN+CISCO, Barbos, 11:02 , 26-Дек-06, (24)  
      • TRUNK+VLAN+CISCO, avator, 22:16 , 28-Дек-06, (25)  

Сообщения по теме [Сортировка по времени, UBB]


1. "TRUNK+VLAN+CISCO"  
Сообщение от Николай email(??) on 19-Дек-06, 10:55 
Что выводит на 2950 и 2811 по команде #sh int trunk
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 11:10 
>Что выводит на 2950 и 2811 по команде #sh int trunk

cat2960#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan
Gi0/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Gi0/1       1-4094

Port        Vlans allowed and active in management domain
Gi0/1       1,10-15

Port        Vlans in spanning tree forwarding state and not pruned
Gi0/1       1,10-15

c2811-gw-voip#sh int trunk

ничего!!!!!!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "TRUNK+VLAN+CISCO"  
Сообщение от Specialized P1 on 19-Дек-06, 11:24 
ну так на транковом порту каталисты кроме switchport mode trunk
должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я коненчо могу ошибаться
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 11:27 
>ну так на транковом порту каталисты кроме switchport mode trunk
>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>коненчо могу ошибаться

Нет вы не ошибаетесь, да в случае если нужно выборочно дать то switchport trunk allowed vlan 1,2,5,...., а у меня все просто switchport trunk allowed vlan all поэтому етой строки не видно.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "TRUNK+VLAN+CISCO"  
Сообщение от Кирилл (??) on 19-Дек-06, 11:29 
>ну так на транковом порту каталисты кроме switchport mode trunk
>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>коненчо могу ошибаться

Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
А то мало ли он ISL tag вставляет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "TRUNK+VLAN+CISCO"  
Сообщение от Кирилл (??) on 19-Дек-06, 11:30 
>>ну так на транковом порту каталисты кроме switchport mode trunk
>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>коненчо могу ошибаться
>
>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>А то мало ли он ISL tag вставляет.


перепутал
на interface GigabitEthernet0/1 каталиста

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 11:32 
>>ну так на транковом порту каталисты кроме switchport mode trunk
>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>коненчо могу ошибаться
>
>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>А то мало ли он ISL tag вставляет.

cat2960(config-if)#switchport trunk ?
  allowed  Set allowed VLAN characteristics when interface is in trunking mode
  native   Set trunking native characteristics when interface is in trunking mode
  pruning  Set pruning VLAN characteristics when interface is in trunking mode

Нет такой команды

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "TRUNK+VLAN+CISCO"  
Сообщение от fantom (??) on 19-Дек-06, 11:46 
>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>коненчо могу ошибаться
>>
>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>А то мало ли он ISL tag вставляет.
>
>cat2960(config-if)#switchport trunk ?
>  allowed  Set allowed VLAN characteristics when interface is in
>trunking mode
>  native   Set trunking native characteristics when interface is
>in trunking mode
>  pruning  Set pruning VLAN characteristics when interface is in
>trunking mode
>
>Нет такой команды


На кошке ip routing набрать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 12:09 
>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>коненчо могу ошибаться
>>>
>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>А то мало ли он ISL tag вставляет.
>>
>>cat2960(config-if)#switchport trunk ?
>>  allowed  Set allowed VLAN characteristics when interface is in
>>trunking mode
>>  native   Set trunking native characteristics when interface is
>>in trunking mode
>>  pruning  Set pruning VLAN characteristics when interface is in
>>trunking mode
>>
>>Нет такой команды
>
>
>На кошке ip routing набрать

набрал, чуда не произошло:-(((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "TRUNK+VLAN+CISCO"  
Сообщение от fantom (??) on 19-Дек-06, 12:40 
>>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>>коненчо могу ошибаться
>>>>
>>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>>А то мало ли он ISL tag вставляет.
>>>
>>>cat2960(config-if)#switchport trunk ?
>>>  allowed  Set allowed VLAN characteristics when interface is in
>>>trunking mode
>>>  native   Set trunking native characteristics when interface is
>>>in trunking mode
>>>  pruning  Set pruning VLAN characteristics when interface is in
>>>trunking mode
>>>
>>>Нет такой команды
>>
>>
>>На кошке ip routing набрать
>
>набрал, чуда не произошло:-(((

А "внутри" VLAN-а пинг есть?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 12:45 
>>>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>>>коненчо могу ошибаться
>>>>>
>>>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>>>А то мало ли он ISL tag вставляет.
>>>>
>>>>cat2960(config-if)#switchport trunk ?
>>>>  allowed  Set allowed VLAN characteristics when interface is in
>>>>trunking mode
>>>>  native   Set trunking native characteristics when interface is
>>>>in trunking mode
>>>>  pruning  Set pruning VLAN characteristics when interface is in
>>>>trunking mode
>>>>
>>>>Нет такой команды
>>>
>>>
>>>На кошке ip routing набрать
>>
>>набрал, чуда не произошло:-(((
>
>А "внутри" VLAN-а пинг есть?
Да внутри все ок!!!
Но если пинг vlan1->vlan2 request time out!!!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "TRUNK+VLAN+CISCO"  
Сообщение от fantom (??) on 19-Дек-06, 12:48 
>>>>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>>>>коненчо могу ошибаться
>>>>>>
>>>>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>>>>А то мало ли он ISL tag вставляет.
>>>>>
>>>>>cat2960(config-if)#switchport trunk ?
>>>>>  allowed  Set allowed VLAN characteristics when interface is in
>>>>>trunking mode
>>>>>  native   Set trunking native characteristics when interface is
>>>>>in trunking mode
>>>>>  pruning  Set pruning VLAN characteristics when interface is in
>>>>>trunking mode
>>>>>
>>>>>Нет такой команды
>>>>
>>>>
>>>>На кошке ip routing набрать
>>>
>>>набрал, чуда не произошло:-(((
>>
>>А "внутри" VLAN-а пинг есть?
>Да внутри все ок!!!
>Но если пинг vlan1->vlan2 request time out!!!

А как насчет шлюзов? шлюзы прописаны на рабочих станциях?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 12:50 
>>>>>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>>>>>коненчо могу ошибаться
>>>>>>>
>>>>>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>>>>>А то мало ли он ISL tag вставляет.
>>>>>>
>>>>>>cat2960(config-if)#switchport trunk ?
>>>>>>  allowed  Set allowed VLAN characteristics when interface is in
>>>>>>trunking mode
>>>>>>  native   Set trunking native characteristics when interface is
>>>>>>in trunking mode
>>>>>>  pruning  Set pruning VLAN characteristics when interface is in
>>>>>>trunking mode
>>>>>>
>>>>>>Нет такой команды
>>>>>
>>>>>
>>>>>На кошке ip routing набрать
>>>>
>>>>набрал, чуда не произошло:-(((
>>>
>>>А "внутри" VLAN-а пинг есть?
>>Да внутри все ок!!!
>>Но если пинг vlan1->vlan2 request time out!!!
>
>А как насчет шлюзов? шлюзы прописаны на рабочих станциях?

ПРАВИЛЬНЫЙ ВОПРОС, да все прописано:-)))
Вот нашел доку, но концептуальной разницы не вижу
http://cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "TRUNK+VLAN+CISCO"  
Сообщение от fantom (??) on 19-Дек-06, 13:03 
>>>>>>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>>>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>>>>>>коненчо могу ошибаться
>>>>>>>>
>>>>>>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>>>>>>А то мало ли он ISL tag вставляет.
>>>>>>>
>>>>>>>cat2960(config-if)#switchport trunk ?
>>>>>>>  allowed  Set allowed VLAN characteristics when interface is in
>>>>>>>trunking mode
>>>>>>>  native   Set trunking native characteristics when interface is
>>>>>>>in trunking mode
>>>>>>>  pruning  Set pruning VLAN characteristics when interface is in
>>>>>>>trunking mode
>>>>>>>
>>>>>>>Нет такой команды
>>>>>>
>>>>>>
>>>>>>На кошке ip routing набрать
>>>>>
>>>>>набрал, чуда не произошло:-(((
>>>>
>>>>А "внутри" VLAN-а пинг есть?
>>>Да внутри все ок!!!
>>>Но если пинг vlan1->vlan2 request time out!!!
>>
>>А как насчет шлюзов? шлюзы прописаны на рабочих станциях?
>
>ПРАВИЛЬНЫЙ ВОПРОС, да все прописано:-)))
>Вот нашел доку, но концептуальной разницы не вижу
>http://cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml

Тада еще вопросец:
1. что говорит трейс vlan1->vlan2
2. пингается ли, например, 192.168.13.1 из сети 192.168.14.0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 13:22 
>>>>>>>>>>ну так на транковом порту каталисты кроме switchport mode trunk
>>>>>>>>>>должно быть еще что-то типа  switchport trunk allowed vlan 1-15. Я
>>>>>>>>>>коненчо могу ошибаться
>>>>>>>>>
>>>>>>>>>Попробуй на fao/1 2811 прописать switchport trunk encapsulation dot1q
>>>>>>>>>А то мало ли он ISL tag вставляет.
>>>>>>>>
>>>>>>>>cat2960(config-if)#switchport trunk ?
>>>>>>>>  allowed  Set allowed VLAN characteristics when interface is in
>>>>>>>>trunking mode
>>>>>>>>  native   Set trunking native characteristics when interface is
>>>>>>>>in trunking mode
>>>>>>>>  pruning  Set pruning VLAN characteristics when interface is in
>>>>>>>>trunking mode
>>>>>>>>
>>>>>>>>Нет такой команды
>>>>>>>
>>>>>>>
>>>>>>>На кошке ip routing набрать
>>>>>>
>>>>>>набрал, чуда не произошло:-(((
>>>>>
>>>>>А "внутри" VLAN-а пинг есть?
>>>>Да внутри все ок!!!
>>>>Но если пинг vlan1->vlan2 request time out!!!
>>>
>>>А как насчет шлюзов? шлюзы прописаны на рабочих станциях?
>>
>>ПРАВИЛЬНЫЙ ВОПРОС, да все прописано:-)))
>>Вот нашел доку, но концептуальной разницы не вижу
>>http://cisco.com/en/US/products/hw/switches/ps628/products_configuration_example09186a00800ef797.shtml
>
>Тада еще вопросец:
>1. что говорит трейс vlan1->vlan2
>2. пингается ли, например, 192.168.13.1 из сети 192.168.14.0

1. трейс ничего не говорит
2. пингуются тольго айпишники прописаные на роутере хх.1, а вто то что в подсети не отвечает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "TRUNK+VLAN+CISCO"  
Сообщение от fantom (??) on 19-Дек-06, 13:48 
>>Тада еще вопросец:
>>1. что говорит трейс vlan1->vlan2
>>2. пингается ли, например, 192.168.13.1 из сети 192.168.14.0
>
>1. трейс ничего не говорит
>2. пингуются тольго айпишники прописаные на роутере хх.1, а вто то что
>в подсети не отвечает.

т.е. какэто "трейс ничего не говорит" ???
Покажи вывод с 192.168.12.2 трейса на
10.50.4.254

и заодно таблицу маршрутов на станции 192.168.12.2
(если это винда - то в сеансе DOS выполнить route print)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "TRUNK+VLAN+CISCO"  
Сообщение от Николай email(??) on 19-Дек-06, 13:23 
Значиться к слову у 2950 ISL нет. Судя по тому что внутри вланов пинг идет - транк у тебя настроен нормально т.е. фунциклирет. А для того что бы пингать между вланами - тута уже маршрутизация нужна

Если только настаиваешь сделай следующее
(config)#router eigrp 100
(config)#network 192.168.10.0
(config)#network 192.168.11.0
(config)#network 192.168.12.0
(config)#network 192.168.13.0
(config)#network 192.168.14.0
(config)#network 10.50.4.0

Или статикой на порт fa 0/1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 13:32 
>Значиться к слову у 2950 ISL нет. Судя по тому что внутри
>вланов пинг идет - транк у тебя настроен нормально т.е. фунциклирет.
>А для того что бы пингать между вланами - тута уже
>маршрутизация нужна
>
>Если только настаиваешь сделай следующее
>(config)#router eigrp 100
>(config)#network 192.168.10.0
>(config)#network 192.168.11.0
>(config)#network 192.168.12.0
>(config)#network 192.168.13.0
>(config)#network 192.168.14.0
>(config)#network 10.50.4.0
>
>Или статикой на порт fa 0/1

Добавил!!!!
!
router eigrp 100
network 10.0.0.0
network 192.168.10.0
network 192.168.11.0
network 192.168.12.0
network 192.168.13.0
network 192.168.14.0
auto-summary
!

Пробую пинговать из vlan 12(192.168.12.2) -> vlan 15(10.50.4.254) нет пинга:-((((

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "TRUNK+VLAN+CISCO"  
Сообщение от Николай email(??) on 19-Дек-06, 13:46 
Ты зачем 10.0.0.0 сетку добавил? :)
попробуй пинг из подсети 192.168.11.0 в 192.168.12.0
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "TRUNK+VLAN+CISCO"  
Сообщение от Сайко on 19-Дек-06, 14:51 
sh ip route c ОБОИХ устройств - cat2960! и c2811.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 19-Дек-06, 18:05 
>sh ip route c ОБОИХ устройств - cat2960! и c2811.

Восклицательный знак понял:-))))
А вот с рутера
C    192.168.104.0/24 is directly connected, Port-channel1.104
C    192.168.105.0/24 is directly connected, Port-channel1.105
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       10.0.0.0/8 is a summary, 00:07:55, Null0
C       10.50.4.0/24 is directly connected, FastEthernet0/0.15
C    192.168.102.0/24 is directly connected, Port-channel1.102
C    192.168.103.0/24 is directly connected, Port-channel1.103
C    192.168.101.0/24 is directly connected, Port-channel1.101


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "TRUNK+VLAN+CISCO"  
Сообщение от lomo on 25-Дек-06, 16:51 
>>sh ip route c ОБОИХ устройств - cat2960! и c2811.
>
>Восклицательный знак понял:-))))
>А вот с рутера
>C    192.168.104.0/24 is directly connected, Port-channel1.104
>C    192.168.105.0/24 is directly connected, Port-channel1.105
>     10.0.0.0/8 is variably subnetted, 2 subnets, 2
>masks
>D       10.0.0.0/8 is a summary, 00:07:55,
>Null0
>C       10.50.4.0/24 is directly connected, FastEthernet0/0.15
>
>C    192.168.102.0/24 is directly connected, Port-channel1.102
>C    192.168.103.0/24 is directly connected, Port-channel1.103
>C    192.168.101.0/24 is directly connected, Port-channel1.101


Простите, а откуда взялись Port-Channel(ы)?
Я бы еще проверил какой native vlan у транк-портов на роуйтере и свитче.
На обеих сторонах должно быть одно и то же.

Если уже разобрались, то отпишите plz про правильный ответ ;)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "TRUNK+VLAN+CISCO"  
Сообщение от Barbos email on 26-Дек-06, 10:57 
>Привет всем:-)))
>Глупо задавать очевидные вопросы, но .....
>
>Есть рутер 2811 включен транком в каталист 2960.
>Задача:
>1. Организовать некоторое кол-во вланов с возможностью роутинга между ними.
>2. Весь трафик завернуть через роутер(типа vlan1<->2811<->vlan2)
>
>cat2960#sh running-config
>
>..............
>interface FastEthernet0/4
> switchport access vlan 10
>!
>interface FastEthernet0/5
> switchport access vlan 11
>!
>interface FastEthernet0/6
> switchport access vlan 11
>......................
> switchport access vlan 15
>!
>interface FastEthernet0/24
> switchport access vlan 15
>!
>interface GigabitEthernet0/1
> switchport mode trunk
> mls qos trust dscp
> macro description cisco-router
> auto qos voip trust
> spanning-tree portfast trunk
> spanning-tree bpduguard enable
>..................................
>interface Vlan1
> no ip address
> no ip route-cache
>!
>interface Vlan10
> ip address 192.168.10.10 255.255.255.0
> no ip route-cache
>!
>interface Vlan11
> ip address 192.168.11.10 255.255.255.0
> no ip route-cache
>!
>interface Vlan12
> ip address 192.168.12.10 255.255.255.0
> no ip route-cache
>!
>interface Vlan13
> ip address 192.168.13.10 255.255.255.0
> no ip route-cache
>!
>interface Vlan14
> ip address 192.168.14.10 255.255.255.0
> no ip route-cache
>!
>interface Vlan15
> ip address 10.50.4.252 255.255.255.0
> no ip route-cache
>
>
>
>c2811-gw-voip#sh running-config
>
>interface FastEthernet0/1
> no ip address
> duplex auto
> speed auto
>!
>interface FastEthernet0/1.11
> description DMZ_1$ETH-LAN$
> encapsulation dot1Q 11
> ip address 192.168.11.1 255.255.255.0
>!
>interface FastEthernet0/1.12
> description DMZ_2$ETH-LAN$
> encapsulation dot1Q 12
> ip address 192.168.12.1 255.255.255.0
>!
>interface FastEthernet0/1.13
> description DMZ_3$ETH-LAN$
> encapsulation dot1Q 13
> ip address 192.168.13.1 255.255.255.0
>!
>interface FastEthernet0/1.14
> description DMZ_4$ETH-LAN$
> encapsulation dot1Q 14
> ip address 192.168.14.1 255.255.255.0
>!
>interface FastEthernet0/1.15
> encapsulation dot1Q 15
> ip address 10.50.4.253 255.255.255.0
>
>Проблема в том, что нет пингов(вообще нет движения) между вланами:-((
>Не сочтите за труд разъясните в чем проблема!!!

День добрый,
попробуйте дать командочку на свитче такую
show vtp status
Вывод должен иметь такую строчку "VTP Operating Mode              : Server"
или "VTP Operating Mode              : Transparent"
потом
show vlan
Все ваши виланы должны иметь статус "Active"
А еще, catcalyst 2960 имеет только один активный управляющий vlan (для управления свитчом)
Т.к. данный свит 2-го уровня то он не может роутить IP, этим будет заниматься cisco2811

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "TRUNK+VLAN+CISCO"  
Сообщение от Barbos email on 26-Дек-06, 11:02 
>>Привет всем:-)))
>>Глупо задавать очевидные вопросы, но .....
>>
>>Есть рутер 2811 включен транком в каталист 2960.
>>Задача:
>>1. Организовать некоторое кол-во вланов с возможностью роутинга между ними.
>>2. Весь трафик завернуть через роутер(типа vlan1<->2811<->vlan2)
>>
>>cat2960#sh running-config
>>
>>..............
>>interface FastEthernet0/4
>> switchport access vlan 10
>>!
>>interface FastEthernet0/5
>> switchport access vlan 11
>>!
>>interface FastEthernet0/6
>> switchport access vlan 11
>>......................
>> switchport access vlan 15
>>!
>>interface FastEthernet0/24
>> switchport access vlan 15
>>!
>>interface GigabitEthernet0/1
>> switchport mode trunk
>> mls qos trust dscp
>> macro description cisco-router
>> auto qos voip trust
>> spanning-tree portfast trunk
>> spanning-tree bpduguard enable
>>..................................
>>interface Vlan1
>> no ip address
>> no ip route-cache
>>!
>>interface Vlan10
>> ip address 192.168.10.10 255.255.255.0
>> no ip route-cache
>>!
>>interface Vlan11
>> ip address 192.168.11.10 255.255.255.0
>> no ip route-cache
>>!
>>interface Vlan12
>> ip address 192.168.12.10 255.255.255.0
>> no ip route-cache
>>!
>>interface Vlan13
>> ip address 192.168.13.10 255.255.255.0
>> no ip route-cache
>>!
>>interface Vlan14
>> ip address 192.168.14.10 255.255.255.0
>> no ip route-cache
>>!
>>interface Vlan15
>> ip address 10.50.4.252 255.255.255.0
>> no ip route-cache
>>
>>
>>
>>c2811-gw-voip#sh running-config
>>
>>interface FastEthernet0/1
>> no ip address
>> duplex auto
>> speed auto
>>!
>>interface FastEthernet0/1.11
>> description DMZ_1$ETH-LAN$
>> encapsulation dot1Q 11
>> ip address 192.168.11.1 255.255.255.0
>>!
>>interface FastEthernet0/1.12
>> description DMZ_2$ETH-LAN$
>> encapsulation dot1Q 12
>> ip address 192.168.12.1 255.255.255.0
>>!
>>interface FastEthernet0/1.13
>> description DMZ_3$ETH-LAN$
>> encapsulation dot1Q 13
>> ip address 192.168.13.1 255.255.255.0
>>!
>>interface FastEthernet0/1.14
>> description DMZ_4$ETH-LAN$
>> encapsulation dot1Q 14
>> ip address 192.168.14.1 255.255.255.0
>>!
>>interface FastEthernet0/1.15
>> encapsulation dot1Q 15
>> ip address 10.50.4.253 255.255.255.0
>>
>>Проблема в том, что нет пингов(вообще нет движения) между вланами:-((
>>Не сочтите за труд разъясните в чем проблема!!!
>
>День добрый,
>попробуйте дать командочку на свитче такую
>show vtp status
>Вывод должен иметь такую строчку "VTP Operating Mode    
>         : Server"
>
>или "VTP Operating Mode        
>     : Transparent"
>потом
>show vlan
>Все ваши виланы должны иметь статус "Active"
>А еще, catcalyst 2960 имеет только один активный управляющий vlan (для управления
>свитчом)
>Т.к. данный свит 2-го уровня то он не может роутить IP, этим
>будет заниматься cisco2811

А еще у вас ошибочка в конфигурации портов на свитче. Должно быть так
............
interface FastEthernet0/5
switchport access vlan 11
switchport mode access
.................

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "TRUNK+VLAN+CISCO"  
Сообщение от avator (ok) on 28-Дек-06, 22:16 
Прошу прощения за столь запоздалый ответ!!!!:-))))

После продолжительных танцев с бубном все работает.

Тестовый стенд собран и фунциклюет.
Всем принявшим участие в обсуждении проблемы благодарность:-))))
Привожу куски рабочего конфига.

c2811-gw-voip#sh running-config brief
Building configuration...

.................................................

!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.15
encapsulation dot1Q 15
ip address 10.50.4.253 255.255.255.0
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
ip address 192.168.101.1 255.255.255.0
!
interface FastEthernet0/0.102
encapsulation dot1Q 102
ip address 192.168.102.1 255.255.255.0
!
interface FastEthernet0/0.103
encapsulation dot1Q 103
ip address 192.168.103.1 255.255.255.0
!
interface FastEthernet0/0.104
encapsulation dot1Q 104
ip address 192.168.104.1 255.255.255.0
!
interface FastEthernet0/0.105
encapsulation dot1Q 105
ip address 192.168.105.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto

router eigrp 100
network 10.0.0.0
network 192.168.101.0
network 192.168.102.0
network 192.168.103.0
network 192.168.104.0
network 192.168.105.0
network 192.168.200.0
auto-summary
!

cat2960#sh running-config brief
...............................

interface FastEthernet0/1
switchport access vlan 101
!
interface FastEthernet0/2
switchport access vlan 101
!
interface FastEthernet0/3
switchport access vlan 101
!
interface FastEthernet0/4
switchport access vlan 101
!
interface FastEthernet0/5
switchport access vlan 102
switchport mode access
switchport voice vlan 102
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/6
switchport access vlan 102
!
interface FastEthernet0/7
switchport access vlan 102
switchport mode access
switchport voice vlan 102
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/8
switchport access vlan 102
!
interface FastEthernet0/9
switchport access vlan 103
!
interface FastEthernet0/10
switchport access vlan 103
!
interface FastEthernet0/11
switchport access vlan 103
!
interface FastEthernet0/12
switchport access vlan 103
!
interface FastEthernet0/13
switchport access vlan 104
!
interface FastEthernet0/14
switchport access vlan 104
!
interface FastEthernet0/15
switchport access vlan 104
!
interface FastEthernet0/16
switchport access vlan 104
!
interface FastEthernet0/17
switchport access vlan 105
!
interface FastEthernet0/18
switchport access vlan 105
!
interface FastEthernet0/19
switchport access vlan 105
switchport mode access
switchport voice vlan 105
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/20
switchport access vlan 105
!
interface FastEthernet0/21
switchport access vlan 15
switchport mode access
switchport voice vlan 15
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/22
switchport access vlan 15
switchport mode access
switchport voice vlan 15
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/23
switchport mode trunk
mls qos trust dscp
macro description cisco-router
auto qos voip trust
spanning-tree portfast trunk
spanning-tree bpduguard enable
!
interface FastEthernet0/24
switchport mode trunk
mls qos trust dscp
macro description cisco-router
auto qos voip trust
spanning-tree portfast trunk
spanning-tree bpduguard enable
!
interface GigabitEthernet0/1
switchport trunk native vlan 15
switchport mode trunk
macro description cisco-switch
auto qos voip trust
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
switchport access vlan 15
switchport mode access
switchport voice vlan 15
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
macro description cisco-phone
auto qos voip cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan15
ip address 10.50.4.252 255.255.255.0
no ip route-cache
!
interface Vlan101
ip address 192.168.101.10 255.255.255.0
no ip route-cache
!
interface Vlan102
ip address 192.168.102.10 255.255.255.0
no ip route-cache
!
interface Vlan103
ip address 192.168.103.10 255.255.255.0
no ip route-cache
!
interface Vlan104
ip address 192.168.104.10 255.255.255.0
no ip route-cache
!
interface Vlan105
ip address 192.168.105.10 255.255.255.0
no ip route-cache

На лишнее не обращайте внимание:-))))

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру