The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Помогите настроить dial-in сервер на Cisco 3640"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от Бармалей email(ok) on 29-Янв-07, 11:02 
Проблема такова что есть Cisco 3640 c NM на 8 Serial и к нему впридачу стойка модемная ZyXEL RS-1612, также есть три телефонных номера, хочется сделать dial-in сервер из всего этого добра, поиском искал, все немного не то, разговор идет как правило про AUX порты. Поделитесь плз. ссылкой на how-to или самим текстом, очень надо. Заранее извиняюсь на несколько ламерский вопрос.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от citrin email(??) on 29-Янв-07, 12:24 
>Проблема такова что есть Cisco 3640 c NM на 8 Serial и
>к нему впридачу стойка модемная ZyXEL RS-1612, также есть три телефонных
>номера, хочется сделать dial-in сервер из всего этого добра, поиском искал,
>все немного не то, разговор идет как правило про AUX порты.
>Поделитесь плз. ссылкой на how-to или самим текстом, очень надо. Заранее
>извиняюсь на несколько ламерский вопрос.

Пример конфига. Если какие то комадны непонятны - читать, что они значат на cisco.com
Авторизация через Радиус

aaa new-model
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa accounting send stop-record authentication failure
aaa accounting delay-start
aaa accounting update periodic 60
aaa accounting network default start-stop group radius
!
no ip gratuitous-arps
!
interface Loopback0
description -- management interface
ip address 192.168.146.1 255.255.255.255
no ip redirects
no ip proxy-arp
!
interface Null0
no ip unreachables
!
interface Group-Async0
description -- dialup
ip unnumbered Loopback0
ip access-group dialup-access-in in
ip access-group dialup-access-out out
no ip proxy-arp
encapsulation ppp
ip route-cache flow
no ip mroute-cache
no logging event link-status
dialer in-band
dialer idle-timeout 1024 either
dialer-group 1
async default routing
async mode dedicated
peer default ip address pool Clients-pool
no fair-queue
ppp authentication pap
group-range 97 104
!
ip local pool Clients-pool 192.168.144.1 192.168.144.255
ip classless
ip route 192.168.144.0 255.255.225.0 Null0 254 name Clients-pool
!
ip access-list extended dialup-access-in
remark -- filter fragmented TCP traffic (RFC1858)
deny   tcp any any log-input fragments
remark -- filter Windows RPC
deny   tcp any any eq 135
deny   udp any any eq 135
deny   tcp any any eq 445
remark -- permit anything else
permit ip any any
ip access-list extended dialup-access-out
remark -- filter Windows RPC
deny   tcp any any eq 135
deny   udp any any eq 135
deny   tcp any any eq 445
remark -- filter netbios
deny   tcp any any range 137 139
deny   udp any any range netbios-ns netbios-ss
remark -- deny SMTP
deny   tcp any any eq smtp
remark -- permit anything else
permit ip any any

radius-server host 192.168.1.67 auth-port 1812 acct-port 1813 key 7 xxxxxxxxxx
radius-server retransmit 2
radius-server timeout 9
!
line 97 104
exec-timeout 0 0
modem Dialin
transport preferred none
transport input all
autoselect during-login
autoselect ppp
stopbits 1
flowcontrol hardware

Это конфиг от циски со встроенными аналоговыми модемами. В случае если модемы внешние то еще надо будет прописать AT-команды для их инициализации. А в остальном все тоже самое.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от Бармалей email(??) on 29-Янв-07, 13:43 
Ответ развернутый достаточно, спасибо. Однако не совсем я понял что на serial интерфейсах прописывать? Так же создавать группу и потом нужные интерфейсы делать ее членами?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от citrin email(??) on 29-Янв-07, 13:50 
>Ответ развернутый достаточно, спасибо. Однако не совсем я понял что на serial
>интерфейсах прописывать? Так же создавать группу и потом нужные интерфейсы делать
>ее членами?

А что sh line показывает?

В interface Group-Async0 нужно указать те номера линий, которые относятся к данным интерфейсам serial, насколько я понимаю.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от Бармалей email(??) on 29-Янв-07, 14:01 
>>Ответ развернутый достаточно, спасибо. Однако не совсем я понял что на serial
>>интерфейсах прописывать? Так же создавать группу и потом нужные интерфейсы делать
>>ее членами?
>
>А что sh line показывает?
>

dial-in#sh line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
     0 CTY              -    -      -    -    -      0       0     0/0       -
   129 AUX   9600/9600  -    -      -    -    -      0       0     0/0       -
*  130 VTY              -    -      -    -    -     10       0     0/0       -
*  131 VTY              -    -      -    -    -      1       0     0/0       -
   132 VTY              -    -      -    -    -      0       0     0/0       -
   133 VTY              -    -      -    -    -      0       0     0/0       -
   134 VTY              -    -      -    -    -      0       0     0/0       -

Line(s) not in async mode -or- with no hardware support:
1-128

Наверное как то надо будет прописывать интерфейсы в группу.

>В interface Group-Async0 нужно указать те номера линий, которые относятся к данным
>интерфейсам serial, насколько я понимаю.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от sn email(??) on 29-Янв-07, 14:25 
conf t
int ser0
physic asy

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от Бармалей email(ok) on 06-Фев-07, 06:43 
Проблема решена, все наконец то заработало, выкладываю полный конфиг циски, что у меня получилось:


!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dialin
!
enable secret 5
!
username dialin001 password 0 xxxxxx
!
!
!
!
ip subnet-zero
!
modemcap entry Zyx336:AA=ATS0=1
modemcap entry zyxel:FD=&f:AA=S0=2:SPD=115200:DTE=115200:MSC=&B1&C1&D3&G0&H0&I0&K4&L1&M0&N0&P0&R1&S0&T5&X0&Y1*Q2
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 10.2.0.2 255.255.0.0
!
interface Ethernet0/1
no ip address
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/4
no ip address
shutdown
!
interface Serial1/5
no ip address
shutdown
!
interface Serial1/6
no ip address
shutdown
!
interface Serial1/7
no ip address
shutdown
!
interface Group-Async1
physical-layer async
ip unnumbered Ethernet0/0
no ip proxy-arp
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer-group 1
async default routing
async mode interactive
peer default ip address pool setup_pool
no cdp enable
ppp authentication pap
group-range 34 36
!
ip local pool setup_pool 10.2.200.1 10.2.200.3
ip classless
ip route 0.0.0.0 0.0.0.0 10.2.0.1
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
!
line con 0
line 34 36
logging synchronous
login local
modem Dialin
modem autoconfigure discovery
transport preferred none
transport input all
autoselect during-login
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
password 123qwe
login
!
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от Бармалей email(ok) on 08-Фев-07, 10:41 
Еще есть вопрос, как сделать так чтобы cisco дозвонившимся пользователям выдавала еще и настройку DNS серверов? Поднимать DHCP на Cisco ?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от Helper on 08-Фев-07, 11:07 
>Еще есть вопрос, как сделать так чтобы cisco дозвонившимся пользователям выдавала еще
>и настройку DNS серверов?
!
async-bootp dns-server <IP_DNS1> <IP_DNS2>
!

или из радиуса/такакса

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Помогите настроить dial-in сервер на Cisco 3640"  
Сообщение от вовик on 09-Фев-07, 00:26 
>>Еще есть вопрос, как сделать так чтобы cisco дозвонившимся пользователям выдавала еще
>>и настройку DNS серверов?
>!
>async-bootp dns-server <IP_DNS1> <IP_DNS2>
>!
>
>или из радиуса/такакса


а еще такие вопросы кто знает.

использую тотал контрол 3кома, как можно АОН задейтвовать, т.е. знать с какого номера телефона пришел вызов.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру