The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Сети VLAN + маршрутизатор (с самого начала)"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Сети VLAN + маршрутизатор (с самого начала)"  
Сообщение от Beginner (??) on 28-Ноя-07, 11:33 
Здравствуйте!
Помогите, пожалуйста, начинающему в организации vlan'ов и настройке cisco. Информации в интернете много, но она рассчитана либо на профессионала, либо описана столь подробно, что уходит далеко в сторону и становиться еще более запутанной. Вторая проблема в том, что сеть действующая, и самому эксперементировать или что-то пробовать крайне нежелательно.
                          
      |__________Working LAN____________|
                _________|_____
                |  Cisco 1 (C1)          | (10.1.0.0/24)
                |______24п._____| vlan 10 (и др.)
                _________|_____
                |      48п.                    |
                |  Cisco 2 (C2)          |
                |_1п.__2п.__3п.__ |
              /                 |                  \
_______   _______   _______
|LAN 1     |  |LAN 2    |  |    PC      |
|10.2/24    |  |10.3/24    |  | 10.4/24 |
|__vl100_|  |_vl200__|  |______|

Организация сети:
Циски IOS 12.2(35)SE, VTP domain - ORG, обе в режиме transparent, STP rapid-pvst.
С1 - роутер (eigrp), куча подсетей, vlan'ов - полностью рабочая. 24 порт настроен
interface FastEthernet1/0/24
switchport access vlan 10
switchport mode access
spanning-tree portfast

С2 - новая циска, только с магазина :) На 48 порт идет vlan 10.
Соответственно 2 сети, и комп. со своим IP (ip не изменяется).

Цель: Соединить [Lan1] со всеми сетями. Соеденить [Lan2 и PC] с [Lan1], но не с [Working LAN].

Наверное PC можно оставить в покое, т.к. задача с lan2 одинаковая. Дальше идут мои вопросы и предположения (поправьте если что не так), собранные с интернета.
Первоначальные настройки
.....
vtp domain ORG
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
.....
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
spanning-tree vlan 1-1000 priority 10000
.....

Cоздаю на C2 vlan 10 на 48 порту:
.....
vlan 10
name Internet
.....
interface FastEthernet0/48
switchport access vlan 10
switchport mode access
.....
interface Vlan10
ip address 10.1.0.2 255.255.255.0
ip authentication mode eigrp 45 md5
ip authentication key-chain eigrp 45 eigrp

Запускаю EIGRP:
.....
router eigrp 1
network 10.2.0.0 0.0.0.255
network 10.3.0.0 0.0.0.255
auto-summary
.....

Нашел только, что auto-summary - это слияние маршрутов, но легче не стало... Расскажите, плз., в 2-х словах что такое, и когда его надо использовать, а когда нет.
После этого я должен по идее получить маршруты. Далее для lan1 создаю vlan100 на С2 и вешаю на 1 интерфейс
.....
vlan 100
name Office
.....
interface FastEthernet0/1
switchport access vlan 100
switchport mode access
spanning-tree portfast
.....
interface Vlan10
ip address 10.2.0.1 255.255.255.0
no shutdown
.....

Соответственно ничего не работает. Дальше только предположения...
Нужно сначала убрать на С1 на 24 порту убрать spanning-tree portfast (как рекомендует циска, чтоб зацикливания небыло если соединяется не с конечным устройством(?)). Затем добавить vlan100
.....
vlan 100
name Office
.....

Далее наверное нужно на интерфейсе прописать multi vlan,
примерно так (в интернете нашел):
.....
interface FastEthernet1/0/24
switchport multi vlan 10,100
switchport mode multi
.....

но пробуя это сделать на cisco 3560, ничего не получается - т.е. нет такого режима (на 3570 не пробовал).
(config-if)#switchport mode ?
  access        Set trunking mode to ACCESS unconditionally
  dot1q-tunnel  set trunking mode to TUNNEL unconditionally
  dynamic       Set trunking mode to dynamically negotiate access or trunk mode
  private-vlan  Set private-vlan mode
  trunk         Set trunk......

Вот здесь я и встал... (
Объясните, плз, где и что я не правильно делаю. Транки ведь создавать не нужно, т.к. я vlan вручную прописал на обеих цисках? Может все по другому надо делать?
P.S. Сильно не ругайте - я впервые столкнулся с цисками и виланами. (все когда-то бывает в первый раз).

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Сети VLAN + маршрутизатор (с самого начала)"  
Сообщение от sm00th1980 (??) on 28-Ноя-07, 14:35 
ну что вам сказать - рекомендую нанять грамотного в этом деле человека и не парится. Если что-то сломать боитесь - вот и всё. Сами вы 100%-ов дров наломаете судя по вопросам.

Удачи.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Сети VLAN + маршрутизатор (с самого начала)"  
Сообщение от www.bc.ru Дмитрий Перов on 28-Ноя-07, 16:07 
>ну что вам сказать - рекомендую нанять грамотного в этом деле человека
>и не парится. Если что-то сломать боитесь - вот и всё.
>Сами вы 100%-ов дров наломаете судя по вопросам.
>
>Удачи.

Задача довольна простая, новичку поможет например SDM Manager. Через GUI проще конфигурить, чем через командную строку.
Но лучше всего, конечно, обратиться к специалистам. Тем более, что действуете на "живой" сети, а не стенде.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру