The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"DHCP relay и DHCPD !! help"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"DHCP relay и DHCPD !! help"  
Сообщение от ATeam (ok) on 11-Дек-07, 10:59 
Всем доброго времени суток.
Столкнулся с глюком((

На интерфейсе на cisco стоит - ip helper-address 172.16.5.57
Тетсовая машина посылает запрос на получени адреса по DHCP.
На линуксе стоит DHCPD , который получает запрос ,

Вот дебаг с циски -


Dec 11 10:49:00.879: DHCPD: checking for expired leases.
Dec 11 10:49:10.879: DHCPD: checking for expired leases.
Dec 11 10:49:17.039: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:17.039: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:17.039: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:17.043: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:17.043: DHCPD: client's VPN is .
Dec 11 10:49:17.043: DHCPD: Removing previous binding
Dec 11 10:49:17.043: DHCPD: Sending notification of TERMINATION:
Dec 11 10:49:17.043:  DHCPD: address 172.16.1.100 mask 255.255.255.0
Dec 11 10:49:17.043:  DHCPD: reason flags:
Dec 11 10:49:17.043:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:17.043:   DHCPD: lease time remaining (secs) = 482
Dec 11 10:49:17.043: DHCPD: dhcpd_lookup_route: host = 172.16.1.100
Dec 11 10:49:17.043: DHCPD: dhcpd_lookup_route: index = 217
Dec 11 10:49:17.043: DHCPD: Sending notification of DISCOVER:
Dec 11 10:49:17.043:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:17.043:   DHCPD: remote id 030c0000ac10010101000fa00064
Dec 11 10:49:17.043:   DHCPD: circuit id ffffffff
Dec 11 10:49:17.043: DHCPD: setting giaddr to 172.16.1.1.
Dec 11 10:49:17.043: DHCPD: adding relay information option.
Dec 11 10:49:17.043: DHCPD: BOOTREQUEST from 0100.1485.8506.d1 forwarded to 172.16.5.57.
Dec 11 10:49:17.455: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:17.455: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:17.455: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:17.455: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:17.455: DHCPD: client's VPN is .
Dec 11 10:49:17.455: DHCPD: DHCPOFFER notify setup address 172.16.1.100 mask 255.255.255.0
Dec 11 10:49:17.455: DHCPD: Offer callback workspace equal to current 0x5987CF8 (ID=0xB4000003)
Dec 11 10:49:17.455: DHCPD: Saving workspace (ID=0xB4000003)
Dec 11 10:49:17.455: DHCPD: New packet workspace 0x598905C (ID=0x3E000004)
Dec 11 10:49:20.879: DHCPD: checking for expired leases.
Dec 11 10:49:22.035: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:22.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:22.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: client's VPN is .
Dec 11 10:49:22.035: DHCPD: Sending notification of DISCOVER:
Dec 11 10:49:22.035:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:22.035:   DHCPD: remote id 030c0000ac10010101000fa00064
Dec 11 10:49:22.035:   DHCPD: circuit id ffffffff
Dec 11 10:49:22.035: DHCPD: setting giaddr to 172.16.1.1.
Dec 11 10:49:22.035: DHCPD: adding relay information option.
Dec 11 10:49:22.035: DHCPD: BOOTREQUEST from 0100.1485.8506.d1 forwarded to 172.16.5.57.
Dec 11 10:49:22.035: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:22.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:22.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: client's VPN is .
Dec 11 10:49:22.035: DHCPD: DHCPOFFER notify setup address 172.16.1.100 mask 255.255.255.0
Dec 11 10:49:22.035: DHCPD: offer notify return with no delay on intf GigabitEthernet0/1.4000100
Dec 11 10:49:22.035: DHCPD: forwarding BOOTREPLY to client 0014.8585.06d1.
Dec 11 10:49:22.035: DHCPD: No vpn from sub-option, using global
Dec 11 10:49:22.035: DHCPD: Setting giaddr to 172.16.1.1
Dec 11 10:49:22.035: DHCPD: Forwarding reply on numbered intf
Dec 11 10:49:22.035: DHCPD: validating relay information option.
Dec 11 10:49:22.035: DHCPD: relay information option is removed
Dec 11 10:49:22.035: DHCPD: creating ARP entry (172.16.1.100, 0014.8585.06d1).
Dec 11 10:49:22.035: DHCPD: SIOCSARP ioctl failed (error 255).
Dec 11 10:49:22.035: DHCPD: broadcasting BOOTREPLY to client 0014.8585.06d1.
Dec 11 10:49:22.035: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:22.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:22.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: client's VPN is .
Dec 11 10:49:22.035: DHCPD: Finding a relay for client 0100.1485.8506.d1 on interface GigabitEthernet0/1.4000100.
Dec 11 10:49:22.035: DHCPD: Seeing if there is an internally specified pool class:
Dec 11 10:49:22.035:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:22.035:   DHCPD: remote id 030c0000ac10010101000fa00064
Dec 11 10:49:22.035:   DHCPD: circuit id ffffffff
Dec 11 10:49:22.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:22.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.035: DHCPD: client's VPN is .
Dec 11 10:49:22.035: DHCPD: No internally specified class returned
Dec 11 10:49:22.035: DHCPD: there is no pool for 172.16.1.1.
Dec 11 10:49:22.035: DHCPD: there is no pool for 10.100.1.1.
Dec 11 10:49:22.035: DHCPD: Adding binding to hash tree
Dec 11 10:49:22.035: DHCPD: relay binding created for client 0100.1485.8506.d1.
Dec 11 10:49:22.035: DHCPD: Keeping state for received DHCPREQUEST
Dec 11 10:49:22.035: DHCPD: dhcpd_lookup_route: host = 0.0.0.0
Dec 11 10:49:22.035: DHCPD: dhcpd_lookup_route: index = 0
Dec 11 10:49:22.035: DHCPD: No Server Id in Binding or Route for DHCPREQUEST
Dec 11 10:49:22.035: DHCPD: setting giaddr to 172.16.1.1.
Dec 11 10:49:22.035: DHCPD: adding relay information option.
Dec 11 10:49:22.035: DHCPD: BOOTREQUEST from 0100.1485.8506.d1 forwarded to 172.16.5.57.
Dec 11 10:49:22.039: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:22.039: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:22.039: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.039: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:22.039: DHCPD: client's VPN is .
Dec 11 10:49:22.039: DHCPD: forwarding BOOTREPLY to client 0014.8585.06d1.
Dec 11 10:49:22.039: DHCPD: No vpn from sub-option, using global
Dec 11 10:49:22.039: DHCPD: Setting giaddr to 172.16.1.1
Dec 11 10:49:22.039: DHCPD: Forwarding reply while saving lease state
Dec 11 10:49:22.039: DHCPD: creating ARP entry (172.16.1.100, 0014.8585.06d1).
Dec 11 10:49:22.039: DHCPD: SIOCSARP ioctl failed (error 255).
Dec 11 10:49:22.039: DHCPD: Keeping state: Received DHCPACK
Dec 11 10:49:22.039:  DHCPD: lease time = 600
Dec 11 10:49:22.039:  DHCPD: Server ID saved in Binding = 172.16.5.57
Dec 11 10:49:22.039:  DHCPD: Giaddr Address = 172.16.1.1
Dec 11 10:49:22.039: DHCPD: Adding binding to radix tree (172.16.1.100)
Dec 11 10:49:22.039: DHCPD: Sending notification of ASSIGNMENT:
Dec 11 10:49:22.039:  DHCPD: address 172.16.1.100 mask 255.255.255.0
Dec 11 10:49:22.039:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:22.039:   DHCPD: lease time remaining (secs) = 600
Dec 11 10:49:22.039: DHCPD: validating relay information option.
Dec 11 10:49:22.039: DHCPD: relay information option is removed
Dec 11 10:49:22.039:  outbound IF index  = 1
Dec 11 10:49:22.039:  outbound IF sub-index = 4000100
Dec 11 10:49:22.039: DHCPD: Keeping state: Forwarding BOOTREPLY to client 0014.8585.06d1
Dec 11 10:49:27.035: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:27.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:27.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:27.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:27.035: DHCPD: client's VPN is .
Dec 11 10:49:27.035: DHCPD: Found previous binding with giaddr 172.16.1.1
Dec 11 10:49:27.035: DHCPD: Keeping state for received DHCPREQUEST
Dec 11 10:49:27.035:  DHCPD: keeping state: Real Server = 172.16.5.57
Dec 11 10:49:27.035: DHCPD: setting giaddr to 172.16.1.1.
Dec 11 10:49:27.035: DHCPD: adding relay information option.
Dec 11 10:49:27.035: DHCPD: BOOTREQUEST from 0100.1485.8506.d1 forwarded to 172.16.5.57.
Dec 11 10:49:27.039: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:27.039: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:27.039: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:27.039: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:27.039: DHCPD: client's VPN is .
Dec 11 10:49:27.039: DHCPD: forwarding BOOTREPLY to client 0014.8585.06d1.
Dec 11 10:49:27.039: DHCPD: No vpn from sub-option, using global
Dec 11 10:49:27.039: DHCPD: Setting giaddr to 172.16.1.1
Dec 11 10:49:27.039: DHCPD: Forwarding reply while saving lease state
Dec 11 10:49:27.039: DHCPD: creating ARP entry (172.16.1.100, 0014.8585.06d1).
Dec 11 10:49:27.039: DHCPD: SIOCSARP ioctl failed (error 255).
Dec 11 10:49:27.039: DHCPD: Keeping state: Received DHCPACK
Dec 11 10:49:27.039:  DHCPD: lease time = 600
Dec 11 10:49:27.039:  DHCPD: Server ID saved in Binding = 172.16.5.57
Dec 11 10:49:27.039:  DHCPD: Giaddr Address = 172.16.1.1
Dec 11 10:49:27.039: DHCPD: Sending notification of ASSIGNMENT:
Dec 11 10:49:27.039:  DHCPD: address 172.16.1.100 mask 255.255.255.0
Dec 11 10:49:27.039:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:27.039:   DHCPD: lease time remaining (secs) = 600
Dec 11 10:49:27.039: DHCPD: validating relay information option.
Dec 11 10:49:27.039: DHCPD: relay information option is removed
Dec 11 10:49:27.039:  outbound IF index  = 1
Dec 11 10:49:27.039:  outbound IF sub-index = 4000100
Dec 11 10:49:27.039: DHCPD: Keeping state: Forwarding BOOTREPLY to client 0014.8585.06d1
Dec 11 10:49:30.879: DHCPD: checking for expired leases.
Dec 11 10:49:35.035: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:35.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:35.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:35.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:35.035: DHCPD: client's VPN is .
Dec 11 10:49:35.035: DHCPD: Found previous binding with giaddr 172.16.1.1
Dec 11 10:49:35.035: DHCPD: Keeping state for received DHCPREQUEST
Dec 11 10:49:35.035:  DHCPD: keeping state: Real Server = 172.16.5.57
Dec 11 10:49:35.035: DHCPD: setting giaddr to 172.16.1.1.
Dec 11 10:49:35.035: DHCPD: adding relay information option.
Dec 11 10:49:35.035: DHCPD: BOOTREQUEST from 0100.1485.8506.d1 forwarded to 172.16.5.57.
Dec 11 10:49:35.035: DHCPD: input i/f override GigabitEthernet0/1.4000100 for client
Dec 11 10:49:35.035: DHCPD: Reload workspace interface GigabitEthernet0/1.4000100 tableid 0.
Dec 11 10:49:35.035: DHCPD: tableid for 172.16.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:35.035: DHCPD: tableid for 10.100.1.1 on GigabitEthernet0/1.4000100 is 0
Dec 11 10:49:35.035: DHCPD: client's VPN is .
Dec 11 10:49:35.035: DHCPD: forwarding BOOTREPLY to client 0014.8585.06d1.
Dec 11 10:49:35.035: DHCPD: No vpn from sub-option, using global
Dec 11 10:49:35.035: DHCPD: Setting giaddr to 172.16.1.1
Dec 11 10:49:35.035: DHCPD: Forwarding reply while saving lease state
Dec 11 10:49:35.035: DHCPD: creating ARP entry (172.16.1.100, 0014.8585.06d1).
Dec 11 10:49:35.035: DHCPD: SIOCSARP ioctl failed (error 255).
Dec 11 10:49:35.035: DHCPD: Keeping state: Received DHCPACK
Dec 11 10:49:35.035:  DHCPD: lease time = 600
Dec 11 10:49:35.035:  DHCPD: Server ID saved in Binding = 172.16.5.57
Dec 11 10:49:35.035:  DHCPD: Giaddr Address = 172.16.1.1
Dec 11 10:49:35.035: DHCPD: Sending notification of ASSIGNMENT:
Dec 11 10:49:35.035:  DHCPD: address 172.16.1.100 mask 255.255.255.0
Dec 11 10:49:35.035:   DHCPD: htype 1 chaddr 0014.8585.06d1
Dec 11 10:49:35.035:   DHCPD: lease time remaining (secs) = 600
Dec 11 10:49:35.035: DHCPD: validating relay information option.
Dec 11 10:49:35.035: DHCPD: relay information option is removed
Dec 11 10:49:35.035:  outbound IF index  = 1
Dec 11 10:49:35.035:  outbound IF sub-index = 4000100
Dec 11 10:49:35.035: DHCPD: Keeping state: Forwarding BOOTREPLY to client 0014.8585.06d1


Router#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
172.16.1.100        0014.8585.06d1          Dec 11 2007 11:03 AM    Relay


Вот что пишет DHCPD -


DHCPDISCOVER from 00:14:85:85:06:d1 (test) via 172.16.1.1
DHCPOFFER on 172.16.1.100 to 00:14:85:85:06:d1 (test) via 172.16.1.1
DHCPDISCOVER from 00:14:85:85:06:d1 (test) via 172.16.1.1
DHCPOFFER on 172.16.1.100 to 00:14:85:85:06:d1 (test) via 172.16.1.1
DHCPREQUEST from 172.16.1.100 (172.16.5.57) from 00:14:85:85:06:d1  (test) via 172.16.1.1
DHCPACK on 172.16.1.100 to 00:14:85:85:06:d1 (test) via 172.16.1.1
DHCPREQUEST from 172.16.1.100 (172.16.5.57) from 00:14:85:85:06:d1  (test) via 172.16.1.1
DHCPACK on 172.16.1.100 to 00:14:85:85:06:d1 (test) via 172.16.1.1

Якобы айпишник выдаётся, но почему то на машине не присваивается и по новой посылаются запросы на получение ...
В чём может быть косяк ?  подскажите плиз где грабли ...

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "DHCP relay и DHCPD !! help"  
Сообщение от nikl on 11-Дек-07, 11:16 
>Всем доброго времени суток.
>Столкнулся с глюком((
>
>На интерфейсе на cisco стоит - ip helper-address 172.16.5.57

sh run int GigabitEthernet0/1.4000100

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam (ok) on 11-Дек-07, 11:25 
>>Всем доброго времени суток.
>>Столкнулся с глюком((
>>
>>На интерфейсе на cisco стоит - ip helper-address 172.16.5.57
>
>sh run int GigabitEthernet0/1.4000100

!
interface GigabitEthernet0/1.4000100
encapsulation dot1Q 4000 second-dot1q 100-120
radius attribute nas-port-type 34
ip address 10.100.1.1 255.255.255.0 secondary
ip address 172.16.1.1 255.255.255.0
ip helper-address 172.16.5.57
no snmp trap link-status
service-policy type control RULE-401a-1
ip subscriber l2-connected
  initiator dhcp class-aware

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "DHCP relay и DHCPD !! help"  
Сообщение от Basil (??) on 11-Дек-07, 13:48 
>[оверквотинг удален]
>interface GigabitEthernet0/1.4000100
> encapsulation dot1Q 4000 second-dot1q 100-120
> radius attribute nas-port-type 34
> ip address 10.100.1.1 255.255.255.0 secondary
> ip address 172.16.1.1 255.255.255.0
> ip helper-address 172.16.5.57
> no snmp trap link-status
> service-policy type control RULE-401a-1
> ip subscriber l2-connected
>  initiator dhcp class-aware

Я столкнулся с такой же проблемой.
Когда на интерфейсе сказал ip subscriber routed, у меня тоже перестали проходить с DHCP сервера, как только убираешь это, все сразу работает.

Сегодня кейс открою, может что-то узнаем :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam (ok) on 11-Дек-07, 13:51 
>[оверквотинг удален]
>> no snmp trap link-status
>> service-policy type control RULE-401a-1
>> ip subscriber l2-connected
>>  initiator dhcp class-aware
>
>Я столкнулся с такой же проблемой.
>Когда на интерфейсе сказал ip subscriber routed, у меня тоже перестали проходить
>с DHCP сервера, как только убираешь это, все сразу работает.
>
>Сегодня кейс открою, может что-то узнаем :)

Блин , вот засада ((
Я снифером на компе смотрю , ответы с ACK почему то шлются на 255.255.255.255 с циски ...
поэтому мне кажется что комп не принимает ACK ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam (ok) on 11-Дек-07, 14:12 
>[оверквотинг удален]
>> no snmp trap link-status
>> service-policy type control RULE-401a-1
>> ip subscriber l2-connected
>>  initiator dhcp class-aware
>
>Я столкнулся с такой же проблемой.
>Когда на интерфейсе сказал ip subscriber routed, у меня тоже перестали проходить
>с DHCP сервера, как только убираешь это, все сразу работает.
>
>Сегодня кейс открою, может что-то узнаем :)

Да , попробовал разные варианты с ip subscriber l2-connected  ... если убрать или сделать на интерфейсе 0/1 , то оно конечно работает , но встаёт проблема , если авторизации нет , то всё равно трафик разрешён ... это не вариант ...
Надо как то решать глюк с DHCP  при  ip subscriber l2-connected
>>  initiator dhcp class-aware

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam (ok) on 11-Дек-07, 14:44 
>[оверквотинг удален]
>>
>>Сегодня кейс открою, может что-то узнаем :)
>
>Да , попробовал разные варианты с ip subscriber l2-connected  ... если
>убрать или сделать на интерфейсе 0/1 , то оно конечно работает
>, но встаёт проблема , если авторизации нет , то всё
>равно трафик разрешён ... это не вариант ...
>Надо как то решать глюк с DHCP  при  ip subscriber
>l2-connected
>>>  initiator dhcp class-aware

попробуй команду -  ip dhcp smart-relay

мне кажись помогло , правда не сразу он лезет авторизировать сессию почему то ...
иногда айпишник выдаст , но сессию не авторизирует (хотя трафик конечно же весь в этот момент запрещён) ..

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "DHCP relay и DHCPD !! help"  
Сообщение от Basil (??) on 11-Дек-07, 15:34 
>[оверквотинг удален]
>>Надо как то решать глюк с DHCP  при  ip subscriber
>>l2-connected
>>>>  initiator dhcp class-aware
>
>попробуй команду -  ip dhcp smart-relay
>
>мне кажись помогло , правда не сразу он лезет авторизировать сессию почему
>то ...
>иногда айпишник выдаст , но сессию не авторизирует (хотя трафик конечно же
>весь в этот момент запрещён) ..

Тебе помогло, потому что у тебя secondary ip.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam email(ok) on 11-Дек-07, 15:44 
>[оверквотинг удален]
>>>>>  initiator dhcp class-aware
>>
>>попробуй команду -  ip dhcp smart-relay
>>
>>мне кажись помогло , правда не сразу он лезет авторизировать сессию почему
>>то ...
>>иногда айпишник выдаст , но сессию не авторизирует (хотя трафик конечно же
>>весь в этот момент запрещён) ..
>
>Тебе помогло, потому что у тебя secondary ip.

неа , Secondary я давно удалил , что бы не маячило ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "DHCP relay и DHCPD !! help"  
Сообщение от Basil (??) on 11-Дек-07, 16:02 
>[оверквотинг удален]
>>>
>>>мне кажись помогло , правда не сразу он лезет авторизировать сессию почему
>>>то ...
>>>иногда айпишник выдаст , но сессию не авторизирует (хотя трафик конечно же
>>>весь в этот момент запрещён) ..
>>
>>Тебе помогло, потому что у тебя secondary ip.
>
>неа , Secondary я давно удалил , что бы не маячило ...
>

В документации написано вот так:
http://cisco.com/en/US/docs/ios/12_1/iproute/command/referen...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam email(ok) on 11-Дек-07, 16:07 
>[оверквотинг удален]
>>>>иногда айпишник выдаст , но сессию не авторизирует (хотя трафик конечно же
>>>>весь в этот момент запрещён) ..
>>>
>>>Тебе помогло, потому что у тебя secondary ip.
>>
>>неа , Secondary я давно удалил , что бы не маячило ...
>>
>
>В документации написано вот так:
>http://cisco.com/en/US/docs/ios/12_1/iproute/command/referen...

интересно конечно ... но работает без Secondary ...
стоит на интерфейсе основной айпишинк .. и smart-relay ...

Единственный минус , если сессия не авторизована , то при первом включении сетевухи и получении адреса - адрес получает , но сессия не пытается авторизироваться , если выключить включить сетевуху , то сразу и сессия авторизируется и тот же айпшиник выдаётся и всё бегает ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam email(ok) on 11-Дек-07, 18:08 
>[оверквотинг удален]
>
>интересно конечно ... но работает без Secondary ...
>стоит на интерфейсе основной айпишинк .. и smart-relay ...
>
>Единственный минус , если сессия не авторизована , то при первом включении
>сетевухи и получении адреса - адрес получает , но сессия не
>пытается авторизироваться , если выключить включить сетевуху , то сразу и
>сессия авторизируется и тот же айпшиник выдаётся и всё бегает ...
>
>

смотри что нарыл -


The Cisco IOS DHCP relay agent supports the use of unnumbered interfaces. For DHCP clients connected though the unnumbered interfaces, the DHCP relay agent automatically adds a static host route once the DHCP client obtains an address, specifying the unnumbered interface as the outbound interface. The route is automatically removed once the lease time expires or when the client releases the address


убрал айпишиник на подинтерфейсе, сделал unnambered loopback
на loopback повесил сеть ...
всё заработало без smart-relay


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "DHCP relay и DHCPD !! help"  
Сообщение от ATeam email(ok) on 12-Дек-07, 10:42 
>[оверквотинг удален]
>For DHCP clients connected though the unnumbered interfaces, the DHCP relay
>agent automatically adds a static host route once the DHCP client
>obtains an address, specifying the unnumbered interface as the outbound interface.
>The route is automatically removed once the lease time expires or
>when the client releases the address
>
>
>убрал айпишиник на подинтерфейсе, сделал unnambered loopback
>на loopback повесил сеть ...
>всё заработало без smart-relay

А может надёжнее все таки раздавать с циски ? поднять на ней DHCP , а фиксированными управлять внешним скриптом , заходя на циску ? Что скажешь по этому поводу ? какие есть плюсы, какие минусы ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру