The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Помогите плиз настроить FTP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Помогите плиз настроить FTP"  
Сообщение от KobaLTD email on 14-Дек-07, 23:21 
Значит имеем
1) Cisco 827-v4 на ван интерфейсе динамический ip
2) за циской небольшая лакалка 192.168.0.0/24
3) в локалке на адресе 192.168.0.21 стоит машина с линухом (Slackware 12.0) и на ней поднят proftpd на 5500 порту т.к. 21 порт режет провайдер. iptables в режиме все разрешено.
по локалке на ftp достур на ура - задача - чтобы люди могли с инета также ходить на этот ftp в любом режиме (активном, посивном - на выбор помогающего).
Помогите плиз настройть портмапинг и желательно конф от proftpd чтобы это все заработало.
конфиг cisco
Building configuration...

Current configuration : 2425 bytes
!
! No configuration change since last restart
!
version 12.3
no parser cache
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
no service dhcp
!
hostname koba-gw
!
boot-start-marker
boot-end-marker
!
enable secret 5 <вытер>
enable password <вытер>
!
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
no aaa new-model
ip subnet-zero
!
!
ip name-server 212.188.4.10
ip name-server 195.34.32.116
vpdn enable
!
vpdn-group pppoe
request-dialin
  protocol pppoe
!
bridge irb
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip directed-broadcast
ip nat inside
ip virtual-reassembly
no ip route-cache
ip tcp adjust-mss 1452
no ip mroute-cache
no cdp enable
bridge-group 1
bridge-group 1 spanning-disabled
hold-queue 100 out
!
interface ATM0
no ip address
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.150 point-to-point
no ip route-cache
pvc 1/50
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface ATM0.191 point-to-point
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
pvc 1/91
  encapsulation aal5snap
!
!
interface ATM0.192 point-to-point
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
pvc 1/92
  encapsulation aal5snap
!
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp chap hostname ppp0048100@mtu
ppp chap password 0 ecC6drKh
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
ip dns server
!
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static tcp 192.168.0.5 10164 interface Dialer1 10164
ip nat inside source static udp 192.168.0.5 52647 interface Dialer1 52647
!
no logging trap
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
no cdp run
!
!
control-plane
!
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
!
line con 0
password <вырезал>
login
transport preferred all
transport output all
stopbits 1
line vty 0 4
password <вырезал>
login
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
sntp server 193.124.208.250
sntp server 192.43.244.18
end

конфиг proftpd.conf на машине 192.168.0.21 конфиг почти дефолтовый
root@server:/etc# cat ./proftpd.conf
ServerName                      "ProFTPD Koba LTD Server"
ServerType                      standalone
DefaultServer                   on
Port                            5500
PassivePorts 60000 60001
UseReverseDNS                   off
Umask                           022
MaxInstances                    30
User                            nobody
Group                           nogroup
SystemLog                       /var/log/proftpd.log
TransferLog                     /var/log/xferlog
<Directory /*>
  AllowOverwrite                on
</Directory>
<Anonymous ~ftp>
  RequireValidShell             off
  User                          ftp
  Group                         ftp
  UserAlias                     anonymous ftp
  MaxClients                    50
  DisplayLogin                  welcome.msg
  DisplayFirstChdir             .message
  <Limit WRITE>
    DenyAll
  </Limit>
</Anonymous>

root@server:/etc# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

root@server:/etc# netstat -an
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 0.0.0.0:37              0.0.0.0:*               LISTEN
tcp6       0      0 :::22                   :::*                    LISTEN
tcp6       0      0 :::5500                 :::*                    LISTEN
tcp6       0    132 ::ffff:192.168.0.21:22  ::ffff:192.168.0.2:1060 ESTABLISHED
udp        0      0 0.0.0.0:37              0.0.0.0:*
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags       Type       State         I-Node Path
unix  2      [ ACC ]     STREAM     LISTENING     23169    /var/run/proftpd/proftpd.sock
unix  4      [ ]         DGRAM                    10790    /dev/log
unix  2      [ ]         DGRAM                    1932     @/org/kernel/udev/udevd
unix  2      [ ]         DGRAM                    11200    @/org/freedesktop/hal/udev_event
unix  2      [ ACC ]     STREAM     LISTENING     11192    @/var/run/hald/dbus-fErieO3y42
unix  2      [ ACC ]     STREAM     LISTENING     11166    /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     23164    /var/run/proftpd/proftpd.sock
unix  2      [ ACC ]     STREAM     LISTENING     11189    @/var/run/hald/dbus-WJtKptXbYk
unix  3      [ ]         STREAM     CONNECTED     13411    @/var/run/hald/dbus-WJtKptXbYk
unix  3      [ ]         STREAM     CONNECTED     13410
unix  3      [ ]         STREAM     CONNECTED     13409    /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     13408
unix  3      [ ]         STREAM     CONNECTED     11195    @/var/run/hald/dbus-fErieO3y42
unix  3      [ ]         STREAM     CONNECTED     11194
unix  3      [ ]         STREAM     CONNECTED     11191    /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     11190
unix  3      [ ]         STREAM     CONNECTED     11169
unix  3      [ ]         STREAM     CONNECTED     11168
unix  2      [ ]         DGRAM                    11036
unix  2      [ ]         DGRAM                    10810
root@server:/etc#

помогите плиз не дайте умереть идиотом

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Помогите плиз настроить FTP"  
Сообщение от CrAzOiD (??) on 15-Дек-07, 12:55 
ip nat inside source static tcp 192.168.0.21 2121 interface Dialer1 21

URL для тех кто снаружи будет такой ftp://xxx.xxx.xxx.xxx:2121/

Дефлтный конфиг proftpd можно и не править

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Помогите плиз настроить FTP"  
Сообщение от KobaLTD email on 15-Дек-07, 13:12 
>ip nat inside source static tcp 192.168.0.21 2121 interface Dialer1 21
>
>URL для тех кто снаружи будет такой ftp://xxx.xxx.xxx.xxx:2121/
>
>Дефлтный конфиг proftpd можно и не править

:) до этого я то и сам додумался - только вот не прокатывает :(
когда клиет включает пасивный мод он проходит соединение потом авторизацию и даелее просто виснет на моменте листинга директории, если конектиться в активном моде то он также соединяться, проходит авторизацию и вылетает. Насколько я изучил вопрос в пасивном моде фтп сервак сообщает клиентку к какому порту конектиться после успешного проходжения авторизации, но он это отдает с указанием ip:port - но беда в том что сервак незнает что он сидит за натом, в профт есть опция - маскарадинга - но блин у меня динамический ip - так что она бесполезна. В линуне к iptables есть модули специально для фтп который в таком режиме пеняют данные в пакетах - есть ли такое в киске?
в активном моде клиент говорит фтп серверу на какой порт он будет стучаться но блин опять же киска не может динамически открыть эти порты и прокинуть их- или может но я незнаю поэтому и спрашиваю.
для пасивного мода я тоже пробовал в конфиге указать набор портов для пасив мода и этиже порты прокинуть - но вся засада на сколько я понял в том что фтп посылает клиенту команду/данные 192.168.0.21:port а не внешний ip:port - мне так кажеться в этом проблема, и решаться она должна силами киски - но как я не понял или надо както объснить proftpd чтобы он посылал просто порт а не связку ip port - но реально это или нет я не в вкурсе. Если есть у кого работающий proftpd за натом с динамическим ip и он дотупен из инеты выложите плиз конфиг фтп и кусок конфига киски - где пробрасываеться соединение.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Помогите плиз настроить FTP"  
Сообщение от KobaLTD email on 15-Дек-07, 13:21 
>ip nat inside source static tcp 192.168.0.21 2121 interface Dialer1 21
>
>URL для тех кто снаружи будет такой ftp://xxx.xxx.xxx.xxx:2121/
>
>Дефлтный конфиг proftpd можно и не править

да и на скока я понимаю
должно быть
ip nat inside source static tcp 192.168.0.21 21 interface Dialer1 2121
а не
ip nat inside source static tcp 192.168.0.21 2121 interface Dialer1 21
или я не правельно понимаю?  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Помогите плиз настроить FTP"  
Сообщение от KobaLTD email on 15-Дек-07, 13:52 
>[оверквотинг удален]
>>URL для тех кто снаружи будет такой ftp://xxx.xxx.xxx.xxx:2121/
>>
>>Дефлтный конфиг proftpd можно и не править
>
>да и на скока я понимаю
>должно быть
>ip nat inside source static tcp 192.168.0.21 21 interface Dialer1 2121
>а не
>ip nat inside source static tcp 192.168.0.21 2121 interface Dialer1 21
>или я не правельно понимаю?

вобщем спасибо за отвыты :) сам разобрался - ответ почти правельный только с моей поправкой, а не получалось - потому что "сам дурак" - я использовал в качестве клиент FAR - но не выставил там тип фтп листинга UNIX или Autodetect - вот и не работало (правдо я не понимаю почему такие же настройки на локале и все работает - может киска всетаки парсит пакеты и поэтому надо выставлять совместимость - вобщем буду разбираться) - может комунить поможет.
:) Назрел еще 1 вопрос - есть службы динамического днс ddns на сколько я понял киска в принцепе их держит но в моей конфе этого нет  :(
Cisco IOS Software, C820 Software (C820-SV6Y6-M), Version 12.3(11)T2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2004 by Cisco Systems, Inc.
Compiled Fri 29-Oct-04 15:51 by cmong

ROM: System Bootstrap, Version 12.2(4r)XM3, RELEASE SOFTWARE (fc1)

koba-gw uptime is 14 hours, 52 minutes
System returned to ROM by reload at 22:55:29 MSK Fri Dec 14 2007
System restarted at 22:57:35 MSK Fri Dec 14 2007
System image file is "flash:c820-sv6y6-mz.123-11.T2.bin"

Cisco C827-4V (MPC855T) processor (revision 0x1101) with 48128K/1024K bytes of memory.
Processor board ID JAE0828P61S (769522219), with hardware revision 0000
CPU rev number 5
4 POTS Ports
1 Ethernet interface
1 ATM interface
128K bytes of NVRAM.
12288K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102
вопрос в какой версии ios для этого девайся эта опция присутствует?
спасибо за помощь.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Помогите плиз настроить FTP"  
Сообщение от CrAzOiD (??) on 15-Дек-07, 14:06 
>:) Назрел еще 1 вопрос - есть службы динамического днс ddns на
>сколько я понял киска в принцепе их держит но в моей
>конфе этого нет  :(
>Cisco C827-4V (MPC855T) processor (revision 0x1101) with 48128K/1024K bytes of memory.

http://www.cisco.com/go/fn

Итого, во всей ветке 12.4, памяти просить 48/12 - у тебя хватает

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Помогите плиз настроить FTP"  
Сообщение от KobaLTD email on 15-Дек-07, 15:46 
>>:) Назрел еще 1 вопрос - есть службы динамического днс ddns на
>>сколько я понял киска в принцепе их держит но в моей
>>конфе этого нет  :(
>>Cisco C827-4V (MPC855T) processor (revision 0x1101) with 48128K/1024K bytes of memory.
>
>http://www.cisco.com/go/fn
>
>Итого, во всей ветке 12.4, памяти просить 48/12 - у тебя хватает
>

вопрос к знатокам - А если на 827-v4 залить от 827 - ? это реально - я так понимаю отрубиться функции для войс портов - но она вроде требудет по меньше памяти - или это в плане производительности ничего не даст - просто у меня средняя загрузка девайса 65-70%

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Помогите плиз настроить FTP"  
Сообщение от CrAzOiD (??) on 15-Дек-07, 14:00 
>[оверквотинг удален]
>>URL для тех кто снаружи будет такой ftp://xxx.xxx.xxx.xxx:2121/
>>
>>Дефлтный конфиг proftpd можно и не править
>
>да и на скока я понимаю
>должно быть
>ip nat inside source static tcp 192.168.0.21 21 interface Dialer1 2121
>а не
>ip nat inside source static tcp 192.168.0.21 2121 interface Dialer1 21
>или я не правельно понимаю?

да, это я ошибся

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру