The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 2621XM"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Cisco 2621XM"  
Сообщение от merax email(ok) on 14-Мрт-08, 13:38 
Помогите вот с таким вопросом. Имеется циско 2621 в локальной сети. В ети есть внешний шлюз с адресом 192.168.53.1. В циско имеется модуль ADSL. Необходимо зарезервировать основной канал (Локальная сеть) на ADSL.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ukb_urai
!
boot-start-marker
boot-end-marker
!
logging buffered 32000 debugging
enable secret 5 $1$mlNa$NTfXQL4QN4QzuatNtxlE8/
enable password angel
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
vpdn enable
!
vpdn-group pppoe
!
vpdn-group pptp
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/0
framing NO-CRC4
channel-group 0 timeslots 1-2
!
controller E1 0/1
framing NO-CRC4
channel-group 1 timeslots 1-2
!
!
bridge irb
!
!
bba-group pppoe global
!
!
interface FastEthernet0/0
no ip address
speed auto
full-duplex
pppoe enable group global
!
interface FastEthernet0/0.20
!
interface FastEthernet0/0.41
ip nat inside
ip virtual-reassembly
no ip mroute-cache
pppoe enable group global
no keepalive
no cdp enable
!
interface FastEthernet0/0.44
description -==== Remote Office vlan 44 ===-
encapsulation dot1Q 44
ip address 192.168.44.2 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.51
!
interface FastEthernet0/0.53
description -=== Link to LOCAL_NET ====---
encapsulation dot1Q 53
ip address 192.168.53.2 255.255.255.0
ip nat inside
ip virtual-reassembly
no snmp trap link-status
!
interface ATM0/2
no ip address
no atm auto-configuration
no atm ilmi-keepalive
no atm address-registration
no atm ilmi-enable
dsl operating-mode auto
!
interface ATM0/2.1 point-to-point
no snmp trap link-status
pvc 1/50
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0.53
ip access-group LOG in
ip access-group LOG out
ip tcp header-compression
peer default ip address pool pool_pppoe
ppp authentication ms-chap-v2 chap
!
interface Dialer1
ip address negotiated
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip policy route-map NAT
dialer pool 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ****
ppp chap password 0 *********
ppp pap sent-username **** password 0 *********
!
interface BVI1
no ip address
!
ip route 0.0.0.0 0.0.0.0 192.168.53.1
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.44.0 255.255.255.0 192.168.53.1
ip route 192.168.50.0 255.255.255.0 11.0.0.2
ip route 192.168.51.0 255.255.255.0 FastEthernet0/1
ip route 192.168.53.0 255.255.255.0 11.0.0.2
!
!
ip http server
ip http secure-server
!
ip access-list standard mfUkb
deny   any
permit any
!
access-list 115 permit ip 0.0.0.102 255.255.255.0 any
access-list 133 permit tcp host 192.168.53.102 any eq telnet
access-list 133 permit tcp host 192.168.53.190 any eq telnet
access-list 133 deny   tcp any any
!
snmp-server community public RO
!
route-map NAT permit 10
match ip address 115
set interface Dialer1
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip

Направте хотя бы на путь истинный. Заранее благодарен.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

  • Cisco 2621XM, CrAzOiD, 14:02 , 14-Мрт-08, (1)  
    • Cisco 2621XM, merax, 14:27 , 14-Мрт-08, (2)  
      • Cisco 2621XM, merax, 14:28 , 14-Мрт-08, (3)  
        • Cisco 2621XM, CrAzOiD, 14:37 , 14-Мрт-08, (4)  
          • Cisco 2621XM, merax, 09:57 , 29-Апр-08, (5)  

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 2621XM"  
Сообщение от CrAzOiD (ok) on 14-Мрт-08, 14:02 
>[оверквотинг удален]
> set interface Dialer1
>!
>!
>!
>control-plane
>!
>bridge 1 protocol ieee
>bridge 1 route ip
>
>Направте хотя бы на путь истинный. Заранее благодарен.

SLA + track на дефолтный маршрут ip route 0.0.0.0 0.0.0.0 192.168.53.1
(определить только что считать падением канала)
на маршруте ip route 0.0.0.0 0.0.0.0 Dialer1 увеличиваете административную дистанцию

с NAT и прочим надо отдельно разбираться... в приведенном куске конфига вообще не понятно как у вас трансляции происходят
судя по всему этот маршрутизатор не пограничный и не он делает NAT, а есть нечто с адресом 192.168.53.1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Cisco 2621XM"  
Сообщение от merax email(ok) on 14-Мрт-08, 14:27 
>[оверквотинг удален]
>>Направте хотя бы на путь истинный. Заранее благодарен.
>
>SLA + track на дефолтный маршрут ip route 0.0.0.0 0.0.0.0 192.168.53.1
>(определить только что считать падением канала)
>на маршруте ip route 0.0.0.0 0.0.0.0 Dialer1 увеличиваете административную дистанцию
>
>с NAT и прочим надо отдельно разбираться... в приведенном куске конфига вообще
>не понятно как у вас трансляции происходят
>судя по всему этот маршрутизатор не пограничный и не он делает NAT,
>а есть нечто с адресом 192.168.53.1

Что то я не догнал? Естественно что маршрутизатор не пограничный. Мне не надо определять живучесть канала. Мне надо по роуте-мап отдельные адреса направлять на ADSL а остально

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Cisco 2621XM"  
Сообщение от merax email(ok) on 14-Мрт-08, 14:28 
Прошу прощения!!

а остальной трафик гнать на шлюз. Вот и все.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Cisco 2621XM"  
Сообщение от CrAzOiD (ok) on 14-Мрт-08, 14:37 
>Прошу прощения!!
>
>а остальной трафик гнать на шлюз. Вот и все.

фраза "зарезервировать" может быть истолкована по-разному...
в вашей ситуации рисуете route-map и вешаете его на внутренний интерфейс, типа такого:

route-map RM1 permit 10
match ip address ACL1
set ip next-hop x.x.x.x # IP на той стороне ADSL

описываете в этом ACL что должно и/или не должно попадать в маршрутизацию
ip access-list extended ACL1
deny   ....
permit ....
deny   ip any any

ПыСы Настройки NAT на интерфейсах (nat inside/outside) при отстутвии описания трансляций совершенно лишние

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Cisco 2621XM"  
Сообщение от merax (ok) on 29-Апр-08, 09:57 

Спс решил проблему так, мож кому пригодится :)

Врбаем слежение

ip sla monitor 1
type echo protocol ipIcmpEcho 217.20.88.13 source-interface Dialer1
timeout 2000
frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 192.168.53.1 source-interface FastEthernet0/0.53
timeout 2000
frequency 3
ip sla monitor schedule 2 life forever start-time now
!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!

Пишем роуты

ip route 0.0.0.0 0.0.0.0 Dialer1 50 track 1
ip route 0.0.0.0 0.0.0.0 192.168.53.1 100 track 2

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру