The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Непонятная ситуация с IP на интерфейсе 851W"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"Непонятная ситуация с IP на интерфейсе 851W"  +/
Сообщение от boroda10 email(ok) on 18-Апр-08, 10:35 
Конфиг:

Current configuration : 11629 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
aaa new-model
!
!
aaa authentication login local_authen local
aaa authorization exec local_author local
!
!
aaa session-id common
clock timezone PCTime 3
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
no ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.11 10.10.10.254
!
ip dhcp pool sdm-pool1
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 77.50.0.3 77.50.1.3
!
ip dhcp pool iphone
   hardware-address 001f.5b4d.a93d
   client-name iphone
!
ip dhcp pool desktop
   hardware-address 0001.6c16.416b
   client-name desktop
!
ip dhcp pool x61s
   hardware-address 0018.de73.87d1
   client-name x61s
!
!
ip cef
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip tcp synwait-time 10
no ip bootp server
ip domain name yourdomain.com
ip name-server 77.50.0.3
ip name-server 77.50.1.3
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
crypto pki trustpoint TP-self-signed-3252981482
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3252981482
revocation-check none
rsakeypair TP-self-signed-3252981482
!
!
crypto pki certificate chain TP-self-signed-3252981482
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33323532 39383134 3832301E 170D3038 30323233 31303336
  33395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32353239
  38313438 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100F083 2C480079 EA5B86B2 C71B4174 5FCA8CEE FECC8D43 65935250 2F4127DD
  FBF31EB6 19B1ACE8 3C6243C6 68285242 94F5CB87 9A9B5968 BF7AB564 78E2FF8F
  4BC4F0A8 D5767C5F 2AAE0C9C C78BD317 FB8B27D6 30AE0583 7FEAFD4C 489218C3
  378241C5 E272D16D 8DC58957 8C73CEA9 5CBE23C3 9A53C398 F2255B5C 5A092EFF
  542F0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 14085B43 0460F7D0 DE7B0C9E 92C15A88 3D3A28A3
  82301D06 03551D0E 04160414 085B4304 60F7D0DE 7B0C9E92 C15A883D 3A28A382
  300D0609 2A864886 F70D0101 04050003 8181003F 8F158640 0FAB39E7 F4FA9308
  8AE226D2 54993C7E 3A28D651 4BF5B64C 5BBACD90 0E320118 56822735 3EC0A6DC
  D4C5EC20 4A2259B8 34867DF7 57718BB1 9FABED76 7B013E19 4AFD2838 89D3C6ED
  DA4E38A2 2FC39565 6232A10F 716D06A9 9DC7B6A9 C786337D 72C234B3 179CA4F8
  C6E000BB 0DD6BCF3 8DA574BC 20D7D9C7 5C8DAF
  quit
!
!
username XXXXXXX privilege 15 secret 5 XXXXXXXXXXXXXXXXXXXXXXXXX
!
!
!
bridge irb
!
!
!
interface Null0
no ip unreachables
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ES_WAN$$FW_OUTSIDE$
mac-address 0011.6b25.860d
ip address 77.50.142.XX 255.255.255.0
ip access-group 101 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
ip inspect DEFAULT100 out
ip nat outside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid Cisco
    authentication open
    authentication key-management wpa
    wpa-psk ascii 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXxxx
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2427
station-role root
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
no ip address
ip tcp adjust-mss 1452
bridge-group 1
!
interface BVI1
description $ES_LAN$$FW_INSIDE$
ip address 10.10.10.1 255.255.255.0
ip access-group 100 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1412
!
ip route 0.0.0.0 0.0.0.0 77.50.142.1
!
ip http server
ip http access-class 2
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp 10.10.10.2 3389 interface FastEthernet4 3389
ip nat inside source static tcp 10.10.10.2 4759 interface FastEthernet4 4759
ip nat inside source static tcp 10.10.10.2 8080 interface FastEthernet4 8080
ip nat inside source static tcp 10.10.10.2 8090 interface FastEthernet4 8090
!
logging trap debugging
access-list 1 remark INSIDE_IF=BVI1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 2 remark HTTP Access-class list
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 62.118.2.70
access-list 2 permit 10.10.10.0 0.0.0.255
access-list 2 deny   any
access-list 100 deny   ip 77.50.142.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 permit tcp any host 77.50.142.XX eq 4759
access-list 101 permit tcp any host 77.50.142.XX eq 8090
access-list 101 permit tcp any host 77.50.142.XX eq 8080
access-list 101 permit tcp any host 77.50.142.XX eq 3389
access-list 101 permit tcp host 62.118.2.XX host 77.50.142.XX eq telnet
access-list 101 permit tcp host 62.118.2.XX host 77.50.142.XX eq 22
access-list 101 permit tcp host 62.118.2.XX host 77.50.142.XX eq www
access-list 101 permit tcp host 62.118.2.XX host 77.50.142.XX eq 443
access-list 101 permit tcp host 62.118.2.XX host 77.50.142.XX eq cmd
access-list 101 deny   udp any host 77.50.142.XX eq snmp
access-list 101 permit udp host 77.50.1.3 eq domain host 77.50.142.XX
access-list 101 permit udp host 77.50.0.3 eq domain host 77.50.142.XX
access-list 101 deny   ip 10.10.10.0 0.0.0.255 any
access-list 101 permit icmp any host 77.50.142.XX echo-reply
access-list 101 permit icmp any host 77.50.142.XX time-exceeded
access-list 101 permit icmp any host 77.50.142.XX unreachable
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip host 0.0.0.0 any
access-list 101 permit tcp host 10.10.10.2 eq 3389 any
access-list 101 permit tcp host 10.10.10.2 eq 8080 any
access-list 101 permit tcp host 10.10.10.2 eq 4759 any
access-list 101 permit tcp host 10.10.10.2 eq 8090 any
access-list 101 deny   ip any any
access-list 102 remark VTY Access-class list
access-list 102 remark SDM_ACL Category=1
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 102 deny   ip any any
no cdp run
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner exec ^CCCCC
% Password expiration warning.
^C
banner login ^CCCCCAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login authentication local_authen
no modem enable
transport output telnet
line aux 0
login authentication local_authen
transport output telnet
line vty 0 4
access-class 102 in
authorization exec local_author
login authentication local_authen
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Цели - пробросить порты снаружи через FastEthernet4 до 10.10.10.2 с именем desktop.

Она единственная сидит на порту свитча FastEthernet0, а остальные все цепляются по радио.
FastEthernet4 - wan.
Все машины нормально привязываются к ip, но при попытке получения адреса desktop получает сообщение, что ip 10.10.10.2 уже используется. При этом я не могу понять кем. Мак этого фантомного адреса тот же, что на Dot11Radio0 и BVI1, при этом сама 851-я считает что на этих интерфейсах ip нет. По радио никто левый не цепляется, видно было бы в логах.
Сама cisco в лог пишет попытку повторного получения 10.10.10.2 платой 0001.6c16.416b(desktop). Сниффер действительно видит, что ходят пакеты с 10.10.10.2
и маком Dot11Radio0 и BVI1, при выключенном десктопе.
Если попытаться ту же машину же привязать к другому ip, то начинается все точно тоже самое, только с другим адресом. Достаточно убрать в конфиге привязку этой платы к mac и очистить все кэши то машина сама получает 10.10.10.2 и отлично на нем дальше живет.
Все остальные три компьютера при этом ведут себя без всяких выкрутасов.
desktop - единственный на которой стоит vista.
Версия IOS c850-advsecurityk9-mz.124-15.T4, с более ранней было аналогично.

Весь мозг уже сломал.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Непонятная ситуация с IP на интерфейсе 851W"  +/
Сообщение от KobaLTD email on 18-Апр-08, 16:22 
>[оверквотинг удален]
>и маком Dot11Radio0 и BVI1, при выключенном десктопе.
>Если попытаться ту же машину же привязать к другому ip, то начинается
>все точно тоже самое, только с другим адресом. Достаточно убрать в
>конфиге привязку этой платы к mac и очистить все кэши то
>машина сама получает 10.10.10.2 и отлично на нем дальше живет.
>Все остальные три компьютера при этом ведут себя без всяких выкрутасов.
>desktop - единственный на которой стоит vista.
>Версия IOS c850-advsecurityk9-mz.124-15.T4, с более ранней было аналогично.
>
>Весь мозг уже сломал.

Насколько я помню по спецыфикации МС надо юзать не hardware-address, а client-identifier - наскока я понимаю в этом проблема.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Непонятная ситуация с IP на интерфейсе 851W"  +/
Сообщение от boroda10 email(ok) on 18-Апр-08, 17:51 
>[оверквотинг удален]
>>конфиге привязку этой платы к mac и очистить все кэши то
>>машина сама получает 10.10.10.2 и отлично на нем дальше живет.
>>Все остальные три компьютера при этом ведут себя без всяких выкрутасов.
>>desktop - единственный на которой стоит vista.
>>Версия IOS c850-advsecurityk9-mz.124-15.T4, с более ранней было аналогично.
>>
>>Весь мозг уже сломал.
>
>Насколько я помню по спецыфикации МС надо юзать не hardware-address, а client-identifier
>- наскока я понимаю в этом проблема.

Абсолютно прав. Но проблема увы не в этом. Это я просто наплодил на рабочем столе столько копий разных конфигов, что просто сюда спросонья запостил не тот.(третьи сутки сидел до ночи)
Конечно у меня они все прописаны как client-identifier, на эти грабли я уже наступил ранее. И ВСЕ они работают, кроме одного.
Сейчас я прописал еще arp 10.10.10.Х XXXX.XXXX.XXXX ARPA
cisco в логах и злосчастная машина, перестали ругаться на дублирующийся ip,
но теперь в чертовой висте, несмотря на то, что по ipconfig все ок,
не виден адрес шлюза 10.10.10.1 и DNS, хотя 10.10.10.3 у соседней машины
отлично виден.
Причем сама машина 10.10.10.2 при этом отлично пингуется, как с cisco(10.10.10.1),
так и с соседа 10.10.10.3.

Сдается мне, косяк скорее в висте, только вот как его найти...

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Непонятная ситуация с IP на интерфейсе 851W"  +/
Сообщение от boroda10 email(ok) on 18-Апр-08, 20:48 
Разобрался. Сам накосячил в форвардинге портов.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Непонятная ситуация с IP на интерфейсе 851W"  +/
Сообщение от alexrn (ok) on 18-Июл-11, 12:24 
А как вы прописывали hardware-address или client-identifier для  iPhone? Работет ли?
У меня сейчас как раз проблема с DHCP для MacBook'ов и iPhone'ов, не выдает те адреса которые ставлю в пуле и все.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру