The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка NETFLOW совместно с SLA+NAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от vremennoya (ok) on 27-Май-08, 20:21 
Настроено SLA+NAT, переключение с канала на канал работает.
Необходимо настроить NETFLOW для корректного подсчета трафика по натовым адресам.
Подскажите, пожалуйста, как это сделать в моем случае.
!
!
ip sla 1
icmp-echo 213.180.204.8 source-interface FastEthernet0
timeout 1000
threshold 40
frequency 3
!
ip sla schedule 1 life forever start-time now
!
ip sla 2
icmp-echo 81.19.70.3 source-interface FastEthernet1
timeout 1000
threshold 40
frequency 3
!
ip sla schedule 2 life forever start-time now
!
!
track 100 rtr 1 reachability
delay down 15 up 10
!
track 200 rtr 2 reachability
delay down 15 up 10
!
!
interface FastEthernet0
ip address 172.16.101.60 255.255.0.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip policy route-map ISP0
duplex auto
speed auto
!
!
interface FastEthernet1
ip address 10.5.5.2 255.255.0.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip policy route-map ISP1
duplex auto
speed auto
!
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$$ES_LAN$$FW_INSIDE$
ip address 10.10.10.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
!
ip route 0.0.0.0 0.0.0.0 172.16.0.1 track 100
ip route 0.0.0.0 0.0.0.0 10.5.5.1 2 track 200
!
ip route 81.19.70.3 255.255.255.255 10.5.5.1
ip route 213.180.204.8 255.255.255.255 172.16.0.1
!
ip nat inside source route-map ISP0 interface FastEthernet0 overload
ip nat inside source route-map ISP1 interface FastEthernet1 overload
!
access-list 110 permit ip 10.10.10.0 0.0.0.255 any
!
route-map ISP0 permit 10
match ip address 110
match interface FastEthernet0
!
route-map ISP1 permit 10
match ip address 110
match interface FastEthernet1
!
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от CrAzOiD (ok) on 27-Май-08, 22:24 
>[оверквотинг удален]
>access-list 110 permit ip 10.10.10.0 0.0.0.255 any
>!
>route-map ISP0 permit 10
> match ip address 110
> match interface FastEthernet0
>!
>route-map ISP1 permit 10
> match ip address 110
> match interface FastEthernet1
>!

В вашем и в общем случае
на интерфейсах
ip flow ingress
ip flow egress

ip flow-export source FastEthernet0/0
ip flow-export version 9
ip flow-export destination 172.24.1.1 9996

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от vremennoya (ok) on 28-Май-08, 15:06 
>[оверквотинг удален]
>>!
>
>В вашем и в общем случае
>на интерфейсах
>ip flow ingress
>ip flow egress
>
>ip flow-export source FastEthernet0/0
>ip flow-export version 9
>ip flow-export destination 172.24.1.1 9996

Спасибо, в случае с одним внешним интерфейсом работает.

Как быть если надо считать трафик на обоих внешний интерфейсах?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от vremennoya (ok) on 28-Май-08, 15:29 
>[оверквотинг удален]
>>ip flow ingress
>>ip flow egress
>>
>>ip flow-export source FastEthernet0/0
>>ip flow-export version 9
>>ip flow-export destination 172.24.1.1 9996
>
>Спасибо, в случае с одним внешним интерфейсом работает.
>
>Как быть если надо считать трафик на обоих внешний интерфейсах?

Не выставляется второй
ip flow-export source

Если уже есть
ip flow-export source FastEthernet 0
указываю второй ip flow-export source, то он просто замещается...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 16:19 
>[оверквотинг удален]
>>Спасибо, в случае с одним внешним интерфейсом работает.
>>
>>Как быть если надо считать трафик на обоих внешний интерфейсах?
>
>Не выставляется второй
>ip flow-export source
>
>Если уже есть
>ip flow-export source FastEthernet 0
>указываю второй ip flow-export source, то он просто замещается...

Эта команда подразумевает что только один адрес интерфейса будет являться адресом net-flow пакетов
Зачем вам два?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от CrAzOiD (ok) on 28-Май-08, 16:19 
>[оверквотинг удален]
>>ip flow ingress
>>ip flow egress
>>
>>ip flow-export source FastEthernet0/0
>>ip flow-export version 9
>>ip flow-export destination 172.24.1.1 9996
>
>Спасибо, в случае с одним внешним интерфейсом работает.
>
>Как быть если надо считать трафик на обоих внешний интерфейсах?

А вы просто гадаете или попробовали и не получилось?
Покажите что не получилось

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Настройка NETFLOW совместно с SLA+NAT"  
Сообщение от vremennoya (??) on 28-Май-08, 17:47 
>[оверквотинг удален]
>>>ip flow-export source FastEthernet0/0
>>>ip flow-export version 9
>>>ip flow-export destination 172.24.1.1 9996
>>
>>Спасибо, в случае с одним внешним интерфейсом работает.
>>
>>Как быть если надо считать трафик на обоих внешний интерфейсах?
>
>А вы просто гадаете или попробовали и не получилось?
>Покажите что не получилось

Все получилось, написал не подумав, спасибо за помощь.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру