The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Маршрутизация. VLAN и int Tunnel"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Маршрутизация. VLAN и int Tunnel"  
Сообщение от Дмитрий (??) on 19-Июн-08, 12:26 
Здравствуйте уважаемые коллеги!
В процессе настройки оборудования наткнулся на проблему.

Есть маршрутизатор Cisco 7500 и коммутатор Catalyst 3550. Они соединены  ip-ip туннелем. На коммутаторе создано несколько VLAN'ов, в каждом из которых живет своя сеть, у которой шлюзом по умолчанию является каталист. Подсети между собой маршрутизируется, все работает как часы. Но вот встала задача смаршрутизировать сеть, находящуюся за 7500'й и и сети в VLAN'ах каталиста.
Казалось бы все просто, туннель работает, статические маршруты прописаны, роутер и каталист видят друг друга по транзитным IP. Но вот пакеты из сети за каталистом не идут дальше самого каталиста.
Вот конфиг комутатора(убрал лишнее) :

========================================================
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname L3.saum.lan
!
no aaa new-model
ip subnet-zero
ip routing
ip icmp rate-limit unreachable 1000
ip domain-name saum.lan
ip name-server 10.17.0.2
ip dhcp excluded-address 192.168.17.1 192.168.17.99
ip dhcp excluded-address 192.168.18.1 192.168.18.99
ip dhcp excluded-address 192.168.16.1 192.168.16.99
!
ip dhcp pool Saum.Net
   network 192.168.17.0 255.255.255.0
   domain-name saum.lan
   dns-server 10.17.0.2
   netbios-name-server 10.17.0.2
   netbios-node-type h-node
   default-router 192.168.17.1
!
ip dhcp pool Fasad.Net
   network 192.168.16.0 255.255.255.0
   domain-name saum.lan
   dns-server 10.17.0.2
   netbios-name-server 10.17.0.2
   default-router 192.168.16.1
!
ip dhcp pool Pasific.Net
   network 192.168.18.0 255.255.255.0
   domain-name saum.lan
   dns-server 10.17.0.2
   netbios-name-server 10.17.0.2
   netbios-node-type h-node
   default-router 192.168.18.1
!
vtp mode transparent
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2-5,11-13
!
ip tcp selective-ack
ip tcp timestamp
!
!
interface Tunnel0
description Tunnel-to-MA (195.194.193.0)
bandwidth 9
ip address 172.21.17.2 255.255.255.0
ip mtu 1460
delay 50000
tunnel source 86.xxx.xxx.88
tunnel destination 86.xxx.xxx.86
tunnel mode ipip
!
interface FastEthernet0/45
switchport access vlan 12
switchport mode access
spanning-tree portfast
!
interface Vlan1
no ip address
no ip proxy-arp
!
interface Vlan2
ip address 86.xxx.xxx.88 255.255.255.240
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache cef
no ip route-cache
!
interface Vlan3
ip address 10.17.10.2 255.255.255.252
no ip proxy-arp
!
interface Vlan11
description Saum LAN
ip address 192.168.17.1 255.255.255.0
ip directed-broadcast
!
interface Vlan12
description Pasific Cargo LAN
ip address 192.168.18.1 255.255.255.0
no ip unreachables
ip directed-broadcast
no ip mroute-cache
!
interface Vlan13
description Fasad-System LAN
ip address 192.168.16.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.17.10.1
ip route 195.194.193.0 255.255.255.0 172.21.17.1
ip http server
ip http secure-server

=================================================================

195.194.193.0/24 это и есть сеть за роутером, которую нужно связать с сетями за коммутатором.
Причем проблема на 90% в каталисте, ибо  при пинге машины 192.168.18.100 из сети 195.194.193.0, на самой машине tcpdump видит реквесты и реплаи, а вот ответ дальше каталиста не уходит.

Traceroute из сети 195.194.193.0 пишет следующее:

>tracert -d 192.168.18.100

Трассировка маршрута к 192.168.18.100 с максимальным числом прыжков 30

  1    <1 мс    <1 мс    <1 мс  195.194.193.44
  2     1 ms    <1 мс    <1 мс  10.0.0.1
  3     2 ms     3 ms     3 ms  172.21.17.2
  4     *        *        *     Превышен интервал ожидания для запроса.

Tracerroute из сети 192.168.18.0 затыкается на 192.168.18.1, т.е. самом каталисте.

Причем из сети 195.194.193.0 сам каталист виден:

>tracert -d 192.168.18.1

Трассировка маршрута к 192.168.18.1 с максимальным числом прыжков 30

  1    <1 мс    <1 мс    <1 мс  195.194.193.44
  2    <1 мс    <1 мс    <1 мс  10.0.0.1
  3     3 ms     4 ms     3 ms  192.168.18.

Трассировка завершена.

В общем мистика какая-то.
Заранее благодарен за любую помощь!

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Маршрутизация. VLAN и int Tunnel"  
Сообщение от Дмитрий (??) on 19-Июн-08, 12:29 
Ах да, забыл.

>show ip route на каталисте:

Gateway of last resort is 10.17.10.1 to network 0.0.0.0

S    195.194.193.0/24 [1/0] via 172.21.17.1
     86.0.0.0/28 is subnetted, 1 subnets
C       86.xxx.xxx.80 is directly connected, Vlan2
     172.21.0.0/24 is subnetted, 1 subnets
C       172.21.17.0 is directly connected, Tunnel0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.17.10.0/30 is directly connected, Vlan3
C       10.17.0.0/28 is directly connected, Vlan4
C    192.168.16.0/24 is directly connected, Vlan13
C    192.168.18.0/24 is directly connected, Vlan12
S*   0.0.0.0/0 [1/0] via 10.17.10.1

Дефол гетвеем для каталиста является роутер, он используется для учета трафика юзеров в сетях. Его ip: 10.17.10.1
Но это так, к слову, ибо трафик на 195.194.193.0 должен идти мимо него.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Маршрутизация. VLAN и int Tunnel"  
Сообщение от SergTel email(ok) on 19-Июн-08, 13:02 
А точно у тебя по туннелю данные идут?
попробуй инкап заменить на  GRE
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Маршрутизация. VLAN и int Tunnel"  
Сообщение от Дмитрий (??) on 20-Июн-08, 02:02 
>А точно у тебя по туннелю данные идут?
>попробуй инкап заменить на  GRE

Да, traceroute это явно показывает.
Прописал в туннелях tunnel mode gre ip, та же история...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Маршрутизация. VLAN и int Tunnel"  
Сообщение от SergTel email(ok) on 20-Июн-08, 06:17 
>>А точно у тебя по туннелю данные идут?
>>попробуй инкап заменить на  GRE
>
>Да, traceroute это явно показывает.
>Прописал в туннелях tunnel mode gre ip, та же история...

О у тебя коммутатор 3550
2 года назад была такая-же задача пробросить туннель до другого подразделения сквозь другую AS
Что-бы я не делал не шли данные через туннель.(в удаленном подразделении был только 3550-12т)
В конечном итоге пришлось взять 2811 и все сделать на нем. схема:2811-(2811-3550)
Думаю на коммутаторе туннель не прокатит, хотя может новые версии исправили данную проблему. Пробовал на c3550-ipservicesk9-mz.122-25.SEE1.bin
Проверялось с динамикой легко. Смотришь на каких интерфейсах работает маршрутизация.
Так вот на туннеле не было ничего, только на VLAN. Соответственно данные не передавались.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Маршрутизация. VLAN и int Tunnel"  
Сообщение от Дмитрий (??) on 20-Июн-08, 08:51 
хм, возможно и железка.
Но тем не менее, реализовать задачу удалось через PBR. Добавил правило, пакеты пошли.
Но вот если возвращаться к статике - затык. :)
Я уже не знаю, может жертвопреношение какое сделать...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру