The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с открытием  некотроых веб сайтов через GRE тунель"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от emv67 email(ok) on 16-Дек-08, 23:47 
Существеут такая сеть
К центральной циске{871} с выходом в инет подключены LAN и 2-е Cisco{831} через GRE тунели
Настроен НАТ
Не открывается(идёт бесконечное подключение без выдачи ошибки) сайт odnoklassniki.ru{и подобные,  с логином и паролём для входа на основной странице} через эти 2-е циски.
При этом другие сайты открываются с  нормальной скоростью.
Из LAN все сайты открываются нормально.
Настройки GRE стандартные
interface Tunnel1
description 1
bandwidth 2048
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
keepalive 20 3
tunnel source x.x.x.x
tunnel destination y.y.y.y

Подскажите кто-нибудь куда копать.
Буду благодарен за любой совет.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от shutdown now on 17-Дек-08, 09:41 
>[оверквотинг удален]
> ip address 192.168.0.1 255.255.255.0
> ip nat inside
> no ip virtual-reassembly
> keepalive 20 3
> tunnel source x.x.x.x
> tunnel destination y.y.y.y
>
>Подскажите кто-нибудь куда копать.
>Буду благодарен за любой совет.
>

подкрути tcp mss, я думаю, поможет


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от oleg_matroskin email(??) on 17-Дек-08, 13:39 
>[оверквотинг удален]
>> no ip virtual-reassembly
>> keepalive 20 3
>> tunnel source x.x.x.x
>> tunnel destination y.y.y.y
>>
>>Подскажите кто-нибудь куда копать.
>>Буду благодарен за любой совет.
>>
>
>подкрути tcp mss, я думаю, поможет

http://www.ciscolab.ru/tcpip/31-gre_fragment.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от emv67 email(ok) on 17-Дек-08, 17:23 
>[оверквотинг удален]
>>> tunnel source x.x.x.x
>>> tunnel destination y.y.y.y
>>>
>>>Подскажите кто-нибудь куда копать.
>>>Буду благодарен за любой совет.
>>>
>>
>>подкрути tcp mss, я думаю, поможет
>
>http://www.ciscolab.ru/tcpip/31-gre_fragment.html

Всем большое спасибо за советы.

Решил так

int tun1
ip tcp adjust-mss 1436

Вобщем то знал про это решение,но смутило то что
не открываются именно некоторые сайты, точнее сайты с авторизацией на главной странице(типа odnoklassniki.ru).
Похоже именно такие сайты(веб серверы) устанавливают бит DF

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от alchie (ok) on 17-Дек-08, 17:29 
>int tun1
>ip tcp adjust-mss 1436
>
>Вобщем то знал про это решение,но смутило то что
>не открываются именно некоторые сайты, точнее сайты с авторизацией на главной странице(типа
>odnoklassniki.ru).
>Похоже именно такие сайты(веб серверы) устанавливают бит DF

дело не в самом DF-бите, а в том, что некоторые параноики фильтруют ICMP без разбору, ломая при этом мехнизм PMTUD

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от Nikolay Georgiev on 17-Дек-08, 18:09 
>[оверквотинг удален]
> ip address 192.168.0.1 255.255.255.0
> ip nat inside
> no ip virtual-reassembly
> keepalive 20 3
> tunnel source x.x.x.x
> tunnel destination y.y.y.y
>
>Подскажите кто-нибудь куда копать.
>Буду благодарен за любой совет.
>

Please read this article:

http://www.cisco.com/en/US/tech/tk827/tk369/technologies_tec...

I think that you have some problem with packets with DF bit.
So, set temporary
debug ip icmp on your router

I had a similar problem with IPSec tunnel and
no crypto ipsec df-bit
has resolved the problem.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Проблема с открытием  некотроых веб сайтов через GRE тунель"  +/
Сообщение от Lena (??) on 10-Окт-09, 18:37 
Please,помогите мне.Я включила интернет,набрала сайт одноклассники.ру.Не грузит,пишет Navigation to this page was canceled.Chto delat????
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру