The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"cisco 2811 не отрабатывает ospf"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 17-Дек-08, 10:48 
добрый день всем. прошу помощи. проблема в следующем: есть две циски соединенные между собой двумя провайдерами. поднят ospf. при падении канала на 2811 fa0/0 рутер пропадает из видимости хотя с 3825 fa0/1 виден но по нему не идут пакеты. в сети есть ещё одна циска настроенная по такой же схеме, там все работает. конфиги сравнивал-эдентично.
основной канал fa0/0, резерв fa0/1-shdsl
cisco 2811:
interface FastEthernet0/0
ip address 172.16.1.5 255.255.255.240
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.0.2 255.255.255.240
ip ospf cost 24
duplex auto
speed auto
!
interface FastEthernet0/0/0
switchport access vlan 2
!
interface FastEthernet0/0/1
switchport access vlan 2
!
interface Vlan2
ip address 192.168.135.239 255.255.255.0
!
router ospf 100
log-adjacency-changes
network 172.16.0.0 0.0.1.255 area 1
network 192.168.135.0 0.0.0.255 area 1

cisco 3825:
interface GigabitEthernet0/0
ip address 172.16.1.1 255.255.255.240
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
ip address 172.16.0.1 255.255.255.240
ip ospf cost 24
duplex auto
speed auto
media-type rj45
!
interface FastEthernet0/0/0
switchport access vlan 2
!
interface FastEthernet0/0/1
switchport access vlan 2
!
!
interface Vlan2
ip address 192.168.129.239 255.255.255.0
no ip proxy-arp
!
!
router ospf 100
log-adjacency-changes
network 172.16.0.0 0.0.1.255 area 1
network 192.168.129.0 0.0.0.255 area 1
default-information originate always metric-type 1
может кто прольёт свет на устранение данной проблемы? буду благодарен

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от lumenous (ok) on 17-Дек-08, 15:15 
Я так полагаю, обе циски просто соединены между собой двумя линками. на обоих поднят  оспф, так?
В нормальном состоянии оспф видит оба линка? sh ip ospf nei
При падении одного линка, в оспф второй остается?
sh ip ospf 100 database что говорит? маршруты видно?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 17-Дек-08, 17:19 
да, верно, соеденены и поднят ospf
в нормальном состоянии все работает и видны все линки на обоих онтерфейсах

router#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.129.239   1   2WAY/DROTHER    00:00:34    172.16.1.1      FastEthernet0/0
192.168.131.239   1   2WAY/DROTHER    00:00:36    172.16.1.11     FastEthernet0/0
192.168.133.239   1   2WAY/DROTHER    00:00:39    172.16.1.3      FastEthernet0/0
192.168.134.239   1   FULL/BDR        00:00:35    172.16.1.4      FastEthernet0/0
192.168.137.239   1   FULL/DR         00:00:36    172.16.1.7      FastEthernet0/0
при падении основного канала-вся таблица пустая. в ospf ничего нет. никаких маршрутов нет

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от lumenous (ok) on 17-Дек-08, 21:07 
>[оверквотинг удален]
>192.168.133.239   1   2WAY/DROTHER    00:00:39  
>  172.16.1.3      FastEthernet0/0
>192.168.134.239   1   FULL/BDR      
>  00:00:35    172.16.1.4    
> FastEthernet0/0
>192.168.137.239   1   FULL/DR      
>   00:00:36    172.16.1.7    
>  FastEthernet0/0
>при падении основного канала-вся таблица пустая. в ospf ничего нет. никаких маршрутов
>нет

Я так полагаю роутеры соединены fa0/0--Gi0/0 И fa0/1--gi0/1 Если так, то почему у вас оспф видно только через один канал с порта fa0/0.
Лично я тут вижу, что оспф только по первому каналу поднят и все. В таблице нейборов нету линка через fa0/1, и само собой ипишника.

Попробуйте debug включать и смотреть что они вам говорят.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от Myxa email(??) on 17-Дек-08, 21:49 
Сильн не вникал, но видится, что ИЗНАЧАЛЬНО всё криво.
1. Так ли нужно выносить в отдельный vlan ?
2. Почему в vlan 100 192.168.135.239/24 & 192.168.126.239/24, курятся ли они вообще в одном влане?
3. Может быть всё-таки более привычный вариант с ip sla?
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 17-Дек-08, 23:13 
>Сильн не вникал, но видится, что ИЗНАЧАЛЬНО всё криво.
>1. Так ли нужно выносить в отдельный vlan ?
>2. Почему в vlan 100 192.168.135.239/24 & 192.168.126.239/24, курятся ли они вообще
>в одном влане?
>3. Может быть всё-таки более привычный вариант с ip sla?

что менно криво? в отдельный vlan определены два порта на свич-модуле, а два порта fa0/0, 0/1 подключены к разным провайдерам для обеспечения резервирования

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

5. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (??) on 17-Дек-08, 23:02 
рутры соеденены именно так 0/0--0/0;0/1--0/1
в ospf на самом деле входят два интерфейса объединённые сетью 172.16.0.0 0.0.1.255
router ospf 100
log-adjacency-changes
network 172.16.0.0 0.0.1.255 area 1
network 192.168.135.0 0.0.0.255 area 1
то что видно только fa0/0 видимо потому как это основной канал через который строится топология. может конечно я в чем то и не прав, для этого собственно и обратился за помощью, но все остальные рутеры собственно выполняют свою функцию на 100% при таком же конфиге.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от lumenous (ok) on 18-Дек-08, 07:26 
>[оверквотинг удален]
>
>router ospf 100
> log-adjacency-changes
> network 172.16.0.0 0.0.1.255 area 1
> network 192.168.135.0 0.0.0.255 area 1
>то что видно только fa0/0 видимо потому как это основной канал через
>который строится топология. может конечно я в чем то и не
>прав, для этого собственно и обратился за помощью, но все остальные
>рутеры собственно выполняют свою функцию на 100% при таком же конфиге.
>

Нет, там должны быть видны все возможные линки. А вот какой канал должен быть основным - это уже другой вопрос.
Как вариант попробуйте прописать сети вот так
network 172.16.0.0 0.0.0.15 area 1
network 172.16.1.0 0.0.0.15 area 1
И попробуйте проверить без ospf cost на портах.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 18-Дек-08, 10:52 
предложенные вами действия не привели к желаемым результатам. убрал ospf cost с интервейсов, прописал две сетки
network 172.16.0.0 0.0.0.15 area 1
network 172.16.1.0 0.0.0.15 area 1
но результат то же что и с network 172.16.0.0 0.0.1.255 area 1
даже оставил в ospf только network 172.16.0.0 0.0.0.15 area 1 но через этот интерфейс циска никого не увидела...подозрение на прова....может он режет запросы. по статическим маршрутам все работает как только перевожу на ospf работает только через fa0/0
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от lumenous (ok) on 18-Дек-08, 11:18 
>предложенные вами действия не привели к желаемым результатам. убрал ospf cost с
>интервейсов, прописал две сетки
>network 172.16.0.0 0.0.0.15 area 1
>network 172.16.1.0 0.0.0.15 area 1
>но результат то же что и с network 172.16.0.0 0.0.1.255 area 1
>
>даже оставил в ospf только network 172.16.0.0 0.0.0.15 area 1 но через
>этот интерфейс циска никого не увидела...подозрение на прова....может он режет запросы.
>по статическим маршрутам все работает как только перевожу на ospf работает
>только через fa0/0

Вполне может быть, что у провайдера проблема. Попробуйте дебагом воспользоваться, посмотрите пытается он хотя бы подключиться или нет

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 18-Дек-08, 11:50 
12-18-2008    11:43:08    Local7.Debug    172.16.1.5    304: Dec 18 08:43:07.772: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet0/1 from 172.16.0.2
12-18-2008    11:43:08    Local7.Debug    172.16.1.5    303: Dec 18 08:43:07.484: OSPF: End of hello processing
12-18-2008    11:43:08    Local7.Debug    172.16.1.5    302: Dec 18 08:43:07.484: OSPF: Rcv hello from 192.168.129.239 area 1 from FastEthernet0/0 172.16.1.1
12-18-2008    11:43:06    Local7.Debug    172.16.1.5    301: Dec 18 08:43:05.780: OSPF: Send hello to 224.0.0.5 area 1 on Vlan2 from 192.168.135.239
12-18-2008    11:43:05    Local7.Debug    172.16.1.5    300: Dec 18 08:43:05.020: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet0/0 from 172.16.1.5
12-18-2008    11:43:05    Local7.Debug    172.16.1.5    299: Dec 18 08:43:04.528: OSPF: End of hello processing
12-18-2008    11:43:05    Local7.Debug    172.16.1.5    298: Dec 18 08:43:04.528: OSPF: Rcv hello from 192.168.133.239 area 1 from FastEthernet0/0 172.16.1.3
12-18-2008    11:43:02    Local7.Debug    172.16.1.5    297: Dec 18 08:43:02.340: OSPF: End of hello processing
12-18-2008    11:43:02    Local7.Debug    172.16.1.5    296: Dec 18 08:43:02.340: OSPF: Rcv hello from 192.168.131.239 area 1 from FastEthernet0/0 172.16.1.11
12-18-2008    11:43:02    Local7.Debug    172.16.1.5    295: Dec 18 08:43:02.084: OSPF: End of hello processing
12-18-2008    11:43:02    Local7.Debug    172.16.1.5    294: Dec 18 08:43:02.084: OSPF: Rcv hello from 192.168.137.239 area 1 from FastEthernet0/0 172.16.1.7
12-18-2008    11:43:02    Local7.Debug    172.16.1.5    293: Dec 18 08:43:01.688: OSPF: End of hello processing
12-18-2008    11:43:02    Local7.Debug    172.16.1.5    292: Dec 18 08:43:01.688: OSPF: Rcv hello from 192.168.134.239 area 1 from FastEthernet0/0 172.16.1.4
12-18-2008    11:42:58    Local7.Debug    172.16.1.5    291: Dec 18 08:42:57.772: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet0/1 from 172.16.0.2
это на поднятых обоих интерфейсах
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 18-Дек-08, 11:59 
вот что происходит при отключении fa0/0
12-18-2008    11:52:16    Local7.Notice    192.168.129.239    426: Dec 18 08:52:15.031: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.135.239 on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired
12-18-2008    11:51:48    Local7.Debug    172.16.1.5    423: Dec 18 08:51:47.782: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet0/1 from 172.16.0.2
12-18-2008    11:51:46    Local7.Debug    172.16.1.5    422: Dec 18 08:51:45.790: OSPF: Send hello to 224.0.0.5 area 1 on Vlan2 from 192.168.135.239
12-18-2008    11:51:44    Local7.Debug    172.16.1.5    421: Dec 18 08:51:43.693: OSPF: Remember old DR 192.168.137.239 (id)
12-18-2008    11:51:44    Local7.Debug    172.16.1.5    420: Dec 18 08:51:43.689:        DR: none    BDR: none
12-18-2008    11:51:44    Local7.Debug    172.16.1.5    419: Dec 18 08:51:43.689: OSPF: Elect DR 0.0.0.0
12-18-2008    11:51:44    Local7.Debug    172.16.1.5    418: Dec 18 08:51:43.689: OSPF: Elect BDR 0.0.0.0
12-18-2008    11:51:44    Local7.Debug    172.16.1.5    417: Dec 18 08:51:43.689: OSPF: DR/BDR election on FastEthernet0/0
12-18-2008    11:51:44    Local7.Debug    172.16.1.5    416: Dec 18 08:51:43.689: OSPF: Neighbor change Event on interface FastEthernet0/0
12-18-2008    11:51:43    Local7.Notice    172.16.1.5    415: Dec 18 08:51:43.689: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.137.239 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
12-18-2008    11:51:43    Local7.Debug    172.16.1.5    414: Dec 18 08:51:43.689:        DR: 192.168.137.239 (Id)   BDR: none
12-18-2008    11:51:43    Local7.Debug    172.16.1.5    413: Dec 18 08:51:43.689: OSPF: Elect DR 192.168.137.239
12-18-2008    11:51:43    Local7.Debug    172.16.1.5    412: Dec 18 08:51:43.689: OSPF: Elect BDR 0.0.0.0
12-18-2008    11:51:43    Local7.Debug    172.16.1.5    411: Dec 18 08:51:43.689: OSPF: DR/BDR election on FastEthernet0/0
12-18-2008    11:51:43    Local7.Debug    172.16.1.5    410: Dec 18 08:51:43.689: OSPF: Neighbor change Event on interface FastEthernet0/0
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от lumenous (ok) on 18-Дек-08, 13:33 
>[оверквотинг удален]
>12-18-2008 11:51:43 Local7.Debug 172.16.1.5 414: Dec 18 08:51:43.689:    
>   DR: 192.168.137.239 (Id)   BDR: none
>12-18-2008 11:51:43 Local7.Debug 172.16.1.5 413: Dec 18 08:51:43.689: OSPF: Elect DR 192.168.137.239
>
>12-18-2008 11:51:43 Local7.Debug 172.16.1.5 412: Dec 18 08:51:43.689: OSPF: Elect BDR 0.0.0.0
>
>12-18-2008 11:51:43 Local7.Debug 172.16.1.5 411: Dec 18 08:51:43.689: OSPF: DR/BDR election on
>FastEthernet0/0
>12-18-2008 11:51:43 Local7.Debug 172.16.1.5 410: Dec 18 08:51:43.689: OSPF: Neighbor change Event
>on interface FastEthernet0/0

Нуу еще можно попробовать убрать из оспф 192.168.135.0 0.0.0.255 с обоих сторон. Оно там вообще для чего? для какого то другого соединения?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 18-Дек-08, 13:40 
192.168.135.0 это локальная сеть и я засунул её в ospf для доступа из других подсетей

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от abdula888 (ok) on 18-Дек-08, 13:41 

192.168.135.0 это локальная сеть и я засунул её в ospf для доступа из других подсетей


Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

15. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от s on 19-Дек-08, 17:35 
Есть подозрение, что по каналу второго оператора не проходят мультикастные пакеты, которыми оперирует ospf. Если Вы в debug ip ospf event на обоих роутерах видите только отправленные пакеты hello на интерфейс 0/1 и не видите полученных с этого интерфеса, то вышеуказанное предположение верно.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от OlegROY (ok) on 30-Окт-13, 23:23 
>[оверквотинг удален]
>  ip address 192.168.129.239 255.255.255.0
>  no ip proxy-arp
> !
> !
> router ospf 100
>  log-adjacency-changes
>  network 172.16.0.0 0.0.1.255 area 1
>  network 192.168.129.0 0.0.0.255 area 1
>  default-information originate always metric-type 1
> может кто прольёт свет на устранение данной проблемы? буду благодарен

shdsl модем роботает попротоколу АТМ. Потому здесь надо применять NBMA топологию

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "cisco 2811 не отрабатывает ospf"  +/
Сообщение от OlegROY (ok) on 30-Окт-13, 23:24 
>[оверквотинг удален]
>  ip address 192.168.129.239 255.255.255.0
>  no ip proxy-arp
> !
> !
> router ospf 100
>  log-adjacency-changes
>  network 172.16.0.0 0.0.1.255 area 1
>  network 192.168.129.0 0.0.0.255 area 1
>  default-information originate always metric-type 1
> может кто прольёт свет на устранение данной проблемы? буду благодарен

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру