The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Эффективная загрузка по двум неравным путям"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 19-Янв-09, 20:10 
Всем доброго времени суток! Подскажите, пожалуйста, как эффективно загрузить два интерфейса Cisco. Есть маршрутизатор Cisco с serial0/0, serial0/1, serial0/2, fa0/0. На serial0/0 горло 1024 кб/с, за которым 8 сетей. Все они (а еще локалка этого рутера через fa0/0) стремятся качать данные из/в 2 сети, находящихся за serial0/1, serial0/2.  До этих сетей  по OSPF через serial0/1  один hop (у serial0/1  band = 1024 ) . До этих же сетей  по OSPF через serial0/2  два hop'а (у serial0/2  band = 768 ) . Естественно, OSPF выбирает serial0/1, в результате все 8 сетей идут через serial0/1, возникает перегрузка serial0/1, а serial0/2 простаивает. Я хотел часть сетей отправить через serial0/2 статикой в стиле: ip route x.x.x.0 255.255.255.0 serial0/2 , трафик, конечно, направляется, но следующий за serial0/2 маршрутизатор не хочет направлять пакеты дальше и эта сеть остается без связи. Вообще, можно чтобы трафик автоматически добавлялся в serial0/2 только при перегрузке serial0/1 (скажем процентов на 80). Баловался с PBR, но что-то не получилось, тут ведь нужно как бы обмануть OSPF.
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Эффективная загрузка по двум неравным путям"  
Сообщение от avallac email on 20-Янв-09, 10:24 
EIGRP ?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 20-Янв-09, 17:25 
>EIGRP ?

Вся сеть на OSPF, нужно еще EIGRP встраивать. Можно, конечно, попробовать, но на скольких смежных рутерах нужно параллельно поднимать  EIGRP, чтобы попробовать ? (желательно не на всей сети)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 21-Янв-09, 13:52 
>>EIGRP ?
>
>Вся сеть на OSPF, нужно еще EIGRP встраивать. Можно, конечно, попробовать, но
>на скольких смежных рутерах нужно параллельно поднимать  EIGRP, чтобы попробовать
>? (желательно не на всей сети)

"Нормальное" решение врядли получиться, можно только притянутые зауши попробовать реализовать.

например косты роут-мапами попытаться вешать разные на разные подсети; выставить одинаковые косты на интрефейсах с разными скоростями (тут уже советовали); поднять между 2-мя нужными маршрутерами тунели так, чтобы шли они разными маршрутами и рулить траф в тунели статикой, если тунель отвалиться - вместо статики сработает динамика.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 22-Янв-09, 09:26 
>[оверквотинг удален]
>>на скольких смежных рутерах нужно параллельно поднимать  EIGRP, чтобы попробовать
>>? (желательно не на всей сети)
>
>"Нормальное" решение врядли получиться, можно только притянутые зауши попробовать реализовать.
>
>например косты роут-мапами попытаться вешать разные на разные подсети; выставить одинаковые косты
>на интрефейсах с разными скоростями (тут уже советовали); поднять между 2-мя
>нужными маршрутерами тунели так, чтобы шли они разными маршрутами и рулить
>траф в тунели статикой, если тунель отвалиться - вместо статики сработает
>динамика.

Тунели IPSec или какой-то внутри EIGRP ? Выложите, пожалуйста, кусок конфига по совмещению статики и динамики. А если прописать ip route x.x.x.0 255.255.255.0 s0/2 , и далее на остальных рутерах до сети назначения также статикой, то если отвалится s0/2, эта статически прописанная сеть перейдет на s0/1, если ее оставить в процессе OSPF вместе с другими ?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Эффективная загрузка по двум неравным путям"  
Сообщение от Cyrill Malevanov email on 20-Янв-09, 12:21 
>[оверквотинг удален]
>. До этих же сетей  по OSPF через serial0/2  
>два hop'а (у serial0/2  band = 768 ) . Естественно,
>OSPF выбирает serial0/1, в результате все 8 сетей идут через serial0/1,
>возникает перегрузка serial0/1, а serial0/2 простаивает. Я хотел часть сетей отправить
>через serial0/2 статикой в стиле: ip route x.x.x.0 255.255.255.0 serial0/2 ,
>трафик, конечно, направляется, но следующий за serial0/2 маршрутизатор не хочет направлять
>пакеты дальше и эта сеть остается без связи. Вообще, можно чтобы
>трафик автоматически добавлялся в serial0/2 только при перегрузке serial0/1 (скажем процентов
>на 80). Баловался с PBR, но что-то не получилось, тут ведь
>нужно как бы обмануть OSPF.

через ip ospf cost сделать пути равными по стоимости, далее
router ospf 1
  traffic-share min across-interfaces

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 20-Янв-09, 17:22 
>[оверквотинг удален]
>>через serial0/2 статикой в стиле: ip route x.x.x.0 255.255.255.0 serial0/2 ,
>>трафик, конечно, направляется, но следующий за serial0/2 маршрутизатор не хочет направлять
>>пакеты дальше и эта сеть остается без связи. Вообще, можно чтобы
>>трафик автоматически добавлялся в serial0/2 только при перегрузке serial0/1 (скажем процентов
>>на 80). Баловался с PBR, но что-то не получилось, тут ведь
>>нужно как бы обмануть OSPF.
>
>через ip ospf cost сделать пути равными по стоимости, далее
>router ospf 1
>  traffic-share min across-interfaces

Попробовал. Пробовал в момент, когда по s0/1 шел трафик 300кб/с (по s0/2 0 кб/с). Никакого эффекта. Говорят, что когда началась сессия (например TCP) при общении двух хостов, то на cisco на какой интерфейс залетел первый пакет сессии, по тому интерфейсу и идет весь трафик сессии. Как-то бы по простому сделать, направив ,например, 3 сети по s0/2, остальные 5 сетей - по s0/1. Только желательно чтобы при пропадании s0/1, все эти 5 сетей переходили на s0/2. Это надо где-то указать, какие сети куда направлять (access-list). ip route x.x.x.0 255.255.255.0 s0/2 если бы позволял следующему рутеру перенаправлять пакеты в сеть назначения, то этого может быть и достаточно было бы, но следующий рутер гасит этот трафик в себе. traffic-share min across-interfaces  в мануале IOS действительно как-бы позволяет разбивать трафик, но что-то наверно нужно еще сделать.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Capuchino on 20-Янв-09, 12:33 
Давайте попробуем сделать так.
1. R#show ip ospf int s0/1
R#show ip ospf int s0/2
зацениваем параметр cost

By default, the cost of an interface is calculated based on the bandwidth; you can force the cost of an interface with the ip ospf cost <value> interface subconfiguration mode command.

2. Делаем в нерабочее время
R(config)#int s0/2
R(config-if)#ip ospf cost <cost> - значение cost такое же как и на s0/1

3. Зацениваем результаты R#s ip route ospf, при этом сохранив результаты команды до
измения cost на s0/2
Я в лабе у себя сделал, у меня половина маршрутов осталась, половина перешла на другой
serial, при это метрика ест-но поменялась у маршрутов.
  


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 20-Янв-09, 17:17 
>[оверквотинг удален]
>R(config)#int s0/2
>R(config-if)#ip ospf cost <cost> - значение cost такое же как и на s0/1
>
>3. Зацениваем результаты R#s ip route ospf, при этом сохранив результаты команды
>до
>измения cost на s0/2
>Я в лабе у себя сделал, у меня половина маршрутов осталась, половина
>перешла на другой
>serial, при это метрика ест-но поменялась у маршрутов.
>

Попробовал. Пробовал в момент, когда по s0/1 шел трафик 300кб/с (по s0/2 0 кб/с). Никакого эффекта. Говорят, что когда началась сессия (например TCP) при общении двух хостов, то на cisco на какой интерфейс залетел первый пакет сессии, по тому интерфейсу и идет весь трафик сессии. Как-то бы по простому сделать, направив ,например, 3 сети по s0/2, остальные 5 сетей - по s0/1. Только желательно чтобы при пропадании s0/1, все эти 5 сетей переходили на s0/2. Это надо где-то указать, какие сети куда направлять (access-list). ip route x.x.x.0 255.255.255.0 s0/2 если бы позволял следующему рутеру перенаправлять пакеты в сеть назначения, то этого может быть и достаточно было бы, но следующий рутер гасит этот трафик в себе.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Capuchino on 22-Янв-09, 16:40 
>[оверквотинг удален]
>0 кб/с). Никакого эффекта. Говорят, что когда началась сессия (например TCP)
>при общении двух хостов, то на cisco на какой интерфейс залетел
>первый пакет сессии, по тому интерфейсу и идет весь трафик сессии.
>Как-то бы по простому сделать, направив ,например, 3 сети по s0/2,
>остальные 5 сетей - по s0/1. Только желательно чтобы при пропадании
>s0/1, все эти 5 сетей переходили на s0/2. Это надо где-то
>указать, какие сети куда направлять (access-list). ip route x.x.x.0 255.255.255.0 s0/2
>если бы позволял следующему рутеру перенаправлять пакеты в сеть назначения, то
>этого может быть и достаточно было бы, но следующий рутер гасит
>этот трафик в себе.

Не, по простому наверное не получится. Давайте пробовать по сложному, через distribute-list и route-map (в route-map будет ссылка на access-list). Идея такая, в route-mape задать для определённых сетей исходящий интерфейс и метрику лучшую чем показывает show ip route, потом cделать distribute-list route-map NET in
Типа ospf протокол link-state поэтому на всех раутерах база ospf одинаковая.
Давайте попробуем, может заработает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Capuchino on 22-Янв-09, 16:51 
Если по простому, то надо добиться, чтобы метрика была одинаковая у маршрута приходящего с 1-ого и 2-ого интерфейсов. Это и пытались сделать указав cost одинаковой
на серийниках.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 22-Янв-09, 17:12 
RouterA---RouterB--RouterC причем А и С так же соединеннымежду собой, все через seril-ы.
Пришла в голову одна простая мысль:
Если все 3 роутера вам подконтрольны?
по сериалам поднимаете FR-ы
Один DLCI пробрасываете напрямую между А и С, один транзитом с А на С через В, аща один А-В и В-С
на сабинтерфейсах с DLCI A-С и А-В-С ставите одинаковый band...
И вуаля!
трафик между A и C будет равномерно разбрасываться по 2-м DLCI...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 23-Янв-09, 09:05 
Кстати если еще понастраивать на FR-е CIR, EIR то можно добиться более ровной нагрузки на каналы.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 23-Янв-09, 13:38 
>Кстати если еще понастраивать на FR-е CIR, EIR то можно добиться более
>ровной нагрузки на каналы.

А Frame Relay совместно с процессом OSPF хорошо будет жить? Ведь кроме этих сетей , разделенных рутерами есть еще сети (вообще у меня везде OSFP full mesh). Те есть из группы сетей, где работает только OSPF (в том числе PPP-линки на serial-ах включены в OSPF процесс) хосты будут попадать , например, в локалку среднего рутера, который отделен с обеих сторон от "внешнего мира" двуми DLCI?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 23-Янв-09, 13:52 
>>Кстати если еще понастраивать на FR-е CIR, EIR то можно добиться более
>>ровной нагрузки на каналы.
>
>А Frame Relay совместно с процессом OSPF хорошо будет жить? Ведь кроме
>этих сетей , разделенных рутерами есть еще сети (вообще у меня
>везде OSFP full mesh). Те есть из группы сетей, где работает
>только OSPF (в том числе PPP-линки на serial-ах включены в OSPF
>процесс) хосты будут попадать , например, в локалку среднего рутера, который
>отделен с обеих сторон от "внешнего мира" двуми DLCI?

Я понимаю. что OSPF over Frame Relay существует давно, просто как оно работает на практике ? (лично не пробовал).

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 23-Янв-09, 14:11 
>[оверквотинг удален]
>>
>>А Frame Relay совместно с процессом OSPF хорошо будет жить? Ведь кроме
>>этих сетей , разделенных рутерами есть еще сети (вообще у меня
>>везде OSFP full mesh). Те есть из группы сетей, где работает
>>только OSPF (в том числе PPP-линки на serial-ах включены в OSPF
>>процесс) хосты будут попадать , например, в локалку среднего рутера, который
>>отделен с обеих сторон от "внешнего мира" двуми DLCI?
>
>Я понимаю. что OSPF over Frame Relay существует давно, просто как оно
>работает на практике ? (лично не пробовал).

Великолепно работает, у меня ppp вообще нет нигде на сериалах - исключительно FR.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 23-Янв-09, 18:26 
>[оверквотинг удален]
>>>везде OSFP full mesh). Те есть из группы сетей, где работает
>>>только OSPF (в том числе PPP-линки на serial-ах включены в OSPF
>>>процесс) хосты будут попадать , например, в локалку среднего рутера, который
>>>отделен с обеих сторон от "внешнего мира" двуми DLCI?
>>
>>Я понимаю. что OSPF over Frame Relay существует давно, просто как оно
>>работает на практике ? (лично не пробовал).
>
>Великолепно работает, у меня ppp вообще нет нигде на сериалах - исключительно
>FR.

Нужно поднимать FR Traffic Shape в стиле (взято из Configuring Frame Relay)
Traffic Shaping with Three Point-to-Point Subinterfaces Example

In the following example, VCs on subinterfaces Serial0.1 and Serial0.2 inherit class parameters from the main interface—namely, those defined in the map class "slow_vcs"—but the VC defined on subinterface Serial0.2 (DLCI 102) is specifically configured to use map class "fast_vcs".

Map class "slow_vcs" uses a peak rate of 9600 and average rate of 4800 bps. Because BECN feedback is enabled, the output rate will be cut back to as low as 2400 bps in response to received BECNs. This map class is configured to use custom queueing using queue-list 1. In this example, queue-list 1 has 3 queues, with the first two being controlled by access lists 100 and 115.

Map class "fast_vcs" uses a peak rate of 64000 and average rate of 16000 bps. Because BECN feedback is enabled, the output rate will be cut back to as low as 8000 bps in response to received BECNs. This map class is configured to use priority-queueing using priority-group 2.

interface serial0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

frame-relay traffic-shaping

frame-relay class slow_vcs

!

interface serial0.1 point-to-point

ip address 10.128.30.1 255.255.255.248

ip ospf cost 200

bandwidth 10

frame-relay interface-dlci 101

!

interface serial0.2 point-to-point

ip address 10.128.30.9 255.255.255.248

ip ospf cost 400

bandwidth 10

frame-relay interface-dlci 102

  class fast_vcs

!

interface serial0.3 point-to-point

ip address 10.128.30.17 255.255.255.248

ip ospf cost 200

bandwidth 10  <-  НЕ ПОНЯЛ

frame-relay interface-dlci 103

!

map-class frame-relay slow_vcs

frame-relay traffic-rate 4800 9600

frame-relay custom-queue-list 1

frame-relay adaptive-shaping becn

!

map-class frame-relay fast_vcs

frame-relay traffic-rate 16000 64000

frame-relay priority-group 2

frame-relay adaptive-shaping becn

!

access-list 100 permit tcp any any eq 2065

access-list 115 permit tcp any any eq 256

!

priority-list 2 protocol decnet high

priority-list 2 ip normal

priority-list 2 default medium

!

queue-list 1 protocol ip 1 list 100

queue-list 1 protocol ip 2 list 115

queue-list 1 default 3

queue-list 1 queue 1 byte-count 1600 limit 200

queue-list 1 queue 2 byte-count 600 limit 200

queue-list 1 queue 3 byte-count 500 limit 200

bandwidth 10  <-  НЕ ПОНЯЛ

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 24-Янв-09, 11:31 
>[оверквотинг удален]
>
>queue-list 1 queue 1 byte-count 1600 limit 200
>
>queue-list 1 queue 2 byte-count 600 limit 200
>
>queue-list 1 queue 3 byte-count 500 limit 200
>
>
>
> bandwidth 10  <-  НЕ ПОНЯЛ

незнаю для чего он там нужен в этом примере, в вашем варианте для начала шейпинг можно вообще не трогать.
Посмотрите по нагрузке - перегрузке, если будут серь езные затыки - тада стоит с шейпингом поиграться.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 27-Янв-09, 18:01 
>[оверквотинг удален]
>>queue-list 1 queue 3 byte-count 500 limit 200
>>
>>
>>
>> bandwidth 10  <-  НЕ ПОНЯЛ
>
>незнаю для чего он там нужен в этом примере, в вашем варианте
>для начала шейпинг можно вообще не трогать.
>Посмотрите по нагрузке - перегрузке, если будут серь езные затыки - тада
>стоит с шейпингом поиграться.

Давно не возился с FR. Просто повязать два сериала между RouterC и RouterB не получается. Чего-то наверно недописал:


RouterC#sh run int s0/0/0:1
Building configuration...

Current configuration : 223 bytes
!
interface Serial0/0/0:1
bandwidth 2048
ip address 192.168.0.65 255.255.255.252
encapsulation frame-relay
keepalive 1
frame-relay map bridge 43 broadcast
frame-relay map bridge 44
frame-relay interface-dlci 43
end


RouterC#sh int s0/0/0:1
Serial0/0/0:1 is up, line protocol is down
  Hardware is GT96K Serial
  Internet address is 192.168.0.65/30
  MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (1 sec)
  LMI enq sent  1558, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
  LMI enq recvd 2297, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:55:23
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1536 kilobits/sec
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 1 packets/sec
     2310 packets input, 30417 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     2089 packets output, 27420 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 output buffer failures, 0 output buffers swapped out
     2 carrier transitions
  Timeslot(s) Used: UNFRAMED, SCC: 0, Transmitter delay is 0 flags


RouterB#sh run int s0
Building configuration...

Current configuration : 249 bytes
!
interface Serial0
bandwidth 2048
ip address 192.168.0.66 255.255.255.252
encapsulation frame-relay
no ip mroute-cache
keepalive 1
fair-queue
frame-relay map bridge 44 broadcast
frame-relay map bridge 43
frame-relay interface-dlci 44
end


RouterB#sh int s0
Serial0 is up, line protocol is down (looped)
  Hardware is HD64570
  Internet address is 192.168.0.66/30
  MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (1 sec)
  LMI enq sent  1463, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
  LMI enq recvd 1971, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:35:20
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1536 kilobits/sec
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1972 packets input, 25883 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     2200 packets output, 28845 bytes, 0 underruns
     0 output errors, 0 collisions, 71 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 28-Янв-09, 12:43 
>[оверквотинг удален]
>0 overrun, 0 ignored, 0 abort
>     2200 packets output, 28845 bytes, 0 underruns
>
>     0 output errors, 0 collisions, 71 interface
>resets
>     0 output buffer failures, 0 output buffers
>swapped out
>     0 carrier transitions
>     DCD=up  DSR=up  DTR=up  RTS=up
> CTS=up

Давай попроще:
RouterC
interface Serial0/0/0:1
encapsulation frame-relay
frame-relay lmi-type q933a
frame-relay intf-type dce
interface Serial0/0/0:1.1 point-to-point
ip address 192.168.0.65 255.255.255.252
bandwidth 2048
frame-relay interface-dlci 43

RouterB
interface Serial0
bandwidth 2048  
encapsulation frame-relay
frame-relay lmi-type q933a
frame-relay intf-type dte
interface Serial0.1 point-to-point
frame-relay interface-dlci 43
bandwidth 2048
ip address 192.168.0.66 255.255.255.252

Если 43 DLCI нада прогнать транзитом через роутер A
RouterA
interface Serial0
desc To_B
encapsulation frame-relay
frame-relay lmi-type q933a
frame-relay intf-type dce
frame-relay interface-dlci 43 switched

interface Serial1
desc To_C
encapsulation frame-relay
frame-relay lmi-type q933a
frame-relay intf-type dte
frame-relay interface-dlci 43 switched

connected B-C Serial0 43 Serial1 43

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 28-Янв-09, 12:45 

frame-relay switching
Не забыть.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 28-Янв-09, 17:33 
>
>frame-relay switching
>Не забыть.

Собрал на столе схему: RouterA-RouterB-RouterC в цепочку, плюс RouterA-RouterС на прямую. RouterA-RouterС DLCI 43 connect через RouterB.
DLCI 44,DLCI 45,DLCI 46 - все между собой. К RouterA fa0/0  - комп со своей сетью, к RouterA fa0/1  - комп со своей сетью, к RouterB,C -тоже (компы = локалки).
Конфиги ниже. Проверял загруженность каналов длинным пингом с RouterA fa0/0,RouterA fa0/1 на комп RouterС (надеясь, что пинг с этих двух компов
пойдет своим путем или равномерно распределится трафик). Хотя везде band 2048 , все равно идет только напрямую на комп RouterС (загрузка через DLCI 43 = 0), хотя в sh ip route показывает два пути. Может мультилинк сделать из DLCI 43, DLCI 44 ?
Только тут два вопроса:
1) Не разу на делал мультилинк на FR, только на PPP
2) через DLCI 43 пакеты пойдут медленнее, процесс уровня приложений, который качает трафик, неизвестно, будет ли корректно собирать пакеты на
хосте-приемнике (тем более если в разрез DLCI 43 кроме RouterB стояли бы еще маршрутизаторы)
Кстати, в конфиге RouterA остатки route-map, который тоже не получился.

RouterA#sh run
Building configuration...

Current configuration : 3358 bytes
!
version 12.3
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname RouterA
!
boot-start-marker
boot-end-marker
!
logging count
logging buffered 10240 debugging
!
username test privilege 15 secret 5 $1$Mxzv$nZ0cTvj8CjZ5rzzzEhxPT.
memory-size iomem 15
clock timezone ESK 5
clock summer-time ESD recurring last Sun Mar 2:00 last Sun Oct 3:00
no network-clock-participate slot 1
no network-clock-participate wic 0
no network-clock-participate wic 1
no aaa new-model
ip subnet-zero
ip cef
!
!
ip tcp path-mtu-discovery
ip dhcp excluded-address 10.40.18.1 10.40.18.100
ip dhcp excluded-address 10.40.20.1 10.40.20.100
ip dhcp smart-relay
!
ip dhcp pool Pool18
   network 10.40.18.0 255.255.255.0
   default-router 10.40.18.1
!
ip dhcp pool Pool20
   network 10.40.20.0 255.255.255.0
   default-router 10.40.20.1
!
frame-relay switching
no ftp-server write-enable
!
!
!
controller E1 0/0
clock source internal
channel-group 1 unframed
!
controller E1 0/1
clock source internal
channel-group 2 unframed
!
controller E1 0/2
!
controller E1 0/3
!
!
interface Loopback0
ip address 192.168.254.100 255.255.255.255
!
interface FastEthernet0/0
ip address 10.40.18.1 255.255.255.0
load-interval 30
duplex auto
speed auto
!
interface Serial0/0:1
bandwidth 2048
no ip address
ip accounting output-packets
encapsulation frame-relay
load-interval 30
invert txclock
frame-relay lmi-type q933a
!
interface Serial0/0:1.1 point-to-point
bandwidth 2048
ip address 192.168.0.66 255.255.255.252
frame-relay interface-dlci 43  
!
interface Serial0/0:1.2 point-to-point
bandwidth 2048
ip address 192.168.0.122 255.255.255.252
frame-relay interface-dlci 45  
!
interface FastEthernet0/1
ip address 10.40.20.1 255.255.255.0
load-interval 30
duplex auto
speed auto
!
interface Serial0/1:2
bandwidth 2048
no ip address
ip accounting output-packets
encapsulation frame-relay
load-interval 30
invert txclock
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial0/1:2.1 point-to-point
bandwidth 2048
ip address 192.168.0.106 255.255.255.252
frame-relay interface-dlci 44  
!
!
router ospf 100
log-adjacency-changes
redistribute connected
redistribute static subnets
network 10.40.18.0 0.0.0.255 area 0
network 10.40.20.0 0.0.0.255 area 0
network 192.168.0.64 0.0.0.3 area 0
network 192.168.0.104 0.0.0.3 area 0
network 192.168.0.120 0.0.0.3 area 0
network 192.168.254.100 0.0.0.0 area 0
!
ip classless
ip http server
ip http authentication local
!
access-list 1 permit 10.40.18.0 0.0.0.255
access-list 2 permit 10.40.20.0 0.0.0.255
route-map equal-access permit 10
match ip address 1
set ip default next-hop 192.168.0.121
!
route-map equal-access permit 20
match ip address 2
set ip default next-hop 192.168.0.105
!
route-map equal-access permit 30
set default interface Null0
!
!
line con 0
logging synchronous
login local
line aux 0
logging synchronous
login local
line vty 0 4
logging synchronous
login local
!
end

RouterA#exit


version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RouterB
!
logging buffered 10240 debugging
!
username test privilege 15 password 7 09584B1A0D1112011F1801393F
clock timezone ESK 5
clock summer-time ESD recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip tcp path-mtu-discovery
ip dhcp database Pool19
ip dhcp excluded-address 10.40.19.1 10.40.19.100
ip dhcp smart-relay
!
ip dhcp pool Pool19
   network 10.40.19.0 255.255.255.0
   default-router 10.40.19.1
!
ip cef
frame-relay switching
!
interface Loopback0
ip address 192.168.254.19 255.255.255.255
!
interface Serial0
bandwidth 2048
no ip address
encapsulation frame-relay
no ip mroute-cache
no keepalive
fair-queue
frame-relay interface-dlci 43 switched
!
interface Serial0.1 point-to-point
bandwidth 2048
ip address 192.168.0.70 255.255.255.252
frame-relay interface-dlci 46  
!
interface Serial1
bandwidth 2048
no ip address
encapsulation frame-relay
no ip mroute-cache
load-interval 30
invert txclock
frame-relay interface-dlci 43 switched
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial1.1 point-to-point
bandwidth 2048
ip address 192.168.0.121 255.255.255.252
frame-relay interface-dlci 45  
!

interface FastEthernet0
ip address 10.40.19.1 255.255.255.0
ip accounting output-packets
full-duplex
!
!
router ospf 100
log-adjacency-changes
redistribute connected
redistribute static subnets
network 10.40.19.0 0.0.0.255 area 0
network 192.168.0.68 0.0.0.3 area 0
network 192.168.0.120 0.0.0.3 area 0
network 192.168.254.19 0.0.0.0 area 0
!
ip classless
no ip http server
ip http authentication local
!
!
connect A-C Serial0 43 Serial1 43
!
!
!
line con 0
logging synchronous
login local
line aux 0
line vty 0 4
logging synchronous
login local
!
end

RouterB#    exit

version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname RouterC
!
boot-start-marker
boot-end-marker
!
logging count
logging buffered 10240 debugging
no logging rate-limit
!
no aaa new-model
!
resource policy
!
clock timezone ESK 5
clock summer-time ESD recurring last Sun Mar 2:00 last Sun Oct 3:00
no network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
ip dhcp smart-relay
no ip dhcp use vrf connected
ip dhcp excluded-address 10.40.13.1 10.40.13.100
!
ip dhcp pool Pool13
   network 10.40.13.0 255.255.255.0
   default-router 10.40.13.1
!
!
no ip ftp passive
frame-relay switching
!
username test privilege 15 secret 5 $1$wBek$hBU0Ow2fuuVgCwfj5tax60
!
!
controller E1 0/0/0
channel-group 1 unframed
!
controller E1 0/0/1
clock source internal
channel-group 2 unframed
!
class-map match-all important_traffic
match access-group 100
!
!
policy-map QoS
class important_traffic
  bandwidth percent 70
class class-default
  fair-queue
!
!
!
interface Loopback0
ip address 192.168.254.250 255.255.255.255
!
interface FastEthernet0/0
ip address 10.40.13.1 255.255.255.0
ip accounting output-packets
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:1
bandwidth 2048
no ip address
encapsulation frame-relay
no keepalive
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial0/0/0:1.1 point-to-point
bandwidth 2048
ip address 192.168.0.65 255.255.255.252
frame-relay interface-dlci 43  
!
interface Serial0/0/0:1.2 point-to-point
bandwidth 2048
ip address 192.168.0.69 255.255.255.252
frame-relay interface-dlci 46  
!
interface Serial0/0/1:2
bandwidth 2048
no ip address
encapsulation frame-relay
load-interval 30
frame-relay lmi-type q933a
!
interface Serial0/0/1:2.1 point-to-point
bandwidth 2048
ip address 192.168.0.105 255.255.255.252
frame-relay interface-dlci 44  
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.40.13.0 0.0.0.255 area 0
network 192.168.0.64 0.0.0.3 area 0
network 192.168.0.68 0.0.0.3 area 0
network 192.168.0.104 0.0.0.3 area 0
network 192.168.254.250 0.0.0.0 area 0
!
ip classless
!
ip http server
!
!
control-plane
!
!
line con 0
logging synchronous
login local
line aux 0
line vty 0 4
logging synchronous
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end

RouterC#exit

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 29-Янв-09, 10:06 
>[оверквотинг удален]
>line vty 0 4
> logging synchronous
> login local
> transport input telnet
>!
>scheduler allocate 20000 1000
>!
> end
>
>RouterC#exit

Чтобы получить попакетную балансировку надо cef отключить.
Таким тестом врядли что-то удидите, одна сессия попадет в один канал, балансировка будет наблюдаться при достаточно большом количестве сессий.

Мультилинк на FR-е поднимал только между 2-мя соседними маршрутерами, незнаю можно ли 2 dlci обьединить в мультилинк.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 29-Янв-09, 10:15 
Поповоду сборки пакетов - пакеты могут приходить не в том порядке, в котором были отправлены - это да, но tcp к этому приспособлен.
Кроме того при некритичной нагрузке на каналы - разница в задержке крайне мала, в чем собственно и прелесть FR-а - транзитные FR свичи при коммутации FR кадров практически не вносят задержек - попробуйте погасить поочереди DLCI 43 и 44 и сравните задержку :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 30-Янв-09, 14:23 
Ну как? получилось что-нить или нет?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 30-Янв-09, 16:08 
>Ну как? получилось что-нить или нет?

Поднял ip load-sharing per-packet (совместно с ip cef) на обоих концах RouterA, RouterC. Нагрузка равномерно распределилась по обоим DLCI 43,44. Т.е. это балансировка OSPF per-packet, когда в таблице маршрутизации до одной сети - два маршрута с равными метриками.  Cisco тогда кидает поочередно пакеты то в один интерфес, то в другой.  Проверял, перекачивая папку 70Мб с помощью NetOp File Tranfer. Получилось по функциональности как мультилинк, причем папка перекачивается ровно в два раза быстрее, чем через один линк. Включить subinterfaces в реальный non-distributed мультилинк-bundle Cisco не дает (и в мануале также). Сейчас сделаю горло на одном из этих двух линков в 1,5 раза меньше (сделаю не unframed, а timeclots 1-20 например), и посмотрю, будут ли в нем теряться пакеты и перекачается ли папка (так как на реальной системе физически линки отличаются по полосе).
Если будут теряться - вопрос далек от окончательного решения.
Per-destination рекомендуется, когда пакеты идут очень отличающимися путями (что у меня наверно в реальности и будет и как применять эту per-destination - еще не знаю).
О результатах напишу. Конфиги и show ниже.
Наверно, тоже (ip load-sharing per-packet) получилось бы без FR, но удобство FR очевидно в плане обслуживания виртульных линков и присвоения им band для OSPF. Вообще, возникает желание сделать на сети FR full-mesh, но:
1)Сколько можно пропустить (switched) DLCI через один физический порт (в среднем E1-порт)?
2)При создании FR позиционировалось как соединение без коррекции ошибок(notification не в счет). Хотя, если в кабеле ошибки - и PPP не поможет.
3)Что, если destination еще дальше за RouterC,а там везде PPP ? (хотя это не должно влиять)


RouterA#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 4 subnets
O       10.40.13.0 [110/49] via 192.168.0.105, 03:17:04, Serial0/1:2.1
C       10.40.18.0 is directly connected, FastEthernet0/0
O       10.40.19.0 [110/49] via 192.168.0.121, 03:17:04, Serial0/0:1.2
C       10.40.20.0 is directly connected, FastEthernet0/1
     192.168.0.0/30 is subnetted, 4 subnets
C       192.168.0.104 is directly connected, Serial0/1:2.1
C       192.168.0.120 is directly connected, Serial0/0:1.2
O       192.168.0.64 [110/96] via 192.168.0.105, 03:17:04, Serial0/1:2.1
O       192.168.0.68 [110/96] via 192.168.0.121, 03:17:04, Serial0/0:1.2
                     [110/96] via 192.168.0.105, 03:17:04, Serial0/1:2.1
     192.168.254.0/32 is subnetted, 3 subnets
O       192.168.254.250 [110/49] via 192.168.0.105, 03:17:04, Serial0/1:2.1
        192.168.254.19 [110/49] via 192.168.0.121, 03:17:04, Serial0/0:1.2
C       192.168.254.100 is directly connected, Loopback0
RouterA# exit


RouterC#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 4 subnets
C       10.40.13.0 is directly connected, FastEthernet0/0
O       10.40.18.0 [110/49] via 192.168.0.106, 03:16:21, Serial0/0/1:2.1
O       10.40.19.0 [110/49] via 192.168.0.70, 03:16:21, Serial0/0/0:1.2
O       10.40.20.0 [110/49] via 192.168.0.106, 03:16:21, Serial0/0/1:2.1
     192.168.0.0/30 is subnetted, 4 subnets
C       192.168.0.104 is directly connected, Serial0/0/1:2.1
O       192.168.0.120 [110/96] via 192.168.0.106, 03:16:21, Serial0/0/1:2.1
                      [110/96] via 192.168.0.70, 03:16:22, Serial0/0/0:1.2
C       192.168.0.64 is directly connected, Serial0/0/0:1.1
C       192.168.0.68 is directly connected, Serial0/0/0:1.2
     192.168.254.0/32 is subnetted, 3 subnets
C       192.168.254.250 is directly connected, Loopback0
O       192.168.254.19 [110/49] via 192.168.0.70, 03:16:23, Serial0/0/0:1.2
O       192.168.254.100 [110/49] via 192.168.0.106, 03:16:23, Serial0/0/1:2.1
RouterC#exit


RouterA#sh run
Building configuration...

Current configuration : 3595 bytes
!
version 12.3
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname RouterA
!
boot-start-marker
boot-end-marker
!
logging count
logging buffered 10240 debugging
!
username test privilege 15 secret 5 $1$Mxzv$nZ0cTvj8CjZ5rzzzEhxPT.
memory-size iomem 15
clock timezone ESK 5
clock summer-time ESD recurring last Sun Mar 2:00 last Sun Oct 3:00
no network-clock-participate slot 1
no network-clock-participate wic 0
no network-clock-participate wic 1
no aaa new-model
ip subnet-zero
ip cef
!
!
ip tcp path-mtu-discovery
ip dhcp excluded-address 10.40.18.1 10.40.18.100
ip dhcp excluded-address 10.40.20.1 10.40.20.100
ip dhcp smart-relay
!
ip dhcp pool Pool18
   network 10.40.18.0 255.255.255.0
   default-router 10.40.18.1
!
ip dhcp pool Pool20
   network 10.40.20.0 255.255.255.0
   default-router 10.40.20.1
!
frame-relay switching
no ftp-server write-enable
!
!
!
controller E1 0/0
clock source internal
channel-group 1 unframed
!
controller E1 0/1
clock source internal
channel-group 2 unframed
!
controller E1 0/2
!
controller E1 0/3
!
!
interface Loopback0
ip address 192.168.254.100 255.255.255.255
!
interface FastEthernet0/0
ip address 10.40.18.1 255.255.255.0
ip accounting output-packets
load-interval 30
duplex auto
speed auto
!
interface Serial0/0:1
bandwidth 2048
no ip address
ip accounting output-packets
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
load-interval 30
invert txclock
frame-relay lmi-type q933a
!
interface Serial0/0:1.1 point-to-point
bandwidth 2048
ip address 192.168.0.66 255.255.255.252
ip load-sharing per-packet
no ip route-cache
shutdown
frame-relay interface-dlci 43  
!
interface Serial0/0:1.2 point-to-point
bandwidth 2048
ip address 192.168.0.122 255.255.255.252
no ip route-cache
frame-relay interface-dlci 45  
!
interface FastEthernet0/1
ip address 10.40.20.1 255.255.255.0
load-interval 30
duplex auto
speed auto
!
interface Serial0/1:2
bandwidth 2048
no ip address
ip accounting output-packets
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
load-interval 30
invert txclock
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial0/1:2.1 point-to-point
bandwidth 2048
ip address 192.168.0.106 255.255.255.252
ip load-sharing per-packet
no ip route-cache
frame-relay interface-dlci 44  
!
interface Serial1/0
no ip address
shutdown
clockrate 2000000
!
interface Serial1/1
no ip address
shutdown
clockrate 2000000
!
interface Serial2/0
no ip address
shutdown
!
interface Serial2/1
no ip address
shutdown
!
interface Serial2/2
no ip address
shutdown
!
interface Serial2/3
no ip address
shutdown
!
router ospf 100
log-adjacency-changes
redistribute connected
redistribute static subnets
network 10.40.18.0 0.0.0.255 area 0
network 10.40.20.0 0.0.0.255 area 0
network 192.168.0.64 0.0.0.3 area 0
network 192.168.0.104 0.0.0.3 area 0
network 192.168.0.120 0.0.0.3 area 0
network 192.168.254.100 0.0.0.0 area 0
!
ip classless
ip http server
ip http authentication local
!
access-list 1 permit 10.40.18.0 0.0.0.255
access-list 2 permit 10.40.20.0 0.0.0.255
route-map equal-access permit 10
match ip address 1
set ip default next-hop 192.168.0.121
!
route-map equal-access permit 20
match ip address 2
set ip default next-hop 192.168.0.105
!
route-map equal-access permit 30
set default interface Null0
!
!
line con 0
logging synchronous
login local
line aux 0
logging synchronous
login local
line vty 0 4
logging synchronous
login local
!
end

RouterA# exit

RouterB#sh run
Building configuration...

Current configuration : 2612 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RouterB
!
logging buffered 10240 debugging
!
username test privilege 15 password 7 09584B1A0D1112011F1801393F
clock timezone ESK 5
clock summer-time ESD recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip tcp path-mtu-discovery
ip dhcp database Pool19
ip dhcp excluded-address 10.40.19.1 10.40.19.100
ip dhcp smart-relay
!
ip dhcp pool Pool19
   network 10.40.19.0 255.255.255.0
   default-router 10.40.19.1
!
frame-relay switching
!
!
!
!
interface Loopback0
ip address 192.168.254.19 255.255.255.255
!
interface Serial0
bandwidth 2048
no ip address
encapsulation frame-relay
no ip mroute-cache
load-interval 30
no keepalive
fair-queue
frame-relay interface-dlci 43 switched
!
interface Serial0.1 point-to-point
bandwidth 2048
ip address 192.168.0.70 255.255.255.252
frame-relay interface-dlci 46  
!
interface Serial1
bandwidth 2048
no ip address
encapsulation frame-relay
no ip mroute-cache
load-interval 30
invert txclock
frame-relay interface-dlci 43 switched
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial1.1 point-to-point
bandwidth 2048
ip address 192.168.0.121 255.255.255.252
frame-relay interface-dlci 45  
!
interface Serial2
no ip address
shutdown
!


!
interface FastEthernet0
ip address 10.40.19.1 255.255.255.0
ip accounting output-packets
full-duplex
!
!
router ospf 100
log-adjacency-changes
redistribute connected
redistribute static subnets
network 10.40.19.0 0.0.0.255 area 0
network 192.168.0.68 0.0.0.3 area 0
network 192.168.0.120 0.0.0.3 area 0
network 192.168.254.19 0.0.0.0 area 0
!
ip classless
no ip http server
ip http authentication local
!
!
!
!
!
!
!
!
!
connect A-C Serial0 43 Serial1 43
!
!
!
!
line con 0
logging synchronous
login local
line aux 0
line vty 0 4
logging synchronous
login local
!
end

RouterB#exit


RouterC#sh run
Building configuration...

Current configuration : 2726 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname RouterC
!
boot-start-marker
boot-end-marker
!
logging count
logging buffered 10240 debugging
no logging rate-limit
!
no aaa new-model
!
resource policy
!
clock timezone ESK 5
clock summer-time ESD recurring last Sun Mar 2:00 last Sun Oct 3:00
no network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
ip dhcp smart-relay
no ip dhcp use vrf connected
ip dhcp excluded-address 10.40.13.1 10.40.13.100
!
ip dhcp pool Pool13
   network 10.40.13.0 255.255.255.0
   default-router 10.40.13.1
!
!
no ip ftp passive
frame-relay switching
!
username test privilege 15 secret 5 $1$wBek$hBU0Ow2fuuVgCwfj5tax60
!
!
controller E1 0/0/0
channel-group 1 unframed
!
controller E1 0/0/1
clock source internal
channel-group 2 unframed
!
class-map match-all important_traffic
match access-group 100
!
!
policy-map QoS
class important_traffic
  bandwidth percent 70
class class-default
  fair-queue
!
!
!
interface Loopback0
ip address 192.168.254.250 255.255.255.255
!
interface FastEthernet0/0
ip address 10.40.13.1 255.255.255.0
ip accounting output-packets
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:1
bandwidth 2048
no ip address
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
load-interval 30
no keepalive
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial0/0/0:1.1 point-to-point
bandwidth 2048
ip address 192.168.0.65 255.255.255.252
ip load-sharing per-packet
no ip route-cache
frame-relay interface-dlci 43  
!
interface Serial0/0/0:1.2 point-to-point
bandwidth 2048
ip address 192.168.0.69 255.255.255.252
no ip route-cache
frame-relay interface-dlci 46  
!
interface Serial0/0/1:2
bandwidth 2048
no ip address
encapsulation frame-relay
no ip route-cache cef
no ip route-cache
load-interval 30
frame-relay lmi-type q933a
!
interface Serial0/0/1:2.1 point-to-point
bandwidth 2048
ip address 192.168.0.105 255.255.255.252
ip load-sharing per-packet
no ip route-cache
frame-relay interface-dlci 44  
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.40.13.0 0.0.0.255 area 0
network 192.168.0.64 0.0.0.3 area 0
network 192.168.0.68 0.0.0.3 area 0
network 192.168.0.104 0.0.0.3 area 0
network 192.168.254.250 0.0.0.0 area 0
!
ip classless
!
ip http server
!
!
control-plane
!
!
line con 0
logging synchronous
login local
line aux 0
line vty 0 4
logging synchronous
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end

RouterC#   exit

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 30-Янв-09, 17:29 
>.... Сейчас сделаю горло на одном из этих двух линков
>в 1,5 раза меньше (сделаю не unframed, а timeclots 1-20 например),
>и посмотрю, будут ли в нем теряться пакеты и перекачается ли
>папка (так как на реальной системе физически линки отличаются по полосе).

вот тут уже можно с трафик шейпингом на FR-ах поиграться, CIR, EIR и т.д.


>
>Если будут теряться - вопрос далек от окончательного решения.
>Per-destination рекомендуется, когда пакеты идут очень отличающимися путями (что у меня наверно
>в реальности и будет и как применять эту per-destination - еще
>не знаю).
>О результатах напишу. Конфиги и show ниже.
>Наверно, тоже (ip load-sharing per-packet) получилось бы без FR, но удобство FR
>очевидно в плане обслуживания виртульных линков и присвоения им band для
>OSPF. Вообще, возникает желание сделать на сети FR full-mesh, но:
>1)Сколько можно пропустить (switched) DLCI через один физический порт (в среднем E1-порт)?

Пока DLCI не закончаться :)
В реалиях 50 шт работало без проблем.

>
>2)При создании FR позиционировалось как соединение без коррекции ошибок(notification не в счет).

TCP/IP с этим должен справиться.

>Хотя, если в кабеле ошибки - и PPP не поможет.
>3)Что, если destination еще дальше за RouterC,а там везде PPP ? (хотя
>это не должно влиять)

Опятьже - IP трафику неположено знать поверх чего он бегает.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 31-Янв-09, 17:33 
>[оверквотинг удален]
>>
>>2)При создании FR позиционировалось как соединение без коррекции ошибок(notification не в счет).
>
>TCP/IP с этим должен справиться.
>
>>Хотя, если в кабеле ошибки - и PPP не поможет.
>>3)Что, если destination еще дальше за RouterC,а там везде PPP ? (хотя
>>это не должно влиять)
>
>Опятьже - IP трафику неположено знать поверх чего он бегает.

Сделал на DLCI 44 физически полосу 14 таймслотов (channel-group 2 timeslots 1-14), т.е. 896 кб/с. Папка перекачивается без ошибки, но скорость по обоим физическим интерфейсам, по которым идут DLCI 43,44 равна 896 кб/с, а хотелось бы, чтобы по одному интерфейсу шло 2048 кб/с, а по второму - 896 кб/с. Т.е. интерфейс с более широким горлом остается недогруженным. Cisco так, наверно, распределяет, потому что видит в своем конфиге channel-group 2 timeslots 1-14. А в реальности более узкое горло сформировано физически не на Cisco. Тогда она наверно будет пихать в оба интерфейса со скоростью 2048 кб/с и в более узком будут отбросы пакетов. Наверно, надо настроить еще ограничение скорости на более узком интерфейсе в стиле CIR (знать бы еще как).
Еще вопросы возникли:
1) Что значит - "Пока DLCI не закончаться". В смыле IP-адреса точка-точка с маской 255.255.255.252 или есть другие ограничения на кол-во DLCI ?
2) Band на подинтерфейсах DLCI - для метрики OSPF или это как-то влияет на реальную полосу пропускания (учитывая, что FR - протокол канального уровня) и все-таки можно было обойтись им одним без применения OSPF  per-packet balance ?
3) Если пропущено много DLCI в одном физическом интерфейсе то, когда хосты качают данные, каждая сессия стремится забрать под себя полосу пропускания по нарастающей, вплоть до исчерпания физики. Значит надо настраивать ограничения на каждый транзитный DLCI на его концах в стиле деления физической полосы транзитных интерфейсов на кол-во DLCI. Так и до модемной скорости упадет. Или я чего-то не понимаю ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

28. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 02-Фев-09, 10:36 
>[оверквотинг удален]
>2) Band на подинтерфейсах DLCI - для метрики OSPF или это как-то
>влияет на реальную полосу пропускания (учитывая, что FR - протокол канального
>уровня) и все-таки можно было обойтись им одним без применения OSPF
> per-packet balance ?
>3) Если пропущено много DLCI в одном физическом интерфейсе то, когда хосты
>качают данные, каждая сессия стремится забрать под себя полосу пропускания по
>нарастающей, вплоть до исчерпания физики. Значит надо настраивать ограничения на каждый
>транзитный DLCI на его концах в стиле деления физической полосы транзитных
>интерфейсов на кол-во DLCI. Так и до модемной скорости упадет. Или
>я чего-то не понимаю ?

Читаете теорию по FR-у, там много описано :)
А "на пальцах" - CIR - "гарантированная" скорость - FR свич пытается обеспечить ее любыми средствами, EIR- "негарантированая", максимально допустимая - CIR + EIR, если канал на данный момент имеет емкость CIR + EIR - абонент получит всю полосу, если канал становится подгруженым, конечным точкам посылается сообщение о необходимости снизить скорость передачи, скорость падает за счет EIR-а, при этом все работает довольно четко и потери именно по каналам практически не наблюдаются, при интенсивной нагрузке - только на крайних точках на входе трафика.

Для нормальной нарезки скоростей на FR-е достаточно ее настроить в одном месте, например на одном транзитном узле.

Для включение шейпера на интерфейсе
frame-relay traffic-shaping

пример Применения:
frame-relay interface-dlci 43 sw
   class B128K

map-class frame-relay B128K
frame-relay traffic-rate 128000 192000

Если память мне не изменяет:
128000 - CIR
192000 - CIR+EIR

Мой опыт - нормальная балансировка на неравноценных каналах получилась только при достаточно большом количестве tcp сессий (примерно 20-25 сессий) и выключенной попакетной балансировке. Конечно ОДИН пользователь в ОДНУ закачку ВСЮ  скорость не получает, но это даже ничего - другие попадают в другой канал и работают вполне комфортно, по крайней мере половина из них :)

Количество DLCI
frame-relay interface-dlci ?
  <16-1007>  Define a switched or locally terminated DLCI
несколько (не более 10 штук) из них служебные, и использовать их нельзя - но вот какие уже точно непомню, надо доку смотреть :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от Serg_777 (ok) on 02-Фев-09, 11:36 
>[оверквотинг удален]
>Конечно ОДИН пользователь в ОДНУ закачку ВСЮ  скорость не получает,
>но это даже ничего - другие попадают в другой канал и
>работают вполне комфортно, по крайней мере половина из них :)
>
>Количество DLCI
>frame-relay interface-dlci ?
>  <16-1007>  Define a switched or locally terminated DLCI
>несколько (не более 10 штук) из них служебные, и использовать их нельзя
>- но вот какие уже точно непомню, надо доку смотреть :)
>

Вообщем, попробовал на реальной системе - в целом в таком варианте пока удовлетворяет. Думаю, вопрос наверно можно считать закрытым. Возникнет ли необходимость в дополнительных настройках - покажет время. В любом случае это уже другая тема. Большое спасибо!!!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

30. "Re: Эффективная загрузка по двум неравным путям"  
Сообщение от fantom email(ok) on 02-Фев-09, 14:07 
>[оверквотинг удален]
>>frame-relay interface-dlci ?
>>  <16-1007>  Define a switched or locally terminated DLCI
>>несколько (не более 10 штук) из них служебные, и использовать их нельзя
>>- но вот какие уже точно непомню, надо доку смотреть :)
>>
>
>Вообщем, попробовал на реальной системе - в целом в таком варианте пока
>удовлетворяет. Думаю, вопрос наверно можно считать закрытым. Возникнет ли необходимость в
>дополнительных настройках - покажет время. В любом случае это уже другая
>тема. Большое спасибо!!!

Та нема за что :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру