The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 1721 wic-4esw. Помогите новичку"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от Zaec email(ok) on 19-Фев-09, 14:52 
Здравствуйте уважаемые знатоки!
Есть ADSL модем Callisto 821+ подключенный к интернету и настроенный роутером (ip 192.168.1.1),  есть cisco 1721 wic-4esw. Необходимо реализовать следующую схему: ADSL модем подключить к FastEthernet0 и раздавать интернет на порты FastEthernet 1-4. Подскажите, пожалуйста, как правильно настроить маршрутизатор, если есть возможность с примером configa.
Заранее благодарен!
Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от visaversa (??) on 20-Фев-09, 19:24 
Во-первых тебе надо прописать на интерфейсе Fas0 ip адрес. Если он динамический то напиши ip address dhcp
Во вторых пробрось простой nat

Прочитать можно например здесь
http://www.opennet.ru/base/cisco/ios_nat.txt.html


>Здравствуйте уважаемые знатоки!
>Есть ADSL модем Callisto 821+ подключенный к интернету и настроенный роутером (ip
>192.168.1.1),  есть cisco 1721 wic-4esw. Необходимо реализовать следующую схему: ADSL
>модем подключить к FastEthernet0 и раздавать интернет на порты FastEthernet 1-4.
>Подскажите, пожалуйста, как правильно настроить маршрутизатор, если есть возможность с примером
>configa.
>Заранее благодарен!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от Zaec email(??) on 23-Фев-09, 12:41 
>Во-первых тебе надо прописать на интерфейсе Fas0 ip адрес. Если он динамический
>то напиши ip address dhcp
>Во вторых пробрось простой nat
>
>Прочитать можно например здесь
>http://www.opennet.ru/base/cisco/ios_nat.txt.html

Спасибо за совет, буду пробовать!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от Zaec email(??) on 25-Фев-09, 17:12 
Вот один человек посоветовал сделать так:
1. FastEthernet0 в сетку Callisto 821+:
interface fa 0
ip add 192.168.1.2 255.255.255.0
no shut

2. Сделать локальную сеть
2.1. Сделать VLAN. VLAN 1 наверное уже есть можно использовать его
2.2. Сделать L3 интерфейс для VLAN из 2.1
interface vlan 1
ip add 192.168.2.1 255.255.255.0
no shut
2.3 Порты wic-4esw на L2 отнести к VLAN из 2.1
interface range fa 1/0 - 3
switchport
switchport mode access
switchport access vlan 1
no shut

3. Сказать маршрут в интернет
ip route 0.0.0.0 0.0.0.0 192.168.1.1

Попробовал настроить всё так как посоветовали. Для начала даже ip оставил такими же, пингуется только vlan1, 192.168.1.1 - не пингуется и инета нет. Если прописать ip route 0.0.0.0 0.0.0.0 vlan1 и подключить callisto к fa1, то интерфейсы fa2-4 свободно пингуют 192.168.1.1 и имеют доступ в инет. В чём может быть причина?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от wertys on 25-Фев-09, 17:31 
>[оверквотинг удален]
>no shut
>
>3. Сказать маршрут в интернет
>ip route 0.0.0.0 0.0.0.0 192.168.1.1
>
>Попробовал настроить всё так как посоветовали. Для начала даже ip оставил такими
>же, пингуется только vlan1, 192.168.1.1 - не пингуется и инета нет.
>Если прописать ip route 0.0.0.0 0.0.0.0 vlan1 и подключить callisto к
>fa1, то интерфейсы fa2-4 свободно пингуют 192.168.1.1 и имеют доступ в
>инет. В чём может быть причина?

В этом случа Вам на модеме нужно прописать маршрут в сеть 192.168.2.0/24, но если я не ошибаюсь можно сделать так:

ip vrf TEST
rd 1111:111

int fa0
ip vrf for TEST

int vlan 1
ip vrf for TEST

Но лучше, как мне кажется, перевести модем в bridge, на циске поднять PPPoE + NAT

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от wertys on 25-Фев-09, 17:34 
>[оверквотинг удален]
>no shut
>
>3. Сказать маршрут в интернет
>ip route 0.0.0.0 0.0.0.0 192.168.1.1
>
>Попробовал настроить всё так как посоветовали. Для начала даже ip оставил такими
>же, пингуется только vlan1, 192.168.1.1 - не пингуется и инета нет.
>Если прописать ip route 0.0.0.0 0.0.0.0 vlan1 и подключить callisto к
>fa1, то интерфейсы fa2-4 свободно пингуют 192.168.1.1 и имеют доступ в
>инет. В чём может быть причина?

В этом случа Вам на модеме нужно прописать маршрут в сеть 192.168.2.0/24, но если я не ошибаюсь можно сделать так:

ip vrf TEST
rd 1111:111

int fa0
ip vrf for TEST

int vlan 1
ip vrf for TEST

Но лучше, как мне кажется, перевести модем в bridge, на циске поднять PPPoE + NAT

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от Zaec email(??) on 25-Фев-09, 18:00 
Мне в другом форуме подсказывают такой же вариант:
Если без перенастройки модема, то настроить маршрутизатор в режим моста. Как-то так:
int f0/0
bridge-group 1
int vlan 1
bridge-group 1

буду пробовать настраивать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от wertys on 25-Фев-09, 18:22 
>Мне в другом форуме подсказывают такой же вариант:
>Если без перенастройки модема, то настроить маршрутизатор в режим моста. Как-то так:
>
>int f0/0
>bridge-group 1
>int vlan 1
>bridge-group 1
>
>буду пробовать настраивать

В этом случае я не вижу смысла циски, подключите к модему обычный свич какой-нить D-Link,

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Cisco 1721 wic-4esw. Помогите новичку"  
Сообщение от Zaec email(??) on 26-Фев-09, 18:03 
Заработало!!! ВСЕМ БОЛЬШОЕ СПАСИБО! Вот конфиг с которым всё заработало. В будущем попробую настроить бриджем.
                                                                            
interface FastEthernet0                                                        
ip address 192.168.1.2 255.255.255.0                                          
ip nat outside                                                                
ip virtual-reassembly                                                          
speed auto                                                                    
!                                                                              
interface FastEthernet1                                                        
!                                                                              
interface FastEthernet2                                                        
!                                                                              
interface FastEthernet3                                                        
!                                                                              
interface FastEthernet4                                                        
!                                                                              
interface Serial0                                                              
no ip address                                                                  
shutdown                                                                      
no fair-queue                                                                  
!                                                                              
interface Serial1                                                              
no ip address                                                                  
shutdown                                                                      
!                                                                              
interface Vlan1                                                                
ip address 192.168.2.1 255.255.255.0                                          
ip nat inside                                                                  
ip virtual-reassembly                                                          
!                                                                              
ip default-gateway 192.168.1.1                                                  
ip forward-protocol nd                                                          
ip route 0.0.0.0 0.0.0.0 192.168.1.1                                            
no ip http server                                                              
!                                                                              
ip nat inside source list 100 interface FastEthernet0 overload                  
!                                                                              
!                                                                              
access-list 100 permit ip any any                                              
!                                                                              
!                                                                              
!                                                                              
control-plane                                                                  
!                                                                              
!                                                                              
line con 0                                                                      
line aux 0                                                                      
line vty 0 4                                                                    
login                                                                          
!                                                                              
end  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру