The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"AS5350, ISDN PRI - GetIdleDMSChan: Interface De-Activated"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"AS5350, ISDN PRI - GetIdleDMSChan: Interface De-Activated"  
Сообщение от Dmitry A. Kirilin email on 15-Апр-09, 18:39 
Для тестирование некоего оборудования понадобился "тестовый стенд", который пробрасывает звонок с одного обычного телефона на другой через E1.

Примерно так:

Тел.1                                                      PRI0
          > IP-АТС <--H323--> AS5350 <      > тестируемое оборудование

Тел.2                                                      PRI1

Тестируемое оборудование абсолютно прозрачно и другим концом подключается ещё кое-куда, что в данной ситуации совершенно непринципиально. Не будем уточнять, для каких целей оно используется. ;)

Затык, как обычно, образовался в циске.
В неё из IP-АТС (АГАТ-UX, очень люблю сиё железо) приходит номер вида 91xx, в неё обратно надо отправить номер вида 1xx. Всё казалось бы просто.
Однако:

Router#sh contr E1
E1 3/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info of slot 3:  HW: 519, PLD Rev: 1
  Framer Version: 0x9

Manufacture Cookie Info:
EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x0A,
Board Hardware Version 2.7, Item Number 73-5268-03,
Board Revision A0, Serial Number JAE0815BXAV,
PLD/ISP Version <unset>,  Manufacture Date 6-Apr-2004.

  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (894 seconds elapsed):
     0 Line Code Violations, 4095 Path Code Violations
     2 Slip Secs, 1 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     1 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 0 Unavail Secs
E1 3/1 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info of slot 3:  HW: 519, PLD Rev: 1
  Framer Version: 0x9

Manufacture Cookie Info:
EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x0A,
Board Hardware Version 2.7, Item Number 73-5268-03,
Board Revision A0, Serial Number JAE0815BXAV,
PLD/ISP Version <unset>,  Manufacture Date 6-Apr-2004.

  Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (896 seconds elapsed):
     1 Line Code Violations, 4095 Path Code Violations
     2 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
     2 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 0 Unavail Secs

Router#sh isdn stat
Global ISDN Switchtype = primary-net5
ISDN Serial3/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        I_Queue_Len 0, UI_Queue_Len 0
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x7FFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 1
ISDN Serial3/1:15 interface
        dsl 1, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
        I_Queue_Len 0, UI_Queue_Len 0
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x7FFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0

Router#sh isdn serv
PRI Channel Statistics:
ISDN Se3/0:15, Channel [1-31]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
ISDN Se3/1:15, Channel [1-31]
  Configured Isdn Interface (dsl) 1
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
   Service State (0=Inservice 1=Maint 2=Outofservice)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Router#sh int Serial3/0:15
Serial3/0:15 is up, line protocol is up (spoofing)
  Hardware is DSX1
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Last input 00:20:35, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4 packets input, 12 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     4 packets output, 12 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
  Timeslot(s) Used:16, Transmitter delay is 0 flags
Router#sh int Serial3/1:15
Serial3/1:15 is up, line protocol is up (spoofing)
  Hardware is DSX1
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Last input 00:21:28, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4 packets input, 12 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     4 packets output, 12 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
  Timeslot(s) Used:16, Transmitter delay is 0 flags


Router#sh deb
CSM Voice:
  Voice Call Switching Module debugging is on
ISDN:
  ISDN events debugging is on
  ISDN Q931 packets debugging is on

  ISDN events debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 31
  1 1 - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - -

  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 31
  1 1 - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - -

Ну и во время совершения звонка наблюдаем:

00:06:08: vdev_allocate (1/0) Switching to voice
00:06:08: csm_install_voice_vdev_vector_common(1/0): vtsp_cdb  0x0
00:06:08: VDEV_ALLOCATE: 1/0 is allocated
00:06:08: ISDN Se3/0:15: Outgoing call id = 0x8003, dsl 0
00:06:08: ISDN Se3/0:15: process_pri_call(): call id 0x8003, number 1100, speed 0, call type VOICE, redialed? f, csm call? f, pdata? t
00:06:08: callER type/plan overridden by call_decode
00:06:08: did't copy oct3a reason: no octet 3a
00:06:08: callED type/plan overridden by call_decode
00:06:08: did't copy oct3a reason: not CALLER_NUMBER_IE
00:06:08:  ISDN Se3/0:15: GetIdleDMSChan: Interface De-Activated
00:06:08: ISDN Se3/0:15: CCPRI_ReleaseCall(): bchan 0, call id 0x8003, call type VOICE
00:06:08: ISDN Se3/0:15: LIF_EVENT: ces/callid 1/0x8003 CALL_REJECTION
00:06:08: ISDN Se3/0:15: LIF_EVENT: ces/callid 1/0x8003 CALL_CLEARED
00:06:08: ISDN Se3/0:15: received CALL_CLEARED  call_id 0x8003
00:06:08: no resend setup, no redial
00:06:08: ISDN Se3/0:15: Got a disconnect on a non-existent call (call id = 0x8003).
00:06:08: This probably is a call that we placed that never got answered.
00:06:08: is_call_use_hdlc_dsp_res call_id:8003, d_idb:63049A3C :: Return False
00:06:08: EVENT_FROM_ISDN: dchan_idb=0x63049A3C, call_id=0x8003, ces=0x1
   bchan=0xFFFFFFFF, event=0x0, cause=0x22
00:06:08: ISDN Se3/0:15: EVENT to CSM:DEV_IDLE: calltype=VOICE, bchan=-1
00:06:08: ISDN Se3/0:15: CALL_DISC: VOICE ERROR: NULL VDEV Common(0xFC): bchan -1, call id 0x8003
00:06:08: vdev_deallocate (1/0) Switching to back modem
00:06:08: VDEV_DEALLOCATE: slot 1 and port 0 is deallocated
00:06:08: CSM DSPLIB(1/0):DSPLIB_IDLE: Modem session transition to IDLE

Не пойму, в каком месте он "De-Activated".

Важное примечание: в данной ситуации вместо тестируемого оборудования используется перекрёстный патч-корд, ибо доступ к оборудованию связан с получением допусков и пропусков, поэтому хотелось бы отладить сначала на обычной меди.

Конфиг:

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
no boot startup-test
enable password [censored]
!
username m0ray password 0 [censored]
!
!
resource-pool disable
!
!
!
!
ip subnet-zero
ip cef
!
isdn switch-type primary-net5
!
voice service pots
!
voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0
h323
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g723r63
codec preference 3 g723r53
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31
!
translation-rule 1
Rule 1 ^91 11
!
translation-rule 2
Rule 1 ^11 1
!
!
!
interface FastEthernet0/0
ip address 192.168.0.120 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
interface Serial3/0:15
no ip address
isdn switch-type primary-net5
isdn incoming-voice modem
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no cdp enable
!
interface Serial3/1:15
no ip address
isdn switch-type primary-net5
isdn incoming-voice modem
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no cdp enable
!
interface Group-Async0
no ip address
group-range 1/00 1/59
!
ip classless
no ip http server
!
!
!
call rsvp-sync
!
voice-port 3/0:D
compand-type a-law
cptone RU
!
voice-port 3/1:D
compand-type a-law
cptone RU
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 100 pots
incoming called-number T
port 3/1:D
!
dial-peer voice 101 voip
incoming called-number .
voice-class codec 1
!
dial-peer voice 201 pots
destination-pattern 91T
translate-outgoing called 1
port 3/0:D
!
dial-peer voice 202 voip
destination-pattern 11T
translate-outgoing called 2
session target ipv4:192.168.0.123
!
!
line con 0
line aux 0
line vty 0 4
login
line 1/00 1/59
modem InOut
!
scheduler allocate 10000 400
end

Что ж я не так делаю-то?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "AS5350, ISDN PRI - GetIdleDMSChan: Interface De-Activated"  
Сообщение от Myxa (??) on 16-Апр-09, 08:59 
Вас не совсем понятно.
У вас второй уровень ISDN не встал, судя по
Layer 2 Status:
        .... State = TEI_ASSIGNED

>Важное примечание: в данной ситуации вместо тестируемого оборудования используется перекрёстный патч-корд...

Вы имеете ввиду, что controller e1 3/0 смотрит на 3/1 ??

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "AS5350, ISDN PRI - GetIdleDMSChan: Interface De-Activated"  
Сообщение от Dmitry A. Kirilin email on 17-Апр-09, 14:06 
>Вас не совсем понятно.
>У вас второй уровень ISDN не встал, судя по
>Layer 2 Status:
>        .... State = TEI_ASSIGNED

Хм, да, давно я не брал в руки шашек.
В какую сторону копать?

>>Важное примечание: в данной ситуации вместо тестируемого оборудования используется перекрёстный патч-корд...
>Вы имеете ввиду, что controller e1 3/0 смотрит на 3/1 ??

Да. Впоследствии между ними будет подключено "прозрачное" устройство.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "AS5350, ISDN PRI - GetIdleDMSChan: Interface De-Activated"  
Сообщение от Myxa (??) on 17-Апр-09, 14:20 
>В какую сторону копать?
>...
>Да. Впоследствии между ними будет подключено "прозрачное" устройство.

Копать в сторону ISDN, а именно определить master/slave и user/network
По умолчанию cisco - slave и user, соответственно, АТС обычно master и network.
Т.е. вам надо на обном из isdn-портов это выставить
network включается на serialx/x:15
isdn protocol-emulate network
а касательно master не готов сходу сказать.
Тут еще не надо забывать про синхронизацию, network-clock-participate

В общем, какие-то сомнения относительно подобной эмуляции порт-в-порт, с живой АТС всё как-то более понятно.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "AS5350, ISDN PRI - GetIdleDMSChan: Interface De-Activated"  
Сообщение от Dmitry A. Kirilin email on 18-Апр-09, 21:38 
>Копать в сторону ISDN, а именно определить master/slave и user/network
>По умолчанию cisco - slave и user, соответственно, АТС обычно master и
>network.
>Т.е. вам надо на обном из isdn-портов это выставить
>network включается на serialx/x:15
>isdn protocol-emulate network
>а касательно master не готов сходу сказать.
>Тут еще не надо забывать про синхронизацию, network-clock-participate

Ну, user/network у меня был выставлен.
Про master/slave и синхру будем посмотреть, благодарствую.

>В общем, какие-то сомнения относительно подобной эмуляции порт-в-порт, с живой АТС всё
>как-то более понятно.

С одной стороны, мне тоже как-то не по себе от этого, но ведь я всё ещё надеюсь, что циска - умное животное. Хоть я их и не люблю за глючность и мелкие, но противные недоделки.

Сам, как уже говорил, давно использую "Агат" и "М-200" для телефонки и "Mikrotik" для IP.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру