The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Два канала между цисками - как себя поведут?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 23-Апр-09, 10:08 
Привет всем!

Есть такая ситуация: Два удаленных офиса. В одном Catalyst 3550, в другом Cisco 3745. Между ними 2 канала связи - один 24 МБит/сек, второй 2 МБит/сек. Надо организовать отказоустойчивую связь, т.е. при падении быстрого канала, чтобы поднимался медленный, а при возврате в работу быстрого - медленный опускался. Схема вот такая:

                                          --Trunk FE0/1-- Канал 2 Мбит/с   --Trunk FE0/1--
LAN --Trunk-- Cat3550                                                                                        C3745 --Trunk FE0/3 --Trunk-- LAN
                                          --Trunk FE0/2-- Канал 24 Мбит/с --Trunk FE0/2--

Я предполагаю, что если подключить оба канал, то cisco своими механизмами должна увидеть петлю и один из них задаунить. Я предполагаю, что это будет более медленный. В случае падения быстрого канала, петля пропадет и медленный канал поднимется автоматически. В случае возвращения в работу быстрого - опять петля и даун медленного канала. Если бы все было так просто :) Но я не уверен, вдруг начнутся косяки со связью, поэтому рисковать не могу.

Разъясните, плиз, как поведет себя cisco в данной ситуации...

P.S. Вместо C3745 возможно использовать Cat2960 (жаже желательно), вместо Cat3550 возможно Cat3560

Заранее сенкс...
С уважением, Дмитрий

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Два канала между цисками - как себя поведут?"  
Сообщение от lumenous (ok) on 23-Апр-09, 10:22 
>[оверквотинг удален]
>просто :) Но я не уверен, вдруг начнутся косяки со связью,
>поэтому рисковать не могу.
>
>Разъясните, плиз, как поведет себя cisco в данной ситуации...
>
>P.S. Вместо C3745 возможно использовать Cat2960 (жаже желательно), вместо Cat3550 возможно Cat3560
>
>
>Заранее сенкс...
>С уважением, Дмитрий

Вам нужен STP. Попробуйте rapid-pvst (если он поддерживается на этих коммутаторах).
И настройте приоритеты портов. Переход с канала на канал будет укладываться в секунду точно.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Два канала между цисками - как себя поведут?"  
Сообщение от sh_ email(ok) on 23-Апр-09, 10:23 
Используйте OSPF для этого.

Если поменяете все на коммутаторы, то с помощью STP все разрулится.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Два канала между цисками - как себя поведут?"  
Сообщение от den (??) on 23-Апр-09, 11:18 
>Используйте OSPF для этого.
>
>Если поменяете все на коммутаторы, то с помощью STP все разрулится.

Вариантов много: STP, Etherchannel, MPLS, OSPF,iBGP взависимости чего вы хотите и на каком уровне

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Два канала между цисками - как себя поведут?"  
Сообщение от Bokl on 23-Апр-09, 11:22 
>>Используйте OSPF для этого.
>>
>>Если поменяете все на коммутаторы, то с помощью STP все разрулится.
>
>Вариантов много: STP, Etherchannel, MPLS, OSPF,iBGP взависимости чего вы хотите и на
>каком уровне

HSRP?
http://www.opennet.ru/base/cisco/hsrp.txt.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Два канала между цисками - как себя поведут?"  
Сообщение от Bokl on 23-Апр-09, 11:25 
>>>Используйте OSPF для этого.
>>>
>>>Если поменяете все на коммутаторы, то с помощью STP все разрулится.
>>
>>Вариантов много: STP, Etherchannel, MPLS, OSPF,iBGP взависимости чего вы хотите и на
>>каком уровне
>
>HSRP?
>http://www.opennet.ru/base/cisco/hsrp.txt.html

хотя нет. не тот случай.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Два канала между цисками - как себя поведут?"  
Сообщение от BoBa (??) on 23-Апр-09, 11:34 
осталось только выяснить что это за каналы... и будет ли ходить по ним стп вообще...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 23-Апр-09, 12:10 
>осталось только выяснить что это за каналы... и будет ли ходить по
>ним стп вообще...

Да обычные каналы - радио-езернет 24 МБит/с и 2 Мбит/с... И трафик обычный ходит... Так что надо как можно проще реализовать. Обрыв соединений - не критичен, пусть даже секунду переключается. Главное, чтобы автоматически переключалось на медленный канал и возвращалось на быстрый.
EtherСhannel - не пойдет, т.к. надо задействовать только один канал, а не объединять два в один...
Как я думаю должен стандартно отрабатывать STP и не надо никаких настроек.
К тому же на обоих железяках настроен eigrp, возможно он тоже будет участвовать...

Вот в этом-то и вопрос: "КТО?" будет разруливать переключения и по какому алгоритму. Я просто боюсь, чтобы не начались косяки в том плане, что каналы будут переключаться и падать туда-сюда без какого-то контроля... Ну типа - загрузили быстрый канал трафиком, STP подумал, что медленный стал "быстрее" вдруг и переключил на него, а потом обратно... И так постоянно... Вот чего я боюсь. Как проконтролировать этот процесс?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Два канала между цисками - как себя поведут?"  
Сообщение от BoBa (??) on 23-Апр-09, 12:29 
стп знать не знает загружен канал или нет... он только цену порта знает...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 23-Апр-09, 14:19 
>стп знать не знает загружен канал или нет... он только цену порта
>знает...

Как он определяет цену? Исходя из каких критериев? Скорость порта одинаковая на выходе, количество хопов от источника до назначения - одинаковое. Разная только задержка в канале (я считал, что по ней он и определяет скорость, а значит и ценность, канала) или что еще он смотрит?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Два канала между цисками - как себя поведут?"  
Сообщение от BoBa (??) on 23-Апр-09, 14:48 
>или что еще он смотрит?

конфиг вестимо

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Два канала между цисками - как себя поведут?"  
Сообщение от Alex (??) on 23-Апр-09, 14:14 
>К тому же на обоих железяках настроен eigrp, возможно он тоже будет
>участвовать...
>

так на нем и надо все настраивать

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 23-Апр-09, 14:21 
>>К тому же на обоих железяках настроен eigrp, возможно он тоже будет
>>участвовать...
>>
>
>так на нем и надо все настраивать

Что конкретно настраивать на нем можно? Все параметры обоих портов одинаковые, кроме задержки внутри канала...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Два канала между цисками - как себя поведут?"  
Сообщение от lumenous (ok) on 23-Апр-09, 14:24 
>>>К тому же на обоих железяках настроен eigrp, возможно он тоже будет
>>>участвовать...
>>>
>>
>>так на нем и надо все настраивать
>
>Что конкретно настраивать на нем можно? Все параметры обоих портов одинаковые, кроме
>задержки внутри канала...

Зайдите на cisco.com и почитайте что такое STP и как это реализовывается. Там все это есть. Еще и расписано по шагам.

А если отвечать на ваш вопрос, то при настройке STP  вы на портах указываете приоритет вручную и все.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 24-Апр-09, 06:13 
>
>А если отвечать на ваш вопрос, то при настройке STP  вы
>на портах указываете приоритет вручную и все.

Спасибо. Как я понимаю - это и есть самый простой и действенный способ. Зачем еще что-то придумывать и усложнять :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 24-Апр-09, 09:44 
>>
>>А если отвечать на ваш вопрос, то при настройке STP  вы
>>на портах указываете приоритет вручную и все.
>
>Спасибо. Как я понимаю - это и есть самый простой и действенный
>способ. Зачем еще что-то придумывать и усложнять :)

Вопрос поднимается снова... На одном конце стоит коммутатор, на порту которого я могу задать параметр spanning-tree vlan vlan-id port-priority... А на втором конце стоит Cisco 2611. Виланы-то я создал, а вот spanning-tree vlan vlan-id port-priority задать на саб-интерфейсах - не могу. Есть ли в этом необходимость вообще и, если есть, как spanning-tree vlan vlan-id port-priority реализовать на интерфейсах маршрутизатора?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Два канала между цисками - как себя поведут?"  
Сообщение от BoBa (??) on 24-Апр-09, 11:44 
conf t
int blabla
spanning-tree cost blabla

зачем по вланам и сабам?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Два канала между цисками - как себя поведут?"  
Сообщение от Alex (??) on 24-Апр-09, 14:56 
>>>К тому же на обоих железяках настроен eigrp, возможно он тоже будет
>>>участвовать...
>>>
>>
>>так на нем и надо все настраивать
>
>Что конкретно настраивать на нем можно? Все параметры обоих портов одинаковые, кроме
>задержки внутри канала...

объясняю.
у вас поднят eigrp, т.е. между устройствами в сети L3 линки и динамическая маршрутизация.
вопрос, зачем делать сетку кусками L3 кусками L2? Если L2 это конечно не аксесс для пользователей, но в вашей задаче это не так.
не лучше ли все сделать L3 с динамикой, т.е. все сделать одинаково?
дальше читаем на основании чего eigrp выбирает маршруты. первое это пропускная способность (она у вас разная на каналах), задержка, надежность, нагрузка, MTU. т.е. без проблем настраивается то что вам нужно.
плюс, необходимо настроить таймеры EIGRP и кариер делей на интерфейсах и вы получите сходимость быстрее чем у STP.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 27-Апр-09, 08:08 
>
>дальше читаем на основании чего eigrp выбирает маршруты. первое это пропускная способность
>(она у вас разная на каналах), задержка, надежность, нагрузка, MTU. т.е.
>без проблем настраивается то что вам нужно.
>плюс, необходимо настроить таймеры EIGRP и кариер делей на интерфейсах и вы
>получите сходимость быстрее чем у STP.

Ничего не работает... :( Как только поднимаю интерфейс с резервным каналом, оба порта переходят в STP в режим FWD и начинаются косяки в сети... Уже настраивал cost и priority на интерфейсах каталиста. Всё бесполезно... Причем на стенде, где подключены были каталист-каталист двумя линками между собой в сосседних портах FE - всё отрабатывало (но возможно просто каталиста сама решала все там, а не настройки влияли)... А вот на соединении каталист-маршрутизатор - не работает...

Может ли кто с самого начала, используя схему, приведенную в начале, сказать, как правильно реализовать организацию резерва. Уже перечитал кучу литературы по STP, голова кругом идет, но ничего не получается...

P.S. Следует учесть, что для каталиста линк 24МБит/с и 2 Мбит/с подключены через FE, где интерфейс поднимается на 100МБит/с и, как я считаю, для STP их пропускная способность априори одинаковая - 100МБит/с... Может поэтому он не может выбрать правильный линк. Хотя я уже жестко указывал speed 10 на более медленном - результата никакого...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 27-Апр-09, 10:18 
>[оверквотинг удален]
>>>>участвовать...
>>>>
>>>
>>>так на нем и надо все настраивать
>>
>дальше читаем на основании чего eigrp выбирает маршруты. первое это пропускная способность
>(она у вас разная на каналах), задержка, надежность, нагрузка, MTU. т.е.
>без проблем настраивается то что вам нужно.
>плюс, необходимо настроить таймеры EIGRP и кариер делей на интерфейсах и вы
>получите сходимость быстрее чем у STP.

Нельзя ли поподробнее, как настроить EIGRP вообще и для обеспечения переключения/возврата на резерв? Обнаружил сейчас еще проблему в том, что C3745 не обменивается маршрутами с Cat3550, хотя на обоих стоят одинаковые настройки зоны:

router eigrp 1
network 172.16.0.0
network 192.168.0.0
no auto-summary

В остальной сети EIGRP отрабатывает нормально... Может надо его на маршрутизаторах как-то привязывать еще к интерфейсам дополнительно? На коммутаторах все начинает работать сразу после внесения данных строк в конфиг...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 27-Апр-09, 12:23 
>Обнаружил сейчас еще проблему в том, что C3745 не обменивается
>маршрутами с Cat3550, хотя на обоих стоят одинаковые настройки зоны:
>
>router eigrp 1
> network 172.16.0.0
> network 192.168.0.0
> no auto-summary
>

Данную проблему решил. Оказывается радиоточки доступа не передавали пакеты EIGRP. Уже обрадовался, что и STP заработает, но... Проблема осталась - при подключении второго линка начинаются косяки. Вот вывод команд с маршрутизатора. Я думаю там проблему увидел, но как победить - пока не нашел:

С Cat2950 (я его назначил root для vl 88 - выделено) после no sh на резервном порту:
VLAN0088
  Spanning tree enabled protocol ieee
  Root ID    Priority    24664
             Address     0012.43da.0900
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24664  (priority 24576 sys-id-ext 88)
             Address     0012.43da.0900
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 15

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/14           Desg FWD 19        128.14   Shr
Fa0/15           Desg FWD 19        128.15   Shr
Fa0/16           Desg FWD 19        128.16   Shr
Fa0/18           Desg FWD 100       128.18   P2p

А вот с C3745 до и после подключения резервного порта:

Bridge group 88 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0012.0195.ec51
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag set, detected flag set
  Number of topology changes 17 last change occurred 00:08:36 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 21, notification 0, aging 15

Port 10 (FastEthernet0/0.88) of Bridge group 88 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.10.
   Designated root has priority 32768, address 0012.0195.ec51
   Designated bridge has priority 32768, address 0012.0195.ec51
   Designated port id is 128.10, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 4
   BPDU: sent 8306, received 182

Port 13 (FastEthernet2/0.88) of Bridge group 88 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.13.
   Designated root has priority 32768, address 0012.0195.ec51
   Designated bridge has priority 32768, address 0012.0195.ec51
   Designated port id is 128.13, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 5824073, received 0

------------

Bridge group 88 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 0012.0195.ec51
Configured hello time 2, max age 20, forward delay 15
Current root has priority 24664, address 0012.43da.0900
Root port is 10 (FastEthernet0/0.88), cost of root path is 19

Topology change flag not set, detected flag not set
Number of topology changes 17 last change occurred 00:09:49 ago
Times:  hold 1, topology change 35, notification 2
         hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (FastEthernet0/0.88) of Bridge group 88 is forwarding
  Port path cost 19, Port priority 128, Port Identifier 128.10.
  Designated root has priority 24664, address 0012.43da.0900
  Designated bridge has priority 24664, address 0012.43da.0900
  Designated port id is 128.18, designated path cost 0
  Timers: message age 2, forward delay 0, hold 0
  Number of transitions to forwarding state: 4
  BPDU: sent 8332, received 192

Port 13 (FastEthernet2/0.88) of Bridge group 88 is forwarding
  Port path cost 19, Port priority 128, Port Identifier 128.13.
  Designated root has priority 24664, address 0012.43da.0900
  Designated bridge has priority 32768, address 0012.0195.ec51
  Designated port id is 128.13, designated path cost 19
  Timers: message age 0, forward delay 0, hold 0
  Number of transitions to forwarding state: 1
  BPDU: sent 5824109, received 0

Как видно из выделенного - он увидел рутовый Cat2950, но почему-то предпочтение отдал порту Port 10 (FastEthernet0/0.88), присвоив ему цену 0... Вот как изменить его мнение, чтобы он 0 присваивал Port 13 (FastEthernet2/0.88)? Как вариант самый простой хочу попробовать просто поменять местами интерфейсы, но не знаю, получится или нет :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 27-Апр-09, 12:35 
Еще заметил, что почему-то

Port 10 (FastEthernet0/0.88) of Bridge group 88 is forwarding
   BPDU: sent 8306, received 182

а на

Port 13 (FastEthernet2/0.88) of Bridge group 88 is forwarding
   BPDU: sent 5824073, received 0

Может в этом кроется проблема?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Два канала между цисками - как себя поведут?"  
Сообщение от Alex (??) on 27-Апр-09, 13:06 
>router eigrp 1
> network 172.16.0.0
> network 192.168.0.0
> no auto-summary
>
>В остальной сети EIGRP отрабатывает нормально... Может надо его на маршрутизаторах как-то
>привязывать еще к интерфейсам дополнительно? На коммутаторах все начинает работать сразу
>после внесения данных строк в конфиг...

покажите конфиги с 3550 и 3750, так будет быстрее и проще
надо проверить в одной ли зоне eigrp находятся эти сети, что сказано насчет passive interface, может настроена аутентификация eigrp...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Два канала между цисками - как себя поведут?"  
Сообщение от Dev_Dimon email(ok) on 27-Апр-09, 13:25 
>
>покажите конфиги с 3550 и 3750, так будет быстрее и проще
>надо проверить в одной ли зоне eigrp находятся эти сети, что сказано
>насчет passive interface, может настроена аутентификация eigrp...

EIGRP заработало нормально - получило все пути со всей сети... Проблема осталась с STP.. Если конфиги надо для настройки STP, то пожалуйста:

C-3745#sh run
Building configuration...

ip subnet-zero
no ip source-route
ip tcp synwait-time 10
!
no ip bootp server
ip cef
!
bridge irb
!
interface FastEthernet0/0
description RRL_to_Cat3550
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
no snmp trap link-status
bridge-group 2
!
interface FastEthernet0/0.88
encapsulation dot1Q 88
no snmp trap link-status
bridge-group 88
!
interface FastEthernet0/1
description to_client
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no mop enabled
bridge-group 88
!
interface FastEthernet2/0
description Radio_to_Cat3550
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet2/0.2
encapsulation dot1Q 2
no snmp trap link-status
bridge-group 2
!
interface FastEthernet2/0.88
encapsulation dot1Q 88
no snmp trap link-status
bridge-group 88
!
interface BVI88
ip address 172.16.88.1 255.255.252.0
!
router eigrp 1
network 172.16.0.0
network 192.168.0.0
no auto-summary
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.102
!
bridge 2 protocol ieee
bridge 2 route ip
bridge 88 protocol ieee
bridge 88 route ip
!
end

----------------

Cat-3550#sh run
Building configuration...

Current configuration : 7343 bytes
!
no service pad
!
mls qos
ip subnet-zero
ip routing
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 88 priority 24576
!
vlan internal allocation policy ascending
!
interface FastEthernet0/15
description to_client
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,88
switchport mode trunk
!
interface FastEthernet0/16
description Radio_to_C3745
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,88
switchport mode trunk
!
interface FastEthernet0/18
description RRL_to_C3745
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,88
switchport mode trunk
shutdown
speed 10
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 172.16.0.102 255.255.252.0
!
router eigrp 1
network 172.16.0.0
network 192.168.0.0
no auto-summary
!
ip classless
!
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру