The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"внутренний сервер через внешний адрес (NAT)"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"внутренний сервер через внешний адрес (NAT)"  
Сообщение от Tolstun (ok) on 25-Апр-09, 23:33 
подскажите, как увидеть из Vlan1 сервер 192.168.0.40 через внешний адрес 26.26.26.26:8080 (gateway у всех 192.168.0.1)

конфиг примерно такой:

interface FastEthernet0/0
ip address 26.26.26.26 255.255.255.252
ip nat outside
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 permanent
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.0.40 8080 interface FastEthernet0/0 8080
!
access-list 1 permit 192.168.0.0 0.0.0.255

вроде надо через loopback (nat on a stick), только не понятно как :-(

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "внутренний сервер через внешний адрес (NAT)"  
Сообщение от Bokl on 26-Апр-09, 11:17 
>[оверквотинг удален]
>!
>ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 permanent
>!
>ip nat inside source list 1 interface FastEthernet0/0 overload
>ip nat inside source static tcp 192.168.0.40 8080 interface FastEthernet0/0 8080
>!
>access-list 1 permit 192.168.0.0 0.0.0.255
>
>вроде надо через loopback (nat on a stick), только не понятно как
>:-(

тебе port forwarding что ли нужен?  чтобы снаружи ты на свой внешний заходил, а попадал на сервак внутри?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "внутренний сервер через внешний адрес (NAT)"  
Сообщение от Tolstun (ok) on 26-Апр-09, 15:46 
здесь port forwarding уже и так работает, а надо чтобы внутри набрать внешний адрес 26.26.26.26:8080 и попасть на свой сервер
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "внутренний сервер через внешний адрес (NAT)"  
Сообщение от Незнайка (ok) on 27-Апр-09, 14:39 
>здесь port forwarding уже и так работает, а надо чтобы внутри набрать
>внешний адрес 26.26.26.26:8080 и попасть на свой сервер

имхо, проще всего это решить при помощи DNS, внешний сервер имен будет отдавать внешний адрес, внутренний сервер имен - внутренний адрес. Все прозрачно и просто для конечных пользователей.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "внутренний сервер через внешний адрес (NAT)"  
Сообщение от Tolstun (ok) on 27-Апр-09, 20:43 
внутреннего DNS нет, а если порт у внутреннего сервера один, а внешний порт другой, то split horizon DNS не подходит
ios умеет делать NAT для DNS запросов, только если используется  NAT без port forwading
похоже эту задачу так толком никто и не решил

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "внутренний сервер через внешний адрес (NAT)"  
Сообщение от Tolstun (ok) on 27-Апр-09, 22:15 
действительно через split-horizon DNS оказалось проще сделать, благо порты 1 в 1 прокинуты
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру