The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Шейпер на interface Tunnel0"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 08-Июл-09, 13:40 
Подскажите, как организовать очередь приоритетов на interface Tunnel0? Команды priority-group там я нет.
Нужно направить трафик от 192.168.1.161 в первую очередь. Создал вот такой list, как его прицепить к интерфейсу?

priority-list 1 protocol ip high list 10
priority-list 1 protocol ip low list 20
priority-list 1 queue-limit 50 60 60 80
priority-list 1 default normal

access-list 10 permit 192.168.1.161  0.0.0.0
access-list 10 deny any

access-list 20 deny 192.168.1.161  0.0.0.0
access-list 20 permit 192.168.1.0  0.0.0.255
access-list 20 deny any

Спасибо

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Шейпер на interface Tunnel0"  +/
Сообщение от mdenisov email(ok) on 08-Июл-09, 18:10 
>[оверквотинг удален]
>priority-list 1 default normal
>
>access-list 10 permit 192.168.1.161  0.0.0.0
>access-list 10 deny any
>
>access-list 20 deny 192.168.1.161  0.0.0.0
>access-list 20 permit 192.168.1.0  0.0.0.255
>access-list 20 deny any
>
>Спасибо

Можно, например, через service-policy, детали курите по CBWFQ

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 09-Июл-09, 10:15 

>Можно, например, через service-policy, детали курите по CBWFQ

class-map match-any VOIP-SIGNAL
match ip dscp cs5
match ip precedence 4
match ip precedence 3
class-map match-any VOIP-RTP
match ip dscp ef
match ip precedence 5
!
!
policy-map QOS-Policy
class VOIP-SIGNAL
  priority percent 5
class VOIP-RTP
  priority percent 70
class class-default
  fair-queue
random-detect

Соорудил вот такую конструкцию - ошибка осталась.

При указании
shape average 128000
всё работает - но это не выход (

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Шейпер на interface Tunnel0"  +/
Сообщение от mdenisov email(ok) on 09-Июл-09, 10:24 
>Соорудил вот такую конструкцию - ошибка осталась.
>
>При указании
>shape average 128000
>всё работает - но это не выход (

Что за ошибка то и что не работает? Бывают конечно некоторые тонкости, например max-reserved-bandwidth, или qos pre-classify для ipsec'а.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 09-Июл-09, 11:11 
>>Соорудил вот такую конструкцию - ошибка осталась.
>>
>>При указании
>>shape average 128000
>>всё работает - но это не выход (
>
>Что за ошибка то и что не работает? Бывают конечно некоторые тонкости,
>например max-reserved-bandwidth, или qos pre-classify для ipsec'а.

при применении политики на интерфейсе


cisco(config-pmap-c)#interface Tunnel0
cisco(config-if)#service-policy output QOS-Policy
Class Based Weighted Fair Queueing not supported on interface Tunnel0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Шейпер на interface Tunnel0"  +/
Сообщение от mdenisov email(ok) on 09-Июл-09, 11:13 
>[оверквотинг удален]
>>
>>Что за ошибка то и что не работает? Бывают конечно некоторые тонкости,
>>например max-reserved-bandwidth, или qos pre-classify для ipsec'а.
>
>при применении политики на интерфейсе
>
>
>cisco(config-pmap-c)#interface Tunnel0
>cisco(config-if)#service-policy output QOS-Policy
>Class Based Weighted Fair Queueing not supported on interface Tunnel0

О как, а что за платформа?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 09-Июл-09, 11:24 
>[оверквотинг удален]
>>>например max-reserved-bandwidth, или qos pre-classify для ipsec'а.
>>
>>при применении политики на интерфейсе
>>
>>
>>cisco(config-pmap-c)#interface Tunnel0
>>cisco(config-if)#service-policy output QOS-Policy
>>Class Based Weighted Fair Queueing not supported on interface Tunnel0
>
>О как, а что за платформа?

cisco 1841

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Шейпер на interface Tunnel0"  +/
Сообщение от shurick (??) on 09-Июл-09, 12:09 
>[оверквотинг удален]
>>>при применении политики на интерфейсе
>>>
>>>
>>>cisco(config-pmap-c)#interface Tunnel0
>>>cisco(config-if)#service-policy output QOS-Policy
>>>Class Based Weighted Fair Queueing not supported on interface Tunnel0
>>
>>О как, а что за платформа?
>
>cisco 1841

У меня вот так:
policy-map dmvpn-policy-map-1
class voice
  priority percent 65
class call-control
  bandwidth percent 10
class class-default
  fair-queue
policy-map parent-policy-map-1
class class-default
  shape average percent 100
  service-policy dmvpn-policy-map-1
interface Tunnel0
qos pre-classify
interface FastEthernet0/0.575
service-policy output parent-policy-map-1

Где-то в недрах сайта Cisco есть описание такой конструкции.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 09-Июл-09, 12:28 
прошу прощения что не нарисовал всю схему работы.
Стоит циска у нас и в филиалах. Для неё выделен специальный канал - по которому ходят только туннельные интерфейсы. Больше никакой трафик туда не попадает. Нужно порезать трафик именно в туннеле по приоритетам. На внешнем весь трафик равнозначный.

Посоветовали вот так, сейчас попробую )

class-map match-any VOIP-SIGNAL
match ip dscp cs5
match ip precedence 4
match ip precedence 3
class-map match-any VOIP-RTP
match ip dscp ef
match ip precedence 5
!
!
policy-map QOS-Policy
class VOIP-SIGNAL
priority percent 5
class VOIP-RTP
priority percent 70
!
policy-map PARENT_POLICY
class class-default
shape average 10000000
service-policy QOS-Policy
!
Interface tunnel0
Service-policy output PARENT_POLICY

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Шейпер на interface Tunnel0"  +/
Сообщение от shurick (??) on 09-Июл-09, 12:46 
>[оверквотинг удален]
>class VOIP-RTP
>priority percent 70
>!
>policy-map PARENT_POLICY
>class class-default
>shape average 10000000
>service-policy QOS-Policy
>!
>Interface tunnel0
>Service-policy output PARENT_POLICY

Туннельный интерфейс привязан к какому-то физическому интерфейсу. Вот на этот физический интерфейс, согласно сайту Циско, и нужно вешать PARENT_POLICY. К сожалению пока не нашел ссылку на статью.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 09-Июл-09, 12:56 
>[оверквотинг удален]
>>class class-default
>>shape average 10000000
>>service-policy QOS-Policy
>>!
>>Interface tunnel0
>>Service-policy output PARENT_POLICY
>
>Туннельный интерфейс привязан к какому-то физическому интерфейсу. Вот на этот физический интерфейс,
>согласно сайту Циско, и нужно вешать PARENT_POLICY. К сожалению пока не
>нашел ссылку на статью.

Но политики не отругались, прицепились и на tunnel0 - сейчас попробуем протестить )
Пока вот что
cisco#sh policy-map  interface tunnel0
Tunnel0

  Service-policy output: PARENT_POLICY

    Class-map: class-default (match-any)
      6325 packets, 505792 bytes
      5 minute offered rate 13000 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes)
           512000/512000    3200   12800     12800     25        1600

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      0         6325      378038    3         983       no

      Service-policy : QOS-Policy

        Class-map: VOIP-SIGNAL (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp cs5 (40)
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: ip precedence 4
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: ip precedence 3
            0 packets, 0 bytes
            5 minute rate 0 bps
          Queueing
            Strict Priority
            Output Queue: Conversation 40
            Bandwidth 5 (%)
            Bandwidth 25 (kbps) Burst 625 (Bytes)
            (pkts matched/bytes matched) 0/0
            (total drops/bytes drops) 0/0

        Class-map: VOIP-RTP (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp ef (46)
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: ip precedence 5
            0 packets, 0 bytes
            5 minute rate 0 bps
          Queueing
            Strict Priority
            Output Queue: Conversation 40
            Bandwidth 70 (%)
            Bandwidth 358 (kbps) Burst 8950 (Bytes)
            (pkts matched/bytes matched) 0/0
            (total drops/bytes drops) 0/0

        Class-map: class-default (match-any)
          6325 packets, 505792 bytes
          5 minute offered rate 13000 bps, drop rate 0 bps
          Match: any

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Шейпер на interface Tunnel0"  +/
Сообщение от shurick (??) on 09-Июл-09, 13:09 
>[оверквотинг удален]
>            
>(total drops/bytes drops) 0/0
>
>        Class-map: class-default (match-any)
>          6325 packets,
>505792 bytes
>          5 minute
>offered rate 13000 bps, drop rate 0 bps
>          Match: any
>

Нашел теорию. Вот что пишет циско: http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tec...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Шейпер на interface Tunnel0"  +/
Сообщение от shurick (??) on 09-Июл-09, 12:23 
>[оверквотинг удален]
>>>при применении политики на интерфейсе
>>>
>>>
>>>cisco(config-pmap-c)#interface Tunnel0
>>>cisco(config-if)#service-policy output QOS-Policy
>>>Class Based Weighted Fair Queueing not supported on interface Tunnel0
>>
>>О как, а что за платформа?
>
>cisco 1841

А еще есть у циско per tunnel qos, но работает только с ios-ами от 12.4(22)T. Читать здесь: http://www.cisco.com/en/US/docs/ios/security/configuration/g...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Шейпер на interface Tunnel0"  +/
Сообщение от Vitaly email(??) on 09-Июл-09, 12:33 
>[оверквотинг удален]
>>>>cisco(config-pmap-c)#interface Tunnel0
>>>>cisco(config-if)#service-policy output QOS-Policy
>>>>Class Based Weighted Fair Queueing not supported on interface Tunnel0
>>>
>>>О как, а что за платформа?
>>
>>cisco 1841
>
>А еще есть у циско per tunnel qos, но работает только с
>ios-ами от 12.4(22)T. Читать здесь: http://www.cisco.com/en/US/docs/ios/security/configuration/g...

У меня 12.4 , но в остальных офисах полный зоопарк (

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру