The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблемы с L2TP на Cisco 3825"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблемы с L2TP на Cisco 3825"  +/
Сообщение от prof_gcc email(ok) on 30-Июл-09, 10:16 
Господа прошу вашей помощи, не могу из винды приконектится к циске по L2TP + Ipsec стандартным клиентом. Ниже привожу конфиг естественно только то что касается VPN

aaa new-model
!
!
!
aaa authentication login default local
aaa authentication ppp default local
!
!
aaa session-id common

vpdn-group L2TP
! Default L2TP VPDN group
accept-dialin
  protocol l2tp
  virtual-template 1
l2tp security crypto-profile L2TP
no l2tp tunnel authentication
!

username profgcc password 0 my_password

crypto isakmp policy 100
encr 3des
authentication pre-share
group 2
crypto isakmp key mykey address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set L2TP esp-3des esp-sha-hmac
mode transport
!
crypto map L2TP 100 ipsec-isakmp profile L2TP
set transform-set L2TP
!
!
!
!
!
interface Loopback1
ip address 172.16.0.254 255.255.255.0
!
interface GigabitEthernet0/0.2
description ADMINISTRATIVE_INTERFACE
encapsulation dot1Q 3
ip address 10.0.1.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
crypto map L2TP
!
interface Virtual-Template1
ip unnumbered Loopback1
peer default ip address pool mypool
ppp authentication ms-chap-v2 callin
!
ip local pool mypool 172.16.0.1 172.16.0.253


C таким конфигом нихрена не работает debug ppp nego

Jul 30 06:01:58.707: ppp187 PPP: Send Message[Dynamic Bind Response]
Jul 30 06:01:58.707: ppp187 PPP: Using vpn set call direction
Jul 30 06:01:58.707: ppp187 PPP: Treating connection as a callin
Jul 30 06:01:58.707: ppp187 PPP: Session handle[710000D3] Session id[187]
Jul 30 06:01:58.707: ppp187 PPP: Phase is ESTABLISHING, Passive Open
Jul 30 06:01:58.707: ppp187 LCP: State is Listen
Jul 30 06:02:00.695: ppp187 LCP: Timeout: State Listen
Jul 30 06:02:00.695: ppp187 LCP: O CONFREQ [Listen] id 1 len 15
Jul 30 06:02:00.695: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:00.695: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:02.711: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:02.711: ppp187 LCP: O CONFREQ [REQsent] id 2 len 15
Jul 30 06:02:02.711: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:02.711: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:04.727: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:04.727: ppp187 LCP: O CONFREQ [REQsent] id 3 len 15
Jul 30 06:02:04.727: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:04.727: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:06.743: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:06.743: ppp187 LCP: O CONFREQ [REQsent] id 4 len 15
Jul 30 06:02:06.743: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:06.743: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:08.759: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:08.759: ppp187 LCP: O CONFREQ [REQsent] id 5 len 15
Jul 30 06:02:08.759: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:08.759: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:10.775: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:10.775: ppp187 LCP: O CONFREQ [REQsent] id 6 len 15
Jul 30 06:02:10.775: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:10.775: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:12.791: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:12.791: ppp187 LCP: O CONFREQ [REQsent] id 7 len 15
Jul 30 06:02:12.791: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:12.791: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:14.807: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:14.807: ppp187 LCP: O CONFREQ [REQsent] id 8 len 15
Jul 30 06:02:14.807: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:14.807: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:16.823: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:16.823: ppp187 LCP: O CONFREQ [REQsent] id 9 len 15
Jul 30 06:02:16.823: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:16.823: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:18.839: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:18.839: ppp187 LCP: O CONFREQ [REQsent] id 10 len 15
Jul 30 06:02:18.839: ppp187 LCP:    AuthProto MS-CHAP-V2 (0x0305C22381)
Jul 30 06:02:18.839: ppp187 LCP:    MagicNumber 0x25C136B3 (0x050625C136B3)
Jul 30 06:02:20.855: ppp187 LCP: Timeout: State REQsent
Jul 30 06:02:20.855: ppp187 LCP: O TERMREQ [REQsent] id 10 len 4
Jul 30 06:02:20.855: ppp187 PPP: Phase is TERMINATING
Jul 30 06:02:20.855: ppp187 LCP: State is Listen
Jul 30 06:02:20.855: ppp187 PPP: Sending Acct Event[Down] id[D1]
Jul 30 06:02:20.855: ppp187 LCP: State is Closed
Jul 30 06:02:20.855: ppp187 PPP: Phase is DOWN
Jul 30 06:02:20.855: ppp187 PPP: Send Message[Disconnect]

При этом при вот таком конфиге все норм

aaa new-model
!
!
!
aaa authentication login default local
aaa authentication ppp default local
!
!
aaa session-id common

vpdn-group L2TP
! Default L2TP VPDN group
accept-dialin
  protocol l2tp
  virtual-template 1
no l2tp tunnel authentication
!

username profgcc password 0 my_password

crypto isakmp policy 100
encr 3des
authentication pre-share
group 2
crypto isakmp key mykey address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set L2TP esp-3des esp-sha-hmac
mode transport
!
crypto map L2TP 100 ipsec-isakmp
set peer 10.0.5.51
set transform-set L2TP
match address 101
!
!
!
!
!
interface Loopback1
ip address 172.16.0.254 255.255.255.0
!
interface GigabitEthernet0/0.2
description ADMINISTRATIVE_INTERFACE
encapsulation dot1Q 3
ip address 10.0.1.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
crypto map L2TP
!
interface Virtual-Template1
ip unnumbered Loopback1
peer default ip address pool mypool
ppp authentication ms-chap-v2 callin
!
ip local pool mypool 172.16.0.1 172.16.0.253
access-list 101 permit udp host 10.0.1.1 eq 1701 host 10.0.1.51 eq 1701

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблемы с L2TP на Cisco 3825"  +/
Сообщение от lesha4ever email(ok) on 30-Июл-09, 16:46 
Для разных виндовсов разные конфиги. Виста использует другие алгоритмы. Скидую реальный пример когда работает и ХР и Виста

vpdn enable
vpdn logging
!
vpdn-group VPDN-L2TP
! Default L2TP VPDN group
accept-dialin
  protocol l2tp
  virtual-template 1
lcp renegotiation on-mismatch
no l2tp tunnel authentication
!
vpdn-group VPDN-PPTP
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 2
pptp tunnel echo 10
ip pmtu
ip mtu adjust
!
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
group 2
!
crypto isakmp policy 20
encr 3des
authentication pre-share
group 2
!
!
crypto isakmp key SECRETKEY address 0.0.0.0 0.0.0.0
crypto isakmp invalid-spi-recovery
crypto isakmp keepalive 60
!
!
crypto ipsec transform-set L2TP esp-3des esp-md5-hmac
mode transport
crypto ipsec transform-set L2TP_V ah-sha-hmac esp-3des esp-sha-hmac
mode transport
!
crypto dynamic-map L2TP_D 10
set transform-set L2TP L2TP_V
!
!
crypto map L2TP 20 ipsec-isakmp dynamic L2TP_D
!
!
interface Virtual-Template1
ip unnumbered Loopback0
ip access-group VPN_L2TP in
peer default ip address pool vpnpool2
ppp mtu adaptive
ppp authentication ms-chap-v2
ppp ipcp dns 10.X.X.X
!
interface Virtual-Template2
description $FW_OUTSIDE$
ip unnumbered Loopback0
ip access-group VPN_PPTP in
autodetect encapsulation ppp
peer default ip address pool vpnpool2
ppp encrypt mppe auto
ppp authentication ms-chap-v2
ppp ipcp dns 10.X.X.X
!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблемы с L2TP на Cisco 3825"  +/
Сообщение от prof_gcc email(ok) on 30-Июл-09, 17:25 
>[оверквотинг удален]
>interface Virtual-Template2
> description $FW_OUTSIDE$
> ip unnumbered Loopback0
> ip access-group VPN_PPTP in
> autodetect encapsulation ppp
> peer default ip address pool vpnpool2
> ppp encrypt mppe auto
> ppp authentication ms-chap-v2
> ppp ipcp dns 10.X.X.X
>!

Спасибо, я тоже пробовал создавать dynamic-map но почемуто не хотело, в итоге конфиг и для Висты и для XP

vpdn enable
!
vpdn-group L2TP
! Default L2TP VPDN group
accept-dialin
  protocol l2tp
  virtual-template 1
no l2tp tunnel authentication

crypto isakmp policy 100
encr 3des
authentication pre-share
group 2
crypto isakmp key mykey address 0.0.0.0 0.0.0.0
crypto isakmp invalid-spi-recovery
!
crypto ipsec transform-set L2TP esp-3des esp-sha-hmac
mode transport
!
crypto dynamic-map DIN 10
set transform-set L2TP
!
!
crypto map L2TP 100 ipsec-isakmp dynamic DIN
!
!
interface Loopback1
ip address 172.16.0.254 255.255.255.0
!
interface Virtual-Template1
ip unnumbered Loopback1
peer default ip address pool mypool
ppp encrypt mppe auto
ppp authentication ms-chap-v2 callin
!
ip local pool mypool 172.16.0.1 172.16.0.253

И все работает и там и там


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблемы с L2TP на Cisco 3825"  +/
Сообщение от GolDi (??) on 31-Июл-09, 09:34 
>[оверквотинг удален]
> ip unnumbered Loopback1
> peer default ip address pool mypool
> ppp encrypt mppe auto
> ppp authentication ms-chap-v2 callin
>!
>ip local pool mypool 172.16.0.1 172.16.0.253
>
>
>
>И все работает и там и там

Я так и не поняли к какому интерфейсу применяется >crypto map L2TP ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблемы с L2TP на Cisco 3825"  +/
Сообщение от prof_gcc email(ok) on 31-Июл-09, 10:23 
Для тестов я применял к внутреннему, в итоге ко внешнему, к тому с которого будут конектится
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблемы с L2TP на Cisco 3825"  +/
Сообщение от lesha4ever email(ok) on 31-Июл-09, 10:47 
>[оверквотинг удален]
>> ppp encrypt mppe auto
>> ppp authentication ms-chap-v2 callin
>>!
>>ip local pool mypool 172.16.0.1 172.16.0.253
>>
>>
>>
>>И все работает и там и там
>
> Я так и не поняли к какому интерфейсу применяется >crypto map L2TP ?

Внешний!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру