The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Два провайдера - PBR + NAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Два провайдера - PBR + NAT"  +/
Сообщение от merko email(ok) on 13-Окт-09, 09:08 
Помогите разобраться, второй день парюсь...
С циски пинги в интернет ходят а с внутренней сети (Vlan1) не идут. Судя по всему next-hop не срабатывает. Если прописать маршрут на какой-нибудь ресурс, то пинги идут.
NAT работает.
Ошибка по моему где-то в route-map'е, не могу понять где...

конфиг:

ip sla monitor 1
type echo protocol ipIcmpEcho 213.228.116.Y source-interface FastEthernet0/0
timeout 10000
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 195.206.58.Y source-interface FastEthernet0/1
timeout 10000
ip sla monitor schedule 2 life forever start-time now
vpdn enable

!
track 1 rtr 1 reachability
!
track 2 rtr 2 reachability
!
!
!
interface FastEthernet0/0
ip address 172.25.0.1 255.255.255.252
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 195.206.58.X 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan1
ip address 172.25.1.40 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname qwe
ppp chap password 0 qwe

ip local policy route-map rm_local
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 50 track 1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 100 track 2
!
no ip http server
ip http authentication local
ip http secure-server
ip nat inside source route-map ISP1 interface Dialer1 overload
ip nat inside source route-map ISP2 interface FastEthernet0/1 overload
!
ip access-list extended local_ISP1
permit ip host 195.46.102.X any
ip access-list extended local_ISP2
permit ip host 195.206.58.X any
!
dialer-list 1 protocol ip permit
route-map rm_local permit 10
match ip address local_ISP1
match interface Dialer1
set ip next-hop 213.228.116.Y
!
route-map rm_local permit 20
match ip address local_ISP2
match interface FastEthernet0/1
set ip default next-hop 195.206.58.Y
!
route-map ISP2 permit 10
match interface FastEthernet0/1
!
route-map ISP1 permit 10
match interface Dialer1

_____________________________

Делаю ping 77.88.21.8 из внутренней сети (с адреса 172.25.1.111), пинг не проходит но трансляция есть. Значит нат работет...
---NAT---
Router#sh ip nat tr
Pro Inside global      Inside local       Outside local      Outside global
icmp 195.206.58.X:0  172.25.0.1:0       213.228.116.Y:0  213.228.116.Y:0
icmp 195.206.58.X:1024 172.25.1.111:1024 77.88.21.8:1024   77.88.21.8:1024
icmp 195.206.58.X:1  195.206.58.X:1   195.206.58.Y:1   195.206.58.Y:1


Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Два провайдера - PBR + NAT"  +/
Сообщение от merko2005yandex.ru on 13-Окт-09, 17:16 
up
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Два провайдера - PBR + NAT"  +/
Сообщение от merko email(??) on 14-Окт-09, 06:34 
ПИПЕЦ
нашел ошибку
ip route 0.0.0.0 0.0.0.0 Dialer1 50 track 1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 100 track 2

а надо
ip route 0.0.0.0 0.0.0.0 213.228.116.X 50 track 1
ip route 0.0.0.0 0.0.0.0 195.206.58.X 100 track 2

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Два провайдера - PBR + NAT"  +/
Сообщение от Myxa email(??) on 14-Окт-09, 10:20 
>нашел ошибку
>ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 100 track 2

Вообще, категорически не рекомендуется делать статику на широковещательный интерфейс, в этом случае - только на адрес

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру