The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"проблема с двумя провайдерами в cisco 871 "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 15-Авг-16, 14:57 
Добрый день. Помогите разобраться в проблеме!?
Есть железка: cisco 871, два провайдера: "гига" и "мега"
С "гига" нужно в сеть (10 ПК) раздавать интернет.
При помощи "мега" пользователи слинкованы с др. офисом.

Так вот, при данном конфиге очень странно работает интернет, любые странички открываются очень медленно (2-3 мин)... Почему так ?

Если ткнуть "гига"ой  на прямую в ПК проблем нет...

proba#sh run
Building configuration...


version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname proba
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
memory-size iomem 10
ip source-route
!
!
!
!
ip cef
ip domain name mbt.local
ip name-server 77.88.8.1
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel1
description office 1 - office 2
ip address 10.50.200.2 255.255.255.252
tunnel source FastEthernet4                Туннель через провайдера "мега"
tunnel mode ipip                    Провайдер даёт только ЛВС 100 м\бит.
tunnel destination 10.58.45.1                Интернета нет.
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
switchport access vlan 2
!
interface FastEthernet4
ip address 10.66.6.68 255.255.255.0            Линк "мега"
duplex auto
speed auto
!
interface Vlan1
ip address 10.70.74.5 255.255.255.0            ЛВС на 10 ПК(все пк прописанны статикой - dhcp нет)
ip nat inside
ip virtual-reassembly
!
interface Vlan2
ip address 85.x.x.x 255.255.255.252            Линк "гига" с которого надо раздавать интернет
ip nat outside
ip virtual-reassembly
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface Vlan2 overload
ip route 0.0.0.0 0.0.0.0 10.49.5.1
ip route 0.0.0.0 0.0.0.0 Vlan2 85.173.81.105
ip route 10.x.x.x 255.255.255.0 Tunnel1            ресурсы в удаленном офисе
ip route 10.x.x.x 255.255.255.0 Tunnel1            ресурсы в удаленном офисе

!
access-list 1 permit 10.70.74.0 0.0.0.255        
!
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 2 in
exec-timeout 60 0
privilege level 15
logging synchronous
transport input ssh
!
end
      

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от Roman (??) on 15-Авг-16, 18:01 
а вот это :
ip route 0.0.0.0 0.0.0.0 10.49.5.1
зачем?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 16-Авг-16, 10:05 
> а вот это :
> ip route 0.0.0.0 0.0.0.0 10.49.5.1
> зачем?

Это шлюз "мега". Без него туннель не заводиться.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

6. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 16-Авг-16, 10:14 
>> а вот это :
>> ip route 0.0.0.0 0.0.0.0 10.49.5.1
>> зачем?
> Это шлюз "мега". Без него туннель не заводиться.

Простите, но я еще ошибся по запаре с моделькой железяки. Она 881я, я не 871

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

2. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от Andrey (??) on 15-Авг-16, 19:45 
>[оверквотинг удален]
>  no modem enable
> line aux 0
> line vty 0 4
>  access-class 2 in
>  exec-timeout 60 0
>  privilege level 15
>  logging synchronous
>  transport input ssh
> !
> end

Про второй дефолтовый маршрут уже написали. Я добавлю что dns server лучше вынести с С871. При нынешних сайтах лучше поставить хотя-бы "малинку" для этих целей, но не маршрутизатор такого уровня. Кстати можете проверить загрузку CPU.

И чтобы потом не было вопросов про медленный туннель: проверьте MTU/MSS на туннеле и поставьте нужные числа с обоих сторон. Это частая проблема при различных проблемах на тунельных интерфейсах.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 16-Авг-16, 10:07 
>[оверквотинг удален]
>>  transport input ssh
>> !
>> end
> Про второй дефолтовый маршрут уже написали. Я добавлю что dns server лучше
> вынести с С871. При нынешних сайтах лучше поставить хотя-бы "малинку" для
> этих целей, но не маршрутизатор такого уровня. Кстати можете проверить загрузку
> CPU.
> И чтобы потом не было вопросов про медленный туннель: проверьте MTU/MSS на
> туннеле и поставьте нужные числа с обоих сторон. Это частая проблема
> при различных проблемах на тунельных интерфейсах.

С туннелем через "мегу" проблем нет вообще к стати...

Проблема только с интернетом (

"поставить хотя-бы "малинку"" это кто, что ?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 16-Авг-16, 10:14 
>[оверквотинг удален]
>> Про второй дефолтовый маршрут уже написали. Я добавлю что dns server лучше
>> вынести с С871. При нынешних сайтах лучше поставить хотя-бы "малинку" для
>> этих целей, но не маршрутизатор такого уровня. Кстати можете проверить загрузку
>> CPU.
>> И чтобы потом не было вопросов про медленный туннель: проверьте MTU/MSS на
>> туннеле и поставьте нужные числа с обоих сторон. Это частая проблема
>> при различных проблемах на тунельных интерфейсах.
> С туннелем через "мегу" проблем нет вообще к стати...
> Проблема только с интернетом (
> "поставить хотя-бы "малинку"" это кто, что ?

Простите, но я еще ошибся по запаре с моделькой железяки. Она 881я, я не 871

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

11. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от Andrey (??) on 16-Авг-16, 13:34 
>[оверквотинг удален]
>> Про второй дефолтовый маршрут уже написали. Я добавлю что dns server лучше
>> вынести с С871. При нынешних сайтах лучше поставить хотя-бы "малинку" для
>> этих целей, но не маршрутизатор такого уровня. Кстати можете проверить загрузку
>> CPU.
>> И чтобы потом не было вопросов про медленный туннель: проверьте MTU/MSS на
>> туннеле и поставьте нужные числа с обоих сторон. Это частая проблема
>> при различных проблемах на тунельных интерфейсах.
> С туннелем через "мегу" проблем нет вообще к стати...
> Проблема только с интернетом (
> "поставить хотя-бы "малинку"" это кто, что ?

https://www.raspberrypi.org/

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от rusadmin (ok) on 16-Авг-16, 11:57 

> Так вот, при данном конфиге очень странно работает интернет, любые странички открываются
> очень медленно (2-3 мин)... Почему так ?

судя по симптомам проблема с MTU, хотя не вижу, чтобы инет через тоннели ходил. Если только у провайдера где то MTU <1500
Попробуйте на внешнем интерфейсе повесить
interface Vlan2
ip mtu 1400
ip tcp adj 1360

Значения с потолка взяты.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 16-Авг-16, 12:22 
>> Так вот, при данном конфиге очень странно работает интернет, любые странички открываются
>> очень медленно (2-3 мин)... Почему так ?
> судя по симптомам проблема с MTU, хотя не вижу, чтобы инет через
> тоннели ходил. Если только у провайдера где то MTU <1500
> Попробуйте на внешнем интерфейсе повесить
> interface Vlan2
>  ip mtu 1400
>  ip tcp adj 1360
> Значения с потолка взяты.

возьму на заметку совет c MTU провайдера "гига" ( он к стати г.вно:)) Но, что дают, то и берём...

Интернет по тоннелю не ходит... Он только в ЛВС на 10пк должен раздаваться и всё.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от rusadmin (ok) on 16-Авг-16, 12:25 
>[оверквотинг удален]
>> тоннели ходил. Если только у провайдера где то MTU <1500
>> Попробуйте на внешнем интерфейсе повесить
>> interface Vlan2
>>  ip mtu 1400
>>  ip tcp adj 1360
>> Значения с потолка взяты.
> возьму на заметку совет c MTU провайдера "гига" ( он к стати
> г.вно:)) Но, что дают, то и берём...
> Интернет по тоннелю не ходит... Он только в ЛВС на 10пк должен
> раздаваться и всё.

а я и не писал, что он ходит по тоннелю. Я писал касаемо исключительно инета.

Плюс ко всему замените маршрут ip route 0.0.0.0 0.0.0.0 10.49.5.1 на более точный. Два маршрута по умолчанию в разные, по назначению, сети будут только мешать друг другу.
Например
ip route 10.58.45.1 255.255.255.255 10.49.5.1

Плюс ко всему № 2: в тоннеле настройте ip mtu и ip tcp adj. Вам провайдер канал дает с размером пакета не более 1500. Минус заголовки IP (тоннель). Вот и считайте.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 16-Авг-16, 12:43 
>[оверквотинг удален]
> а я и не писал, что он ходит по тоннелю. Я писал
> касаемо исключительно инета.
> Плюс ко всему замените маршрут ip route 0.0.0.0 0.0.0.0 10.49.5.1 на более
> точный. Два маршрута по умолчанию в разные, по назначению, сети будут
> только мешать друг другу.
> Например
> ip route 10.58.45.1 255.255.255.255 10.49.5.1
> Плюс ко всему № 2: в тоннеле настройте ip mtu и ip
> tcp adj. Вам провайдер канал дает с размером пакета не более
> 1500. Минус заголовки IP (тоннель). Вот и считайте.

Вот мне тоже кажется вся проблема тут: "ip route 0.0.0.0 0.0.0.0 10.49.5.1"
Пробую поменять маршрут на предложенный Вами.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

12. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от rusadmin (ok) on 18-Авг-16, 06:59 
>[оверквотинг удален]
>> Плюс ко всему замените маршрут ip route 0.0.0.0 0.0.0.0 10.49.5.1 на более
>> точный. Два маршрута по умолчанию в разные, по назначению, сети будут
>> только мешать друг другу.
>> Например
>> ip route 10.58.45.1 255.255.255.255 10.49.5.1
>> Плюс ко всему № 2: в тоннеле настройте ip mtu и ip
>> tcp adj. Вам провайдер канал дает с размером пакета не более
>> 1500. Минус заголовки IP (тоннель). Вот и считайте.
> Вот мне тоже кажется вся проблема тут: "ip route 0.0.0.0 0.0.0.0 10.49.5.1"
> Пробую поменять маршрут на предложенный Вами.

результаты отпишите, думаю, есть люди кому тоже интересен данный вопрос

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 19-Авг-16, 13:15 
>[оверквотинг удален]
>>> точный. Два маршрута по умолчанию в разные, по назначению, сети будут
>>> только мешать друг другу.
>>> Например
>>> ip route 10.58.45.1 255.255.255.255 10.49.5.1
>>> Плюс ко всему № 2: в тоннеле настройте ip mtu и ip
>>> tcp adj. Вам провайдер канал дает с размером пакета не более
>>> 1500. Минус заголовки IP (тоннель). Вот и считайте.
>> Вот мне тоже кажется вся проблема тут: "ip route 0.0.0.0 0.0.0.0 10.49.5.1"
>> Пробую поменять маршрут на предложенный Вами.
> результаты отпишите, думаю, есть люди кому тоже интересен данный вопрос

Эксперименты будут проводиться 22,23.08.16... По результатам отпишусь обязательно

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от vadoc email(ok) on 31-Авг-16, 08:58 
>[оверквотинг удален]
>>>> только мешать друг другу.
>>>> Например
>>>> ip route 10.58.45.1 255.255.255.255 10.49.5.1
>>>> Плюс ко всему № 2: в тоннеле настройте ip mtu и ip
>>>> tcp adj. Вам провайдер канал дает с размером пакета не более
>>>> 1500. Минус заголовки IP (тоннель). Вот и считайте.
>>> Вот мне тоже кажется вся проблема тут: "ip route 0.0.0.0 0.0.0.0 10.49.5.1"
>>> Пробую поменять маршрут на предложенный Вами.
>> результаты отпишите, думаю, есть люди кому тоже интересен данный вопрос
> Эксперименты будут проводиться 22,23.08.16... По результатам отпишусь обязательно

Эксперемент затянулся немного :) Проблема решилась! Спасибо большое всем за помощь. Отдельно спасибо "rusadmin":

"Плюс ко всему замените маршрут ip route 0.0.0.0 0.0.0.0 10.49.5.1 на более точный. Два маршрута по умолчанию в разные, по назначению, сети будут только мешать друг другу.
Например
ip route 10.58.45.1 255.255.255.255 10.49.5.1"

Это действительно решило проблему. Скорее всего "железка" тупила при двух одинаковых маршрутах вида:

ip route 0.0.0.0 0.0.0.0 10.49.5.1
ip route 0.0.0.0 0.0.0.0 Vlan2 85.173.81.105


Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "проблема с двумя провайдерами в cisco 871 "  +/
Сообщение от ShyLion (ok) on 31-Авг-16, 16:48 
> Это действительно решило проблему. Скорее всего "железка" тупила при двух одинаковых маршрутах
> вида:
> ip route 0.0.0.0 0.0.0.0 10.49.5.1
> ip route 0.0.0.0 0.0.0.0 Vlan2 85.173.81.105

Она не тупила, она балансировала, половину потоков отправляла другим маршрутом.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру