The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка cisco 1841 клиента, для PPPOE "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от KudriK_TF email(ok) on 01-Фев-10, 10:04 
Народ, помогите кто может, работаю в фирме и не давно дали настроить cisco 1841 для другой организации. Сам с cisco  никогда не связывался, но порывшись в документации и мануалах маленько и разобрался и настроил для нашей местной сети, регистрация через сервер, все работает. Чтобы настроить и проверить PPPOE забрал роут домой, и вроде все делаю правильно, воспользовался конфигом "Андрея Маркелова" - http://www.markelov.net/articles.php?lng=ru&pg=128
но не работает, причем dns роут получает и транслирует на PC, с роутера сеть пингуется, пробовал на ya.ru , dhcp раздает, по настройкам вроде не отклонялся , но интернет страницы не открываются, при этом с компа я пингуется только роут, сеть и dns не видны. умные люди подсказали что вроде хоть и dns транслируются но запрос комп на них посылать надо отдельно настраивать. хотя я думаю что косяк в nat. До настройки с сайта Маркелова пользовался конфигами cisco.com - http://www.cisco.com/en/US/tech/tk175/tk15/technologies_conf... но не раздавались dns, хотя пинг на знакомые dns сервера проходил как с компа так и с естественно с роутера, но пропинговать тот же ya.ru  я не мог ни там ни там. Помогите пожалуйста. Если кого нибудь заинтересует могу выложить конфиг.
Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от maputa (ok) on 01-Фев-10, 10:24 
Скорее всего НАТ.
Нужен конфиг.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от KudriK_TF email(ok) on 01-Фев-10, 10:27 
>Скорее всего НАТ.
>Нужен конфиг.

хорошо, сейчас сделаю, сконфурю то есть (я конфиг помню до строчки), только к сожалению проверить смогу только после 6, а то я на работе сижу, как домой приеду((

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от KudriK_TF email(ok) on 01-Фев-10, 11:42 
!
version 12.4
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname run
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ANos$1YEoFkUVCQkgc7ESX0oRm1
!
aaa new-model
!
!
!
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.0.1 172.16.0.10
!
ip dhcp pool k
   import all
   network 172.16.0.0 255.255.255.0
   default-router 172.16.0.1
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
no cdp enable
hold-queue 32 in
!
interface FastEthernet0/1
no ip address
no ip unreachables
ip tcp adjust-mss 1452
shutdown
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip access-group 110 in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname omkc77009
ppp chap password 7 115A1D044713085A01
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
ip nat inside source list 102 interface Dialer0 overload
!
access-list 102 permit ip 172.16.0.0 0.0.0.255 any
access-list 110 permit tcp any any gt 1023 established
access-list 110 permit tcp any any eq www
access-list 110 permit tcp any any eq smtp
access-list 110 permit tcp any any eq pop3
access-list 110 permit tcp any any eq ftp
access-list 110 permit tcp any any eq ftp-data
access-list 110 permit tcp any any eq domain
access-list 110 permit udp any any eq domain
access-list 110 permit udp any eq domain any
access-list 110 permit tcp any eq domain any
access-list 110 deny   ip any any
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane
!
!
line con 0
exec-timeout 15 0
password 7 060506324F41
line aux 0
line vty 0 4
exec-timeout 15 0
password 7 060506324F41
!
scheduler allocate 20000 1000
end

я могу ошибаться, но вроде все было так, точнее скажу вечерком, уже дома, ребят тут есть ошибки? Пожалуйста помогите.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от shadow_alone (ok) on 01-Фев-10, 14:12 
вроде в сё нормально за исключением
shutdown на fa0/1
но думаю это опечатка.

А вы как проверяете?
может все совсем просто, то есть, вы получаете адрес по dhcp до тех пор пока он получит dns по pppoe? ну это я так, подумал, на всякий случай.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от kudrik_tf on 01-Фев-10, 18:51 
>вроде в сё нормально за исключением
>shutdown на fa0/1
>но думаю это опечатка.
>
>А вы как проверяете?
>может все совсем просто, то есть, вы получаете адрес по dhcp до
>тех пор пока он получит dns по pppoe? ну это я
>так, подумал, на всякий случай.

Спасибо что откликнулись, в инет подключениях я не силен.... да, спасибо, shutdown  малек опечатался. ситуация такая, я подключаюсь к fa 0/0 кабелем который втыкаю в сетевую компа, в fa 0/1 кабель провайдера. при этом, роутер получает через звонилку ip и раздает мне ip через dhcp, и dns, которые я проверяю в параметрах подключения на компьютере: dhcp - 172.16.0.11, dns - получил два адреса. но я теперь пропинговать ничего не могу, даже с роутера. Народ помогите, может инфа с портов что нить прояснит:
astEthernet0/0 is up, line protocol is up
  Hardware is Gt96k FE, address is 0026.cb29.94a0 (bia 0026.cb29.94a0)
  Internet address is 172.16.0.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:01:54, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/32/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     364 packets input, 42166 bytes
     Received 248 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     319 packets output, 24118 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

run#sh int fa 0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is Gt96k FE, address is 0026.cb29.94a1 (bia 0026.cb29.94a1)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1713 packets input, 155499 bytes
     Received 1498 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     334 packets output, 22218 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

run#sh int dialer 0
Dialer0 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is 109.120.27.55/32
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi1
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:37:43
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 6498 bytes
     237 packets output, 8411 bytes
Bound to:
Virtual-Access1 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP
  PPPoE vaccess, cloned from Dialer0
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di0 (Encapsulation PPP)
  Last input 00:00:56, output never, output hang never
  Last clearing of "show interface" counters 00:17:20
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     225 packets input, 6648 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     244 packets output, 8546 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

run#sh ip dns view
DNS View default parameters:
Logging is off
DNS Resolver settings:
  Domain lookup is enabled
  Default domain name:
  Domain search list:
  Lookup timeout: 3 seconds
  Lookup retries: 2
  Domain name-servers:
    217.25.209.2
    217.25.208.6
DNS Server settings:
  Forwarding of queries is enabled
  Forwarder timeout: 3 seconds
  Forwarder retries: 2

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от kudrik_tf on 01-Фев-10, 19:02 
спасибо огроменное, я не знаю как но все заработало!!!! просто чудо какое то!!! огроменное спасибо за помощь, так классно ощущать что ты не один и тебе помогут!

если кому-нибудь пригодиться вот конфигурация на Cisco 1841 Client для настройки PPPoe

Building configuration...

Current configuration : 2089 bytes
!
version 12.4
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname run
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$ANos$1YEoFkUVCQkgc7ESX0oRm1
!
aaa new-model
!
!
!
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.0.1 172.16.0.10
!
ip dhcp pool k
   import all
   network 172.16.0.0 255.255.255.0
   default-router 172.16.0.1
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
no cdp enable
hold-queue 32 in
!
interface FastEthernet0/1
no ip address
no ip unreachables
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip access-group 110 in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname omkc77009
ppp chap password 7 115A1D044713085A01
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
ip nat inside source list 102 interface Dialer0 overload
!
access-list 102 permit ip 172.16.0.0 0.0.0.255 any
access-list 110 permit tcp any any gt 1023 established
access-list 110 permit tcp any any eq www
access-list 110 permit tcp any any eq smtp
access-list 110 permit tcp any any eq pop3
access-list 110 permit tcp any any eq ftp
access-list 110 permit tcp any any eq ftp-data
access-list 110 permit tcp any any eq domain
access-list 110 permit udp any any eq domain
access-list 110 permit udp any eq domain any
access-list 110 permit tcp any eq domain any
access-list 110 deny   ip any any
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane
!
!
line con 0
exec-timeout 15 0
password 7 060506324F41
line aux 0
line vty 0 4
exec-timeout 15 0
password 7 060506324F41
!
scheduler allocate 20000 1000
end


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от angelweb email(??) on 01-Фев-10, 20:38 
>спасибо огроменное, я не знаю как но все заработало!!!! просто чудо какое
>то!!! огроменное спасибо за помощь, так классно ощущать что ты не
>один и тебе помогут!
>

Начинающим так же рекомендую http://faq-cisco.ru/

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Настройка cisco 1841 клиента, для PPPOE "  +/
Сообщение от KudriK_TF (ok) on 02-Фев-10, 05:37 

>Начинающим так же рекомендую http://faq-cisco.ru/

спасибо!! я туда уже заходил!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру