The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"как правильно настроить маршрут"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"как правильно настроить маршрут"  +/
Сообщение от diman_neo (ok) on 20-Мрт-10, 01:20 
Есть 2 cisco 877 на одной инет adsl на другой l2tp + локалка (билайн)
так вот поднят туннель и все бы хорошо но, циска не видит локалку от билайна.
с циски 1 я в локалку могу ходить легко а вот с 2 нет (та локалка которая приходит по dhcp на vlan1)

вот схема сети http://s12.radikal.ru/i185/1003/81/26b2e21e8bd2.jpg
конфиг первой "1"
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname neocisco
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
!
!
ip ddns update method no-ip.org
HTTP
  add http://xxxxxxxxxxxxxxxx@dynupdate.no-ip.com/nic/updateh...
xxxxxxxxxxxxx&myip=
  remove xxxxxxxxxxxxxxxxxxxxxx@dynupdate.no-ip.com/nic/updatehostname
=xxxxxxxxxxxx
interval maximum 20 0 0 0
interval minimum 0 0 20 0
!
!
multilink bundle-name authenticated
!
!
username Cisco privilege 15 password 0 xxxxxxxxxx
!
!
archive
log config
  hidekeys
!
!
pseudowire-class class1
encapsulation l2tpv2
ip local interface FastEthernet0
!
!
!
!
interface Tunnel1
description tunnel to Kolia
ip address 10.10.20.20 255.255.255.0
ip virtual-reassembly
ip tcp adjust-mss 1436
tunnel source Virtual-PPP1
tunnel destination xxxxxxxxxxxxx
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
switchport access vlan 300
!
interface FastEthernet2
switchport access vlan 300
!
interface FastEthernet3
switchport access vlan 300
!
interface Virtual-PPP1
ip ddns update hostname xxxxxxxxxxxxx
ip ddns update no-ip.org host xxxxxxxxxxxxx
ip address negotiated
ip nat outside
ip virtual-reassembly
no cdp enable
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxx
ppp chap password 0 35383131
pseudowire xxxxxxxxxxxxx 10 pw-class class1
!
interface Vlan1
ip address dhcp
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1400
!
interface Vlan300
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1400
!
interface Vlan100
no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 192.168.0.0 255.255.255.0 Tunnel1
ip route 192.168.1.0 255.255.255.0 Tunnel1
ip route 192.168.5.0 255.255.255.0 Tunnel1
ip route 10.0.0.0 255.0.0.0 dhcp
ip route 85.21.72.83 255.255.255.255 dhcp
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Tunnel1 overload
ip nat inside source list 100 interface Tunnel1 overload
ip nat inside source list LAN interface Vlan1 overload
ip nat inside source list TUN interface Tunnel1 overload
ip nat inside source list WAN interface Virtual-PPP1 overload
ip nat inside source static tcp 10.10.10.1 23 interface Virtual-PPP1 22
ip nat inside source static tcp 10.10.10.10 2000 interface Vlan1 2000
ip nat inside source static udp 10.10.10.10 2000 interface Vlan1 2000
!
ip access-list extended LAN
permit ip 10.10.10.0 0.0.0.255 10.0.0.0 0.255.255.255
permit ip 10.10.10.0 0.0.0.255 83.102.146.0 0.0.0.231
permit ip 10.10.10.0 0.0.0.255 host 85.21.29.242
permit ip 10.10.10.0 0.0.0.255 85.21.79.0 0.0.0.255
permit ip 10.10.10.0 0.0.0.255 85.21.90.0 0.0.0.255
permit ip 10.10.10.0 0.0.0.255 host 195.14.50.16
permit ip 10.10.10.0 0.0.0.255 host 195.14.50.26
permit ip 10.10.10.0 0.0.0.255 0.0.0.0 255.255.255.0
permit ip 10.10.10.0 0.0.0.255 host 85.21.72.83
permit ip 10.10.10.0 0.0.0.255 85.21.72.0 0.0.0.255
permit ip 10.10.20.0 0.0.0.255 10.0.0.0 0.255.255.255
ip access-list extended TUN
permit ip 10.10.10.0 0.0.0.255 192.168.0.0 0.0.0.255
permit ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
ip access-list extended WAN
permit ip 10.10.10.0 0.0.0.255 any
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password xxxxxxxx
login local
!
scheduler max-task-time 5000
end


конфиг второй "2"

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool inet
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.100 255.255.255.0
   dns-server 85.175.46.130 85.175.46.122
!
!
ip domain name cisco_adsl
!
multilink bundle-name authenticated
!
!
username cisco privilege 15 password 0 xxxxxx
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface Tunnel1
description tunnel to dima
ip address 10.10.20.21 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1436
tunnel source Dialer0
tunnel destination xxxxxxxxx
!
interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
pvc 0/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface FastEthernet0
switchport access vlan 100
!
interface FastEthernet1
switchport access vlan 200
!
interface FastEthernet2
switchport access vlan 300
!
interface FastEthernet3
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
rate-limit input 512000 96000 192000 conform-action transmit exceed-action drop
rate-limit output 1024000 192000 384000 conform-action transmit exceed-action d
rop
!
interface Vlan200
ip address 192.168.1.100 255.255.255.0
ip nat inside
ip virtual-reassembly
rate-limit input 512000 96000 192000 conform-action transmit exceed-action drop
rate-limit output 2048000 384000 768000 conform-action transmit exceed-action d
rop
!
interface Vlan300
ip address 192.168.5.5 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxxxxxxxxxxxxxxxxx
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.0.0.0 255.0.0.0 Tunnel1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.0.240 5060 interface Dialer0 5060
ip nat inside source static tcp 192.168.0.240 5061 interface Dialer0 5061
ip nat inside source static tcp 10.10.10.100 51017 interface Dialer0 51017
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 10.10.10.0 0.0.0.255
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password xxxxxxx
login local
!
scheduler max-task-time 5000
end

  

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "как правильно настроить маршрут"  +/
Сообщение от Gbyte email(ok) on 20-Мрт-10, 11:25 
>Есть 2 cisco 877 на одной инет adsl на другой l2tp +
>локалка (билайн)
>так вот поднят туннель и все бы хорошо но, циска не видит
>локалку от билайна.
>с циски 1 я в локалку могу ходить легко а вот с
>2 нет (та локалка которая приходит по dhcp на vlan1)

на схеме не понятно его есть локлка билайна.

покажи #sho ip route и трасировку какого-либо ip-адреса в локалке билайна с обоих рутеров.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "как правильно настроить маршрут"  +/
Сообщение от diman_neo email(ok) on 21-Мрт-10, 15:11 
>[оверквотинг удален]
>>локалка (билайн)
>>так вот поднят туннель и все бы хорошо но, циска не видит
>>локалку от билайна.
>>с циски 1 я в локалку могу ходить легко а вот с
>>2 нет (та локалка которая приходит по dhcp на vlan1)
>
>на схеме не понятно его есть локлка билайна.
>
>покажи #sho ip route и трасировку какого-либо ip-адреса в локалке билайна с
>обоих рутеров.

Все победил.
на маршрутизаторе 1 нужно было ip компа внести в acces list LAN и ip туннеля тоже.
ну и косяк был в маске. теперь все работает отлично. Кент доволен, ну и для меня как для новичка это очередная победа.!!!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру