The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"добавить аттрибут в radius-пакет"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (AAA, Radius, Tacacs)
Изначальное сообщение [ Отслеживать ]

"добавить аттрибут в radius-пакет"  +/
Сообщение от Yury (??) on 07-Апр-10, 12:27 
Добрый день.

Не подскажите команду, которой можно добавить аттрибуты
        Acct-Input-Octets
        Acct-Output-Octets
        Acct-Input-Packets
        Acct-Output-Packets
        Acct-Session-Time
в interim-update пакеты, которые голосовая кошка шлет радиусу. К сожалению, сейчас в interim-update нет таких аттрибутов, что сказывается на неправильной тарификации звонков.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "добавить аттрибут в radius-пакет"  +/
Сообщение от sproot (ok) on 07-Апр-10, 14:05 
>Добрый день.
>
>Не подскажите команду, которой можно добавить аттрибуты
>        Acct-Input-Octets
>        Acct-Output-Octets
>        Acct-Input-Packets
>        Acct-Output-Packets
>        Acct-Session-Time
>в interim-update пакеты, которые голосовая кошка шлет радиусу. К сожалению, сейчас в
>interim-update нет таких аттрибутов, что сказывается на неправильной тарификации звонков.

Версия ios? При таких настройках все работает:

aaa accounting delay-start
aaa accounting suppress null-username
aaa accounting update periodic 10 jitter maximum 10
aaa accounting network default start-stop group radius
aaa accounting system default start-stop group radius

radius-server attribute 44 include-in-access-req
radius-server attribute nas-port format e SSSSAPPPUUUUUUUUUUUUUUUUUUUUUUUU
radius-server dead-criteria time 120 tries 50
radius-server host x.x.x.x auth-port 1812 acct-port 1813
radius-server timeout 160
radius-server deadtime 1440
radius-server vsa send accounting
radius-server vsa send authentication


IOS (tm) C2600 Software (C2600-TELCO-M), Version 12.3(6f), RELEASE SOFTWARE (fc1)

Смотрите чего не хватает. Подозреваю, что трабла где-то в районе aaa accounting update ..

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "добавить аттрибут в radius-пакет"  +/
Сообщение от Yury (??) on 08-Апр-10, 13:11 
Железо 5300.

Странная ситуация, поскольку аттрибутов нет только для голосовых звонков, для диалапа они есть.

Смотрим пункт 5.3
http://www.faqs.org/rfcs/rfc2866.html

написано, что все нужные аттрибуты правильно применять только к Stop пакету. Тогда каким образом они выставляются в Interim-пакетах при диалапе. Можете прояснить ситуацию.


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "добавить аттрибут в radius-пакет"  +/
Сообщение от sproot (ok) on 08-Апр-10, 14:07 
>[оверквотинг удален]
>
>Странная ситуация, поскольку аттрибутов нет только для голосовых звонков, для диалапа они
>есть.
>
>Смотрим пункт 5.3
>http://www.faqs.org/rfcs/rfc2866.html
>
>написано, что все нужные аттрибуты правильно применять только к Stop пакету. Тогда
>каким образом они выставляются в Interim-пакетах при диалапе. Можете прояснить ситуацию.
>

Конфиг pls.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "добавить аттрибут в radius-пакет"  +/
Сообщение от Yury (??) on 08-Апр-10, 16:54 
Конфиг

!RANCID-CONTENT-TYPE: cisco

!

!Chassis type: AS5300 - a AS5300 router

!CPU: R4K, R4700 CPU at 150Mhz, impl 33, Rev 1.0, 512KB L2 Cache

!

!Memory: main 131072K/16384K

!Memory: nvram 128K

!

!Processor ID: 19562246

!

!Power: Redundant Power System is not present.

!

!Image: Software: C5300-IK8S-M, 12.2(11)T11,  RELEASE SOFTWARE (fc1)

!Image: Compiled: Thu 15-Apr-04 15:51 by hqluong

!Image: flash:c5300-ik8s-mz.122-11.T11.bin

!

!ROM Bootstrap: Version 12.0(2)XD1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

!BOOTLDR: Version 12.2(15)T10,  RELEASE SOFTWARE (fc2)

!

!

!

!BootFlash: Boot flash directory:

!BootFlash: File  Length   Name/status

!BootFlash:   1   2321744  c5300-boot-mz.122-15.T10.bin
!BootFlash:   2   10397    viaton.tcl
!BootFlash:   3   2381556  c5300-boot-mz.123-6e.bin
!BootFlash: [4713892 bytes used, 3674716 available, 8388608 total]

!BootFlash: 8192K bytes of processor board Boot flash (Read/Write)

!

!Flash: System flash directory:

!Flash: File  Length   Name/status

!Flash:   1   11479204  c5300-ik8s-mz.122-11.T11.bin
!Flash:   2   504964   vcw-vfc-mz.c549.hc.11.31.bin
!Flash:   3   451126   mica-modem-pw.2.9.5.0.bin
!Flash:   4   471236   vcw-vfc-mz.c549.hc.10.27.bin
!Flash: [12906788 bytes used, 3870428 available, 16777216 total]

!Flash: 16384K bytes of processor board System flash (Read/Write)

!

!Flash: nvram: Directory of nvram:/

!Flash: nvram:   109  -rw-       10734              <no date>  startup-config

!Flash: nvram:   110  ----        1110              <no date>  private-config

!Flash: nvram:     1  ----          13              <no date>  persistent-data

!Flash: nvram:     2  -rw-           0              <no date>  ifIndex-table

!Flash: nvram:     3  ----          12              <no date>  persistant-data

!Flash: nvram: 124920 bytes total (109952 bytes free)

!

!Flash: bootflash: Directory of bootflash:/

!Flash: bootflash:     1  -rw-     2321744   Mar 09 2004 15:28:27  c5300-boot-mz.122-15.T10.bin

!Flash: bootflash:     2  -rw-       10397   Feb 17 2005 07:51:50  viaton.tcl

!Flash: bootflash:     3  -rw-     2381556   Jun 16 2009 17:31:03  c5300-boot-mz.123-6e.bin

!Flash: bootflash: 8388608 bytes total (3674716 bytes free)

!

!Interface: LANCE unit 0

!       cable type : No cable

!       cable type : V.35 DTE cable

!       cable type : No cable

!       cable type : No cable

!

!

!

!

!Modem: IOS-Bundled Default Firmware-Filename             Version  Firmware-Type

!Modem: =====================================             =======  =============

!Modem: system:/ucode/mica_board_firmware                 3.0.2.0  Mica Boardware

!Modem: system:/ucode/mica_port_firmware                  2.9.2.0  Mica Portware

!Modem: system:/ucode/microcom_firmware                   5.2.30   Microcom F/W and DSP

!Modem: On-Flash Firmware-Filename                        Version  Firmware-Type

!Modem: ==========================                        =======  =============

!Modem: flash:mica-modem-pw.2.9.5.0.bin                   2.9.5.0  Mica Portware

!Modem: SPE-# SPE-Type   SPE-Range     Version    Upgrade Firmware-Filename

!Modem: 1/0   MICA-DMM   1/0   - 1/11  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/1   MICA-DMM   1/12  - 1/23  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/2   MICA-DMM   1/24  - 1/35  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/3   MICA-DMM   1/36  - 1/47  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/4   MICA-DMM   1/48  - 1/59  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/5   MICA-DMM   1/60  - 1/71  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/6   MICA-DMM   1/72  - 1/83  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!Modem: 1/7   MICA-DMM   1/84  - 1/95  2.9.5.0    N/A     flash:mica-modem-pw.2.9.5.0.bin

!

!

config-register 0x2102

version 12.2

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname Viaton-MSK

!

aaa new-model

aaa session-mib disconnect

!

aaa authentication login default group tacacs+ local

aaa authentication login h323 group radius

aaa authentication login CONSOLE local

aaa authentication ppp default group radius

aaa authentication ppp dialup group radius

aaa authorization exec h323 group radius

aaa accounting delay-start

aaa accounting update newinfo periodic 1

aaa accounting network default start-stop group radius

aaa accounting connection h323 start-stop group radius

aaa nas port extended

aaa session-id common

enable secret 5 $1$JXRj$B220Fjo2CUXPmZht/ntts0

!

username xxxxxx password xxxxxxxxxxxxx

spe 1/0 1/8

firmware location flash:mica-modem-pw.2.9.5.0.bin

!

resource-pool disable

clock timezone MSK 3

clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

!

modem country mica russia

ip subnet-zero

no ip source-route

no ip rcmd domain-lookup

ip rcmd remote-host root 10.73.192.34 root enable

ip rcmd remote-host root 10.73.192.37 root enable

ip rcmd remote-host root 10.73.192.47 root enable

ip rcmd rsh-enable

ip domain name new-service.ru

ip name-server 10.73.194.253

ip name-server 10.73.192.33

!

isdn switch-type primary-net5

isdn voice-call-failure 0

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "AT" OK "ATDT \T" TIMEOUT 60 CONNECT \c

modemcap entry V-92:MSC=&F&D2S54=16584S0=0S29=12S21=15S62=8S63=3S34=18000S40=10S10=50:TPL=mica

modemcap entry My-Mica:MSC=&F&D2S54=16584S0=0S29=12S21=15S62=8S63=3S34=18000S35=500S40=16S10=50S39=3S59=3:TPL=mica

!

voice hunt user-busy

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service pots

fax protocol t38 ls-redundancy 0 hs-redundancy 0

!

voice service voip

signaling forward unconditional

fax protocol t38 ls-redundancy 0 hs-redundancy 0

h323

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

codec preference 4 g726r32

codec preference 5 g726r24

codec preference 6 g726r16

codec preference 7 g723ar63

codec preference 8 g723ar53

codec preference 9 g723r63

!

fax interface-type modem

mta receive maximum-recipients 0

!

controller E1 0

framing NO-CRC4

clock source line primary

pri-group timeslots 1-31

description -- To Equant

!

controller E1 1

shutdown

clock source line secondary 1

!

controller E1 2

shutdown

clock source line secondary 2

!

controller E1 3

shutdown

clock source line secondary 3

!

gw-accounting aaa

method voip

!

translation-rule 3331

Rule 0 ^3338.% 8 ANY subscriber

!

translation-rule 7452679

Rule 1 * 8080#8495 ANY unknown

!

translation-rule 9000

Rule 1 * 8081# ANY unknown

!

translation-rule 8812801

Rule 0 ^88128010 0 ANY unknown

Rule 1 ^88128011 1 ANY unknown

Rule 2 ^88128012 2 ANY unknown

Rule 3 ^88128013 3 ANY unknown

Rule 4 ^88128014 4 ANY unknown

Rule 5 ^88128015 5 ANY unknown

Rule 6 ^88128016 6 ANY unknown

Rule 7 ^88128017 7 ANY unknown

Rule 8 ^88128018 8 ANY unknown

Rule 9 ^88128019 9 ANY unknown

!

translation-rule 88128011

Rule 0 any 8127186960 ANY national

!

interface Loopback0

description --- Viaton-MSK address ---

ip address 10.73.192.15 255.255.255.255

h323-gateway voip bind srcaddr 80.73.192.15

!

interface Tunnel0

description --- Tunnel to VMB-Service via Equant ---

no ip address

tunnel source FastEthernet0

tunnel destination 10.73.192.65

tunnel sequence-datagrams

tunnel path-mtu-discovery

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

description --- Viaton to SPB/Chappy Serial 2/3 ---

bandwidth 2048

ip address 10.73.192.146 255.255.255.252

ip access-group 10 in

fair-queue

!

interface Serial2

no ip address

shutdown

no fair-queue

!

interface Serial3

no ip address

shutdown

no fair-queue

!

interface Serial0:15

no ip address

encapsulation ppp

no logging event link-status

no snmp trap link-status

isdn switch-type primary-net5

isdn not-end-to-end 56

isdn incoming-voice modem

isdn T309-enable

isdn T203 30000

isdn T310 60000

isdn send-alerting

isdn bchan-number-order ascending

isdn sending-complete

no fair-queue

no cdp enable

!

interface FastEthernet0

description --- To Equant ---

ip address 125.121.242.141 255.255.255.252

ip access-group 30 in

duplex full

speed 100

no cdp enable

!

interface Group-Async0

description --- Viaton-MSK ---

ip unnumbered FastEthernet0

ip access-group 100 out

encapsulation ppp

no logging event link-status

async mode dedicated

no snmp trap link-status

peer default ip address pool VIATON_POOL

ppp max-bad-auth 3

ppp authentication pap chap

group-range 1 96

!

ip local pool VIATON_POOL 125.121.60.129 195.151.60.190

ip classless

ip route 0.0.0.0 0.0.0.0 125.121.242.142

ip route 10.73.192.0 255.255.240.0 10.73.192.145 25

ip tacacs source-interface Loopback0

no ip http server

!

ip radius source-interface Loopback0

!

logging trap debugging

logging facility local1

logging 10.73.192.34

access-list 1 permit 10.73.192.34

!

tacacs-server host 10.73.192.34

tacacs-server key xxxxxx

snmp-server community superplus RW 2

snmp-server community vivisection RO 1

snmp-server enable traps tty

!

radius-server host 10.73.192.56 auth-port 1812 acct-port 1813

radius-server retransmit 3

radius-server attribute 8 include-in-access-req

radius-server attribute 44 include-in-access-req

radius-server attribute nas-port format c

radius-server attribute list u

!

radius-server key 7 08235949081E04

radius-server authorization permit missing Service-Type

radius-server vsa send accounting

radius-server vsa send authentication

call rsvp-sync

!

call application voice debit_card_ivr2 tftp://10.73.192.41/utm/ivr/netup_debit_card_ivr.1.0.0.tcl

call application voice debit_card_ivr2 uid-len 12

call application voice debit_card_ivr2 pin-len 10

call application voice debit_card_ivr2 warning-time 10

call application voice debit_card_ivr2 retry-count 2

call application voice debit_card_ivr2 language 1 ru

call application voice debit_card_ivr2 language 2 en

call application voice debit_card_ivr2 set-location ru 0 tftp://10.73.192.41/utm/ivr/prompts/ru/

call application voice debit_card_ivr2 set-location en 0 tftp://10.73.192.41/vmb/en/

!

voice-port 0:D

output attenuation 1

echo-cancel coverage 32

cptone RU

description -- Equant --

bearer-cap 3100Hz

!

mgcp profile default

!

dial-peer cor custom

!

dial-peer voice 2 pots

application debit_card_ivr2

incoming called-number 4117796

ip qos dscp cs5 signaling

!

dial-peer voice 8003 pots

description --- local calls to tdm ---

preference 8

destination-pattern 8916T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

no digit-strip

direct-inward-dial

port 0:D

!

dial-peer voice 8812801 pots

description --- spb calls to tdm ---

preference 8

destination-pattern 8812801T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

translate-outgoing calling 88128011

translate-outgoing called 8812801

no digit-strip

direct-inward-dial

port 0:D

!

dial-peer voice 10 voip

description --- Incoming VoIP Calls ---

incoming called-number T

voice-class codec 1

playout-delay maximum 200

playout-delay nominal 100

playout-delay minimum high

no vad

!

line con 0

login authentication CONSOLE

line 1 96

exec-timeout 20 0

no flush-at-activation

modem InOut

modem autoconfigure type My-Mica

transport output none

line aux 0

line vty 0 4

access-class 1 in

exec-timeout 60 0

escape-character 3

!

ntp server 10.73.192.1

end

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "добавить аттрибут в radius-пакет"  +/
Сообщение от sproot (ok) on 09-Апр-10, 15:24 
Эээ...да, действительно такая проблема имеет место быть. Вышеприведенный конфиг взял с pppoe терминатора.
Потом посмотрел конфиг и аккаунтинг голосовой циски(раньше, на нее не было возможности зайти) и увидел,
что в update пакетах действительно нет нужных Вам атрибутов. Посмотрел что есть в инете, прочитал это:

http://www.planetcisco.org/en/US/docs/ios/voice/cdr/develope...

и вот это:

https://cisco.com/en/US/docs/ios/voice/aaa/configuration/gui...

и пришел к выводу, что циска не добавляет эти атрибуты в update пакеты по причине их бессмысленности.
Т.к. нет смысла считать байтики разговора, в то время когда считают время разговора. Байты для разговора не актуальны,
а для передачи данных в самый раз. Может имеет смысл подойти к проблеме с другой стороны, со стороны так называемой "неправильной тарификации". С чего вдруг, она неправильная и почему она привязывается к update пакету?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "добавить аттрибут в radius-пакет"  +/
Сообщение от Yury (??) on 12-Апр-10, 11:35 
Насчет байтов я согласен, мне меня бы устроил один аттрибут Acct-Session-Time.

Дело в том, что биллинг обновляет информацию о текущей сессии на основании аттрибута Acct-Session-Time. Бывают случаи, когда сессии зависают. В таком случае звонка по факту нет на железе, но сессия присутствует в биллинге. Если клиент позвонит в такой момент биллинг не даст ему установить соединение, поскольку с точки зрения биллинга он уже говорит (есть текущая сессия).

Вот чтобы отличить зависшую сессию от долгой, нужна информация из аттрибута update пакета. Если его получить нет возможности, придется изменить биллинг.


>чего вдруг, она неправильная и почему она привязывается к update пакету?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "добавить аттрибут в radius-пакет"  +/
Сообщение от sproot (ok) on 12-Апр-10, 16:36 
>Насчет байтов я согласен, мне меня бы устроил один аттрибут Acct-Session-Time.
>
>Дело в том, что биллинг обновляет информацию о текущей сессии на основании
>аттрибута Acct-Session-Time.

У меня тоже в voice аккаунтинге нет Acct-Session-Time в update пакетах.

Биллинг поддерживает только один метод трекинга сессии? Можно, например,
для промежуточного подсчета продолжительности звонка, использовать vsa аттрибут h323-connect-time
и вычислять разницу между приходом update пакета по данной сессии и временем в атрибуте. Конечно,
при этом VGW и радиус сервера должный быть синхронизированы с общими ntp серверами.

>Бывают случаи, когда сессии зависают. В таком случае звонка
>по факту нет на железе, но сессия присутствует в биллинге. Если
>клиент позвонит в такой момент биллинг не даст ему установить соединение,
>поскольку с точки зрения биллинга он уже говорит (есть текущая сессия).
>
>
>Вот чтобы отличить зависшую сессию от долгой, нужна информация из аттрибута update
>пакета. Если его получить нет возможности, придется изменить биллинг.

Чтобы отличить зависшую сессию от продолжительной можно считать update пакеты по данной сессии.
Если не пришло N пакетов в течении заданного промежутка времени, то тогда считать сессию зависшей и
кильнуть ее либо через POD, либо через SNMP. POD, конечно, предпочтительней, т.к. не привязывается к оборудованию.

Именно так, в настоящее время, работает наш купленный биллинг.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру