The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Помогите с VOIP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"Помогите с VOIP"  +/
Сообщение от Dak_k email(ok) on 13-Апр-10, 09:17 
Заранее прошу строго не судить. настраиваю 1 раз.

Есть 2 Роутера Cisco 2801 и 2811. телефоны с 2801 на 2811 звонят нормально. Проблема: с 2811 на 2801 звонки доходят, но когда поднимаю трубку, звенящий не понимает что трубку подняли и продолжает звонить. Что нужно? помогите плз.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Помогите с VOIP"  +/
Сообщение от xbax email(ok) on 13-Апр-10, 10:59 
>Заранее прошу строго не судить. настраиваю 1 раз.
>
>Есть 2 Роутера Cisco 2801 и 2811. телефоны с 2801 на 2811
>звонят нормально. Проблема: с 2811 на 2801 звонки доходят, но когда
>поднимаю трубку, звенящий не понимает что трубку подняли и продолжает звонить.
>Что нужно? помогите плз.

Конфиги покажи. Телефоны куда подключены?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Помогите с VOIP"  +/
Сообщение от Dak_k email(ok) on 13-Апр-10, 11:33 
>>Заранее прошу строго не судить. настраиваю 1 раз.
>>
>>Есть 2 Роутера Cisco 2801 и 2811. телефоны с 2801 на 2811
>>звонят нормально. Проблема: с 2811 на 2801 звонки доходят, но когда
>>поднимаю трубку, звенящий не понимает что трубку подняли и продолжает звонить.
>>Что нужно? помогите плз.
>
>Конфиги покажи. Телефоны куда подключены?

телефон с номером 102 подключен на 2811
телефон с номером 202 подключен на 2801

роутер 2811

...
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
fax protocol t38 ls-redundancy 2 hs-redundancy 2 fallback none
h323    
sip      
  registrar server expires max 3600 min 3600
  redirect contact order best-match
  no call service stop
!        
!        
voice class codec 1
codec preference 1 g729r8 bytes 40
codec preference 2 g711alaw
codec preference 3 g711ulaw
!        
voice class codec 3
codec preference 1 g729r8

!
voice translation-rule 1
rule 1 /2965354/ /100/
!        


!
dial-peer voice 100 voip
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:195.189.31.38
incoming called-number .
dtmf-relay rtp-nte sip-notify
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
dial-peer voice 101 voip
max-conn 4
destination-pattern 0.T
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:195.189.31.38
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
dial-peer voice 102 voip
description Almaty outgoing dial
max-conn 4
destination-pattern [1-7,9]......
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:195.189.31.38
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
dial-peer voice 103 voip
description Long-distance KZ RU
destination-pattern 8[2-9].........
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:195.189.31.38
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad  
!
!
dial-peer voice 104 voip
description Long-distance line
destination-pattern 8[10].T
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:195.189.31.38
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!  
dial-peer voice 200 voip
description to Unity Express aim device
destination-pattern 15.
voice-class codec 1
session protocol sipv2
session target ipv4:192.168.2.2
dtmf-relay sip-notify rtp-nte
no vad  
!
!
dial-peer voice 1000 pots
dial-peer voice 11 pots
destination-pattern 140
port 0/0/1
!
!
dial-peer voice 110 voip
destination-pattern 20[1-9]
voice-class codec 1
session protocol sipv2
session target ipv4:10.1.2.2
dtmf-relay sip-notify rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad  
!
!
dial-peer voice 111 voip
destination-pattern 0..
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:195.189.31.38
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad  
!
!
sip-ua    
credentials username XXXX password XXXXXXXX realm 195.189.31.38
retry invite 3
retry response 3
retry bye 3
retry cancel 3
retry options 10
timers trying 1000
registrar ipv4:195.189.31.38 expires 3600 secondary
sip-server ipv4:195.189.31.38
!!

на этом роутере мне кажется все норм, звоню в город работает, входящие тоже.
К этому роутеру протинули еще один 2801 для тестов по SIP.

вот его конфиги:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname A
!
boot-start-marker
boot-end-marker
!

!
no aaa new-model
clock timezone ALM 5
dot11 syslog
ip source-route
!
!
no ip dhcp use vrf connected
no ip dhcp conflict logging
!
ip dhcp pool dauren
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
   dns-server 192.168.1.9
   option 150 ip 192.168.2.1
!
!
ip cef
no ip domain lookup
no ipv6 cef
ntp server 192.168.1.9
!        
multilink bundle-name authenticated
!        
!        
!        
!        
!        
!        
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!        
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
fax protocol t38 ls-redundancy 2 hs-redundancy 2 fallback none
h323    
  no call service stop
sip      
  registrar server expires max 3600 min 3600
  redirect contact order best-match
  no call service stop
!        
!        
!        
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!        
voice class codec 700
codec preference 1 g711alaw
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
!        
voice-card 0
dsp services dspfarm
!        
!        
!        
!        
!        
archive  
log config
  hidekeys
!        
!        
!        
!        
!        
!        
!        
!        
!        
interface FastEthernet0/0 //локалка
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!        
interface FastEthernet0/1 // подключен к 2811
ip address 10.1.2.2 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!        
ip default-gateway 10.1.2.1
ip forward-protocol nd
ip route 192.168.1.0 255.255.255.0 10.1.2.1
ip route 192.168.2.0 255.255.255.0 10.1.2.1
no ip http server
no ip http secure-server
!        
!        
ip nat inside source list 2 interface FastEthernet0/1 overload
!        
access-list 2 permit any
dialer-list 1 protocol ip permit
!        
!        
!        
!        
!        
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
tftp-server flash:P00307020200.bin
tftp-server flash:sccp70.8-4-2s.loads
!        
control-plane
!        
!        
!        
!        
mgcp fax t38 ecm
!        
sccp local FastEthernet0/0
sccp      
!        
dspfarm profile 1 transcode  
associate application SCCP
shutdown
!        
!        
dial-peer voice 110 voip  
description Outgoing to IT
max-conn 4
destination-pattern .T
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:10.1.2.1
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad  
!        
dial-peer voice 100 voip
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:10.1.2.1
incoming called-number .
dtmf-relay rtp-nte sip-notify
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad  
!        
!        
gateway  
timer receive-rtp 1200
!        
    
!        
!        
telephony-service
sdspfarm transcode sessions 20
max-ephones 10
max-dn 150
ip source-address 192.168.3.1 port 2000
timeouts ringing 60
system message TeSt Ip PhOnE
load 7960-7940 P00307020200
load 7970 SCCP70.8-4-2S.loads
time-format 24
date-format dd-mm-yy
max-conferences 4 gain -6
call-forward pattern .T
moh music-on-hold.au
transfer-system full-consult
transfer-pattern .T
directory entry 1 711 name First Phone
directory entry 2 722 name Second Phone
directory entry 3 733 name Analogue Telephone
create cnf-files version-stamp 7960 Jul 18 2006 12:38:44
!        
    
!        
ephone-dn  2
number 202
no huntstop
!        
!        
ephone-dn  3
number 203
!        
!        
      
!        
ephone  2
device-security-mode none
mac-address 0017.A4E4.89D6
button  1:2        
!        
!        
ephone  3
device-security-mode none
mac-address 0024.BE7A.00BF
button  1:3
!        

Звонки с 202 -> 102 норм, работает! А с 102 -> 202 не видит что подняли трубку!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Помогите с VOIP"  +/
Сообщение от xbax (??) on 13-Апр-10, 11:43 
>[оверквотинг удален]
>телефон с номером 102 подключен на 2811
>телефон с номером 202 подключен на 2801
>
>роутер 2811
>
>...
>!
>interface FastEthernet0/1 // подключен к 2811
> ip address 10.1.2.2 255.255.255.0
> ip nat outside

Имхо NAT твоя проблема. Попробуй без него. Зачем он тебе вообще в этой конфигурации нужен?


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Помогите с VOIP"  +/
Сообщение от Dak_k email(ok) on 13-Апр-10, 12:38 
>[оверквотинг удален]
>>роутер 2811
>>
>>...
>>!
>>interface FastEthernet0/1 // подключен к 2811
>> ip address 10.1.2.2 255.255.255.0
>> ip nat outside
>
>Имхо NAT твоя проблема. Попробуй без него. Зачем он тебе вообще в
>этой конфигурации нужен?

Работает! Спасибо.
А если мне нужен будет NAT, Они что, совсем не совместимы? Как надо прописать НАТ, если вдруг он понадобится?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Помогите с VOIP"  +/
Сообщение от xbax (ok) on 13-Апр-10, 12:39 
>[оверквотинг удален]
>>>interface FastEthernet0/1 // подключен к 2811
>>> ip address 10.1.2.2 255.255.255.0
>>> ip nat outside
>>
>>Имхо NAT твоя проблема. Попробуй без него. Зачем он тебе вообще в
>>этой конфигурации нужен?
>
>Работает! Спасибо.
>А если мне нужен будет NAT, Они что, совсем не совместимы? Как
>надо прописать НАТ, если вдруг он понадобится?

Гугли NAT и SIP. Там не все так просто.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Помогите с VOIP"  +/
Сообщение от GolDi (??) on 13-Апр-10, 13:06 
>[оверквотинг удален]
>>>interface FastEthernet0/1 // подключен к 2811
>>> ip address 10.1.2.2 255.255.255.0
>>> ip nat outside
>>
>>Имхо NAT твоя проблема. Попробуй без него. Зачем он тебе вообще в
>>этой конфигурации нужен?
>
>Работает! Спасибо.
>А если мне нужен будет NAT, Они что, совсем не совместимы? Как
>надо прописать НАТ, если вдруг он понадобится?

Просто для понимания:
dial-peer voice 100 voip
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:10.1.2.1  вот эта строка игнорируется
incoming called-number .      при такой строке


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Помогите с VOIP"  +/
Сообщение от Dak_k email(ok) on 13-Апр-10, 13:07 
>[оверквотинг удален]
>>А если мне нужен будет NAT, Они что, совсем не совместимы? Как
>>надо прописать НАТ, если вдруг он понадобится?
>
>Просто для понимания:
>dial-peer voice 100 voip
>voice-class codec 1
>voice-class sip dtmf-relay force rtp-nte
>session protocol sipv2
>session target ipv4:10.1.2.1  вот эта строка игнорируется
>incoming called-number .      при такой строке

Понятно. СПС!


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Помогите с VOIP"  +/
Сообщение от xbax email(ok) on 15-Апр-10, 11:40 
>[оверквотинг удален]
>>
>>Просто для понимания:
>>dial-peer voice 100 voip
>>voice-class codec 1
>>voice-class sip dtmf-relay force rtp-nte
>>session protocol sipv2
>>session target ipv4:10.1.2.1  вот эта строка игнорируется
>>incoming called-number .      при такой строке
>
>Понятно. СПС!

Я бы так однозначно не говорил. Диал-пир может работать как и исходящий, так и входящий.
В этом конкретном примере строка
>>session target ipv4:10.1.2.1

не работает банально потому, что в диал пире нет строки с destination-pattern, т.е. диал пир определен пока только как входящий.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру