The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"помогите настроить 871W вешается"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"помогите настроить 871W вешается"  +/
Сообщение от PJss email on 18-Апр-10, 11:52 
Всем привет, помогите мне с одной проблемой, есть циска 871w после включения работает нормально но со временем забивается память(от использования инета зависит), в лог сваливается ошибка о недостаточной памяти и отрубается CEF после чего или просто медленней работать начинает или вешается совсем...
P.S. в в цисках мало чего понимаю потому буду признателен и за не относящиеся советы по конфигу.

логи и конфиг:

PJsCisco#sh mem alloc tota
                Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
Processor   83109BD0    70214704    46727184    23487520    23455928    23466840
      I/O    7400000    12582912     4043132     8539780     8539780     8537916

Allocator PC Summary for: Processor

    PC          Total   Count  Name
0x80A86840   12404840     376  TAL: MTRIE n08
0x80A91870    2955336      94  ADJ: adjacency
0x8006FDB8    2660960      83  ipnat localtre
0x818DE118    2503792      76  CCE dp subbloc
0x803BA318    1694420    1729  *Packet Header*
0x8002F178    1634608     204  Process Stack
0x81CF8D60    1508524      23  regex
0x80A1B490    1160920      20  CEF: fib
0x80A06A30    1116184      40  CEF: paths
0x80A54BF4     860156      16  CEF: fib GSB
0x808C151C     836672      12  Init
0x806A1830     766272      38  ARP Entry
0x80A152F8     742344      30  CEF: pathl
0x8177EA3C     732972      55  TW Buckets
0x80A45B10     679312      28  CEF: pathl ifs
0x80F5B2E0     602496      30  IP ARP Adjacen
0x80698F24     549796      27  dynamic ARP su
0x8178008C     543920       9  pak subblock chunk
0x80A2B0CC     480764      22  CEF: fib_fib_s
0x806A421C     339088      63  ARP tree node
0x80A2AECC     293612      16  CEF: fib_fib_s
0x80A52E14     262248       2  CEF: hash table
0x803E98E8     209328      76  Normal


Allocator PC Summary for: I/O

    PC          Total   Count  Name
0x803E9900    1250240      27  Normal
0x803E9840    1184000       4  FastEthernet0
0x803BA36C    1150400     631  *Packet Data*
0x81EF2474     155648     256  SEC Data Buffer
0x8055D784     116192      80  USB Startup
0x81EF2714      61504       1  SEC Crypto Pak
0x81EF24DC      24576     256  SEC Key Buffer
0x81EF2538      24576     256  SEC IPv4 Buffer
0x81EF255C      24576     256  SEC IPv4 Options Buffer
0x81EF2584      24576     256  SEC IPv6 Buffer
0x804BDDB8       8512       1  Init
0x804BDC7C       8256       1  Init
0x801270F4       1088       1  *Init*
0x8018609C       1088       1  Init
0x80260318       1088       1  Init
0x80127684       1088       1  Init
0x80127094        576       1  *Init*
0x801270B8        576       1  *Init*
0x801270DC        576       1  *Init*
0x8018608C        576       1  Init
0x80260308        576       1  Init
0x80127630        576       1  Init
0x8012764C        576       1  Init

вот этот "TAL: MTRIE n08" постепенно отжирает всю память

и в итоге вываливается подобная ошибка:


*Apr 16 23:05:12: %DNSSERVER-3-UDPDNSOVERLOAD: Low available memory: dropping <i
d# 43557> from <cli 192.168.0.52>.
*Apr 16 23:05:16: %DNSSERVER-3-UDPDNSOVERLOAD: Low available memory: dropping <i
d# 43557> from <cli 192.168.0.52>.
*Apr 16 23:05:54: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed fro
m 0x80072BB0, alignment 16
Pool: Processor  Free: 138396  Cause: Memory fragmentation
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "IP ARP Adjacency", ipl= 3, pid= 85,  -Traceback= 0x8003DC44z 0x80057
87Cz 0x80072BB4z 0x80A86844z 0x80A888DCz 0x80A88EB0z 0x80A81AC4z 0x80A0BAC4z 0x8
0A294B4z 0x80A0E124z 0x80A22B24z 0x80A22C84z 0x80A8FBD0z 0x80A919E0z 0x80A91E88z
0x80AD0D34z
*Apr 16 23:05:54: %COMMON_FIB-3-NOMEM: Memory allocation failure for validating
prefix in IPv4 CEF [0x80A3414C] (fatal) (1 subsequent failure).
*Apr 16 23:05:54: %COMMON_FIB-4-DISABLING: IPv4 CEF is being disabled due to a f
atal error.
*Apr 16 23:05:55: %DNSSERVER-3-UDPDNSOVERLOAD: Low available memory: dropping <i
d# 921> from <cli 192.168.0.52>.


конфиг

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname PJsCisco
!
boot-start-marker
boot system flash:c870-advsecurityk9-mz.124-24.T2.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization exec default local
!
!
aaa session-id common
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 3:00
!
crypto pki trustpoint TP-self-signed-4029212631
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4029212631
revocation-check none
rsakeypair TP-self-signed-4029212631
!
!
dot11 syslog
no ip source-route
!
!
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.0.50
!
ip dhcp pool LAN
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 192.168.0.1
!
!
ip cef
no ip bootp server
ip name-server 213.21.0.5
ip name-server 213.21.31.5
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username admin privilege 15 secret 5 пароль
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description === Internet ===$ETH-WAN$
ip address dhcp
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly max-reassemblies 110
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
description === LAN ===
ip address pool LAN
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ntp disable
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet4
ip http server
ip http authentication local
no ip http secure-server
!
!
ip dns server
ip dns spoofing
ip nat inside source list 1 interface FastEthernet4 overload
!
access-list 1 permit any
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
escape-character 3
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
escape-character 3
!
scheduler max-task-time 5000
ntp server 192.43.244.18
ntp server 207.46.232.182
end


пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "помогите настроить 871W вешается"  +/
Сообщение от frob (ok) on 18-Апр-10, 19:38 
>пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin

Скорее всего в обеих прошивках имеется (возможно один и тот же) баг с утечкой памяти.
Если есть контракт на поддержку откройте кейс, TAC вам этот баг идентифицирует и скажет в какой версии исправлено и/или как обойти (если есть варианты).

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "помогите настроить 871W вешается"  +/
Сообщение от ShyLion (ok) on 19-Апр-10, 09:20 
>пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin

Зачем тебе "Т" прошивки?? Они и памяти жрут больше и дыр в них больше.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "помогите настроить 871W вешается"  +/
Сообщение от PJss email on 19-Апр-10, 09:52 
>>пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin
>
>Зачем тебе "Т" прошивки?? Они и памяти жрут больше и дыр в
>них больше.

А какую тогда брать? я самую свежею старался найти

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "помогите настроить 871W вешается"  +/
Сообщение от ShyLion (ok) on 19-Апр-10, 12:29 
>А какую тогда брать? я самую свежею старался найти

Странно, на 871 нет не "Т" релизов 12.4.
Попробуй 124-15.T13

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "помогите настроить 871W вешается"  +/
Сообщение от PJss email on 19-Апр-10, 18:52 
>>А какую тогда брать? я самую свежею старался найти
>
>Странно, на 871 нет не "Т" релизов 12.4.
>Попробуй 124-15.T13

пока не нашёл 124-15.T13 залил c870-advsecurityk9-mz.151-1.T.bin
проблема вроде не появляется, весь день гоняем торенты, ошибок не появляется, роутер не виснет, есть ли смысл заливать 124 когда найду или так и остаться на 151 ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "помогите настроить 871W вешается"  +/
Сообщение от ShyLion (ok) on 20-Апр-10, 08:46 
>>>А какую тогда брать? я самую свежею старался найти
>>
>>Странно, на 871 нет не "Т" релизов 12.4.
>>Попробуй 124-15.T13
>
>пока не нашёл 124-15.T13 залил c870-advsecurityk9-mz.151-1.T.bin
>проблема вроде не появляется, весь день гоняем торенты, ошибок не появляется, роутер
>не виснет, есть ли смысл заливать 124 когда найду или так
>и остаться на 151 ?

я краем уха слышал (слышал), что в 15 софте введена активация и он какое-то время работает просто так а потом просит его купить. так-что....

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "помогите настроить 871W вешается"  +/
Сообщение от oleg_matroskin (??) on 19-Апр-10, 10:03 
>[оверквотинг удален]
> transport input telnet ssh
> escape-character 3
>!
>scheduler max-task-time 5000
>ntp server 192.43.244.18
>ntp server 207.46.232.182
>end
>
>
>пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin

ip route 0.0.0.0 0.0.0.0 FastEthernet4
пропишите маршрут правильно!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "помогите настроить 871W вешается"  +/
Сообщение от PJss email on 19-Апр-10, 10:21 
>>
>>
>>пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin
>
>ip route 0.0.0.0 0.0.0.0 FastEthernet4
>пропишите маршрут правильно!

уточните пожалуйста, поменять "FastEthernet4"  на адрес гейта?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "помогите настроить 871W вешается"  +/
Сообщение от oleg_matroskin (??) on 19-Апр-10, 11:15 
>>>
>>>
>>>пробовал с двумя прошивками  c870-advipservicesk9-mz.124-24.T3.bin и c870-advsecurityk9-mz.124-24.T2.bin
>>
>>ip route 0.0.0.0 0.0.0.0 FastEthernet4
>>пропишите маршрут правильно!
>
>уточните пожалуйста, поменять "FastEthernet4"  на адрес гейта?

Ага

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "помогите настроить 871W вешается"  +/
Сообщение от PJss email on 11-Май-10, 10:52 
Всем снова добрый день, проблема с вешаньем решилась прошивкой c870-advipservicesk9-mz.124-15.T13.bin  спасибо за советы, но теперь немного надоедает другая проблема:

Периодически вне зависимости от чего либо конкретного, даже когда меня нет дома, оборудование провайдера банит мой роутер, после звонка в тех поддержку специалисты утверждают что мой роутер начинает раздавать адреса по ДХЦП, или же я неверно воткнул кабель, но во всех этих случаях провода я даже и не трогаю и роутер не должен раздавать никаких адресов. Это может случаться раз или два в неделю, а может месяц не проявлятся. В логах иногда можно обнаружить странные записи типа
May 10 21:25:11: %DNSSERVER-3-BADQUERY: Bad DNS query from 77.73.142.209
May 10 21:25:16: %DNSSERVER-3-BADQUERY: Bad DNS query from 87.103.244.128
May 10 21:25:27: %DNSSERVER-3-BADQUERY: Bad DNS query from 87.103.244.128
адреса не из подсети провайдера и не локальные.
Отключил ДХЦП клиента на внешнем интерфейсе, не помогло.
Подскажите что можно сделать? отрубить ДХЦП совсем? нехотелось бы...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру