The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"icmp-jitter и Dialer. Как настроить?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 22-Апр-10, 15:35 
Народ помогите решить проблему. Есть два провайдера у обоих реальные IP один по Ethernet второй через (резервный) ADSl. Сначала настроил icmp-echo, все заработало. Но из-за частых переключений решил настроить icmp-jitter, на основном провайдере все заработало, но на резервном провайдера трекинг подниматься не хочет. Т.е если основной провайдер падает переключение на резервного не происходит, но когда основной поднимается канал нормально восстанавливается.
source-ip указал IP выданные провайдером.

Я так думаю что проблема в том, что при попытке прописать
set ip next-hop на второго провайдера надо писать IP адрес шлюза.
Как его прописать применительно к Dialer 0?
Провайдер говорит что шлюз выдается по DHCP и может меняться без предупреждения.

Вот кусочек конфига:
Код:

multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
initiate-to ip 192.168.100.2

track 1 ip sla 100
delay down 15 up 15
!
track 2 ip sla 200
delay down 15 up 15
!
!
!
!
interface FastEthernet0/0
ip address 192.168.100.2 255.255.255.0
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface FastEthernet0/2/0
description MAXNET
ip address *.*.*.41 255.255.255.192
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname ******-39dml1
ppp chap password 7 03560E53525A77
!
ip local policy route-map PING_POLICY
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 217.15.192.1 50 name main_ISP track 1
ip route 0.0.0.0 0.0.0.0 Dialer0 100 name reserv_ISP track 2
ip http server
ip http secure-server
!
!
ip nat inside source route-map ISP_main interface FastEthernet0/2/0 overload
ip nat inside source route-map ISP_reserv interface Dialer0 overload
!
ip access-list extended PING_DOMOLINK
permit icmp host *.*.*.170 host 62.148.128.1
ip access-list extended PING_MAXNET
permit icmp host *.*.*.41 host 195.112.96.34
!
ip sla 100
icmp-jitter 195.112.96.34 source-ip *.*.*.41 num-packets 5
timeout 10000
threshold 10000
frequency 30
ip sla schedule 100 life forever start-time now
ip sla 200
icmp-jitter 62.148.128.1 source-ip *.*.*.170 num-packets 5
timeout 10000
threshold 10000
frequency 30
ip sla schedule 200 life forever start-time now
access-list 100 deny   ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
access-list 101 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run

!
!
!
!
route-map ISP_reserv permit 10
match ip address 100
match interface Dialer0
!
route-map ISP_main permit 10
match ip address 100
match interface FastEthernet0/2/0
!
route-map PING_POLICY permit 10
match ip address PING_MAXNET
set ip next-hop 217.15.192.1
set interface FastEthernet0/2/0
!
route-map PING_POLICY permit 20
match ip address PING_DOMOLINK
set ip next-hop dynamic dhcp
set interface Dialer0

event manager applet clear_nat
event track 1 state any
action 0.9 cli command "enable"
action 1.0 cli command "clear ip nat translation *"
action 2.0 cli command "clear ip nat translation forced"
!
end


LOG

Track 1
  IP SLA 100 state
  State is Up
    24 changes, last change 01:32:04
  Delay up 15 secs, down 15 secs
  Latest operation return code: OK
  Latest RTT (millisecs) 1
  Tracked by:
    STATIC-IP-ROUTING 0
    EEM applet clear_nat
Track 2
  IP SLA 200 state
  State is Down
    5 changes, last change 03:58:15
  Delay up 15 secs, down 15 secs
  Latest operation return code: Timeout
  Tracked by:
    STATIC-IP-ROUTING 0

PSLAs Latest Operation Statistics

IPSLA operation id: 100
Type of operation: icmp-jitter
        Latest RTT: 1 milliseconds
Latest operation start time: *11:25:39.066 UTC Thu Apr 22 2010
Latest operation return code: OK
RTT Values:
        Number Of RTT: 5                RTT Min/Avg/Max: 1/1/3
Latency one-way time:
        Number of Latency one-way Samples: 0
        Source to Destination Latency one way Min/Avg/Max: 0/0/0
        Destination to Source Latency one way Min/Avg/Max: 0/0/0
Jitter Time:
        Number of SD Jitter Samples: 4
        Number of DS Jitter Samples: 4
        Source to Destination Jitter Min/Avg/Max: 0/1/1
        Destination to Source Jitter Min/Avg/Max: 0/1/1
Packet Late Arrival: 0
Out Of Sequence: 0
        Source to Destination: 0        Destination to Source 0
        In both Directions: 0
Packet Skipped: 0       Packet Unprocessed: 0
Packet Loss: 0
        Loss Period Length Min/Max: 0/0
Number of successes: 106
Number of failures: 0
Operation time to live: Forever

IPSLA operation id: 200
Type of operation: icmp-jitter
        Latest RTT: NoConnection/Busy/Timeout
Latest operation start time: *11:25:13.646 UTC Thu Apr 22 2010
Latest operation return code: Timeout
RTT Values:
        Number Of RTT: 0                RTT Min/Avg/Max: 0/0/0
Latency one-way time:
        Number of Latency one-way Samples: 0
        Source to Destination Latency one way Min/Avg/Max: 0/0/0
        Destination to Source Latency one way Min/Avg/Max: 0/0/0
Jitter Time:
        Number of SD Jitter Samples: 0
        Number of DS Jitter Samples: 0
        Source to Destination Jitter Min/Avg/Max: 0/0/0
        Destination to Source Jitter Min/Avg/Max: 0/0/0
Packet Late Arrival: 0
Out Of Sequence: 0
        Source to Destination: 0        Destination to Source 0
        In both Directions: 0
Packet Skipped: 0       Packet Unprocessed: 0
Packet Loss: 0
        Loss Period Length Min/Max: 0/0
Number of successes: 0
Number of failures: 105
Operation time to live: Forever


Уже всю голову сломал.
может у кого идеи есть

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 22-Апр-10, 15:50 
>Уже всю голову сломал.
>может у кого идеи есть

просто мысля, надо проверять
в локальной политике, set ip next-hop 1.1.1.1

глобально:

ip route 1.1.1.1 255.255.255.255 dialer0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 22-Апр-10, 16:29 
>>Уже всю голову сломал.
>>может у кого идеи есть
>
>просто мысля, надо проверять
>в локальной политике, set ip next-hop 1.1.1.1
>
>глобально:
>
>ip route 1.1.1.1 255.255.255.255 dialer0

Пробывал вместо 1.1.1.1 нули.
не разрешает так указывать.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 22-Апр-10, 16:31 
>[оверквотинг удален]
>>
>>просто мысля, надо проверять
>>в локальной политике, set ip next-hop 1.1.1.1
>>
>>глобально:
>>
>>ip route 1.1.1.1 255.255.255.255 dialer0
>
>Пробывал вместо 1.1.1.1 нули.
>не разрешает так указывать.

какие нули?
пробуй как я написал

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 09:09 
>[оверквотинг удален]
>>>
>>>глобально:
>>>
>>>ip route 1.1.1.1 255.255.255.255 dialer0
>>
>>Пробывал вместо 1.1.1.1 нули.
>>не разрешает так указывать.
>
>какие нули?
>пробуй как я написал

Неа не заработало.

Вообще получается очень интересная ситуация.
Я вчера на второго провайдера настроил icmp-echo, срузу все поднялось и заработало и переключается и восстанавливается.
Т.е основной через icmp-itter резервный через icmp-echo.
Ну мне это не нравится.


после вчерашних экспериментов получается что  icmp-echo все равно работает если в качестве источника icmp запросов указать не Dialer 0 а IP выданный провайдером на dialer интерфейс.
при настройке icmp-jitter можно в качестве источника запросов указывать только IP, но все равно Track переходит в down.
Я тогда вообще ничего не понимаю.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 09:46 
>Я тогда вообще ничего не понимаю.

у меня на виртуалке тоже че-то сходу не вышло, попробую еще покивирять.

Но, тут еще есть такой нюанс - пир адрес провайдера скорее всего всегда один и тот-же, можно попробовать некст-хопом задать его.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 09:58 
>>Я тогда вообще ничего не понимаю.
>
>у меня на виртуалке тоже че-то сходу не вышло, попробую еще покивирять.
>
>
>Но, тут еще есть такой нюанс - пир адрес провайдера скорее всего
>всегда один и тот-же, можно попробовать некст-хопом задать его.

Как это сделать?
Под пир адресом ты имеешь ввиду шлюз?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 10:02 
>Как это сделать?
>Под пир адресом ты имеешь ввиду шлюз?

sho ip int dialer0 | inc Peer address

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 10:22 
>>Как это сделать?
>>Под пир адресом ты имеешь ввиду шлюз?
>
>sho ip int dialer0 | inc Peer address

Пинать не надо.
Я не понял смысл данной команды.

Вот tracert через dialer 0

Miniat>tracert www.ya.ru

Tracing route to ya.ru [77.88.21.8]
over a maximum of 30 hops:

  1     5 ms    <1 ms    <1 ms  192.168.0.1
  2   168 ms   323 ms    22 ms  10.50.254.158
  3    32 ms    30 ms    29 ms  ya.ru [77.88.21.8]

На сколько я понял то 10.50.254.158 и есть шлюз?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 10:45 
>Пинать не надо.

не понял

>Я не понял смысл данной команды.
>Вот tracert через dialer 0
>На сколько я понял то 10.50.254.158 и есть шлюз?

это всего лишь адрес с которого приходят icmp-ttl-expired

у ppp соединения есть собственный адрес и адрес peer'а (другого конца)
вот этот адрес другого конца и можно посмотреть при поднятом интерфейсе
sho ip int dial0 | inc Peer address

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 10:54 
>[оверквотинг удален]
>
>>Я не понял смысл данной команды.
>>Вот tracert через dialer 0
>>На сколько я понял то 10.50.254.158 и есть шлюз?
>
>это всего лишь адрес с которого приходят icmp-ttl-expired
>
>у ppp соединения есть собственный адрес и адрес peer'а (другого конца)
>вот этот адрес другого конца и можно посмотреть при поднятом интерфейсе
>sho ip int dial0 | inc Peer address

Ничего не показывает.
gateway#show ip interface dialer 0 | include ?
  LINE  Regular Expression

gateway#show ip interface dialer 0
Dialer0 is up, line protocol is up
  Internet address is *.*.*.170/32
  Broadcast address is 255.255.255.255
  Address determined by IPCP
  MTU is 1492 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF switching turbo vector
  IP Null turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is enabled, interface in domain outside
  BGP Policy Mapping is disabled
  Input features: Stateful Inspection, Dialer i/f override, Virtual Fragment Rea
ssembly, Virtual Fragment Reassembly After IPSec Decryption, NAT Outside, MCI Ch
eck
  Output features: CCE Output Classification, Post-routing NAT Outside, Stateful
Inspection, Dialer idle reset
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

11. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 11:00 
>[оверквотинг удален]
>>
>>это всего лишь адрес с которого приходят icmp-ttl-expired
>>
>>у ppp соединения есть собственный адрес и адрес peer'а (другого конца)
>>вот этот адрес другого конца и можно посмотреть при поднятом интерфейсе
>>sho ip int dial0 | inc Peer address
>
>Ничего не показывает.
>gateway#show ip interface dialer 0 | include ?
>  LINE  Regular Expression

route-map PING_POLICY permit 10
  match ip address PING_MAXNET
set ip next-hop 217.15.192.1
! тут убрать вот это:
!set interface FastEthernet0/2/0
!
route-map PING_POLICY permit 20
match ip address PING_DOMOLINK
! а тут это:
! set ip next-hop dynamic dhcp
set interface Dialer0
!

на самих интерфейсах запретить хождение icmp, которое должно работать на соседнем

interface FastEthernet0/2/0
ip access-group f020_out
interface Dialer0
ip access-group dial0_out
!
ip access-list ext f020_out
  deny icmp host *.*.*.170 host 62.148.128.1
  permit ip any any
!
ip access-list ext dial0_out
  deny icmp host *.*.*.41 host 195.112.96.34
  permit ip any any
!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 11:41 
>[оверквотинг удален]
> ip access-group dial0_out
>!
>ip access-list ext f020_out
>  deny icmp host *.*.*.170 host 62.148.128.1
>  permit ip any any
>!
>ip access-list ext dial0_out
>  deny icmp host *.*.*.41 host 195.112.96.34
>  permit ip any any
>!

не помогло.....

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 12:03 
>не помогло.....

покаж крайний конфиг

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 12:25 
>>не помогло.....
>
>покаж крайний конфиг

Current configuration : 6034 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$eQI9$H4Tmsqj.Q3iXPNnw81OjY/
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
crypto pki trustpoint TP-self-signed-353804864
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-353804864
revocation-check none
rsakeypair TP-self-signed-353804864
!
!
crypto pki certificate chain TP-self-signed-353804864
certificate self-signed 01
  3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33353338 30343836 34301E17 0D313030 34313930 36333534
  345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3335 33383034
  38363430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  D4ED874B E46861AF 942A1AA6 F719C857 4F423E36 EFE94889 A6F8D638 DCE967A1
  17C9F238 3616CAB2 FA058C18 4C718EEC 48DFC74D F26C6ADC ABCFAEC8 5F7BBEE0
  2BA818D0 39B3932C E426E9D4 06E5B3DD 00E0B289 3C53E85E 1FE033B2 00343B78
  47ABB986 075BE2A7 D197843F 66A193AB BB2A73C0 92CEACC4 BE3EF4D5 CEF4F45B
  02030100 01A37630 74300F06 03551D13 0101FF04 05300301 01FF3021 0603551D
  11041A30 18821667 6F6C7562 5F676174 65776179 2E474F4C 55424E43 4F301F06
  03551D23 04183016 8014C227 8EDE4E14 6B9662D5 12DF00BD D3A82866 B21A301D
  0603551D 0E041604 14C2278E DE4E146B 9662D512 DF00BDD3 A82866B2 1A300D06
  092A8648 86F70D01 01040500 03818100 00345C18 0CDB9F2A BC209FE8 C13184DF
  6AA8F2ED 98B4162A F187D88D 06209D5C 3440CD4A 864602BA D0F45F1D 0DFFFE4C
  26E79F71 73CA1B8B C98E8194 1D52EA0D 5632859E 8DB42EDB DB080E90 5AC08927
  BA14937A 4196B5AC EDD592E9 94C0FD91 8ED04D1A DC4EB673 20EC34EE C9FBDEE9
  A79FCCDC 53CDF08F 4F3E7BBB 6F95A69D
        quit
dot11 syslog
ip source-route
ip cef
!
!
!
!
ip domain name
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
initiate-to ip 192.168.100.2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
username administrator privilege 15 password 7 05111E0C74146322
!
!
!
archive
log config
  hidekeys
!
!
ip ssh version 2
!
track 1 ip sla 100 reachability
delay down 15 up 15
!
track 2 ip sla 200 reachability
delay down 15 up 15
!
!
!
!
interface FastEthernet0/0
ip address 192.168.100.2 255.255.255.0
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface FastEthernet0/2/0
description MAXNET
ip address *.*.*.41 255.255.255.192
ip access-group f020 out
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
ip access-group dial0 out
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname golub-39dml1
ppp chap password 7 03560E53525A77
!
ip local policy route-map PING_POLICY
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 217.15.192.1 50 name main_ISP track 1
ip route 0.0.0.0 0.0.0.0 Dialer0 100 name reserv_ISP track 2
ip route 62.148.128.1 255.255.255.255 Dialer0 permanent name DNSDOMOLINK_isp_res
erv
ip route 195.112.96.34 255.255.255.255 217.15.192.1 permanent name DNSMAXNET_isp
_main
ip http server
ip http secure-server
!
!
ip nat inside source route-map ISP_main interface FastEthernet0/2/0 overload
ip nat inside source route-map ISP_reserv interface Dialer0 overload
!
ip access-list extended PING_DOMOLINK
permit icmp host *.*.*.170 host 62.148.128.1
ip access-list extended PING_MAXNET
permit icmp host *.*.*.41 host 195.112.96.34
ip access-list extended dial0
deny   icmp host *.*.*.41 host 195.112.96.34
permit ip any any
ip access-list extended f020
deny   icmp host *.*.*.170 host 62.148.128.1
permit ip any any
!
ip sla 100
icmp-jitter 195.112.96.34 source-ip *.*.*.41 num-packets 5
timeout 10000
threshold 10000
frequency 30
ip sla schedule 100 life forever start-time now
ip sla 200
icmp-jitter 62.148.128.1 source-ip *.*.*.170 num-packets 5
timeout 10000
threshold 10000
frequency 30
ip sla schedule 200 life forever start-time now
access-list 100 deny   ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
access-list 101 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run

!
!
!
!
route-map ISP_reserv permit 10
match ip address 100
match interface Dialer0
!
route-map ISP_main permit 10
match ip address 100
match interface FastEthernet0/2/0
!
route-map PING_POLICY permit 10
match ip address PING_MAXNET
set ip next-hop 217.15.192.1
!
route-map PING_POLICY permit 20
match ip address PING_DOMOLINK
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control
description Music On Hold Port
!
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
password 7 0956560A4C5D3A39
login
no modem enable
line aux 0
line vty 0 4
login local
transport input ssh
!
event manager applet clear_nat
event track 1 state any
action 0.9 cli command "enable"
action 1.0 cli command "clear ip nat translation *"
action 2.0 cli command "clear ip nat translation forced"
!
end

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 12:53 
>route-map PING_POLICY permit 20
> match ip address PING_DOMOLINK
>!

а set interface dial0 где потерял?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 15:04 
>>route-map PING_POLICY permit 20
>> match ip address PING_DOMOLINK
>>!
>
>а set interface dial0 где потерял?

Все добавил.
Ну все равно результат 0.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

21. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 07:31 
>>>route-map PING_POLICY permit 20
>>> match ip address PING_DOMOLINK
>>>!
>>
>>а set interface dial0 где потерял?
>
>Все добавил.
>Ну все равно результат 0.

Так, давай максимально очистим конфиг и начнем от простого к сложному

сделай дефолтный маршрут через езернет-провайдера
и сделай локальную политику, которая матчит любой icmp траффик с set interface dialer0
отключи клиентов
и debug ip policy
term mon
ping 8.8.8.8

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

22. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 26-Апр-10, 09:22 
>[оверквотинг удален]
>
>Так, давай максимально очистим конфиг и начнем от простого к сложному
>
>сделай дефолтный маршрут через езернет-провайдера
>и сделай локальную политику, которая матчит любой icmp траффик с set interface
>dialer0
>отключи клиентов
>и debug ip policy
>term mon
>ping 8.8.8.8

Вообщем если честно я думаю проблема не в маршрутах и локальных политиках.
Просто вот сейчас взял изменил одну строчку в конфе, вместо icmp-jitter написал icmp-echo на резервном канале и все заработало. Основной работает через джиттер.
Я тут статью нашел http://sysadmins.ru/topic221769.html
Вот подумал может надо пинговать с локального IP циски, или с интерфеса куда подключен модем, или с с IP VLAN 1.
Только я не  представляю как нужно изменить acces-list что бы пинги из внутренней сети ходили.
Поможешь?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

23. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 26-Апр-10, 11:49 
>[оверквотинг удален]
>
>Просто вот сейчас взял изменил одну строчку в конфе, вместо icmp-jitter написал
>icmp-echo на резервном канале и все заработало. Основной работает через джиттер.
>
>Я тут статью нашел http://sysadmins.ru/topic221769.html
>Вот подумал может надо пинговать с локального IP циски, или с интерфеса
>куда подключен модем, или с с IP VLAN 1.
>Только я не  представляю как нужно изменить acces-list что бы пинги
>из внутренней сети ходили.
>Поможешь?

А зачем вообще джиттер измерять?

А с локальным IP все просто, можно лупбек сделать и его сорсом ставить.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

24. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 26-Апр-10, 15:44 
>[оверквотинг удален]
>>Вот подумал может надо пинговать с локального IP циски, или с интерфеса
>>куда подключен модем, или с с IP VLAN 1.
>>Только я не  представляю как нужно изменить acces-list что бы пинги
>>из внутренней сети ходили.
>>Поможешь?
>
>А зачем вообще джиттер измерять?
>
>А с локальным IP все просто, можно лупбек сделать и его сорсом
>ставить.

Вообщем вот до чего дошел.
Если в вместо адреса 195.112.96.34 (ДНС нашего прова) вписать любой адрес расположенный чуть дальше (ну пинги приходят 5-6 мс), то icmp-jitter так же перестает работать даже на основном канале. Если вместо 195.112.96.34 вписать адрес шлюза провайдера 195.112.101.1 то все опять начинает работать.
Как я теперь уже понял в icmp-jitter надо настроить где время ответа и задержки.
вообщем копаю. Может мыслишки у кого есть.
Код:
ip sla 100
icmp-jitter 195.112.96.34 source-ip *.*.*.41 num-packets 5
timeout 10000
threshold 10000
frequency 30
sla schedule
100 life forever start-time now

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

25. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от maputa (ok) on 26-Апр-10, 20:42 
>>[оверквотинг удален]
>ip sla 100
> icmp-jitter 195.112.96.34 source-ip *.*.*.41 num-packets 5
> timeout 10000
> threshold 10000
> frequency 30
>sla schedule
> 100 life forever start-time now

Была таже беда. icmp-jitter работал только до гейта провайдера, что бесполезно.
Заработало вот так:
ip sla 1
path-jitter 93.х.x.x source-ip 192.168.y.y num-packets 5 targetOnly
frequency 15
ip sla schedule 1 life forever start-time now

где 93.х.х.х - популярный хост всегда в апе :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

26. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 27-Апр-10, 16:20 
>[оверквотинг удален]
>> 100 life forever start-time now
>
>Была таже беда. icmp-jitter работал только до гейта провайдера, что бесполезно.
>Заработало вот так:
>ip sla 1
> path-jitter 93.х.x.x source-ip 192.168.y.y num-packets 5 targetOnly
> frequency 15
>ip sla schedule 1 life forever start-time now
>
>где 93.х.х.х - популярный хост всегда в апе :)

СПАСИБО ТЕБЕ БОЛЬШУЩЕЕ!!!
Все заработало.
Единственное для меня непонятно, резервный TRACK поднимается только если его запрашивать с внутреннего адреса циски.
Если в источнике указать IP адрес dialer интерфейса, то канал не работает.

А в остальном в все ОК.
Еще раз огромное спасибо!!!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

27. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от maputa (ok) on 27-Апр-10, 17:11 
route-map PING_POLICY permit 20
match ip address PING_DOMOLINK
set interface Null0


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

28. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 28-Апр-10, 10:13 
>route-map PING_POLICY permit 20
>match ip address PING_DOMOLINK
>set interface Null0

У меня заработало даже без этих route-map.
Какой тогда в них смысл?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

12. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от ShyLion (ok) on 23-Апр-10, 11:05 
>gateway#show ip interface dialer 0
>Dialer0 is up, line protocol is up
>  Internet address is *.*.*.170/32
>  Broadcast address is 255.255.255.255
>  Address determined by IPCP
>  MTU is 1492 bytes
>  Helper address is not set

странно
IOS какой?

r1#sho ip int s1/0
Serial1/0 is up, line protocol is up
  Internet address is 172.16.1.2/32
  Broadcast address is 255.255.255.255
  Address determined by IPCP
  Peer address is 172.16.1.1
  ...

вот так обычно показывает

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 11:39 
>[оверквотинг удален]
>
>r1#sho ip int s1/0
>Serial1/0 is up, line protocol is up
>  Internet address is 172.16.1.2/32
>  Broadcast address is 255.255.255.255
>  Address determined by IPCP
>  Peer address is 172.16.1.1
>  ...
>
>вот так обычно показывает

show ver
Cisco IOS Software, C1861 Software (C1861-ADVIPSERVICESK9-M), Version 12.4(24)T,
RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 25-Feb-09 17:13 by prod_rel_team

ROM: System Bootstrap, Version 12.4(11r)XW3, RELEASE SOFTWARE (fc1)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

16. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от maputa (ok) on 23-Апр-10, 12:22 
Можно попробовать path-jitter.

В PING_POLICY
set interface Null0

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "icmp-jitter и Dialer. Как настроить?"  +/
Сообщение от areon (ok) on 23-Апр-10, 15:06 
>[оверквотинг удален]
>
>r1#sho ip int s1/0
>Serial1/0 is up, line protocol is up
>  Internet address is 172.16.1.2/32
>  Broadcast address is 255.255.255.255
>  Address determined by IPCP
>  Peer address is 172.16.1.1
>  ...
>
>вот так обычно показывает

Насколько я знаю у нас провайдер сознательно скрывает промежуточные переходы.
поэтому возможно ничего не показывается

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру