The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"PPTP сервер удаленного доступа и NAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"PPTP сервер удаленного доступа и NAT"  +/
Сообщение от visaversa email(??) on 20-Июл-10, 18:11 
Доброго времени суток!
Имеется циска с двумя портами, один смотрит в инет, второй в локалку. Сейчас на ней настроен сервер удаленного доступа PPTP, для подключений из инета к внутренней локалке.
Конфиг примитивен. Выкладываю основной кусок

vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
local name pptp

username VPNuser privilege 0 password 7 12020F2C1901082

interface GigabitEthernet0/0
description LAN
ip address 192.168.72.3 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
media-type rj45


interface Virtual-Template1
ip unnumbered Loopback1
no ip redirects
no ip proxy-arp
ip nat inside
no ip virtual-reassembly
no ip route-cache same-interface
load-interval 30
autodetect encapsulation ppp
peer default ip address pool default
ppp encrypt mppe 128
ppp authentication ms-chap ms-chap-v2


ip nat inside source list 111 interface GigabitEthernet0/0 overload

interface GigabitEthernet0/1
description WAN
ip address 11.111.11.11 255.255.255.252
ip access-group 113 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
duplex auto
speed auto
media-type rj45


Теперь руководство просит организовать NAT, чтоб внутренние адреса натились на внешний. но проблема в том что строка ip nat outside имеется в LAN интерфейсе как часть конфига pptp сервера, и организовать простой нат не выходит. Подскажите как быть?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "PPTP сервер удаленного доступа и NAT"  +/
Сообщение от shadow_alone (ok) on 20-Июл-10, 21:03 
Уберите НАТ для доступа в локалку, он по сути не нужен, пусть будет просто рутинг.
А для выхода наружу для локалки включите НАТ.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "PPTP сервер удаленного доступа и NAT"  +/
Сообщение от visaversa email(??) on 21-Июл-10, 12:10 
Коллега, вы гений!
Действительно, роутинга оказалось достаточно

>Уберите НАТ для доступа в локалку, он по сути не нужен, пусть
>будет просто рутинг.
>А для выхода наружу для локалки включите НАТ.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру