The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco два провайдера, 4 тунеля, tunnel source"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Nerian email on 03-Авг-10, 10:41 
Добрый день!

Подскажите как правильно организовать. С двух сторон по Cisco 2811. На каждой из них по два провайдера. Соотвественно реально есть четыре пути для туннелей:
CiscoA ISP1 <-> CiscoB ISP1
CiscoA ISP2 <-> CiscoB ISP1
CiscoA ISP1 <-> CiscoB ISP2
CiscoA ISP2 <-> CiscoB ISP2

Получается на каждой стороне надо прописывать по четыре тунеля для организации такой связки? Из за того что нужно указывать tunnel source не получается ограничится ДВУМЯ на каждой стороне для создания четырёх возможных путей.

Сейчас работает упрашённая схема:
CiscoA ISP1 <-> CiscoB ISP1.
CiscoA ISP2 <-> CiscoB ISP2.

Вопрос собственно можно ли указав на каждой стороне по два тунеля, добится четырёх путей? Или нужно прописывать каждый по отдельности?

Спасибо.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Николай (??) on 03-Авг-10, 10:47 
>[оверквотинг удален]
>ограничится ДВУМЯ на каждой стороне для создания четырёх возможных путей.
>
>Сейчас работает упрашённая схема:
>CiscoA ISP1 <-> CiscoB ISP1.
>CiscoA ISP2 <-> CiscoB ISP2.
>
>Вопрос собственно можно ли указав на каждой стороне по два тунеля, добится
>четырёх путей? Или нужно прописывать каждый по отдельности?
>
>Спасибо.

Незнаю что такое прописывать каждый по отдельности, а вот организовать 4 работающих маршрута одновременно можно.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Nerian email on 03-Авг-10, 11:21 
>[оверквотинг удален]
>>CiscoA ISP1 <-> CiscoB ISP1.
>>CiscoA ISP2 <-> CiscoB ISP2.
>>
>>Вопрос собственно можно ли указав на каждой стороне по два тунеля, добится
>>четырёх путей? Или нужно прописывать каждый по отдельности?
>>
>>Спасибо.
>
>Незнаю что такое прописывать каждый по отдельности, а вот организовать 4 работающих
>маршрута одновременно можно.

Каким образом?

На стороне CiscoA:

interface Tunnel11
ip address 192.168.101.1 255.255.255.0
tunnel source CiscoA-ISP1-IP
tunnel destination CiscoB-ISP1-IP
...
!
interface Tunnel12
ip address 192.168.102.1 255.255.255.0
tunnel source CiscoA-ISP1-IP
tunnel destination CiscoB-ISP2-IP
...
!
interface Tunnel21
ip address 192.168.103.1 255.255.255.0
tunnel source CiscoA-ISP2-IP
tunnel destination CiscoB-ISP1-IP
...
!
interface Tunnel22
ip address 192.168.104.1 255.255.255.0
tunnel source CiscoA-ISP2-IP
tunnel destination CiscoB-ISP2-IP
...
!

На стороне Cisco B:

interface Tunnel11
ip address 192.168.101.1 255.255.255.0
tunnel source CiscoB-ISP1-IP
tunnel destination CiscoA-ISP1-IP
...
!
interface Tunnel12
ip address 192.168.102.1 255.255.255.0
tunnel source CiscoB-ISP2-IP
tunnel destination CiscoA-ISP1-IP
...
!
interface Tunnel21
ip address 192.168.103.1 255.255.255.0
tunnel source CiscoB-ISP1-IP
tunnel destination CiscoA-ISP2-IP
...
!
interface Tunnel22
ip address 192.168.104.1 255.255.255.0
tunnel source CiscoB-ISP2-IP
tunnel destination CiscoA-ISP2-IP
...
!

Или можно как нибудь по другому?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от j_vw on 04-Авг-10, 01:16 
>Незнаю что такое прописывать каждый по отдельности, а вот организовать 4 работающих
>маршрута одновременно можно.

Надоело.....
Задолбали "умники"
Будьте добры.... "конфиг в студию"....
Если он рабочий, то я, лично, готов вам сотню баксов презентовать... ;)
Условие: без BGP и трекеров.

Уже нет сил материться:
http://www.opennet.ru/openforum/vsluhforumID6/21360.html?n=j...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Николай (??) on 04-Авг-10, 09:58 
>[оверквотинг удален]
>
>Надоело.....
>Задолбали "умники"
>Будьте добры.... "конфиг в студию"....
>Если он рабочий, то я, лично, готов вам сотню баксов презентовать... ;)
>
>Условие: без BGP и трекеров.
>
>Уже нет сил материться:
>http://www.opennet.ru/openforum/vsluhforumID6/21360.html?n=j...

Так что за паника :)

По умолчанию EIGRP выполняет балансировку нагрузки между 4 маршрутами с одинаковой метрикой.
Изменение количества маршрутов, между которыми выполняется балансировка нагрузки:
(config-router)# maximum-paths 4
для неравозначной (разный бендвидс на тунелях) метрики используем множитель
(config-router)# variance 2

Значится поднимаем EIGRP анонсируем сетки тунелей и конечные пользовательские сети и вперед - снимает статистику по бендвидз, для особо дотошных вводим комманду
sh ip eigrp topo & трасировка маршрута ну в принципе и все.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Valery12 (ok) on 04-Авг-10, 11:08 
>[оверквотинг удален]
>
>Изменение количества маршрутов, между которыми выполняется балансировка нагрузки:
>(config-router)# maximum-paths 4
>для неравозначной (разный бендвидс на тунелях) метрики используем множитель
>(config-router)# variance 2
>
>Значится поднимаем EIGRP анонсируем сетки тунелей и конечные пользовательские сети и вперед
>- снимает статистику по бендвидз, для особо дотошных вводим комманду
>sh ip eigrp topo & трасировка маршрута ну в принципе и все.
>

насколько я понял автор предыдущего поста требовал конфиг не 4 одновременно работающих маршрутов внутри автономной системы а 4 одновременно работающих туннелей в среде где внутренние протоколы маршрутизации использовать нельзя

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Valery12 (ok) on 04-Авг-10, 11:26 
>[оверквотинг удален]
>
>Надоело.....
>Задолбали "умники"
>Будьте добры.... "конфиг в студию"....
>Если он рабочий, то я, лично, готов вам сотню баксов презентовать... ;)
>
>Условие: без BGP и трекеров.
>
>Уже нет сил материться:
>http://www.opennet.ru/openforum/vsluhforumID6/21360.html?n=j...

не скажу что это рабочий вариант , потому что проверить не пришлось но у меня используется DMVPN с одним провайдером и в свое время я искал варианты если их будет два (но так и не случилось) и кое что нашел
и так
в центре два провайдера и два адреса 1.1.1.1 и 2.2.2.2
в филиале тоже два, адреса динамические
и там и там добавляем статические маршруты к провайдерским сетям
и собственно туннели

в центре (только основные команды)

interface Tunnel0
ip address 10.0.0.1 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp network-id 1000
ip ospf network broadcast
ip ospf cost 10000
ip ospf priority 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1000
!
interface Tunnel1
ip address 10.0.1.1 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp network-id 1000
ip ospf network broadcast
ip ospf cost 1000
ip ospf priority 1
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 1000
!
interface Tunnel2
ip address 10.0.2.1 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp network-id 2000
ip ospf network broadcast
ip ospf cost 100
ip ospf priority 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 2000
!
interface Tunnel3
ip address 10.0.3.1 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp network-id 2000
ip ospf network broadcast
ip ospf cost 10
ip ospf priority 1
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 2000

в филиалах

interface Tunnel0
ip address 10.0.0.2 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast 1.1.1.1
ip nhrp map 10.0.0.1 1.1.1.1
ip nhrp network-id 1000
ip nhrp nhs 10.0.0.1
ip ospf network broadcast
ip ospf cost 10000
ip ospf priority 0
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 1000
!
interface Tunnel1
ip address 10.0.1.2 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast 2.2.2.2
ip nhrp map 10.0.1.1 2.2.2.2
ip nhrp network-id 1000
ip nhrp nhs 10.0.1.1
ip ospf network broadcast
ip ospf cost 1000
ip ospf priority 0
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1000
!
interface Tunnel2
ip address 10.0.2.2 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast 1.1.1.1
ip nhrp map 10.0.2.1 1.1.1.1
ip nhrp network-id 2000
ip nhrp nhs 10.0.2.1
ip ospf network broadcast
ip ospf cost 100
ip ospf priority 0
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 2000
!
interface Tunnel3
ip address 10.0.3.2 255.255.255.0
no ip redirects
ip nhrp authentication test
ip nhrp map multicast 2.2.2.2
ip nhrp map 10.0.3.1 2.2.2.2
ip nhrp network-id 2000
ip nhrp nhs 10.0.3.1
ip ospf network broadcast
ip ospf cost 10
ip ospf priority 0
tunnel source FastEthernet0/1
tunnel mode gre multipoint
tunnel key 2000

"ip ospf cost" разные поэтому трафик пойдет по главному туннелю и только при его падении по следующему, если сделать одинаковые то и балансировка должна быть


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

7. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от j_vw on 04-Авг-10, 12:02 
Это нерабочий конфиг.....
Человек, у которого вы его нашли, просто попробовал сделать "лабу" на dynamips.
Но кое что не учел....
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от Valery12 (ok) on 04-Авг-10, 13:06 
>Это нерабочий конфиг.....
>Человек, у которого вы его нашли, просто попробовал сделать "лабу" на dynamips.
>
>Но кое что не учел....

жаль, значит остается вариант DMVPN с двумя хабами в центре, слава богу "железа" хватает.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Cisco два провайдера, 4 тунеля, tunnel source"  +/
Сообщение от j_vw on 04-Авг-10, 15:51 
>жаль, значит остается вариант DMVPN с двумя хабами в центре, слава богу
>"железа" хватает.

Ну есть еще "костыль" с secondory адресом....
Ну, или, ip sla.... Правда время сходимости тут зависит не от протокола маршрутизации, а от таймаутов трекеров.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру