The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"c1760 l2tpv3 vlan"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"c1760 l2tpv3 vlan"  +1 +/
Сообщение от arma35 email(ok) on 29-Сен-10, 15:28 
не могу пробросить vlan через L2TPv3. точнее тунель установился, сессия есть. на пакеты между хостами не ходят, точнее даже 1-2 пинга при поднятии тунеля проходят, и всё тишина..
для теста собрал роутеры рядом.
обе cisco: 1760 128ram,32 flash, IOS: adv ent 12.4.23

*** FIRST-ROUTER ***

l2tp-class class1
authentication
password secret
!
pseudowire-class class-pw
encapsulation l2tpv3
protocol l2tpv3 class1
ip local interface Loopback0
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
!
interface FastEthernet0/0.990
encapsulation dot1Q 990
ip address 10.254.254.3 255.255.255.0
!
interface FastEthernet0/0.991
encapsulation dot1Q 991
xconnect 10.0.0.5 991 pw-class class-pw
!


*** SECOND ROUTER ***

l2tp-class class1
authentication
password secret
pseudowire-class class-pw
encapsulation l2tpv3
protocol l2tpv3 class1
ip local interface Loopback0
!
interface Loopback0
ip address 10.0.0.5 255.255.255.255
!
!
interface FastEthernet0/0.990
encapsulation dot1Q 990
ip address 10.254.254.5 255.255.255.0
no cdp enable
!
interface FastEthernet0/0.992
encapsulation dot1Q 992
no cdp enable
xconnect 10.0.0.3 991 pw-class class-pw
!

что не так я сделал??

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "c1760 l2tpv3 vlan"  +/
Сообщение от Николай (??) on 29-Сен-10, 15:48 
:))) Вопрос обхвата  l2tpv3 протокола. На сабинтрфейсе он не заработает (сам недавно стал на эти грабли). Делай его на физическом интерфейсе а сабинтерфейсы с тегами уже передвай удаленной стороне - на той стороне аналогично.

interface FastEthernet0/0
description L2TPv3
no ip address
duplex auto
speed auto
xconnect 192.168.31.125 123 pw-class vlan-xconnect
!
interface FastEthernet0/0.3
description Blade switch vlan
encapsulation dot1Q 3
!
interface FastEthernet0/0.120
description NLB Proxy
encapsulation dot1Q 120
!
interface FastEthernet0/0.130
description UDMZ
encapsulation dot1Q 130

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "c1760 l2tpv3 vlan"  +/
Сообщение от arma35 email(ok) on 29-Сен-10, 16:57 
да мне бы хотелось разные виланы, на разные циски пробросить
да, а как же заявления циски:
http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/l2tp...

********************
Configuring a Negotiated L2TPv3 Session for an Xconnect VLAN Subinterface Example

The following is a sample configuration of a dynamic L2TPv3 session for a VLAN Xconnect interface. In this example, only VLAN traffic with a VLAN ID of 5 is tunneled. In the other direction, the L2TPv3 session identified by a virtual circuit identifier of 123 receives forwarded frames whose VLAN ID fields are rewritten to contain the value 5. L2TPv3 is used as both the control plane protocol and the data encapsulation.

l2tp-class class1
authentication
password secret

pseudowire-class vlan-xconnect
encapsulation l2tpv3
protocol l2tpv3 class1
ip local interface Loopback0

interface Ethernet0/0.1
encapsulation dot1Q 5
xconnect 10.0.3.201 123 pw-class vlan-xconnect
********************

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "c1760 l2tpv3 vlan"  +/
Сообщение от Николай (??) on 29-Сен-10, 17:00 
на практике такая реализация у меня не завелась - отпишитесь если получиться
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "c1760 l2tpv3 vlan"  +/
Сообщение от lumenous (ok) on 29-Сен-10, 17:22 
>[оверквотинг удален]
>  authentication
>  password secret
> pseudowire-class vlan-xconnect
>  encapsulation l2tpv3
>  protocol l2tpv3 class1
>  ip local interface Loopback0
> interface Ethernet0/0.1
>  encapsulation dot1Q 5
>  xconnect 10.0.3.201 123 pw-class vlan-xconnect
> ********************

А как вариант - попробуйте сделать как Николай просит, чтобы убедиться что в целом туннель работает. А то может и на обычном интерфейсе не заведется...

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "c1760 l2tpv3 vlan"  +/
Сообщение от arma35 email(ok) on 29-Сен-10, 17:35 
>[оверквотинг удален]
>>  encapsulation l2tpv3
>>  protocol l2tpv3 class1
>>  ip local interface Loopback0
>> interface Ethernet0/0.1
>>  encapsulation dot1Q 5
>>  xconnect 10.0.3.201 123 pw-class vlan-xconnect
>> ********************
> А как вариант - попробуйте сделать как Николай просит, чтобы убедиться что
> в целом туннель работает. А то может и на обычном интерфейсе
> не заведется...

да у меня портов физических столько нету ;(( даже на тест..
есть с1760 (без wic'ов с езернетом)

самое главное - мне не понятно почему 2-3 пинга при поднятии тунеля проскакивают, как так?!?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "c1760 l2tpv3 vlan"  +/
Сообщение от lumenous (ok) on 29-Сен-10, 18:01 
>[оверквотинг удален]
>>>  encapsulation dot1Q 5
>>>  xconnect 10.0.3.201 123 pw-class vlan-xconnect
>>> ********************
>> А как вариант - попробуйте сделать как Николай просит, чтобы убедиться что
>> в целом туннель работает. А то может и на обычном интерфейсе
>> не заведется...
> да у меня портов физических столько нету ;(( даже на тест..
> есть с1760 (без wic'ов с езернетом)
> самое главное - мне не понятно почему 2-3 пинга при поднятии тунеля
> проскакивают, как так?!?

Что ж вы сразу это не сказали =))
Попробуйте с дебагом поиграться, может быть скажет что-нибудь...

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "c1760 l2tpv3 vlan"  +/
Сообщение от lumenous (ok) on 29-Сен-10, 18:02 
>[оверквотинг удален]
>>>> ********************
>>> А как вариант - попробуйте сделать как Николай просит, чтобы убедиться что
>>> в целом туннель работает. А то может и на обычном интерфейсе
>>> не заведется...
>> да у меня портов физических столько нету ;(( даже на тест..
>> есть с1760 (без wic'ов с езернетом)
>> самое главное - мне не понятно почему 2-3 пинга при поднятии тунеля
>> проскакивают, как так?!?
> Что ж вы сразу это не сказали =))
> Попробуйте с дебагом поиграться, может быть скажет что-нибудь...

Ой, пардон. Оказывается сказали =)

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "c1760 l2tpv3 vlan"  +/
Сообщение от arma35 email(ok) on 29-Сен-10, 19:25 
> Попробуйте с дебагом поиграться, может быть скажет что-нибудь...

да чтото ничего понятного для себя я там не увидел...
пипец, а езернет пробросить надо (((

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

9. "c1760 l2tpv3 vlan"  +/
Сообщение от fantom (ok) on 30-Сен-10, 09:28 
На 28-ой серии все это прекрасно работает с сабинтерфейсами - попробуйте ИОС заменить.
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "c1760 l2tpv3 vlan"  +/
Сообщение от arma35 email(ok) on 30-Сен-10, 10:25 
> На 28-ой серии все это прекрасно работает с сабинтерфейсами - попробуйте ИОС
> заменить.

сейчас стоит - c1700-adventerprisek9-mz.124-23.bin
до этого пробывал на c1700-advipservicesk9-mz.124-25a.bin
аналогично..
(одни из самых новороченных для этой серии я так понимаю)

а у тебя на каком ИОСе работает??

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "c1760 l2tpv3 vlan"  +/
Сообщение от fantom (ok) on 30-Сен-10, 11:57 
>> На 28-ой серии все это прекрасно работает с сабинтерфейсами - попробуйте ИОС
>> заменить.
> сейчас стоит - c1700-adventerprisek9-mz.124-23.bin
> до этого пробывал на c1700-advipservicesk9-mz.124-25a.bin
> аналогично..
> (одни из самых новороченных для этой серии я так понимаю)
> а у тебя на каком ИОСе работает??

Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(11)XW9, RELEASE SOFTWARE (fc1)

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "c1760 l2tpv3 vlan"  +2 +/
Сообщение от arma35 email(ok) on 07-Окт-10, 13:00 
Ну так у когонить в мире работает на 17хх проброс вилана через L2TPv3 ???
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

13. "c1760 l2tpv3 vlan"  +/
Сообщение от John37rus on 30-Авг-11, 13:11 
> Ну так у когонить в мире работает на 17хх проброс вилана через
> L2TPv3 ???

To successfully rewrite VLANs, it may be necessary to disable the Spanning Tree Protocol (STP). This can be done on a per-VLAN basis by using the no spanning-tree vlan command.
На каталистах сделаешь disable STP для используемых вланов и все заработает :)

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру