The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Переадресация звонка pots на as5350"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"Переадресация звонка pots на as5350"  +/
Сообщение от postavik email(ok) on 09-Фев-11, 17:23 
Подскажите пример конфига для перенаправления звонка пришедшего с pots, на заданный номер (опять же в pots), чтобы позвонившему не нужно было ничего набирать дополнительно.
Возможно ли такое организовать средствами только as5350, без участия PBX.

Грубо говоря, as5350 висит на номере 123456, а позвонивший на этот номер попал бы на 987654. (нужно на случай падения PBX переадресовать все звонки с циски на обычный тел.)

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Переадресация звонка pots на as5350"  +/
Сообщение от aZL on 09-Фев-11, 17:32 
> Грубо говоря, as5350 висит на номере 123456, а позвонивший на этот номер
> попал бы на 987654. (нужно на случай падения PBX переадресовать все
> звонки с циски на обычный тел.)

Дык, у AS5350 нет FXS-интерфейса, как Вы хотите подключить к ней обычный телефон?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Переадресация звонка pots на as5350"  +/
Сообщение от postavik (ok) on 09-Фев-11, 18:09 
> Дык, у AS5350 нет FXS-интерфейса, как Вы хотите подключить к ней обычный
> телефон?

Звонок должен придти с E1 и уйти туда же.
Например при таком конфиге единственного пира:

dial-peer voice 101 pots
huntstop
destination-pattern 987654
incoming called-number .T
port 3/0:D
forward-digits all

дозвонившись на 123456 и донабрав номер 987654, звонок уходит на него. Мне нужен конфиг при котором не нужно делать донабор

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Переадресация звонка pots на as5350"  +/
Сообщение от BJ (ok) on 09-Фев-11, 19:22 
direct-inward-dial в диал-пир добавьте.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Переадресация звонка pots на as5350"  +/
Сообщение от postavik email(ok) on 10-Фев-11, 08:17 
> direct-inward-dial в диал-пир добавьте.

А зачем? PBX же нет. Если добавляю, то циска отвечает уже модемным соединением.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Переадресация звонка pots на as5350"  +/
Сообщение от BJ (ok) on 10-Фев-11, 09:24 
Конфиг серийника покажите.

> А зачем? PBX же нет. Если добавляю, то циска отвечает уже модемным
> соединением.

direct-inward-dial к PBX не имеет никакого отношения, она задает логику работы циски: принять звонок и пустить его сразу в дальнейшую обработку используя A номер.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Переадресация звонка pots на as5350"  +/
Сообщение от postavik email(ok) on 10-Фев-11, 09:40 
BJ и evghoul! Спасибо!!! добавил direct-inward-dial и translation-profile. Все работает!!!


Пока конфиг в таком виде:

boot-start-marker
boot system flash c5350-ik9su2-mz.124-11.T.bin
no boot startup-test
boot-end-marker
!
resource-pool disable
!
aaa session-id common
clock calendar-valid
spe default-firmware spe-firmware-1
ip cef
!
!
multilink bundle-name authenticated
isdn switch-type primary-net5
!
!
voice translation-rule 1
rule 1 /327881/ /237891/
!
!
voice translation-profile 2
translate called 1
!
trunk group  1
hunt-scheme round-robin both down

controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31
!
interface Serial3/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice modem 64
no fair-queue
no cdp enable
!
interface Serial3/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice modem
no cdp enable
!
interface Group-Async0
no ip address
encapsulation slip
no ip mroute-cache
no snmp trap link-status
no peer default ip address
no fair-queue
group-range 1/00 1/59
!
!
dialer clid group 123
!
!
call leg event-log
!
voice-port 3/0:D
input gain -3
output attenuation -3
cptone RU
bearer-cap 3100Hz
!
voice-port 3/1:D
input gain -3
output attenuation -4
echo-cancel coverage 64
cptone RU
bearer-cap 3100Hz
!
!
!
dial-peer voice 100 pots
translation-profile incoming 2
huntstop
incoming called-number 327881
direct-inward-dial
!
dial-peer voice 101 pots
destination-pattern 237891
port 3/0:D
forward-digits all
!
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
line aux 0
modem InOut
transport input all
transport output all
line vty 0 4
access-class 1 in
exec-timeout 30 0
line vty 5 15
access-class 1 in
line 1/00 1/58
session-timeout 30
no flush-at-activation
modem InOut
transport preferred none
transport input all
transport output none
escape-character BREAK
line 1/59
session-timeout 30
no flush-at-activation
modem InOut
monitor
transport preferred none
transport input all
transport output none
escape-character BREAK
!
scheduler allocate 10000 400
ntp master 1
end


Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

3. "Переадресация звонка pots на as5350"  +/
Сообщение от evghoul (ok) on 09-Фев-11, 18:16 
с помощью translation-profile

voice translation-rule 1
rule 1 /123456/ /987654/
!

voice translation-profile 2
translate called 1
!

dial-peer voice 123456 pots
translation-profile incoming 2
incoming called-number 123456
!

dial-peer voice 987654 pots
destination-pattern 123456
trunkgroup TGNAME
! ^ чтобы ушло в нужный поток

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Переадресация звонка pots на as5350"  +/
Сообщение от postavik email(ok) on 10-Фев-11, 08:10 
Если делаю с пом. translation-profile, то остается необходимость донабора, только уже набирать нужно не 987654, а 123456.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру