The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"shape cisco 3560"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (ACL, фильтрация и ограничение трафика)
Изначальное сообщение [ Отслеживать ]

"shape cisco 3560"  +/
Сообщение от arma35 email(ok) on 10-Фев-11, 13:39 
Добрый день!

будет ли работать такая схема на cisco 3560:

!
class-map match-all 5mbps
desc *2,5 Megabits/s shape*
match access-group 199
match access-group 198
!
class-map match-all 5mbps
desc *5 Megabits/s shape*
match access-group 197
match access-group 196
!
class-map match-all 10mbps
desc *10 Megabits/s shape*
match access-group 195
match access-group 194
!
!
policy-map shape
desc *shape*
class 2.5mbps
  police 2560000 80000 exceed-action drop
class 5mbps
  police 5000000 160000 exceed-action drop
class 10mbps
  police 10000000 320000 exceed-action drop
!
interface FastEthernet0/1
description *uplink to INET*
switchport access vlan 101
switchport mode access
service-policy input shape
!
interface FastEthernet0/2
description *Client#1*
switchport access vlan 201
switchport mode access
  service-policy input shape
!
interface FastEthernet0/3
description *Client#2*
switchport access vlan 201
switchport mode access
service-policy input shape
!
interface FastEthernet0/3
description *Client#2*
switchport access vlan 202
switchport mode access
service-policy input shape
!
access-list 199 permit ip any host 192.168.1.2
access-list 199 permit ip host 192.168.1.2 any
access-list 198 permit ip any host 192.168.2.2
access-list 198 permit ip host 192.168.2.2 any
access-list 197 permit ip any host 192.168.3.2
access-list 197 permit ip host 192.168.3.2 any
!


или я чтото пропустил??

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "shape cisco 3560"  +/
Сообщение от aZL on 10-Фев-11, 15:46 
IMHO так не будет работать.
А можно уточнить задачу?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "shape cisco 3560"  +/
Сообщение от arma35 email(ok) on 10-Фев-11, 16:45 
> IMHO так не будет работать.
> А можно уточнить задачу?

почему не будет??

задача проста -  сделать шейп по клиентам, как на входящий так и на исходящий траффик..
клиенты - все по разным сетям, портам, виланам..

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "shape cisco 3560"  +1 +/
Сообщение от aZL on 10-Фев-11, 17:50 
> почему не будет??

Ну, для начала потому, что в Ваши классы с match-all ничего попадать не будет. Должно быть match-any. :)
А дальше: очевидно, для input - вполне и поедет, хотя, мне кажется более интересным решение через per-Vlan policing из-за возможности иерархии политик. А вот на output, насколько знаю, работает только через srr-queue bandwidth limit . Ещё не следует забывать о non-IP traffic, это ж всё-таки коммутатор.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "shape cisco 3560"  +/
Сообщение от arma35 email(ok) on 10-Фев-11, 18:09 
>> почему не будет??
> Ну, для начала потому, что в Ваши классы с match-all ничего попадать
> не будет. Должно быть match-any. :)

о блин, точно! )

> А дальше: очевидно, для input - вполне и поедет, хотя, мне кажется
> более интересным решение через per-Vlan policing из-за возможности иерархии политик. А
> вот на output, насколько знаю, работает только через srr-queue bandwidth limit
> . Ещё не следует забывать о non-IP traffic, это ж всё-таки
> коммутатор.

Кстати, а если коммутатор будет выполнять роль центрального-транзитного ядра для раздачи инета клиентам, и только инета
т.е.:

client1 ---
client2 --- catalist 2950 --- catalsit 3560 --- INET
client3 ---

на каталисте 3560:

interface FastEthernet0/1
description *uplink to INET*
switchport access vlan 101
switchport mode access
service-policy input shape

interface FastEthernet0/2
description *to c2950 clients*
switchport trunk allowed vlan 201-220
switchport mode trunk
service-policy input shape

сработает схема? ;)


а каким образом через Vlan можно??
попробовал - rate-limit, чтото не вышло..

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "shape cisco 3560"  +/
Сообщение от aZL on 11-Фев-11, 09:17 
> а каким образом через Vlan можно??
> попробовал - rate-limit, чтото не вышло..

Можно почитать:
http://www.opennet.ru/base/cisco/catalyst_vlan_policy.txt.html
http://blog.internetworkexpert.com/2008/09/11/comparing-traf.../
Вот тут по 3750, но на 3560 аналогично:
http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/so...

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру