The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ограничение трафика Cisco 2801"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (ACL, фильтрация и ограничение трафика)
Изначальное сообщение [ Отслеживать ]

"Ограничение трафика Cisco 2801"  +/
Сообщение от Vladsky email(ok) on 10-Сен-11, 23:39 
Добрый день!
есть роутер 2801 используется в качестве Voip шлюза и также как gateway небольшой сети в интернет. Канал инета от провайдера узкий, 4Мбит. и еще 1 Мбит голос. как ограничить  ширину канала? т.е. чтобы не забивать ее всю, и сделать ограничения по скорости доступа в инет определенным узлам сети?
я так понимаю способо несколько от QOS до policy или шейпить траф. попытался сделать так. как вообще мониторить что трафи режется?

class-map match-all Traf1
match access-group 102
class-map match-all Traf2
match access-group 103
class-map match-all voice
match protocol h323
match protocol sip

!
!
policy-map Policy1
class Traf1
    shape peak 2048000
class voice
    shape peak 512000
policy-map Policy2
class Traf2
    shape peak 2048000
class voice
    shape peak 512000

# внутренний интерйес локалка, на нем 2 vlan данные и голос
interface FastEthernet0/0
no ip address
ip tcp adjust-mss 1372
duplex auto
speed auto
service-policy output Policy2

# внешний интерфейс

interface FastEthernet0/1
ip address xxx.xxx.xxx.xxx 255.255.255.252
ip access-group 111 in
ip nat outside
ip inspect FIREWALL out
ip virtual-reassembly
duplex auto
speed auto
service-policy output Policy1

# данные
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 172.16.0.254 255.255.255.0
ip access-group social_net in
ip nat inside
ip virtual-reassembly
!
# голос
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
ip virtual-reassembly

access-list 102 permit ip 172.16.0.128 0.0.0.127 any - подсеть
access-list 102 permit ip any host 172.16.0.114 - опред узел не включеный в подсеть выше

access-list 103 permit ip any 172.16.0.128 0.0.0.127
access-list 103 permit ip any host 172.16.0.114

правильно ли в данном случае назначаю акцесс листы и полиси?
также есть туннельный интерфейс, с другой циской, по нему идут и данные и голос, в данном случае полиси будут рещать и его? или надо отдельную полиси?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


2. "Ограничение трафика Cisco 2801"  +/
Сообщение от ivb (??) on 12-Сен-11, 13:30 
Для VOIP шейпинг не рекомендуется использовать, ухудшается jitter.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Ограничение трафика Cisco 2801"  +/
Сообщение от Vladsky email(ok) on 13-Сен-11, 14:50 
> Для VOIP шейпинг не рекомендуется использовать, ухудшается jitter.

ok. а в целом правильно ли я делаю? везде на аутпут вешаю полиси, в случае внутреннего интерфейса, получается ограничивается трафик для всех клиентов до 2Мбит суммарно? акцесс листы имеют правильный соурс и дестинейшн?


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Ограничение трафика Cisco 2801"  +/
Сообщение от Vladsky email(ok) on 05-Ноя-11, 23:36 
>> Для VOIP шейпинг не рекомендуется использовать, ухудшается jitter.
> ok. а в целом правильно ли я делаю? везде на аутпут вешаю
> полиси, в случае внутреннего интерфейса, получается ограничивается трафик для всех клиентов
> до 2Мбит суммарно? акцесс листы имеют правильный соурс и дестинейшн?

и все же, что то неверно, суда по логам полиси:
#sh policy-map interface
FastEthernet0/0

  Service-policy output: Policy2

    Class-map: Traf2 (match-all)
      2 776 519 packets, 2349309592 bytes
      5 minute offered rate 9000 bps, drop rate 0 bps
      Match: access-group 103
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/3866/0
      (pkts output/bytes output) 2760777/2331188588
      shape (peak) cir 1024000, bc 4096, be 4096
      target shape rate 2048000

    Class-map: voice (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol h323
      Match: protocol sip
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      shape (peak) cir 256000, bc 1024, be 1024
      target shape rate 512000

    Class-map: class-default (match-any)
      7 077 473 packets, 5214920665 bytes
      5 minute offered rate 126000 bps, drop rate 0 bps
      Match: any
      
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 33261411/10864430030
FastEthernet0/1

  Service-policy output: Policy1

    Class-map: Traf1 (match-all)
      27906 packets, 2275681 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 102
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 27898/2269185
      shape (peak) cir 1024000, bc 4096, be 4096
      target shape rate 2048000

    Class-map: voice (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol h323
      Match: protocol sip
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      shape (peak) cir 256000, bc 1024, be 1024
      target shape rate 512000

    Class-map: class-default (match-any)
      8 851 009 packets, 1685872340 bytes
      5 minute offered rate 33000 bps, drop rate 0 bps
      Match: any
          
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 8842091/1689518113


что за дефолтные правила? почему не шейпится голосовой траф?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Ограничение трафика Cisco 2801"  +/
Сообщение от fantom (ok) on 07-Ноя-11, 10:30 
>[оверквотинг удален]
>       target shape rate 512000
>     Class-map: class-default (match-any)
>       8 851 009 packets, 1685872340 bytes
>       5 minute offered rate 33000 bps,
> drop rate 0 bps
>       Match: any
>       queue limit 64 packets
>       (queue depth/total drops/no-buffer drops) 0/0/0
>       (pkts output/bytes output) 8842091/1689518113
> что за дефолтные правила? почему не шейпится голосовой траф?

Class-map: voice (match-all) Что означает? подумали?

Match: protocol h323
Match: protocol sip

т.е. пакет должен быть ОДНОВРЕМЕННО h323 и sip.... и как вы себе это представляете?

Железка в точности выполняет ваши инструкции :)

Class-map: class-default - это все, что не попало в предыдущие классы.

Class-map: voice скорее всего надо сделать  (match-any) и посмотреть на эффект.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру