The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Netflow и два VRF "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Учет трафика и статистика)
Изначальное сообщение [ Отслеживать ]

"Netflow и два VRF "  +/
Сообщение от ilya (??) on 12-Апр-12, 11:15 
Есть 2821.
К ней приходят два провайдера.
Один провайдер в vrf default.
Второй пров засунут в vrf 1, и несколько людей пользуются этим провайдером (т.е. просто тупа два VRF Lite).
В vrf default есть нетфлоу коллектор, который собирает статистику с этой самой 2811.
Но данные из vrf 1 туда не попадают :(
Как самым простым способом собрать netflow данные с vrf 1?
Подключать коллектор к vrf 1 не хочу :)
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Netflow и два VRF "  +/
Сообщение от рюмка on 13-Апр-12, 02:07 
Конфиг бы..


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Netflow и два VRF "  +/
Сообщение от ilya (??) on 13-Апр-12, 15:46 
> Конфиг бы..

дык простейший...

ip dhcp use vrf connected
!
ip dhcp pool dhcp_pool_red
   vrf prov2
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1
   domain-name customer_red
   dns-server 8.8.8.8
!
!
ip vrf prov2
rd 100:10

провайдер комстар идет через врф.
interface Vlan10
description comstar
ip vrf forwarding prov2
ip address 8.2.2.2 255.255.255.252
ip nat outside
ip virtual-reassembly
!
interface Vlan11
ip vrf forwarding prov2
ip address 10.0.0.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly


основной провайдер для локалки
interface GigabitEthernet0/0
bandwidth 100000
ip address ХХХХ
ip nat outside
ip nat enable
ip virtual-reassembly


interface GigabitEthernet0/1.99
description LAN
encapsulation dot1Q 199
ip address 172.18.1.1 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly


ip flow-export version 5
ip flow-export destination ip_collector 9996

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Netflow и два VRF "  +/
Сообщение от dmitry (??) on 16-Апр-12, 07:43 
>[оверквотинг удален]
> interface GigabitEthernet0/1.99
>  description LAN
>  encapsulation dot1Q 199
>  ip address 172.18.1.1 255.255.255.0
>  ip flow ingress
>  ip flow egress
>  ip nat inside
>  ip virtual-reassembly
> ip flow-export version 5
> ip flow-export destination ip_collector 9996

Прописать пару маршрутов: global rt --> vrf, vrf --> global rt
ip route 10.0.0.0 255.255.255.0 vlan11
ip route vrf prov2 172.18.1.0 255.255.255.0 gi0/1.99
как-то так...

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру