The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Подключение по vpn из андроида"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VPN, VLAN, туннель)
Изначальное сообщение [ Отслеживать ]

"Подключение по vpn из андроида"  +/
Сообщение от back2egg on 14-Май-12, 19:03 
Имеется cisco 3660
Имеется телефон с андроидом 2.3.5
Задача - подключиться с телефона по vpn
Перепробовал на маршрутизаторе pptp, l2tp, l2tp ipsec со всевозможными комбинациями методов аутентификации и методов шифрования. Все бесполезно.
В логе вижу что аутентификация проходит (кроме l2tp ipsec), но при согласовании ip-адресов "соединение разорвано без объяснения причин". На андроиде дурацкое сообщение "не возможно установить соединение. возможно не удается согласовать параметры шифрования". Но по моему я уже все варианты перебрал. Каждый вариант сначала проверял соединяясь с ноутбука. Все работает.
Не подскажете, какие установки для vpn нужно сделать на маршрутизаторе чтобы можно было подключиться из андроида? Очень нужно. А то приходится постоянно таскать с собой ноутбук.
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Подключение по vpn из андроида"  +/
Сообщение от shadow_alone (ok) on 14-Май-12, 20:40 
А ты с телефона по wifi пытаешься или по 3g? если по 3g, то порой провайдеры блокирует такую возможность.
В остальном у меня все работает и с mppe и без.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Подключение по vpn из андроида"  +/
Сообщение от Aleks305 (ok) on 14-Май-12, 22:52 
> А ты с телефона по wifi пытаешься или по 3g? если по
> 3g, то порой провайдеры блокирует такую возможность.
> В остальном у меня все работает и с mppe и без.

у меня с планшета с android не получилось по l2tp ipsec подключиться к cisco asa. пакетов даже asa почему-то не видит входящих

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Подключение по vpn из андроида"  +/
Сообщение от shadow_alone (ok) on 14-Май-12, 22:53 
> у меня с планшета с android не получилось по l2tp ipsec подключиться
> к cisco asa. пакетов даже asa почему-то не видит входящих

Вы как подключены то?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Подключение по vpn из андроида"  +/
Сообщение от dima (??) on 15-Май-12, 08:21 
ОПСОСЫ сканируют трафик.

и потому VPN не разрешают.

ФСБ не спит!

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Подключение по vpn из андроида"  +/
Сообщение от back2egg on 15-Май-12, 08:56 
> А ты с телефона по wifi пытаешься или по 3g? если по
> 3g, то порой провайдеры блокирует такую возможность.

Да и так и так пробовал. Вообще-то я пробовал через 3g еще и следующим образом - телефон переводил в режим точки доступа и подключался с ноутбука по pptp. Все работает. Так что провайдер не причем тут.
> В остальном у меня все работает и с mppe и без.

А версия андроида какая если не секрет?


Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

6. "Подключение по vpn из андроида"  +/
Сообщение от shadow_alone (ok) on 15-Май-12, 14:26 
> А версия андроида какая если не секрет?

Да на любой работает, и на 2.3.5 и на 4.0.3

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Подключение по vpn из андроида"  +/
Сообщение от back2egg on 15-Май-12, 17:28 
> Да на любой работает, и на 2.3.5 и на 4.0.3

А что же у меня тогда не так может быть?


Current configuration : 4657 bytes
!
!
version 12.4
service timestamps debug uptime
service timestamps log datetime msec localtime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname gw0
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXX
enable password 7 XXXXXXXXXXXXXXXXXXXXXXXXX
!
aaa new-model
!
!
aaa authentication banner ^C
^C
aaa authentication username-prompt "login: "
aaa authentication login default local
aaa authentication login console local
aaa authentication ppp default local
aaa authentication arap default line
aaa authorization exec default local
aaa authorization exec console none
aaa authorization network default local
aaa authorization network groupauthor local
!
!
aaa session-id common
clock timezone BST 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name domain.com
ip name-server 1.1.1.1
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
vpdn enable
!
vpdn-group PPTP
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 2
!
voice-card 0
!
!
!
!
!
username xxx password 7 XXXXXXXXXXXXXXXXXXXX
archive
log config
  hidekeys
!
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh port 2010 rotary 1
ip ssh version 1
!
!
!
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
ip access-group 101 in
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
ip address 192.168.250.254 255.255.255.0 secondary
ip address 3.3.3.3 255.255.255.0
duplex auto
speed auto
!
interface Virtual-Template2
ip unnumbered FastEthernet0/1
peer default ip address pool PPTP_POOL
ppp encrypt mppe 128 required
ppp bridge ip
ppp authentication ms-chap-v2
ppp ipcp dns 1.1.1.1
!
ip local pool PPTP_POOL 3.3.3.10 3.3.3.20
ip default-gateway 1.1.1.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 1.1.1.1
no ip http server
no ip http secure-server
!
!
!
!
map-list oracle
logging trap debugging
logging 3.3.3.4
no cdp run

!
!
!
!
!
snmp-server community sss RO 11
snmp-server enable traps tty
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
password 7 XXXXXXXXXXXXX
rotary 1
transport input ssh
!
scheduler allocate 20000 1000
ntp server 1.1.1.1
end

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Подключение по vpn из андроида"  +/
Сообщение от Viewer (ok) on 15-Май-12, 17:30 
Нам помог апдейт на 4 версию андроида, там разных типов ipsec-ов поприбавили.
Cisco Pix 525, ipsec.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Подключение по vpn из андроида"  +/
Сообщение от Aleks305 (ok) on 17-Май-12, 12:03 
> Нам помог апдейт на 4 версию андроида, там разных типов ipsec-ов поприбавили.
> Cisco Pix 525, ipsec.

замучал на днях ASA, но Android подключил. Интересные моменты?
1) Подключение происходит только c аутентификацией по pre-shared ключам. По сертификатам ни в какую, с одним и тем же сертификатом, комп с Виста подключается, Андроид - нет. Ошибка в дебаге не понятна, погуглив решения не нашел.
2) Подключение можно произвести только в defaultRAGroup с Android, так как там нет возможности нигде указать название другой группы. С компа по сертификату можно попасть в другую группу.
3) Бывает проблема с самим Андроидом. У меня два девайса, один - китайский планшет, второй смартфон Sony Ericson. И там и там версия прошивки примерно одинакова 2.1 - 2.3. С планшета вообще не пытается подключиться, со смартфона - все ок.

Итог: нельзя с различными девайсами с Андроид гарантировать,что подключение произойдет.С каждым надо работать индивидуально.
Версия ASA 8.4.2 была, 8.4.3 тоже все ок.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Подключение по vpn из андроида"  +/
Сообщение от Mapshal email on 26-Окт-15, 14:42 
Я использую для этого http://thesafety.us/en, все очень просто, легко настраиваемые VPN
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру